Subject: [MIB-DOCTORS] FW: MIB vs YANG augmentation

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 12 Feb 2021 13:47:33 +0000

Hi,

I don't know the answer to this question from a MIB POV.

Is there a MIB expert who can please help me provide an answer to back to Glenn for their IEEE MIB question?

Regards,
Rob

From: Glenn Parsons <[email-masked]>
Sent: 11 February 2021 22:05
To: Rob Wilton (rwilton) <[email-masked]>; Scott Mansfield <[email-masked]>
Cc: Christophe Mangin <[email-masked]>
Subject: MIB vs YANG augmentation

Rob,

In one of our projects, we are updating the MIB and YANG at the same time to support a new feature.  For the MIB the entire module is revised, but the YANG is augmented.

I wondered why the MIB could not be augmented.  The point is adding a row to a table cannot be done with an AUGMENT.  But you can do that in YANG...

I just want to confirm our understanding is correct.

Cheers,
Glenn.

PS. This is more of a MIB vs YANG question, so maybe beyond YANGsters...  And we don't have a MIB-doctors equivalent in 802...

From: Christophe Mangin <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, February 10, 2021 7:38 AM
To: Glenn Parsons <[email-masked]<mailto:[email-masked]>>
Cc: Stephan Kehrer <[email-masked]<mailto:[email-masked]>>
Subject: follow up to the resolution of your comment (#17) against CBdb D1.1 (MIB augmentation)

Hi Glenn,

I've tried to understand further how the AUGMENTS clause is used in MIBs.
What I could gain from my < investigations > is that a MIB defining a table that includes an existing table (in other MIB), i.e. both tables have the same < conceptual rows >, can just AUGMENT the original table by adding < columnar objects > to it. These new < columnar objects > are addressed using the same INDEX as in the original table.

In the case of CBdb, the addition of a new stream identification function definition consists in the addition of a new value for the parameters < Ieee8021CBStreamIdentificationType > and < ieee8021StreamIdStreamIdIdentificationTypeSelect >, which are already existing < columnar objects > of the table < ieee8021StreamIdStreamIdentificationTable >.
So, CBdb does not add new < columnar objects > to an existing table. This could be a reason for not augmenting.

More generally, the concept behing MIB's table augmentation is different of the YANG augmentation, which can be used to extend a whole module.
Then I would say that CBdb's MIB is a revision of CB's (CBcv's in fact).

I hope this is accurate enough (I'm not a MIB specialist) to clarify the choice made for CBdb's MIB.
Feel free to let me know your feeling about it.

Cheers,
Christophe

Christophe Mangin
  Information and Network Systems (INS) Team
  Communication & Information Systems (CIS) Division
Mitsubishi Electric R&D Centre Europe (MERCE)
Phone: +33 2 23 45 58 33 / http://www.fr.mitsubishielectric-rce.eu<https://protect2.fireeye.com/v1/url?k=01239d2e-5eb8a44f-0123ddb5-86d8a30ca42b-e1c1f3f01a83f67a&q=1&e=7cc6b745-e9f0-4993-8881-2a93c0863ddc&u=http%3A%2F%2Fwww.fr.mitsubishielectric-rce.eu%2F>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Fri, 12 Feb 2021 15:00:10 +0100

An AUGMENT in SMIv2 says that there is a table and I define a new
table that logically augments (extends) the first table, i.e., rows in
the orignal table may "continue" in the augmenting table. A row in an
"augmenting" table can't exist without a corresponding row in the base
table.

In YANG, the augment statement is much more powerful, you can say for
that schema node over there, I am augmenting a complex schema tree
into it, i.e., it is a way to put additional definitions into some
existing tree at the "right" place.

/js

> _______________________________________________
> MIB-DOCTORS mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mib-doctors

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <https://www.jacobs-university.de/>

---

From: "Rob Wilton (rwilton)" <[email-masked]>
Date: Fri, 12 Feb 2021 15:47:42 +0000

Juergen,

Thanks for the quick response.

Regards,
Rob

> -----Original Message-----
> From: Juergen Schoenwaelder <[email-masked]>
> Sent: 12 February 2021 14:00
> To: Rob Wilton (rwilton) <[email-masked]>
> Cc: [email-masked]
> Subject: Re: [MIB-DOCTORS] FW: MIB vs YANG augmentation
> 
> > In one of our projects, we are updating the MIB and YANG at the same
> time to support a new feature.  For the MIB the entire module is revised,
> but the YANG is augmented.
> >
> > I wondered why the MIB could not be augmented.  The point is adding a
> row to a table cannot be done with an AUGMENT.  But you can do that in
> YANG...
> >
> > PS. This is more of a MIB vs YANG question, so maybe beyond YANGsters...
> And we don't have a MIB-doctors equivalent in 802...
> >
> > From: Christophe Mangin
> <[email-masked]<mailto:[email-masked]>>
> > To: Glenn Parsons
> <[email-masked]<mailto:[email-masked]>>
> > Cc: Stephan Kehrer
> <[email-masked]<mailto:stephan.kehrer.committees@gmai
> l.com>>
> > What I could gain from my < investigations > is that a MIB defining a
> table that includes an existing table (in other MIB), i.e. both tables
> have the same < conceptual rows >, can just AUGMENT the original table by
> adding < columnar objects > to it. These new < columnar objects > are
> addressed using the same INDEX as in the original table.
> >
> > In the case of CBdb, the addition of a new stream identification
> function definition consists in the addition of a new value for the
> parameters < Ieee8021CBStreamIdentificationType > and <
> ieee8021StreamIdStreamIdIdentificationTypeSelect >, which are already
> existing < columnar objects > of the table <
> ieee8021StreamIdStreamIdentificationTable >.
> > So, CBdb does not add new < columnar objects > to an existing table.
> This could be a reason for not augmenting.
> >
> > More generally, the concept behing MIB's table augmentation is different
> of the YANG augmentation, which can be used to extend a whole module.
> > Phone: +33 2 23 45 58 33 / http://www.fr.mitsubishielectric-
> rce.eu<https://protect2.fireeye.com/v1/url?k=01239d2e-5eb8a44f-0123ddb5-
> 86d8a30ca42b-e1c1f3f01a83f67a&q=1&e=7cc6b745-e9f0-4993-8881-
> 2a93c0863ddc&u=http%3A%2F%2Fwww.fr.mitsubishielectric-rce.eu%2F>
> >
>