Subject: [mif-arch-dt] Relationship to Existing Concepts

From: Margaret Wasserman <[email-masked]>
Date: Tue, 14 May 2013 03:28:36 -0400

How do provisioning domains relate to existing processes, like:
–DNS lookups (and split DNS)?
–Upper-layer destination address selection?
–Source address/next hop selection?
–Selection of address pools/”referral pools” by SCTP or other upper-layer mechanisms?
–Others?

---

From: Hui Deng <[email-masked]>
Date: Fri, 24 May 2013 15:14:05 +0800

Hello all,
 
From the last teleconf we have agreed to work on 
1) Definition of PvD and PvS, Ted also susggest PvO.  Margaret will kindly help to lead the discussion during next teleconf about this.
Just one small question. can I ask Margaret and Suresh, what's the objective for us define this, we may need clarify in the last document.
 
Here I have two other thoughts about our discussion
1) Do we need PvD Identifier, what is it used for?
 Can Dave, Suresh, and Dmitry kindly help to share some ideas how we would better to move forward on this?
 
2) Relationship between "Context" and PvD, Marc shared a good idea about "application will choose context other than PvD."
Margaret has asked questions about relationship between source address and PvD, guess it could be abstracted into context and PvD
so, Marc, do u have some  idea about what's relationship between them?
 
My two cents,
Thanks a lot for your discussion
 
-Hui

---

From: Hui Deng <[email-masked]>
Date: Fri, 24 May 2013 15:21:28 +0800

inline please
 
> From: [email-masked]
> Date: Tue, 14 May 2013 03:28:36 -0400
> To: [email-masked]
> Subject: [mif-arch-dt] Relationship to Existing Concepts
> 
> 
> –DNS lookups (and split DNS)?when a host has two PvDs, and multiple PvS for DNS resolver, host may pick the suffix match based PvS, then we can use new language to explain it?
> –Selection of address pools/”referral pools” by SCTP or other upper-layer mechanisms?these three are all "context", question continue to be asked like what's the relationship between "Context" and PvD? Best, -Hui
> –Others?
> 
> 
> _______________________________________________
> mif-arch-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif-arch-dt

---

From: Dmitry Anipko <[email-masked]>
Date: Mon, 27 May 2013 23:29:21 +0000

Some thoughts below:

>>> -DNS lookups (and split DNS)?
>>when a host has two PvDs, and multiple PvS for DNS resolver, host may pick the suffix match based PvS, then we can use new language to explain it?

Depending on the use case, the host could decide to pick one, or multiple PVDs to be used for a given DNS lookup.

The host may pick one PVD if e.g. host policy demanded to use a particular PVD for a particular purpose (e.g. download MMS). The implementation could use a PVD ID to chose the PVD, or it could match DNS suffix (or possibly DNS suffix will be one of the forms of the PVD ID).

The host may pick multiple PVDs, if e.g. they are general purpose PVDs providing connectivity to the Internet, and the host wanted to maximize chances for connectivity in Happy Eyeballs style. In this case, the host could do the lookups in parallel, or in sequence. In either case, it would use for the following connection request the PVD, where the lookup results were obtained.

Alternatively, the host may use for the lookup only one PVD, based on the PVD connectivity properties, user preference, etc.

>>> -Upper-layer destination address selection?
> -Source address/next hop selection?

Say, the DNS lookup succeeded in a particular PVD.  Then, for each obtained destination address, the host would perform a route lookup among next-hops, which advertised prefixes and/or specific routes belonging to the PVD mentioned above.

Once the best next-hop is found, best source is selected according to the RFC 6724, but with a constrain that the source address must belong to a range associated with the PVD. If needed, the host would use the prefix policy from the same PVD.

When destination/source pairs are identified, then they are sorted using the RFC 6724 rules and the prefix policy table from this PVD.

-Dmitry

________________________________
From: [email-masked] on behalf of Hui Deng
Sent: Friday, May 24, 2013 12:21 AM
To: [email-masked]; [email-masked]
Subject: Re: [mif-arch-dt] Relationship to Existing Concepts

inline please

> -DNS lookups (and split DNS)?
when a host has two PvDs, and multiple PvS for DNS resolver, host may pick the suffix match based PvS, then we can use new language to explain it?

> -Upper-layer destination address selection?
> -Source address/next hop selection?
> -Selection of address pools/"referral pools" by SCTP or other upper-layer mechanisms?
these three are all "context", question continue to be asked like what's the relationship between "Context" and PvD?

Best,

-Hui

> -Others?

---

From: Hui Deng <[email-masked]>
Date: Tue, 28 May 2013 15:20:13 +0800

just one comment inline start with ==>
 
From: [email-masked]
To: [email-masked]; [email-masked]; [email-masked]
Date: Mon, 27 May 2013 23:29:21 +0000
Subject: Re: [mif-arch-dt] Relationship to Existing Concepts

 

The host may pick one PVD if e.g. host policy demanded to use a particular PVD for a particular purpose (e.g. download MMS). The implementation could use a PVD ID to chose the PVD, or it could match DNS suffix (or possibly DNS suffix will be
 one of the forms of the PVD ID).
 
The host may pick multiple PVDs, if e.g. they are general purpose PVDs providing connectivity to the Internet, and the host wanted to maximize chances for connectivity in Happy Eyeballs style. In this case, the host could do the lookups in parallel,
 or in sequence. In either case, it would use for the following connection request the PVD, where the lookup results were obtained.

 ==> if policy and DNS suffix is not succeed, then fall back to Happy Eyeball Style -Hui

---

From: Dmitry Anipko <[email-masked]>
Date: Tue, 28 May 2013 13:56:08 +0000

>> ==> if policy and DNS suffix is not succeed, then fall back to Happy Eyeball Style

I think this is one of the options the host could decide to implement, but the architecture defining PVDs and their properties doesn't need to mandate it.

________________________________
From: [email-masked] on behalf of Hui Deng
Sent: Tuesday, May 28, 2013 12:20 AM
To: Dmitry Anipko; [email-masked]; [email-masked]
Subject: Re: [mif-arch-dt] Relationship to Existing Concepts

 ==> if policy and DNS suffix is not succeed, then fall back to Happy Eyeball Style

-Hui