Subject: Re: [mif] definition of a MIF host

From: <[email-masked]>
Date: Fri, 28 Aug 2009 10:50:28 +0200

Bonjour,

Désolé pour la réponse très tardive mais j'étais en congé après l'IETF.

En fait, la definition du "MIF host" est déjà compatible avec la définition monami6. La problématique MIF intervient dés que plusieurs adresses IP sont utilisées:

Extrait de la section 2:

A MIF host is defined as:
   o  a [RFC1122] IPv4 and/or [RFC4294] IPv6 compliant host
   o  configured with more than one IP addresses (excluding loopback,
      link-local)

Je pense donc qu'une référence au draft monami6 pourrait suffire. Je propose de modifier la section " 3.3. Mobility and other IP protocols" comme suit:

This document assumes hosts only implementing [RFC1122] for IPv4 and [RFC4294] for IPv6, and not using any kind of new transport protocols. If definition of MIF host presents similarities with multihomed nodes [ietf-monami6-multihoming-motivation-scenario], it is not required for the host to support additional IP mobility or multihoming protocols, such as SHIM6, SCTP, Mobile IP, HIP, RRG, LISP or else.  Moreover, the peer of the connection is also not required to use these mechanisms.

Autre possibilité: modifier la section 2:

A MIF host is defined as:
   o  a [RFC1122] IPv4 and/or [RFC4294] IPv6 compliant host
   o  as per [ietf-monami6-multihoming-motivation-scenario], a MIF host is configured with more than one IP addresses (excluding loopback, link-local) 

Commentaires?

A+
Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de Marc
> Blanchet
> Envoyé : jeudi 30 juillet 2009 17:31
> À : Nicolas Montavont
> Cc : [email-masked]
> Objet : Re: [mif] definition of a MIF host
> 
> - thanks. it is in fact very good input. the monami6 definition is
> however a bit v6 specific (eg. prefixes advertised on the link) where
> mif shall be af agnostic. I'll adapt it for mif.
> 
> Marc.
> 
> Nicolas Montavont a écrit :
> > Hi,
> >
> > (I'm only starting to follow this group, so I hope my question was not
> > discussed before...)
> >
> > I'd like to come back on the discussion on a MIF host as defined in
> > draft-blanchet-mif-problem-statement-00.
> >
> > In the former WG Monami6, we worked on the following document:
> >
> > http://tools.ietf.org/id/draft-ietf-monami6-multihoming-motivation-
> scenario-03.txt
> >
> >
> > where we also proposed a definition for a multihomed node. We came up
> > with the following definitions:
> >
> >    Interface
> >
> >       A node's point of attachment to a link (as defined in [5])
> >
> >    Multihomed Node
> >
> >       A node (either a host or a router) is multihomed when it has
> >       several global IPv6 addresses to choose between, i.e. in the
> >       following cases when it is either:
> >
> >       *  multi-prefixed: multiple prefixes are advertised on the link(s)
> >          the node is attached to, or.
> >
> >       *  multi-interfaced: the node has multiple interfaces to choose
> >          between, on the same link or not.
> >
> > Basically it says that a node is multi-homed as soon as it has multiple
> > addresses of the same scope, from which it can choose to send data
> > packets. What was good IMHO in this definition, is that it is concise
> > and does not try to cover all cases where you can end up in that case.
> >
> > So for the purpose of draft-blanchet-mif-problem-statement-00, I would
> > suggest to keep the definition very short, and then have examples in
> > another section that show how a host can be multi-homed / MIF (several
> > interfaces, several administrative domains, etc).
> >
> > In the same sense, I think that the bullet "Communications using these
> > IP addresses may happen simultaneous and independently." should not be
> > in the definition, but again, in some explanations of scenarios.
> >
> > Regards,
> > Nicolas
> > _______________________________________________
> > mif mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/mif
> 
> 
> --
> =========
> IPv6 book: Migrating to IPv6, Wiley. http://www.ipv6book.ca
> Stun/Turn server for VoIP NAT-FW traversal: http://numb.viagenie.ca
> DTN news service: http://reeves.viagenie.ca
> 
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif

---

From: <[email-masked]>
Date: Fri, 28 Aug 2009 11:39:15 +0200

Hi,

Sorry for this email in French sent by error to the ML... The subject is how to refer to monami6 host in MIF definition. I wished to get consensus with Nicolas and Marc before notifying the ML...

BR,
Pierrick

> De : [email-masked] [mailto:[email-masked]] De la part de
> [email-masked]
> Envoyé : vendredi 28 août 2009 10:50
> À : [email-masked]; [email-masked]
> Cc : [email-masked]
> En fait, la definition du "MIF host" est déjà compatible avec la
> définition monami6. La problématique MIF intervient dés que plusieurs
> adresses IP sont utilisées:
> 
> Extrait de la section 2:
> 
> Je pense donc qu'une référence au draft monami6 pourrait suffire. Je
> propose de modifier la section " 3.3. Mobility and other IP protocols"
> comme suit:
> 
> This document assumes hosts only implementing [RFC1122] for IPv4 and
> [RFC4294] for IPv6, and not using any kind of new transport protocols. If
> definition of MIF host presents similarities with multihomed nodes [ietf-
> monami6-multihoming-motivation-scenario], it is not required for the host
> to support additional IP mobility or multihoming protocols, such as SHIM6,
> SCTP, Mobile IP, HIP, RRG, LISP or else.  Moreover, the peer of the
> connection is also not required to use these mechanisms.
> 
>    o  as per [ietf-monami6-multihoming-motivation-scenario], a MIF host is
> configured with more than one IP addresses (excluding loopback, link-
> local)
> 
> 
> Commentaires?
> 
> A+
> Pierrick
>

---

From: Scott Brim <[email-masked]>
Date: Fri, 28 Aug 2009 08:51:40 -0400

Excerpts from Nicolas Montavont on Thu, Jul 30, 2009 01:58:35PM +0200:
> In the same sense, I think that the bullet "Communications using
> these IP addresses may happen simultaneous and independently."
> should not be in the definition, but again, in some explanations of
> scenarios.

Everything you say is fine with me except this.  This sentence does
not refer to actual simultaneous/independent use, which could go in
scenarios.  Rather it says "may happen", i.e. the endpoint has
arranged to be _capable_ of using multiple addresses simultaneously
and independently -- through enabling and configuring interfaces.
When that is done, the MIF problem arises.  If addresses are only used
sequentially, there need not be a MIF problem.  So this sentence
describes an essential part of the problem, and I think it should be
retained.

Scott

---

From: Scott Brim <[email-masked]>
Date: Fri, 28 Aug 2009 08:57:25 -0400

>    o  as per [ietf-monami6-multihoming-motivation-scenario], a MIF host is configured with more than one IP addresses (excluding loopback, link-local) 

IMHO MIF scope is not just mobile, so it's better to adopt and
generalize the text for MIF.  

Scott

---

From: <[email-masked]>
Date: Fri, 28 Aug 2009 15:36:22 +0200

> generalize the text for MIF.

Agreed. That's the idea.

---

From: Zhen Cao <[email-masked]>
Date: Sun, 30 Aug 2009 16:20:54 +0800

But there is a conflict between "generalization" and "specification".
There were many email discussions that would like to generalize the
scope of this WG, but it seems when we try to generalize the problem,
it becomes not so specific. Anyway, I would like to know how do you
want to generalize the text.

Thanks and regards,
Zhen