Subject: [mif] problem-statement: api

From: Marc Blanchet <[email-masked]>
Date: Mon, 09 Nov 2009 15:55:44 +0900

Hi,
  following the two comments on the mic about adding some text in the PS 
about API/Connection manager, here is first text proposal that would be 
added to section 5.

"Some implementations, specially in the mobile world, have higher-level 
API and/or connection managers. These mechanisms are not standardized 
and do not necessarily behave the same way in the presence of the MIF 
problems. Therefore, a standard API could be considered."

Please put more meat around the bone...

Regards, Marc.

---

From: <[email-masked]>
Date: Mon, 9 Nov 2009 17:25:07 +0100

Hi,

I couldn't attend the meeting, so I don't know exactly what it has been said. However, I agree the ps should address API/Connection manager. Actually, I think this feature is worth a dedicated section. So, based on Marc's proposal, I'd propose the following text, please feel free to comment/modify: 

x. Connection management

Some implementations, specially in the mobile world, have higher-level
API, and/or connection managers, to address IP configuration issues in a context of multiple provisioning domains. Depending on the implementation, and/or OS, these mechanisms do not necessarily behave the same way in the presence of the MIF problems [draft-ietf-mif-current-practices]. Therefore, at least, standardization of such an API should be considered in order to facilitate implementation of mechanisms addressing MIF issues. In the same way, harmonized behaviour of connection manager across different implementations and/or OS would bring more consistency for MIF users; in such a case, standardization of a framework for connection manager, would be valuable. 

Then in section 5, I'd reword a little bit the Marc's text:

* When available, implementation of multiple interfaces API and/or connection managers do not necessarily behave the same way in the presence of the MIF problems. API and/or framework for connection managers should be standardized for the sake of harmonization in addressing MIF issues. 

Feel free to comment.

Regards,
Pierrick

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de Marc
> Blanchet
> Envoyé : lundi 9 novembre 2009 07:56
> À : [email-masked]
> Objet : [mif] problem-statement: api
> 
> Hi,
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif

---

From: Miika Komu <[email-masked]>
Date: Mon, 09 Nov 2009 19:47:35 +0200

[email-masked] wrote:

Hi,

I have sent this link earlier to this mailing list but there was no 
discussion or comments:

http://tools.ietf.org/html/draft-ietf-shim6-multihome-shim-api
http://www.ietf.org/mail-archive/web/mif/current/msg00549.html

Would it be possible to have a section referencing this work in the 
problem statement draft? The draft is all about multihoming and APIs 
after all.

---

From: Kevin Chin <[email-masked]>
Date: Mon, 9 Nov 2009 10:19:22 -0800

Hi-

Re: "API and/or framework for connection managers should be standardized for
the sake of harmonization in addressing MIF issues"

Why is there a need to address the API space? There is a big difference from
Problem Statement definition and API standardization.

regards,
Kevin

On Mon, Nov 9, 2009 at 8:25 AM, <[email-masked]> wrote:

>
> Hi,
>
> I couldn't attend the meeting, so I don't know exactly what it has been
> said. However, I agree the ps should address API/Connection manager.
> Actually, I think this feature is worth a dedicated section. So, based on
> Marc's proposal, I'd propose the following text, please feel free to
> comment/modify:
>
> x. Connection management
>
> API, and/or connection managers, to address IP configuration issues in a
> context of multiple provisioning domains. Depending on the implementation,
> and/or OS, these mechanisms do not necessarily behave the same way in the
> presence of the MIF problems [draft-ietf-mif-current-practices]. Therefore,
> at least, standardization of such an API should be considered in order to
> facilitate implementation of mechanisms addressing MIF issues. In the same
> way, harmonized behaviour of connection manager across different
> implementations and/or OS would bring more consistency for MIF users; in
> such a case, standardization of a framework for connection manager, would be
> valuable.
>
> * When available, implementation of multiple interfaces API and/or
> connection managers do not necessarily behave the same way in the presence
> of the MIF problems. API and/or framework for connection managers should be
> standardized for the sake of harmonization in addressing MIF issues.
>
> Feel free to comment.
>
> Regards,
> Pierrick
>

---

From: Zhen Cao <[email-masked]>
Date: Tue, 10 Nov 2009 12:10:07 +0800

Hi,

Although i was not at the meeting site, i attended the meeting using
the audio streaming service and was clear that people agreed to
elaborate the API issues more clearly in the PS draft.

There is a subsection 3.6 talking about socket API, you might want to
merge your text into that section? For the text you provided, I
suggest we describe in a way that is more problem oriented. IMO, the
problem is two fold, (a) we do not have advanced API to support some
MIF features and (b) different implementations deliver different
higher level API, so there is a harmonization problem between them.

I provided the text as follows:

"First, TCP/IP stack currently does not provide advanced API to
specify the source IP address or to set preferences on the address
selection policies for both IPv4 and IPv6 address family. Secondly,
differently operation system implementations delivery different set of
high level API, some exported with connection managers to address
connection issues to multiple provisioning domains. These mechanisms
do not necessarily behave the same way in the presence of the MIF
problems [draft-ietf-mif-current-practices]. This results in the
inconsistence problem and makes application developers confused when
they want to develop application across different platforms"

-Z

---

From: <[email-masked]>
Date: Tue, 10 Nov 2009 10:00:28 +0100

Hi Mika,

Sorry for having missed your first email. That's a good input we can refer to, but without focusing in shim specific issue. If no objection from the WG, we could include the reference into the API section we are currently discussing. Thanks.

Regards,
Pierrick

> De : Miika Komu [mailto:[email-masked]]
> Envoyé : lundi 9 novembre 2009 18:48
> À : SEITE Pierrick RD-RESA-REN
> Cc : [email-masked]; [email-masked]
> Objet : Re: [mif] problem-statement: api
> 
> presence of the MIF problems [draft-ietf-mif-current-practices].
> Therefore, at least, standardization of such an API should be considered
> in order to facilitate implementation of mechanisms addressing MIF issues.
> In the same way, harmonized behaviour of connection manager across
> different implementations and/or OS would bring more consistency for MIF
> users; in such a case, standardization of a framework for connection
> manager, would be valuable.
> >
> of the MIF problems. API and/or framework for connection managers should
> be standardized for the sake of harmonization in addressing MIF issues.
> >
> > Feel free to comment.
> >
> > Regards,
> > Pierrick
> >

---

From: <[email-masked]>
Date: Tue, 10 Nov 2009 10:35:52 +0100

Hi Kevin,
 
Actually we have already an API section in the ps draft, even if standardization of the API is not in the current MIF charter. FMU of meeting discussion, the idea is just to improve the actual API section with some words about issues with having disparate API behaviour across different OS; and, at least, stress that multi-platform applications using such an API (e.g. connection managers) would take benefit from standardization in the field. 
 
Regards,
Pierrick
 
________________________________

De : Kevin Chin [mailto:[email-masked]] 
Envoyé : lundi 9 novembre 2009 19:19
À : SEITE Pierrick RD-RESA-REN
Cc : [email-masked]; [email-masked]
Objet : Re: [mif] problem-statement: api
 
Hi-
 
Re: "API and/or framework for connection managers should be standardized for the sake of harmonization in addressing MIF issues"
 
Why is there a need to address the API space? There is a big difference from Problem Statement definition and API standardization.
 
regards,
Kevin

Hi,

x. Connection management

Feel free to comment.

Regards,
Pierrick

---

From: <[email-masked]>
Date: Tue, 10 Nov 2009 11:15:01 +0100

Hi,

> De : Zhen Cao [mailto:[email-masked]]
> Envoyé : mardi 10 novembre 2009 05:10
> merge your text into that section? 

You're right.

For the text you provided, I
> higher level API, so there is a harmonization problem between them.

That makes sense, thanks.