Subject: [mif] FW: New Version Notification for draft-dec-dhcpv6-route-option-04

From: Wojciech Dec <[email-masked]>
Date: Mon, 12 Jul 2010 11:45:40 +0200

Hi All,

We have posted an updated version of the DHCPv6 route option, which
incorporates several important changes:
- Clarification/simplification of the scenario addressed
- Change of option usage rules, in accordance with rfc3315
- Change of option structure to allow extensibility.

http://www.ietf.org/id/draft-dec-dhcpv6-route-option-04.txt

We welcome comments and feedback on the draft.

Regards.
Woj.

------ Forwarded Message
From: IETF I-D Submission Tool <[email-masked]>
Date: Mon, 12 Jul 2010 02:41:00 -0700 (PDT)
Subject: New Version Notification for draft-dec-dhcpv6-route-option-04

A new version of I-D, draft-dec-dhcpv6-route-option-04.txt has been
successfully submitted by Wojciech Dec and posted to the IETF repository.

Filename:  draft-dec-dhcpv6-route-option
Revision:  04
Title:   DHCPv6 Route Options
Creation_date:  2010-07-12
WG ID:   Independent Submission
Number_of_pages: 13

Abstract:
This document describes the DHCPv6 Route Options for provisioning
IPv6 routes on a DHCPv6 client.  This is expected to improve the
ability of an operator to configure and influence a client's ability
to pick an appropriate route to a destination when this client is
multi-homed and where other means of route configuration may be
impractical.  The options are primarily envisaged for configuring a
broadband Residential Gateway (RG) router, but are generic enough to
be used by other types of DHCPv6 clients that have basic host routing
capabilities.

The IETF Secretariat.

------ End of Forwarded Message

---

From: <[email-masked]>
Date: Fri, 23 Jul 2010 12:32:05 +0200

Hi,

Thank you for this draft. Few observations:

Would this I-D benefit of multi-homed host based example (where host is configured to favor e.g. one interface for default traffic and the other interface for selected traffic)? 

Section 3 mentions router 2 may belong to different ISP than router 1. However, the document did not make it clear that the DHCPv6 client should ask for routing information from all of its network connections (DHCPv6 servers of ISP 1 and 2). Is that obvious or should it be clarified? It might be that in case of fixed network a single DHCPv6 server could provide all information (ISP 1 and 2 collaborating), but in case of mobile hosts that is not doable.

Can the single prefix on OPTION_RT_PREFIX be also ::/0 to indicate preferred default route? Or is the intent to use RFC4191 to convey the default route information?

Best regards,

Teemu

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext Wojciech Dec
> Sent: 12. heinäkuuta 2010 12:46
> To: [email-masked]
> Subject: [mif] FW: New Version Notification for draft-dec-dhcpv6-route-
> option-04
> 
> Hi All,
> 
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif

---

From: Wojciech Dec <[email-masked]>
Date: Fri, 23 Jul 2010 13:06:51 +0200

Hi Teemu,

On 23/07/2010 12:32, "[email-masked]"
<[email-masked]> wrote:

> Would this I-D benefit of multi-homed host based example (where host is
> configured to favor e.g. one interface for default traffic and the other
> interface for selected traffic)?

Woj> Yes, absolutely. The motivational scenario we have in the draft depicts
a router, but the mechanism is equally applicable to a suitably capable
host.

> 
> Section 3 mentions router 2 may belong to different ISP than router 1.
> However, the document did not make it clear that the DHCPv6 client should ask
> for routing information from all of its network connections (DHCPv6 servers of
> ISP 1 and 2). Is that obvious or should it be clarified? It might be that in
> case of fixed network a single DHCPv6 server could provide all information
> (ISP 1 and 2 collaborating), but in case of mobile hosts that is not doable.

Woj> Thanks for the feedback, we will clarify. We've had some reorganization
of the scenarios and the text probably got left over.

> 
> Can the single prefix on OPTION_RT_PREFIX be also ::/0 to indicate preferred
> default route? Or is the intent to use RFC4191 to convey the default route
> information?

Woj> In the draft we do not prescribe any rules/checks for the conveyed
route/prefixes, so it can be anything that makes operational and practical
sense in a given deployment.

-Woj.

---

From: <[email-masked]>
Date: Fri, 23 Jul 2010 13:52:13 +0200

> a router, but the mechanism is equally applicable to a suitably capable

I also read through two other documents of this topic (draft-sarikaya-mif-dhcpv6solution and draft-sun-mif-route-config-dhcp6). Let's see how things end up next week, but if needed I can contribute some text for this.

> sense in a given deployment.

I was checking as the draft says:"Route Prefix Option is used to convey information about a single prefix that represents destination network, reachable via certain router. ", but then again, the ::/0 is a single prefix:)

Teemu