Subject: Re: [mif] Preferring IPv4 interface over IPv6 interface? A problem to be covered?

From: <[email-masked]>
Date: Sun, 8 Aug 2010 09:48:08 +0200

Hi,

The scenario I have in my mind is following.

The current very common practice is that single homed mobile phones select WLAN over cellular if both kinds of networks are reachable.

Now if the mobile phone becomes multihomed, it will dynamically choose for each transport session which interface to use (assuming both are "default").

If the cellular operator is quicker to deploy IPv6 than WLAN operator, it might become a problem that host favors cellular interface too much: from cellular operator and maybe from user point of view as well (this relates to "traffic offloading"). This may be even exaggerated by NAT64 in IPv6-only cellular access making all IPv4 internet look like being reachable over IPv6 (but for this case we are also working in behave to enable host detect NAT64 and downprioritize IPv6 addresses with ISP NAT64 prefix).

Hence in such scerios - for operational and cost reasons - we think there might be need for hosts to prefer IPv4 over IPv6 for "bulk traffic" (when application does not care - of course always on apps, listeners, P2P etc may prefer IPv6 still).

Best regards,

Teemu

----- Original message -----
> On 2010-08-08 15:02, Ted Lemon wrote:
> > On Aug 7, 2010, at 6:57 PM, Brian E Carpenter wrote:
> > > There's nothing to prevent such a mechanism also
> > > defining interface preferences.
> >
> > Yes, there is.    Presumably, if there is some difference between the
> interfaces, it will be because each interface is connected to a network
> managed by a different entity.    Thus, there is no reasonable basis for
> assuming that what either entity defines as a policy is in fact valid
> for the node.
>
> That could well be, in which case the host's own policy should
> predominate.
> I guess my point is that we don't know the deployment scenario, so we
> need
> mechanisms that can be applied in a wide range of scenarios, not just
> yours
> or mine.
>
>      Brian
> _______________________________________________
> mif mailing list
> [email-masked]<mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/mif
>

---

From: Zhen Cao <[email-masked]>
Date: Sun, 8 Aug 2010 16:54:27 +0800

Hi

This problem has been discussed in the list before, as
http://www.ietf.org/mail-archive/web/mif/current/msg00700.html
http://www.ietf.org/mail-archive/web/mif/current/msg00701.html

Address selection of the current problem statement may have already
covered this issue implicitly.

-Zhen

On Sun, Aug 8, 2010 at 3:48 PM,  <[email-masked]> wrote:
> The current very common practice is that single homed mobile phones select
> WLAN over cellular if both kinds of networks are reachable.
>
> Now if the mobile phone becomes multihomed, it will dynamically choose for
> each transport session which interface to use (assuming both are "default").
>
> If the cellular operator is quicker to deploy IPv6 than WLAN operator, it
> might become a problem that host favors cellular interface too much: from
> cellular operator and maybe from user point of view as well (this relates to
> "traffic offloading"). This may be even exaggerated by NAT64 in IPv6-only
> cellular access making all IPv4 internet look like being reachable over IPv6
> (but for this case we are also working in behave to enable host detect NAT64
> and downprioritize IPv6 addresses with ISP NAT64 prefix).
>
> Hence in such scerios - for operational and cost reasons - we think there
> might be need for hosts to prefer IPv4 over IPv6 for "bulk traffic" (when
> application does not care - of course always on apps, listeners, P2P etc may
> prefer IPv6 still).
>
> Best regards,
>
> Teemu
>
>> [email-masked]
> [email-masked]

---

From: Ted Lemon <[email-masked]>
Date: Sun, 8 Aug 2010 09:48:13 -0400

> Hence in such scerios - for operational and cost reasons - we think there might be need for hosts to prefer IPv4 over IPv6 for "bulk traffic" (when application does not care - of course always on a…

But in this scenario, what you really want is for the host to prefer the one interface over the other.   The fact that you need it to prefer IPv4 over IPv6 is immaterial--if the situation were reversed, and the WLAN operator were providing IPv6 only, while the mobile operator were only providing IPv4, you would want it to prefer IPv6.

So it doesn't really make sense to talk about this in terms of IPv6 or IPv4--what you want is to be able to prefer one interface over the other.

---

From: <[email-masked]>
Date: Sun, 8 Aug 2010 18:57:28 +0200

What I want is to prefer interface A and IPv6. Now, if interface A does not support IPv6, the device either has to choose a different interface or choose to use IPv4. 
If I stick to the interface and use IPv4, my apps may lose end-to-end connectivity.
If I stick to IPv6 and interface B, I may end up with lower available bandwidth and higher costs.
In a device which can have both interfaces on simultaneously (not practical because of battery consumption), the apps may choose depending on the cost/connectivity factor, but in devices with only one interface active, some apps will suffer.

- gabor

---

From: <[email-masked]>
Date: Mon, 9 Aug 2010 10:32:27 +0200

> > Hence in such scerios - for operational and cost reasons - we think
> there might be need for hosts to prefer IPv4 over IPv6 for "bulk
> traffic" (when application does not care - of course always on apps,
> listeners, P2P etc may prefer IPv6 still).
> 
> But in this scenario, what you really want is for the host to prefer
> the one interface over the other.   The fact that you need it to prefer
> IPv4 over IPv6 is immaterial--if the situation were reversed, and the
> WLAN operator were providing IPv6 only, while the mobile operator were
> only providing IPv4, you would want it to prefer IPv6.
> 
> So it doesn't really make sense to talk about this in terms of IPv6 or
> IPv4--what you want is to be able to prefer one interface over the
> other.

Gabor put it nicely:"What I want is to prefer interface A and IPv6.". 

So indeed you are right, interface sometimes need to be preferred above address family.

Teemu

---

From: Zhen Cao <[email-masked]>
Date: Thu, 12 Aug 2010 23:11:00 +0800

> So indeed you are right, interface sometimes need to be preferred above address family.

If the WLAN is IPv6 only, and cellular is IPv4, to avoid NAT64, it
should prefer cellular, but regarding the interface, it prefers WLAN.
How to decide then?

---

From: Scott Brim <[email-masked]>
Date: Thu, 12 Aug 2010 13:04:45 -0400

> should prefer cellular, but regarding the interface, it prefers WLAN.

What if going through the NAT gives you better throughput than going
native?  You won't know until you actually try.

I suggest avoiding policies that are static (e.g. "prefer v6"), and
using policies that respond to dynamic changes (e.g. "try v4 and v6 and
choose à la http://tools.ietf.org/html/draft-wing-http-new-tech-00").

---

From: <[email-masked]>
Date: Sat, 14 Aug 2010 08:13:05 +0200

> should prefer cellular, but regarding the interface, it prefers WLAN.

The cellular has NAT44 probably anyway (at the time we get output of MIF deployed), hence I would prefer WLAN's NAT64 for default traffic. The application can explicitly bind its socket to IPv4 address if it really cares about used AF.

Teemu