Subject: Re: [mif] Recharter discussion - update again

From: <[email-masked]>
Date: Fri, 10 Sep 2010 14:08:51 +0200

Hi,
 
Maybe it's too late but, if not, I'd propose to rephrase DHCP item as:
 
2) DHCPv6 routing configuration: a specification of DHCPv6 options allowing to provision client nodes with routing information (e.g. regarding first-hop selection).
 
Pierrick
 
________________________________

De : Hui Deng [mailto:[email-masked]] 
Envoyé : mardi 31 août 2010 04:57
À : Margaret Wasserman
Cc : SEITE Pierrick RD-RESA-REN; [email-masked]; [email-masked]; [email-masked]
Objet : Recharter discussion - update again
 
Hi All
 
Update it again, check below:
 
Regards,
 
-Hui
 
1) Split-DNS solution: 
a specification for describing a way for a network to communicate to
nodes information required to perform advanced DNS server selection
in split-DNS deployments. The specification shall describe the
information to be delivered for nodes and the protocol to be used
for delivery.
 
2) DHCPv6 routing configuration: 
a specification of DHCPv6 options allowing client nodes to perform
route table configuration.
 
3) MIF API: 
While no changes are needed for applications to run on multiple 
interface hosts, this API could provide additional services to 
applications running on hosts attached to multiple provisioning 
domains. For instance, these services could help in solving 
first-hop, source address and/or DNS selection issues. 
 
 Goals and Milestones
Nov 2010: Initial WG draft on Split-DNS solution
Nov 2010: Initial WG draft on DHCPv6 option for routing configuration
Nov 2010: Initial WG draft on MIF API extension.   
Nov 2011: Submit Split-DNS solution to IESG for publication as 
 a Proposed Standard RFC
Nov 2011: Submit DHCPv6 routing configuration option to IESG for publication as a
 Proposed Standard RFC 
Nov 2011: Submit MIF API extension solution to IESG for publication
 as an Informational RFC

---

From: Alexandru Petrescu <[email-masked]>
Date: Sat, 11 Sep 2010 14:16:25 +0200

Hello MIF,

I have a particular interest in MIF for simultaneous use of multiple 
egress interfaces for bandwidth augmentation on a Mobile Router.  But it 
is not for this reason I post now.  I post now to ask about Default 
Route delivered to a single-egress-interfaced Mobile Router.  This 
discussion was originated in the MEXT WG upon IESG LC of the 
DHCPv6-PD-NEMO draft, then redirected to DHC WG then MIF WG was 
mentioned too.

Le 31/08/2010 04:56, Hui Deng a écrit :
[...]
> 2) DHCPv6 routing configuration: a specification of DHCPv6 options
> allowing client nodes to perform route table configuration.

Would this item allow for a draft describing the way in which
DHCPv6(/-PD) assigns a Default Route to a single-egress-interfaced
Mobile Router?

My problem is a Mobile Router connected on the home link.  It acquires a
prefix (the Mobile Network Prefix) using DHCPv6-PD.  Being a Router it
doesn't configure a default route from SLAAC (if I want it to I have to
switch it from Router to Host - burdensome).  DHCPv6 doesn't deliver it
a Default Route either.  So I am left with a nice machine without a
default route - I have to manually configure it.

I could write a draft telling that DHCPv6 option is delivered to a
single-egress-interfaced Mobile Router and allows it to configure a
default route.  Would this draft fit within this potential Charter item?

Any comments appreciated: is this kind of work appropriate here?  Is
another alternative work (like DHCPv6 tells Router to acquire this from
SLAAC, and modify SLAAC)?  Could this be adapted to MIF by saying there
_could_ be multiple such egress interfaces each with its own default
route (hard, there should be only one default - the last resort)?

Any comments appreciated about how to set a default route on a Mobile
Router single-egress interface.

Alex

> 3) MIF API: While no changes are needed for applications to run on
> multiple interface hosts, this API could provide additional services
> to applications running on hosts attached to multiple provisioning
> first-hop, source address and/or DNS selection issues. Goals and
> Milestones Nov 2010: Initial WG draft on Split-DNS solution Nov 2010:
> Initial WG draft on DHCPv6 option for routing configuration Nov 2010:
> Initial WG draft on MIF API extension. Nov 2011: Submit Split-DNS
> solution to IESG for publication as a Proposed Standard RFC Nov 2011:
> Submit DHCPv6 routing configuration option to IESG for publication as
> a Proposed Standard RFC Nov 2011: Submit MIF API extension solution
> to IESG for publication as an Informational RFC
>
>
>
> _______________________________________________ mif mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/mif

---

From: Maglione Roberta <[email-masked]>
Date: Mon, 13 Sep 2010 10:44:09 +0200

Hello Alex,
      There was a draft sometimes ago about a new DHCPv6 option for the default route
http://tools.ietf.org/html/draft-droms-dhc-dhcpv6-default-router-00

the draft now seems expired, but I remember a long religious discussion about DHCPv6 versus RA to provide the default route.

Regards,
Roberta

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: sabato 11 settembre 2010 14.16
To: [email-masked]
Subject: Re: [mif] Default Route with DHCPv6 on a single-egress-interfaced Mobile Router (was: Recharter discussion - update again)

Hello MIF,

Alex

> [email-masked] https://www.ietf.org/mailman/listinfo/mif

_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

Questo messaggio e i suoi allegati sono indirizzati esclusivamente alle persone indicate. La diffusione, copia o qualsiasi altra azione derivante dalla conoscenza di queste informazioni sono rigorosamente vietate. Qualora abbiate ricevuto questo documento per errore siete cortesemente pregati di darne immediata comunicazione al mittente e di provvedere alla sua distruzione, Grazie.

This e-mail and any attachments is confidential and may contain privileged information intended for the addressee(s) only. Dissemination, copying, printing or use by anybody else is unauthorised. If you are not the intended recipient, please delete this message and any attachments and advise the sender by return e-mail, Thanks.

---

From: Hui Deng <[email-masked]>
Date: Mon, 13 Sep 2010 22:31:36 +0800

Hello Alex,

Before discussion, just wondering whether you have read the draft before
http://tools.ietf.org/html/draft-dec-dhcpv6-route-option-03
Whether this draft solve your issue or not?

People from different drafts are working on the merged solution recently,

thanks

-Hui

2010/9/11 Alexandru Petrescu <[email-masked]>

> Hello MIF,
>
> I have a particular interest in MIF for simultaneous use of multiple egress
> interfaces for bandwidth augmentation on a Mobile Router.  But it is not for
> this reason I post now.  I post now to ask about Default Route delivered to
> a single-egress-interfaced Mobile Router.  This discussion was originated in
> the MEXT WG upon IESG LC of the DHCPv6-PD-NEMO draft, then redirected to DHC
> WG then MIF WG was mentioned too.
>

---

From: Brian Haley <[email-masked]>
Date: Mon, 13 Sep 2010 10:48:27 -0400

> Router single-egress interface.

Not sure if this recent Linux change to relax the accepting of RAs to
include routers helps you at all, but from what I've read of these
threads you're running Linux.

http://marc.info/?l=linux-netdev&m=128351876712207&w=2

Of course more than just this change would be needed, but it seems
as though others are wanting to at least look at RAs on a router.

-Brian

---

From: Zhen Cao <[email-masked]>
Date: Mon, 13 Sep 2010 15:11:21 -1000

Hi Perrick,

I do not understand what's the major difference between your proposal
text and the original one.  Do you want to emphasize the "first hop"
selection?

Regards,
Zhen

On Fri, Sep 10, 2010 at 2:08 AM,  <[email-masked]> wrote:
> 2) DHCPv6 routing configuration: a specification of DHCPv6 options allowing
> to provision client nodes with routing information (e.g. regarding first-hop
> selection).
>
>
>
> Pierrick
>
>
>

---

From: <[email-masked]>
Date: Wed, 15 Sep 2010 16:28:43 +0200

Hi,

> -----Message d'origine-----
> De : Zhen Cao [mailto:[email-masked]]
> Envoyé : mardi 14 septembre 2010 03:11
> À : SEITE Pierrick RD-RESA-REN
> Cc : [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> Objet : Re: [mif] Recharter discussion - update again
> 
> Hi Perrick,
> 

Yes, that's the idea.  

Pierrick

> allowing
> > Nov 2011: Submit DHCPv6 routing configuration option to IESG for
> publication
> > as a
> >  Proposed Standard RFC

---

From: Zhen Cao <[email-masked]>
Date: Wed, 15 Sep 2010 16:35:02 -1000

do we really have to restrict that?  DHCP cannot be used to deliver
full routing information for sure.

---

From: <[email-masked]>
Date: Thu, 16 Sep 2010 09:54:40 +0200

Hi,

> Envoyé : jeudi 16 septembre 2010 04:35
> do we really have to restrict that?  

I don't want to restrict anything, just highlight the use-case where DHCP is used to push information allowing the node to make its own decision regarding first-hop.  

Regards,
Pierrick
 
DHCP cannot be used to deliver

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 16 Sep 2010 18:59:56 +0200

Le 13/09/2010 10:44, Maglione Roberta a écrit :
> Hello Alex, There was a draft sometimes ago about a new DHCPv6 option
> for the default route
> the draft now seems expired, but I remember a long religious
> discussion about DHCPv6 versus RA to provide the default route.

Thanks for the pointer!  No, I was not aware of that draft and related 
discussion.

I have comments on it:

> 5.1. DHCP Default Router option
>
>
>    The DHCP Default Router option carries the following information:
>
>    o  Address of the interface for a default router

What is "address of an interface for a default router"?
Or is it"address of the interface of a default router"?

>    o  Source link-layer address for the interface (opt)

I am asking it especially because of this "opt"ional(?) information, 
making it sound like there can be several addresses possible as next-hop 
for a default route entry in the routing table.

>    o  Router lifetime

This is good and needed.

I wonder whether it is necessary to specify text that says that that 
address is actually pre-configured at the DHCP Server configuration file 
(like DHCPv4 does).  I guess it is necessary.

Alex

>
> Regards, Roberta
>
> -----Original Message----- From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Alexandru Petrescu Sent:
> sabato 11 settembre 2010 14.16 To: [email-masked] Subject: Re: [mif]
> Default Route with DHCPv6 on a single-egress-interfaced Mobile Router
> (was: Recharter discussion - update again)
>
> Hello MIF,
>
> egress interfaces for bandwidth augmentation on a Mobile Router.  But
> it is not for this reason I post now.  I post now to ask about
> Default Route delivered to a single-egress-interfaced Mobile Router.
> This discussion was originated in the MEXT WG upon IESG LC of the
> Le 31/08/2010 04:56, Hui Deng a écrit : [...]
> My problem is a Mobile Router connected on the home link.  It
> acquires a prefix (the Mobile Network Prefix) using DHCPv6-PD.  Being
> a Router it doesn't configure a default route from SLAAC (if I want
> it to I have to switch it from Router to Host - burdensome).  DHCPv6
> doesn't deliver it a Default Route either.  So I am left with a nice
> machine without a default route - I have to manually configure it.
>
> another alternative work (like DHCPv6 tells Router to acquire this
> from SLAAC, and modify SLAAC)?  Could this be adapted to MIF by
> saying there _could_ be multiple such egress interfaces each with its
> own default route (hard, there should be only one default - the last
> resort)?
>
> Any comments appreciated about how to set a default route on a
> Mobile Router single-egress interface.
>
> Alex
>
>> multiple interface hosts, this API could provide additional
>> services to applications running on hosts attached to multiple
>> provisioning domains. For instance, these services could help in
>> solving first-hop, source address and/or DNS selection issues.
>> Goals and Milestones Nov 2010: Initial WG draft on Split-DNS
>> solution Nov 2010: Initial WG draft on DHCPv6 option for routing
>> configuration Nov 2010: Initial WG draft on MIF API extension. Nov
>> 2011: Submit Split-DNS solution to IESG for publication as a
>> Proposed Standard RFC Nov 2011: Submit DHCPv6 routing configuration
>> option to IESG for publication as a Proposed Standard RFC Nov 2011:
>> Submit MIF API extension solution to IESG for publication as an
>> Informational RFC
>>
>>
>>
> Questo messaggio e i suoi allegati sono indirizzati esclusivamente
> alle persone indicate. La diffusione, copia o qualsiasi altra azione
> derivante dalla conoscenza di queste informazioni sono rigorosamente
> vietate. Qualora abbiate ricevuto questo documento per errore siete
> cortesemente pregati di darne immediata comunicazione al mittente e
> di provvedere alla sua distruzione, Grazie.
>
> This e-mail and any attachments is confidential and may contain
> privileged information intended for the addressee(s) only.
> Dissemination, copying, printing or use by anybody else is
> unauthorised. If you are not the intended recipient, please delete
> this message and any attachments and advise the sender by return
> e-mail, Thanks.
>
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 16 Sep 2010 19:02:35 +0200

> Whether this draft solve your issue or not?

In a sense, yes, it does solve in a way the issue: I need a default 
route on a Mobile Router at home and that draft could deliver it.  I may 
have comments on it.

> People from different drafts are working on the merged solution recently,

Hmm... which solution and how recent?  Do you mean that authors of
draft-dec-dhcpv6-route-option-03 and of
draft-droms-dhc-dhcpv6-default-router-00 are about to write a common 
draft?  I am not aware of it.  If and when that happens I am interested 
to comment on it.

Alex

> thanks
> -Hui
>
> 2010/9/11 Alexandru Petrescu <[email-masked]
> <mailto:[email-masked]>>
>
>     Hello MIF,
>
>     egress interfaces for bandwidth augmentation on a Mobile Router.
>       But it is not for this reason I post now.  I post now to ask about
>         [email-masked] <mailto:[email-masked]>

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 16 Sep 2010 19:06:32 +0200

Le 13/09/2010 16:48, Brian Haley a écrit :
>> acquires a prefix (the Mobile Network Prefix) using DHCPv6-PD.
>> Being a Router it doesn't configure a default route from SLAAC (if
>> I want it to I have to switch it from Router to Host -
>> burdensome). DHCPv6 doesn't deliver it a Default Route either.  So
>> I am left with a nice machine without a default route - I have to
>> manually configure it.
>>
>>  single-egress-interfaced Mobile Router and allows it to configure
>> a default route.  Would this draft fit within this potential
>> Charter item?
>>
>> saying there _could_ be multiple such egress interfaces each with
>> its own default route (hard, there should be only one default - the
>> last resort)?
>>

Thanks for the pointer Brian.  Indeed that is the kind of patch I
thought would be needed to make a linux Router get receive RAs and
synthesize a default route out of it.

I have to look at it closely in the lab, and at the same time consider
the necessity of DHCPv6 delivering a default route, and the 'M' flag.

Alex

---

From: Hui Deng <[email-masked]>
Date: Fri, 17 Sep 2010 10:23:38 +0800

Hi Alex,

Inline please

2010/9/17 Alexandru Petrescu <[email-masked]>

> In a sense, yes, it does solve in a way the issue: I need a default route
> on a Mobile Router at home and that draft could deliver it.  I may have
> comments on it.
>
> draft-droms-dhc-dhcpv6-default-router-00 are about to write a common draft?
>  I am not aware of it.  If and when that happens I am interested to comment
> on it.
>
No, it is related to
1) draft-dec-dhcpv6-route-option-03
2) draft-sun-mif-route-config-dhcpv6-02
3) draft-sarikaya-mif-dhcpv6solution
They are going to publish a merged one based on draft-dec-dhcpv6 shortly,
please help to comment on it,

thanks

-Hui

>> services