Subject: [mif] DHCPv6 Route Option - conflict resolution

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Thu, 14 Oct 2010 14:11:40 +0200

Hi,

Following my question regarding possible conflicts between routes 
returned to the host in DHCPv6 reply,
Don't you think we could add something in the Route Prefix Option Format 
to allow to indicate how potential conflicts
with routes should be resolved ?

I would then propose the following conflicts resolution options:

a- Use most recent route received from the conflict set
b- Use last recent route received from the conflict set
c- Use whatever implementation decides

Would a "Keep conflicting routes" option be a valid option ?

It is assumed conflicts need to be resolved only occur if prefixes 
intersect at the same preference level
(the highest preference at the time of conflict).

Just a proposal,
knowing that these issues will be addressed by the working group.

Regards

---

From: Wojciech Dec <[email-masked]>
Date: Thu, 14 Oct 2010 15:21:49 +0200

Hi Bruno,

could you clarify what you mean by "conflicts"? Is it a conflict of routes
for the same destination, learned via different sources/protocols besides
the route-option?
With that in mind we have the "metric" attribute defined, which hosts need
to interpret in relation to metrics from other sources. (note that
previously the metric field was called preference, but the purpose is
similar, ie to differentiate between same destination routes).

Thanks,
Woj.

On 14 October 2010 14:11, Bruno Mongazon-Cazavet <
[email-masked]> wrote:

>  Hi,
>
> Following my question regarding possible conflicts between routes returned
> to the host in DHCPv6 reply,
> Don't you think we could add something in the Route Prefix Option Format to
> allow to indicate how potential conflicts
> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif
>

---

From: Bruno Mongazon-Cazavet <[email-masked]>
Date: Thu, 14 Oct 2010 16:11:14 +0200

Le 14/10/2010 15:21, Wojciech Dec a écrit :
> Hi Bruno,
>
> could you clarify what you mean by "conflicts"? Is it a conflict of 
> routes for the same destination, learned via different 
> sources/protocols besides the route-option?

Yes exactly.

> With that in mind we have the "metric" attribute defined, which hosts 
> need to interpret in relation to metrics from other sources. (note 
> that previously the metric field was called preference, but the 
> purpose is similar, ie to differentiate between same destination routes).

Fine.
So what i call a conflict is when 2 routes with the same destination and 
the same metric value are learned  via different sources.
The most simple case is a default route that would be returned in DHCPv6 
route option following the stateful configuration on each interface.

Thanks - Bruno

>
> Thanks,
> Woj.
>
> On 14 October 2010 14:11, Bruno Mongazon-Cazavet 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>      Hi,
>
>     Don't you think we could add something in the Route Prefix Option
>     Format to allow to indicate how potential conflicts
>     [email-masked] <mailto:[email-masked]>