Subject: [mif] clarification question on draft-savolainen-mif-dns-server-selection

From: Zhen Cao <[email-masked]>
Date: Fri, 19 Nov 2010 16:41:19 +0800

Hi Teemu,

How can I understand "Node" in figure 5 and figure 6.  Is it the host
operation system or connection manager?

In Figure 6, it seems the 'Node' intercepts the DNS query from the
application.  I wonder if the application will determine the
destination (DNS server address) when it calls gethostbyname().

Thank you.

-- 
Best regards,
Zhen

---

From: <[email-masked]>
Date: Fri, 19 Nov 2010 09:57:55 +0100

Hi,

Node herein means just CPE or host (or similar entity). It does not take a stand on internal implementation of a node.

In figure 6 the intent is to show application generally asking for DNS resolution for a name, and then node determining where to send the question. In case node is actually a host, this would be then the entity that implements gethostbyname, or similar call. If the node is CPE, then node has DNS proxy that receives the query from an application running on a separate host and then determines where to proxy the DNS request to.

In either case the application does not need to determine what name server to use. Within scope of this spec the application just asks system for resolution and system decides where the question should be sent to.

Best regards,

Teemu

> -----Original Message-----
> From: ext Zhen Cao [mailto:[email-masked]]
> Sent: 19. marraskuuta 2010 10:41
> To: Savolainen Teemu (Nokia-MS/Tampere); mif
> Subject: clarification question on draft-savolainen-mif-dns-server-
> selection
> 
> Hi Teemu,
>

---

From: Zhen Cao <[email-masked]>
Date: Fri, 19 Nov 2010 17:31:21 +0800

> In figure 6 the intent is to show application generally asking for DNS resolution for a name, and then node determining where to send the question. In case node is actually a host, this would be th…

In case of CPE, if the received query already has the destination IP
address to the DNS server? or you mean the destination address of the
query is the Node (as the proxy)?

-- 
Best regards,
Zhen

---

From: <[email-masked]>
Date: Fri, 19 Nov 2010 10:47:47 +0100

> > In figure 6 the intent is to show application generally asking for
> DNS resolution for a name, and then node determining where to send the
> question. In case node is actually a host, this would be then the
> entity that implements gethostbyname, or similar call. If the node is
> CPE, then node has DNS proxy that receives the query from an
> application running on a separate host and then determines where to
> proxy the DNS request to.
> 

The CPE has told hosts in LAN to send DNS queries to the CPE. Hence the queries arrive to CPE's listener and can then be proxied forward to DNS server CPE selects.

Host can also bypass the CPE's DNS proxy by talking directly to some other DNS servers.

This could work e.g. by CPE telling its own address in OPTION_DNS_SERVERS (or RA) and then the special DNS servers with OPTION_DNS_SERVER_SELECT. Legacy hosts would only talk to proxy on the CPE, which would then forward the queries, but modified hosts could talk directly to special DNS servers.

Best regards,

Teemu

---

From: Zhen Cao <[email-masked]>
Date: Fri, 19 Nov 2010 18:11:43 +0800

> This could work e.g. by CPE telling its own address in OPTION_DNS_SERVERS (or RA) and then the special DNS servers with OPTION_DNS_SERVER_SELECT. Legacy hosts would only talk to proxy on the CPE, w…

understand. Anyway, the node must be on the path of the query.  Thank
you for helping me understand better.

-- 
Best regards,
Zhen

---

From: Hui Deng <[email-masked]>
Date: Fri, 19 Nov 2010 20:45:42 +0800

I still have one further clarification:
1) in CPE case, host configured one internet DNS server,
2) CPE does dpi for corporation's DNS server
3) if host query corporation dns server, CPE will intercept it?

is this correct procedure, anyway, it is different from DNS proxy in CPE.

thanks

-Hui

2010/11/19 Zhen Cao <[email-masked]>

> > The CPE has told hosts in LAN to send DNS queries to the CPE. Hence the
> queries arrive to CPE's listener and can then be proxied forward to DNS
> server CPE selects.
> >
> > This could work e.g. by CPE telling its own address in OPTION_DNS_SERVERS
> (or RA) and then the special DNS servers with OPTION_DNS_SERVER_SELECT.
> Legacy hosts would only talk to proxy on the CPE, which would then forward
> the queries, but modified hosts could talk directly to special DNS servers.
>
>  _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif
>

---

From: <[email-masked]>
Date: Fri, 19 Nov 2010 14:33:57 +0100

I haven't heard of that kind of plans. Probably far easier for CPE to configure hosts to use CPE's own address as DNS server address rather than trying to do dpi. And then choose which uplink DNS server to forward the query based on the suffix of FQDN.

Best regards,

Teemu

From: ext Hui Deng [mailto:[email-masked]]
Sent: 19. marraskuuta 2010 14:46
To: Zhen Cao
Cc: Savolainen Teemu (Nokia-MS/Tampere); [email-masked]
Subject: Re: [mif] clarification question on draft-savolainen-mif-dns-server-selection

thanks

-Hui
2010/11/19 Zhen Cao <[email-masked]<mailto:[email-masked]>>

--
Best regards,
Zhen
_______________________________________________
mif mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/mif

---

From: Hui Deng <[email-masked]>
Date: Fri, 19 Nov 2010 22:32:30 +0800

so in case of cpe, host will never use internet DNS server address,

2010/11/19 <[email-masked]>

>  I haven’t heard of that kind of plans. Probably far easier for CPE to
> configure hosts to use CPE’s own address as DNS server address rather than
> trying to do dpi. And then choose which uplink DNS server to forward the
> query based on the suffix of FQDN.
>
>
>
> Best regards,
>
>
>
> Teemu
>
>
>
> *From:* ext Hui Deng [mailto:[email-masked]]
> *Sent:* 19. marraskuuta 2010 14:46
> *To:* Zhen Cao
> *Cc:* Savolainen Teemu (Nokia-MS/Tampere); [email-masked]
> *Subject:* Re: [mif] clarification question on
> draft-savolainen-mif-dns-server-selection
>
>
>