Subject: Re: [mif] Revised DHCPv6 Route Option draft

From: Hui Deng <[email-masked]>
Date: Sun, 7 Nov 2010 11:45:24 +0800

Woj,

Could you help to cover this in your presentation about default or not?

thanks,

-Hui

2010/10/30 Alexandru Petrescu <[email-masked]>

> Le 29/10/2010 17:44, Hui Deng a écrit :
> [...]
>
>  I do not yet understand how multiple interfaces are necessary to
>>> DHCPv6 default routes.
>>>
>>
>> so you believe multiple interfaces are necessary to dhcp route but
>> not default routes?
>>
>
> In a sense yes: I think dhcp route extensions are more necessary (than
> default route) in a multiply-interfaced Host.  I don't see how the
> default route extension of dhcp is necessary for a multiply-interfaced
> Host.
>
> I can not understand a DHCP Server/Relay connected on interface1 of Host
> to tell its default route should be the other interface2.
>
> A multiply-interfaced Host would connect to two different domains whose
> DHCP Servers couldn't know each other.  It would be difficult for one
> DHCP Server of one domain to indicate Host what to do in the other domain.
>
> Alex
>
> -Hui
>>
>>
>> Alex
>>
>> thanks -Hui
>>
>>
>>
>>
>

---

From: Arifumi Matsumoto <[email-masked]>
Date: Sun, 7 Nov 2010 15:16:33 +0900

Hi,

On 2010/10/31, at 0:44, Alexandru Petrescu wrote:

> default route extension of dhcp is necessary for a multiply-interfaced Host.
> 

I think you raise two issues here.

1. why DHCP route option can deliver default route.
2. cross-boundary reference of the next-hop. That is, a dhcp route
  option delivers a route that points to a next-hop that
  belongs to another domain.

Regarding 1,
I don't see why you think the default route special.

If we look at RA, it can, of course, deliver a default route,
as well as specific routes that are enabled by RFC 4191.

If an upstream network provides connectivity to the Internet,
then it provides a default route. If not, it should not do so.

The metric field of each route should be useful if the multiple
upstream networks are in the same administrative domain, which
is what RFC 4191 assumes in my understanding, and even if they
are not in the same administrative domain, it can serve as hints
to the hosts for traffic engineering purpose.

Regarding 2,
here again, you seem to see the default route as the only problem.
I don't see why you see the default route as a special problem.
I'm wondering if a more specific route can/should cross boudary ?

---

From: Wojciech Dec <[email-masked]>
Date: Tue, 9 Nov 2010 11:05:28 +0800

Fully agree with Arifumi.

The DHCPv6 route option draft does not, and should not, preclude the
configuration of a routing setup allowed for in the IP routing architecture,
which is different from actually wanting to have/use a particular set-up.

Regards,
Wojtek.

On 7 November 2010 14:16, Arifumi Matsumoto <[email-masked]> wrote:

> _______________________________________________
> mif mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mif
>