Subject: [mif] I-D Action: draft-ietf-mif-mpvd-arch-04.txt

From: [email-masked]
Date: Fri, 12 Sep 2014 17:25:10 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Multiple Interfaces Working Group of the IETF.

        Title           : Multiple Provisioning Domain Architecture
        Author          : Dmitry Anipko
	Filename        : draft-ietf-mif-mpvd-arch-04.txt
	Pages           : 23
	Date            : 2014-09-12

Abstract:
   This document is a product of the work of the MIF Architecture Design
   team.  It outlines a solution framework for some of the issues
   experienced by nodes that can be attached to multiple networks
   simultaneously.  The framework defines the concept of a Provisioning
   Domain (PvD) which is a a consistent set of network configuration
   information.  PvD aware nodes learn PvD specific information from the
   networks they are attached to and / or other sources.  PvDs are used
   to enable separation and configuration consistency in presence of
   multiple concurrent connections.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mif-mpvd-arch/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-mif-mpvd-arch-04

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-mif-mpvd-arch-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dmitry Anipko <[email-masked]>
Date: Sat, 13 Sep 2014 00:29:48 +0000

This revision includes changes suggested by Ian Farrer per language review (thanks Ian!), and list of contributors as provided by the WG chairs.

Thank you.

-----Original Message-----
From: mif [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, September 12, 2014 5:25 PM
To: [email-masked]
Cc: [email-masked]
Subject: [mif] I-D Action: draft-ietf-mif-mpvd-arch-04.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
mif mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mif

---

From: Ian Farrer <[email-masked]>
Date: Mon, 15 Sep 2014 10:10:53 +0200

Hi,

One additional question that arose whilst I was reviewing the document is from the end of P1 in section 3.4:

One way this could be accomplished is by using a DHCPv6 ORO containing the PvDs that are of interest.
The configuration source can then respond with only the requested information.

I think that the language here is incorrect. The ORO is a list of option codes and this doesn’t have any way of including specific PvDs (unless each PvD was defined as a DHCP option in its own right, which seems unworkable). I guess that the real intension here is to have a new DHCP option which carries information about requested/available PvDs, and for the client to include the option code for this in the ORO. 

If so, proposed new text:

One way this could be accomplished is by using a new DHCPv6 option containing the PvDs that are of interest.
The configuration source can then respond with only the requested information.

Cheers,
Ian