Subject: [mif] Questions on MIF in vehicle environment

From: "[email-masked]" <[email-masked]>
Date: Mon, 15 Sep 2014 19:08:31 +0800

Hi, Folks: 

It has been a long time since I posted something in this list last time. 
Recently, I am doing a project related to intelligent driving and maintenance, which may need the help from this list. 
Basically, one embedded HW platform will be put inside the vehicles. And, GSM, UMTS, WiFi have already been supported. In the near future, we will think of integrating TD-LTE and C2X modules. 
In this application scenario, quite a few sessions with diverse requirements on bandwidth, routing, security, jitter, and reliability should be supported. In the meantime, the connections are quite dynamic along the driving route. Our current NIC management function is not so optimized, and has some negative impact on the service quality. 
Is there any open-source MIF implementation could be available now days? And, our current HW is already very constrained in CPU/Mem resources, so that the implementation should be well optimized for ARM/Linux. 

Your help is greatly appreciated. 
BR
Peny YANG

---

From: <[email-masked]>
Date: Mon, 15 Sep 2014 11:17:28 +0000

Hi Peny,

It would be worth to consider NEMO (RFC 3963) for your use-case; open source available here: http://www.umip.org/ 

Hope that helps,
Pierrick

>-----Message d'origine-----
>De : mif [mailto:[email-masked]] De la part de
>[email-masked]
>Envoyé : lundi 15 septembre 2014 13:09
>À : [email-masked]
>Objet : [mif] Questions on MIF in vehicle environment
>
>Hi, Folks:
>
>Basically, one embedded HW platform will be put inside the vehicles. And,
>GSM, UMTS, WiFi have already been supported. In the near future, we will
>think of integrating TD-LTE and C2X modules.
>In this application scenario, quite a few sessions with diverse requirements on
>bandwidth, routing, security, jitter, and reliability should be supported. In the
>meantime, the connections are quite dynamic along the driving route. Our
>current NIC management function is not so optimized, and has some negative
>impact on the service quality.
>Is there any open-source MIF implementation could be available now days?
>And, our current HW is already very constrained in CPU/Mem resources, so
>that the implementation should be well optimized for ARM/Linux.
>
>_______________________________________________
>mif mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/mif

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 15 Sep 2014 19:31:41 +0800

Hi, Pierrick:

Cool. Your help is greatly appreciated. I will let my man to check it. 

Many thanks
Regards,
Peny

发自我的 iPad

> 在 2014年9月15日，19:17，<[email-masked]> 写道：
> 
> Hi Peny,
>

---

From: Jong-Hyouk Lee <[email-masked]>
Date: Mon, 15 Sep 2014 21:38:16 +0900

Peny, you might be interested in https://project.inria.fr/itssv6/ 
--
Jong-Hyouk Lee, living somewhere between /dev/null and /dev/random
Protocol Engineering Lab., Sangmyung University

#email: [email-masked]
#webpage: https://sites.google.com/site/hurryon

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 15 Sep 2014 16:21:32 +0200

Le 15/09/2014 13:08, [email-masked] a écrit :
> Hi, Folks:
>
> It has been a long time since I posted something in this list last
> time. Recently, I am doing a project related to intelligent driving
> and maintenance, which may need the help from this list. Basically,
> one embedded HW platform will be put inside the vehicles. And, GSM,
> UMTS, WiFi have already been supported. In the near future, we will
> think of integrating TD-LTE and C2X modules. In this application
> scenario, quite a few sessions with diverse requirements on
> bandwidth, routing, security, jitter, and reliability should be
> supported. In the meantime, the connections are quite dynamic along
> the driving route. Our current NIC management function is not so
> optimized, and has some negative impact on the service quality. Is
> there any open-source MIF implementation could be available now days?
> And, our current HW is already very constrained in CPU/Mem resources,
> so that the implementation should be well optimized for ARM/Linux.
>
> Your help is greatly appreciated. BR Peny YANG

Hello,

It all depends of which particular functionality is needed in realizing
this intelligent driving and maintenance, and at which layer.

At the software driver level, open-source software exists for most NICs 
on the market.  There are also some less open sources for 802.11p 
drivers (which one can call C2X).

At the networking layer, almost everything needed is available as 
open-source: IPv4 and IPv6 stacks in linux, umip.org implementation of 
Mobile IPv6, dynamics implementation of Mobile IPv4, NAT masquerading in 
the kernel for IPv4 and IPv6, DHCPv4 and DHCPv6 clients, relays and servers.

At the application layer, there is very little available as open source. 
  These applications are developped very quickly in rapid development 
environments such as java, remote procedure calls, eclipse and more. 
The tools to develop such application software _are_ open source - it is 
the same as for desktop environments.  Along these lines I saw recent 
announcements: BMW CarIT, Automotive Grade Android, Xen hypervisor, 
GENIVI, Apple CarPlay, Google Auto Link (ask Jeremiah Foster).

In terms of making connections reliable to the vehicle- there is nothing 
available as open source either.  This is software depending to a large 
extent to the behaviour of particular chipsets and telecom operators' 
networks.  There is a big challenge to start connections very quickly 
(engine start plus 5 seconds) and to maintain connections up during long 
time while the vehicle moves across large areas).

Alex

> _______________________________________________ mif mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/mif
>
>