Subject: Re: [mile] Updated IODEF Enumeration Reference Format Draft

From: "Black, David" <[email-masked]>
Date: Thu, 6 Dec 2012 13:47:32 -0500

Hi Adam,

Thanks you for considering these comments.  I have a couple of follow-ups:

> So, what you're proposing is that the versioning information be attached to id
> rather than id_type.  That seems reasonable to me.

Yes, although I might say "associated with" as opposed to "attached to".

For example, a useful (at least, IMHO) consequence is that if the same id is used in multiple versions of the same spec without change (e.g., new revised spec versions add ids to enumerations but don't change existing ids), than this approach removes the need in IODEF to explicitly indicate which of the various possible versions of the spec is involved.

> In that message you mention guidance being provided to the Designated Expert.
> Where would that guidance be provided in the draft (or is it provided elsewhere)?

It would go in the IANA Considerations section - we (the WG) get to write that guidance to help a future Designated Expert do the proverbial "right thing".

Thanks,
--David

From: Adam Montville [mailto:[email-masked]]
Sent: Thursday, November 29, 2012 3:29 PM
To: Black, David
Cc: <[email-masked]>
Subject: Re: Updated IODEF Enumeration Reference Format Draft

Hi David,

Thank you for your diligence!  I do appreciate it.

Please see comments inline.

Regards,

Adam

On Nov 17, 2012, at 7:42 AM, "Black, David" <[email-masked]<mailto:[email-masked]>> wrote:

Adam,

Thanks for working on this draft.

I see that the version is included in the id_type string prefix.
I'm assuming that this version is the version number of the registered
specification.  That makes sense if the version doesn't change often
and especially if a version change results in a change to the identifier
format.

How often does the version change for the specs that are the sources of
the enumerations of interest?

>From what I've seen, rarely.  However, emerging enumerations could be used and they might change more frequently.

If the spec version changes often, and especially if enumeration
identifiers from previous versions usually remain valid in new versions,
an alternative approach would be to tie the version to the identifier
format rather than the spec version - this could avoid having several
dozen id_type strings for versions of a single spec.

So, what you're proposing is that the versioning information be attached to id rather than id_type.  That seems reasonable to me.

Please also take a look at these two emails that I sent to the list earlier:

identifier formats: http://www.ietf.org/mail-archive/web/mile/current/msg00853.html

With respect to this message, which is about id and id_type formatting, I'm happy to make adjustments to the draft where necessary.  In that message you mention guidance being provided to the Designated Expert.  Where would that guidance be provided in the draft (or is it provided elsewhere)?

Additionally, I'm interested to know what others think about these approaches.  Again, I'm here to create a draft based on what the community wants to see implemented, so chime in if you have an opinion in these matters.

more on versions: http://www.ietf.org/mail-archive/web/mile/current/msg00854.html

Take and I had an opportunity to speak in Atlanta, and I understand the concern represented in the message above.  This will be addressed in a forthcoming revision.

I have some additional editorial concerns that I'll send to you directly.

Thanks,
--David

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Adam Montville
Sent: Wednesday, November 07, 2012 12:32 PM
To: <[email-masked]<mailto:[email-masked]>>
Subject: [mile] Updated IODEF Enumeration Reference Format Draft

All:

I'm pleased to submit draft-montville-mile-enum-reference-format-01 available at

http://www.ietf.org/id/draft-montville-mile-enum-reference-format-01.txt

Changes:

 *   IANA Table Request Changes

    *   Removed "Name"
    *   Added "Full Name
    *   Added "Abbreviation"

 *   Specified id_type to be <Abbreviation>_<Version>
 *   Reviewed text for scope statements and limited scope to IODEF, while alluding to the method's potential usefulness elsewhere.
 *   Ensured that the Reference class diagram is explicitly referenced as [IODEF].
 *   Updated IANA Considerations to request creation of the table
 *   Updated IANA table format fields with simple descriptions

I look forward to your comments.

Regards,

Adam W. Montville | Security and Compliance Architect
CISA, CISSP

Direct: 503 276-7661
Mobile: 360 471-7815

TRIPWIRE | Take CONTROL
http://www.tripwire.com

---

From: Adam Montville <[email-masked]>
Date: Fri, 14 Dec 2012 17:49:56 +0000

Greetings all...  I'm trying to get this IODEF Enumeration Reference draft nailed down.  I'd like to call your attention to the point David makes below about the IANA Considerations section - the WG needs to provide guidance for the Designated Expert.  I'll be publishing an 02 version of this draft later today and we can improve on that.  Just wanted to provide a heads up.

On Dec 6, 2012, at 10:47 AM, "Black, David" <[email-masked]<mailto:[email-masked]>> wrote:

Hi Adam,

> rather than id_type.  That seems reasonable to me.

Yes, although I might say “associated with” as opposed to “attached to”.

For example, a useful (at least, IMHO) consequence is that if the same id is used in multiple versions of the same spec without change (e.g., new revised spec versions add ids to enumerations but don’t change existing ids), than this approach removes the need in IODEF to explicitly indicate which of the various possible versions of the spec is involved.

> Where would that guidance be provided in the draft (or is it provided elsewhere)?

It would go in the IANA Considerations section - we (the WG) get to write that guidance to help a future Designated Expert do the proverbial “right thing”.

Thanks,
--David

From: Adam Montville [mailto:[email-masked]<http://tripwire.com>]
Sent: Thursday, November 29, 2012 3:29 PM
To: Black, David
Cc: <[email-masked]<mailto:[email-masked]>>
Subject: Re: Updated IODEF Enumeration Reference Format Draft

Hi David,

Regards,

Adam

Adam,

I see that the version is included in the id_type string prefix.
I’m assuming that this version is the version number of the registered
specification.  That makes sense if the version doesn’t change often
and especially if a version change results in a change to the identifier
format.

I have some additional editorial concerns that I’ll send to you directly.

Thanks,
--David

All:

Changes:

     *   Removed "Name"
     *   Added "Full Name
     *   Added "Abbreviation"

Regards,

Direct: 503 276-7661
Mobile: 360 471-7815

TRIPWIRE | Take CONTROL
http://www.tripwire.com

Direct: 503 276-7661
Mobile: 360 471-7815

TRIPWIRE | CONFIDENCE: SECURED
www.tripwire.com<http://www.tripwire.com/>