Subject: [mile] minutes of the MILE session in IETF 89 is now available online

From: "Takeshi Takahashi" <[email-masked]>
Date: Wed, 12 Mar 2014 00:37:21 +0900

Hello all,

The minutes of the MILE session in IETF 89 is now available online.

http://www.ietf.org/proceedings/89/minutes/minutes-89-mile

The summary report for saag is also available online

http://www.ietf.org/mail-archive/web/saag/current/msg04613.html

Thank you very much, David Black and David Misell for kindly volunteering
the note-taking, and David Walterire for kindly volunteering the jabber
scribe.

Take

---

From: Daisuke MIYAMOTO <[email-masked]>
Date: Sat, 15 Mar 2014 18:21:00 +0900

Hello all, and thanks Take for the minutes.

Regarding the lines below, I have one comment.

 > Dave Waltermire: #2: Should we revise XSD to remove usage of hyphens.
 > --> Take issue to list.

  I'm sorry for my misunderstanding.

  In the MILE meeting in IETF 89, what I wanted to say was,
"Nothing has to be changed since workaround is available."

  Fortunately, modern code generators will keep names for serialization; 
even "hyphen" is removed or replaced with "underscore", the 
serialization supports to restore “hyphen”. Even in the case of the old 
code generators,  the workaround (replacement) worked fine. Besides, it 
might be fair to say, "developers might have knowledge about the 
features of their code generation."

  Therefore, I think it is not an outstanding issue.

Kind regards,
Daisuke

(2014/03/12 0:37), Takeshi Takahashi wrote:
> Thank you very much, David Black and David Misell for kindly
> volunteering the note-taking, and David Walterire for kindly
> volunteering the jabber scribe.
>
> Take
>

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Tue, 18 Mar 2014 13:59:36 +0900

Hi Daisuke,

Thank you for your clarification.
I, as an individual engineer, also prefer not to change the top level tag of the IODEF (i.e. <IODEF-Document>) just because of this hyphen issue.

On the other hand, how about putting this note in the implementation draft when you edit its next version?

Take

> -----Original Message-----
> From: mile [mailto:[email-masked]] On Behalf Of Daisuke MIYAMOTO
> Sent: Saturday, March 15, 2014 6:21 PM
> To: [email-masked]
> Subject: Re: [mile] minutes of the MILE session in IETF 89 is now available
> online
> 
>   In the MILE meeting in IETF 89, what I wanted to say was, "Nothing has
> to be changed since workaround is available."
> 
> even "hyphen" is removed or replaced with "underscore", the serialization
> supports to restore “hyphen”. Even in the case of the old code generators,
> the workaround (replacement) worked fine. Besides, it might be fair to say,
> "developers might have knowledge about the features of their code
> generation."
> 
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile