Subject: [mile] Defining RelatedDNS

From: "Roman D. Danyliw" <[email-masked]>
Date: Fri, 27 Feb 2015 20:47:37 +0000

Hello!

RelatedDNS in 5070bis is intended to describe arbitrary DNS records.  While the intent of class is understanding the specified representation has not been clarified.  The issue is tracked in Issue #39 [1] and there is prior discussion on the list [2].  At the Honolulu meeting [3], this topic generated sufficient discussion requiring it to be brought back to the list for further discussion.

Possible options include:

(1) At the Honolulu meeting, Paul Hoffman suggested a draft providing a JSON notation for DNS records.
Background: draft-hoffman-dns-in-json-02
Options: reference outright, convert from JSON to XML
Pro: well-defined format elsewhere
Con: is JSON inside XML a kludge?
Con: experimental draft as a normative reference to standards track document

(2) A comma separated value list of DNS fields
Background: http://www.ietf.org/mail-archive/web/mile/current/msg01329.html
Pro: simple
Con: not sufficiently descriptive as currently suggested

(3) Defining RelatedDNS as iodef:AdditionalData and requiring an extension
Pro: no extra work required
Con: defers action on a need previously articulated in the community

(4) Define an alternative representation for RelatedDNS
Pro: opportunity to create an appropriately tailored solution
Con: requires new work/documentation

Are there other options?  What do you think?

Roman

[1] http://trac.tools.ietf.org/wg/mile/trac/ticket/39
[2] http://www.ietf.org/mail-archive/web/mile/current/msg01325.html
[3] http://www.ietf.org/proceedings/91/minutes/minutes-91-mile

---

From: Jerome Athias <[email-masked]>
Date: Sat, 28 Feb 2015 09:39:56 +0100

1) In short, I would prefer XML for Description, JSON for implementation.
2) not sufficiently descriptive as currently suggested
3) 4) consider:
http://cybox.mitre.org/XMLSchema/objects/DNS_Query/2.1/DNS_Query_Object.xsd
http://cybox.mitre.org/XMLSchema/objects/DNS_Record/2.1/DNS_Record_Object.xsd

2015-02-27 21:47 GMT+01:00 Roman D. Danyliw <[email-masked]>:
> _______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile