Subject: [mile] I-D Action: draft-ietf-mile-rfc5070-bis-12.txt

From: [email-masked]
Date: Thu, 18 Jun 2015 13:18:54 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Managed Incident Lightweight Exchange Working Group of the IETF.

        Title           : The Incident Object Description Exchange Format v2
        Authors         : Roman Danyliw
                          Paul Stoecker
	Filename        : draft-ietf-mile-rfc5070-bis-12.txt
	Pages           : 167
	Date            : 2015-06-18

Abstract:
   The Incident Object Description Exchange Format (IODEF) defines a
   data representation for sharing information commonly exchanged by
   Computer Security Incident Response Teams (CSIRTs) about computer
   security incidents.  This document describes the information model
   for the IODEF and provides an associated data model specified with
   XML Schema.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-mile-rfc5070-bis/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-mile-rfc5070-bis-12

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-mile-rfc5070-bis-12

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Roman D. Danyliw" <[email-masked]>
Date: Thu, 18 Jun 2015 20:20:27 +0000

Hello!

The Changelog for this -12 draft are as follows:

** (schema) Added Service@ServiceName to convey the intended service rather than just a port number (Issue #51)
** (schema) Added @proto-name attribute to the ApplicationHeaderType to make the use of the service name or number possible per the fix for Issue #51
** (text) Added text to EmailData to clarify that that EmailHeaderField can also set the new @proto-name attribute
** (schema) Renamed Counter@type to Counter@unit and changed the semantics of Counter@type to allow rates to be expressed by the Counter class (Issue #52)
** (text) Added clarifying language in Section 2.4 to scope the @translation-id attribute (Issue #49)
** (schema) Corrected schema to make IODEF-Document@formatid be optional -- it was mandatory in schema and optional in text
** (schema) Renamed IODEF-Document@formatid to be @format-id for consistency
** (schema) Added IODEF-Document@private-enum-name and private-enum-id to uniquely identify private extensions (Issue #48)
** (text) Added a new Section 5.3 to explain the use of the private-enum-name and id attributes (Issue #48)
** (schema) Added File@AssociatedSoftware to allow the reference to the software package a file may belong (Issue #53)
** (schema) Corrected IODEF-enum SchemaLocation, added import of xml.xsd to support xml:lang and fixed Section 7.1 example (per Takahashi's feedback: http://mailarchive.ietf.org/arch/msg/mile/ZdZtZM-Vpzbiz3ptSPhcFJ6Kf5I)
** (schema) Added missing reference to xml:lang in the schema to IODEF-Document (per Takahashi's feedback: http://mailarchive.ietf.org/arch/msg/mile/KyBng_nav6xMvXtLEBwjt8HP-sE) but also in Incident, NodeRole and iodef:MLStringType 
** (schema) Added Observable/BulkObservable to allow a list of common indicators in a single text blob (Issue #50)

Roman

________________________________________
From: mile [[email-masked]] on behalf of [email-masked] [[email-masked]]
Sent: Thursday, June 18, 2015 4:18 PM
To: [email-masked]
Cc: [email-masked]
Subject: [mile] I-D Action: draft-ietf-mile-rfc5070-bis-12.txt

Abstract:

_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile