Subject: Re: [mile] comments on the IODEF-bis schema

From: "Takeshi Takahashi" <[email-masked]>
Date: Thu, 18 Jun 2015 12:50:32 +0200

One more comment:

To cope with the xml:lang attribute, I would add the following line to the
IODEF-Document class definition in the schema.

	<xs:attribute ref="xml:lang"/>

Thank you.
Take

> -----Original Message-----
> From: Takeshi Takahashi [mailto:[email-masked]]
> Sent: Thursday, June 18, 2015 11:46 AM
> To: 'Roman D. Danyliw'; [email-masked]'
> Subject: comments on the IODEF-bis schema
> 
> Hello Roman and all
> 
> You might have already corrected, but let me share some comments regarding
the
> schema and example XML.
> 
> [Schema mentioned in Section 8 "The IODEF Schema"]
> 
> 1. schema location
> 
> Old:
> <xs:import namespace="urn:ietf:params:xml:ns:iodef-enum-1.0"
> schemaLocation="http://www.iana.org/xml-registry/schema/iodef-enum-1.0.xsd
> " />
> 
> New:
> <xs:import namespace="urn:ietf:params:xml:ns:iodef-enum-1.0"
> schemaLocation="http://www.iana.org/assignments/xml-registry/schema/iodef-
> enum-1.0.xsd" />
> 
> 2. language attribute
> 
> The import of xml.xsd, which is necessary to use xml:lang attribute, was
missing
> 
> I would add the following line to the schema.
> 
> <xs:import namespace="http://www.w3.org/XML/1998/namespace"
> schemaLocation="http://www.w3.org/2001/xml.xsd" />
> 
> 
> [Example mentioned in Section 7.1 "Worm"]
> 
> I guess you might totally change the examples, but let me anyway share
some
> comments on the current examples.
> 
> 1. namespace
> 
> Version was incremented:
> 
>      xmlns="urn:ietf:params:xml:ns:iodef-2.0"
> 
> 2. language attribute
> 
> I think you intend to use "xml:lang". I would change accordingly.
> 
> <IODEF-Document version="2.00" xml:lang="en"
> 
> 3. ip_protocol -> ip-protocol
> 
> Old: <Service ip_protocol="6">
> New: <Service ip-protocol="6">
> 
> 4. impact class
> 
> Old:         <Impact completion="failed" type="admin"/>
> New:         <SystemImpact completion="failed" type="admin"/>
> 
> 
> Thank you.
> Take
> 
>

---

From: "Roman D. Danyliw" <[email-masked]>
Date: Thu, 18 Jun 2015 14:10:31 +0000

Hello Take!

That was a significant oversight you found where the text doesn't reflect the schema. Thank you. This feedback also applies to Incident, NodeRole and iodef:MLStringType.

These changes will be reflected in the -12 draft.

Roman

> On Jun 18, 2015, at 12:50 PM, Takeshi Takahashi <[email-masked]> wrote:
> 
> One more comment:
>