Subject: [mile] [IANA #921487] Protocol Action: 'The Incident Object Description Exchange Format v2' to Proposed Standard (draft-ietf-mile-rfc5070-bis-25.txt)

From: "Amanda Baber via RT" <[email-masked]>
Date: Wed, 17 Aug 2016 19:09:03 +0000

Dear Roman,

The actions for this document are complete. The designated expert for the XML registries, however, has comments:

"It looks good. Two nits:

schemaLocation attributes are a bad idea
the definition of TimeZone allows for seconds, which is unnecessary (I think)"

If you want to make changes during AUTH48, the RFC Editor will contact us and tell us which updates to make. Alternatively, if you want to make changes now, just let us know.

Please review the actions below and let us know whether we've completed them correctly. When we receive your confirmation, we'll tell the RFC Editor the IANA actions are complete.

ACTION 1:

IANA has added the following entry to the IETF XML ns registry:

iodef-2.0	
urn:ietf:params:xml:ns:iodef-2.0	
http://www.iana.org/assignments/xml-registry/ns/iodef-2.0.txt	
[RFC-ietf-mile-rfc5070-bis-25]  

Please see
http://www.iana.org/assignments/xml-registry

ACTION 2:

IANA has added the following entry to the IESG XML schema registry:

iodef-2.0	
urn:ietf:params:xml:schema:iodef-2.0	
http://www.iana.org/assignments/xml-registry/schema/iodef-2.0.xsd	
[RFC-ietf-mile-rfc5070-bis-25]

Please see
http://www.iana.org/assignments/xml-registry

ACTION 3:

IANA has created 34 registries under the "Incident Object Description Exchange Format v2 (IODEF)" heading at 

http://www.iana.org/assignments/iodef2

Can we tell the RFC Editor these are complete?

Best regards,

Amanda Baber
IANA Lead Specialist
ICANN

---

From: "Roman D. Danyliw" <[email-masked]>
Date: Mon, 22 Aug 2016 20:08:38 +0000

Good afternoon Amanda!

Coming back from vacation.

Ack on this email and thank you for the review!

(1) Let me check on the TimeZone issue.  This was a requested change from IESG review.

(2) Could the reviewer share a bit more context on "schemaLocation" not being a good idea.  Is there a better way?

I'd prefer to change now rather than AUTH48 if there is anything to do.

Roman

> -----Original Message-----
> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: Wednesday, August 17, 2016 3:09 PM
> Cc: [email-masked]
> Subject: [IANA #921487] Protocol Action: 'The Incident Object Description
> Exchange Format v2' to Proposed Standard (draft-ietf-mile-rfc5070-bis-
> 25.txt)
> 
> Dear Roman,
> 
> schemaLocation attributes are a bad idea the definition of TimeZone allows
> for seconds, which is unnecessary (I think)"
> 
> If you want to make changes during AUTH48, the RFC Editor will contact us
> and tell us which updates to make. Alternatively, if you want to make
> changes now, just let us know.
> 
> Please review the actions below and let us know whether we've completed
> them correctly. When we receive your confirmation, we'll tell the RFC Editor
> the IANA actions are complete.
> 
> ACTION 1:
>

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Mon, 22 Aug 2016 21:27:08 +0000

I'll check with him. Thanks!

Amanda

On Mon Aug 22 20:24:38 2016, [email-masked] wrote:
> (2) Could the reviewer share a bit more context on "schemaLocation"
> not being a good idea.  Is there a better way?
> 
> > The actions for this document are complete. The designated expert for
> > the
> > XML registries, however, has comments:
> >

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Mon, 22 Aug 2016 22:47:11 +0000

Hi Roman,

The reviewer writes, "Fixing schemaLocation in a spec makes the spec harder to consume. Implementations that want local copies to be used have to modify the doc to use it."

thanks,
Amanda