Subject: [mile] ROLIE Data Model Attributes

From: "Banghart, Stephen A. (Fed)" <[email-masked]>
Date: Wed, 10 Aug 2016 13:25:51 +0000

All,

Following discussion around ROLIE at IETF 96, there were some issues that we wanted to resolve on list. This email references github issue #33<https://github.com/CISecurity/ROLIE/issues/33>, duplicated here:

Determine rolie:datamodel Attributes

The following proposal was discussed at IETF 96 MILE WG meeting:

Proposal: Create a new extension element with the following attributes:

  *   ns: Provides a globally unique identifier for the namespace of the data model.
  *   version (Optional) : The version of the data model.
  *   schema (Optional) : An IRI to the relevant schema resource.
  *   schema-type (Optional): The type of the schema (e.g. XML Schema, RelaxNG, JSON-LD).
  *

Resolve the following questions on the list:

  *   Will all content models have an associated namespace?
  *   Should we create an IANA registry linking allowed namespaces to information types? See issue #30<https://github.com/CISecurity/ROLIE/issues/30>
  *   Some data model versions are encoded in the namespace. What if the version is not?
  *   If the data model is constrained by a schema, is there value in referencing the schema used?
  *   Most schema formats do not have an associated media type. What vocabulary should we use?
  *   How do we address the encoding of the schema (e.g. UTF-8)? (Suggested by Roman Danyliw).
     *   Perhaps this could be addressed using the mime type for the schema serialization format? This would include the encoding.

Is there any feedback on the proposal or comments regarding the questions? Once we've settled on the attributes we can create a Relax NG schema for the rolie:datamodel element. Any and all feedback would be appreciated.

Thanks,
Stephen Banghart

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Thu, 18 Aug 2016 12:10:08 +0900

Hi,

> Should we create an IANA registry linking allowed namespaces to
information types? See issue #30 

In the github, you have summarized like this: "This was discussed at the
IETF 96 MILE WG meeting. Roman Danyliw suggested that we enumerate the data
models supported by a given information type. An open-world approach should
be taken, allowing private extensions to be used. We need to work out a
mechanism to support this, and propose the solution to the list."

+1.

Clarification question.

Here is my understanding: Once we register the categories to the IANA
registry, I guess we will put a restriction on the value of the "term"
attribute inside "category" element (when scheme =
"urn:ietf:params:rolie:information-type"), but we allow private extensions
by allowing people to define their own Category Document.
If so, will the notional examples of information types mentioned in Section
8.1 become the initial list of IANA table values?

Thank you.

Take

From: mile [mailto:[email-masked]] On Behalf Of Banghart, Stephen A.
(Fed)
Sent: Wednesday, August 10, 2016 10:26 PM
To: [email-masked]
Subject: [mile] ROLIE Data Model Attributes

All,

Following discussion around ROLIE at IETF 96, there were some issues that we
wanted to resolve on list. This email references github issue #33,
duplicated here:

Proposal: Create a new extension element with the following attributes:
. ns: Provides a globally unique identifier for the namespace of the data
model.
. version (Optional) : The version of the data model.
. schema (Optional) : An IRI to the relevant schema resource.
. schema-type (Optional): The type of the schema (e.g. XML Schema, RelaxNG,
JSON-LD).
. 
Resolve the following questions on the list: 
. Will all content models have an associated namespace?
. Should we create an IANA registry linking allowed namespaces to
information types? See issue #30 
. Some data model versions are encoded in the namespace. What if the version
is not?
. If the data model is constrained by a schema, is there value in
referencing the schema used?
. Most schema formats do not have an associated media type. What vocabulary
should we use?
. How do we address the encoding of the schema (e.g. UTF-8)? (Suggested by
Roman Danyliw). 
o Perhaps this could be addressed using the mime type for the schema
serialization format? This would include the encoding.

Is there any feedback on the proposal or comments regarding the questions?
Once we've settled on the attributes we can create a Relax NG schema for the
rolie:datamodel element. Any and all feedback would be appreciated.

Thanks,
Stephen Banghart