Subject: Re: [mile] [IANA #992871] Protocol Action: 'Resource-Oriented Lightweight Information Exchange' to Proposed Standard (draft-ietf-mile-rolie-16.txt)

From: "Banghart, Stephen A. (Fed)" <[email-masked]>
Date: Tue, 9 Jan 2018 19:07:58 +0000

Sabrina,

The authors have looked over Appendix A and have found a few minor errors. I have attached a file to this email titled "rolie.rnc". This attachment contains the updated schema. This could also be used as the file linked in the IANA XML registry, as it is identical to what is in the updated Appendix.

For convenience I have included an XML file ("AppendixA.xml") that contains an updated XML version of the entire Appendix A with correct formatting if this would be easier for you to update the document with.

This schema is in the Relax NG format (.rnc/.rng). Most web browsers fail to render this format (and display the "Document is empty" error), but it is a valid XML schema format. In the IANA XML Registry there are examples of this format generating the same error that you are seeing for our schema: ex. "lost1" (https://www.iana.org/assignments/xml-registry/schema/lost1.rng).

To get the rolie.rnc schema to fully validate with a Relax NG compact validator, the "atomsync.rnc" file I've attached should be included in the same folder.

After updating the appendix to the new schema if the same "Document is empty" error occurs  then it should be fine to continue anyway.

Let me know if you need any other info,
Stephen Banghart

> -----Original Message-----
> From: Sabrina Tanamal via RT [mailto:[email-masked]]
> Sent: Thursday, December 21, 2017 2:11 PM
> Cc: [email-masked]; Banghart, Stephen A. (Fed)
> <[email-masked]>; Waltermire, David A. (Fed)
> <[email-masked]>; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked]
> Subject: [IANA #992871] Protocol Action: 'Resource-Oriented Lightweight
> Information Exchange' to Proposed Standard (draft-ietf-mile-rolie-16.txt)
> 
> Dear Authors,
> 
> The schema provided in Appendix A doesn't appear to be validating correctly
> for us. The page online displayed the following errors:
> 
> This page contains the following errors:
> 
> error on line 1 at column 1: Document is empty
> 
> Below is a rendering of the page up to the first error.
> 
> --
> 
> Are there any changes that need to be made in the document?
> 
> If so, would you want to send us a revised schema before the changes are
> made in the document?
> 
> Thank you,
> 
> Sabrina Tanamal
> IANA Services Specialist

---

From: "Waltermire, David A. (Fed)" <[email-masked]>
Date: Tue, 9 Jan 2018 19:20:13 +0000

Comments below.

> Sent: Friday, December 22, 2017 1:46 AM
> Cc: [email-masked]; Banghart, Stephen A. (Fed) <[email-masked]>;
> Waltermire, David A. (Fed) <[email-masked]>;
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]
> ATTENTION: A RESPONSE TO THIS MESSAGE IS NEEDED
> 
> While we're waiting for your response regarding the schema, could you review
> the other actions in this document and confirm they have been completed
> correctly?
> 
> draft-ietf-mile-rolie-16
> 
> ACTION 1:
> 
> We've added the following entry to the IETF XML ns registry:
> 
> ID: rolie-1.0
> URI:urn:ietf:params:xml:ns:rolie-1.0
> Filename: ns/rolie-1.0.txt
> Reference: [RFC-ietf-mile-rolie-16]
> 
> Please see
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ian
> a.org%2Fassignments%2Fxml-
> registry&data=02%7C01%7Cdavid.waltermire%40nist.gov%7C5b0a8b3887de4
> 5a71b0708d54907b49a%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C
> 0%7C636495219811110555&sdata=nLVFbMIBNlSwSus5etV6ewUcBTteBYELVR
> noFDChWRo%3D&reserved=0

This looks good. Thanks!

> 
> ACTION 2:
> 
> We've added the following entry to the IETF XML schema registry:
> 
> ID: rolie-1.0
> URI: urn:ietf:params:xml:schema:rolie-1.0
> Filename: schema/rolie-1.0.xsd
> Reference: [RFC-ietf-mile-rolie-16]
> 
> Please see
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ian
> a.org%2Fassignments%2Fxml-
> registry&data=02%7C01%7Cdavid.waltermire%40nist.gov%7C5b0a8b3887de4
> 5a71b0708d54907b49a%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C
> 0%7C636495219811110555&sdata=nLVFbMIBNlSwSus5etV6ewUcBTteBYELVR
> noFDChWRo%3D&reserved=0

Most of the entry is correct with the exception of the filename. This should point to the corrected rolie.rnc schema that Stephen just sent you. This will be the same schema as in appendix A.

> 
> ACTION 3:
> 
> We've added the following entry to the IETF URN Sub-namespace for Registered
> Protocol Parameter Identifiers registry
> 
> Registered Parameter Identifier: rolie
> Reference: [RFC-ietf-mile-rolie-16]
> IANA Registry Reference:
> [https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.ian
> a.org%2Fassignments%2Frolie&data=02%7C01%7Cdavid.waltermire%40nist.g
> ov%7C5b0a8b3887de45a71b0708d54907b49a%7C2ab5d82fd8fa4797a93e05
> 4655c61dec%7C1%7C0%7C636495219811110555&sdata=H93J3j1ol6QpyKDZ
> jfez%2B%2FDs2bmD74MM%2BO4nmcd6Lio%3D&reserved=0]
> 
> Please see
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ian
> a.org%2Fassignments%2Fparams&data=02%7C01%7Cdavid.waltermire%40nis
> t.gov%7C5b0a8b3887de45a71b0708d54907b49a%7C2ab5d82fd8fa4797a93e
> 054655c61dec%7C1%7C0%7C636495219811110555&sdata=aeMrxlH3mySxm
> 6vk1Lrv2U8w6VQxgcQChioDK6Igjzs%3D&reserved=0

This looks good. Thanks!

>  
> 
> ACTION 4:
> 
> We've created the following registries under the heading "Resource Oriented
> Lightweight Information Exchange (ROLIE) URN Parameters"
> 
> Resource Oriented Lightweight Information Exchange (ROLIE) URN Parameters
> 
> ROLIE URN Parameters
> Registration Procedure(s)
> Specification Required
> Expert(s)
> Unassigned
> Reference
> [RFC-ietf-mile-rolie-16]
> 
> Name 	Extension URI 	Reference 	Sub-Registry
> category:information-type	urn:ietf:params:rolie:category:information-
> type	[RFC-ietf-mile-rolie-16, Section 8.4]
> 	[https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2F
> www.iana.org%2Fassignments%2Frolie%2Frolie.xhtml%23information-
> type&data=02%7C01%7Cdavid.waltermire%40nist.gov%7C5b0a8b3887de45a
> 71b0708d54907b49a%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%
> 7C636495219811110555&sdata=SYrmpuQb%2F8%2BbK%2FDzTBC1qtOLpfby
> Fmmb%2B8350DEfETo%3D&reserved=0]
> property:content-author-name	urn:ietf:params:rolie:property:content-author-
> name	[RFC-ietf-mile-rolie-16, Section 7.4]	None
> property:content-id	urn:ietf:params:rolie:property:content-id	[RFC-
> ietf-mile-rolie-16, Section 7.4]	None
> property:content-published-date
> 	urn:ietf:params:rolie:property:content-published-date	[RFC-ietf-
> mile-rolie-16, Section 7.4]	None
> property:content-updated-date	urn:ietf:params:rolie:property:content-
> updated-date	[RFC-ietf-mile-rolie-16, Section 7.4]	None
> 
> ROLIE Information Types
> Registration Procedure(s)
> Specification Required
> Expert(s)
> Unassigned
> Reference
> [RFC-ietf-mile-rolie-16]
> No registrations at this time.
> 
> Please see
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ian
> a.org%2Fassignments%2Frolie&data=02%7C01%7Cdavid.waltermire%40nist.g
> ov%7C5b0a8b3887de45a71b0708d54907b49a%7C2ab5d82fd8fa4797a93e05
> 4655c61dec%7C1%7C0%7C636495219811110555&sdata=knaX8cL%2BKRVHy
> tQ6KnboxsBItAVJHxmXuX8bTHoxIZI%3D&reserved=0

These all look good. Thanks!

> > The updated list of Protocol Registries is available here:
> 
> https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.ian
> a.org%2Fprotocols%2F&data=02%7C01%7Cdavid.waltermire%40nist.gov%7C5
> b0a8b3887de45a71b0708d54907b49a%7C2ab5d82fd8fa4797a93e054655c6
> 1dec%7C1%7C0%7C636495219811110555&sdata=qWeLPq4nxnq8EoREfHVby
> QFpLgnIYmhgjcd0jV2hysw%3D&reserved=0
> 
> Once we receive your confirmation, we'll notify the RFC Editor that the actions
> are complete. If a team of authors is responsible for the document, and the
> actions have been performed correctly, please send a single confirmation
> message.

With the exception of the schema registration, the rest looks good. We can quickly review the schema change once you make the edits.

> 
> We'll update any references to this document in the registries when the RFC
> Editor notifies us that they've assigned an RFC number.
> 
> Best regards,
> 
> Sabrina Tanamal
> IANA Services Specialist

Thanks for all your efforts!

Regards,
Dave

---

From: "Amanda Baber via RT" <[email-masked]>
Date: Fri, 12 Jan 2018 22:49:41 +0000

Hi Dave and Stephen,

Can you confirm that the schema has been registered and posted correctly?

ID: rolie-1.0	
URI: urn:ietf:params:xml:schema:rolie-1.0	
https://www.iana.org/assignments/xml-registry/schema/rolie-1.0.rnc
Reference: [RFC-ietf-mile-rolie-16]

Please see
https://www.iana.org/assignments/xml-registry

See also 
https://www.iana.org/assignments/xml-registry/schema/atomsynd.rnc

thanks,

Amanda Baber
Lead IANA Services Specialist

On Tue Jan 09 19:20:40 2018, [email-masked] wrote:
> > <[email-masked]>;
> Most of the entry is correct with the exception of the filename. This
> should point to the corrected rolie.rnc schema that Stephen just sent
> you. This will be the same schema as in appendix A.
> 
> >
> > ACTION 3:
> >
> > category:information-type
> > urn:ietf:params:rolie:category:information-
> With the exception of the schema registration, the rest looks good. We
> can quickly review the schema change once you make the edits.
> 
> >

---

From: "Banghart, Stephen A. (Fed)" <[email-masked]>
Date: Wed, 17 Jan 2018 18:56:05 +0000

Amanda,

The schema and namespace registrations look right, everything seems good.

Thanks,
Stephen Banghart

> From: Amanda Baber via RT [mailto:[email-masked]]
> Sent: Friday, January 12, 2018 5:50 PM
> Cc: Banghart, Stephen A. (Fed) <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Waltermire, David A. (Fed)
> <[email-masked]>; [email-masked];
> [email-masked]
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> ana.org%2Fassignments%2Fxml-registry%2Fschema%2Frolie-
> 1.0.rnc&data=02%7C01%7Cstephen.banghart%40nist.gov%7Cad949b8d26b94
> ec30eeb08d55a0ec56b%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%
> 7C636513941862927764&sdata=0UbAYA%2Fjry33CZca4nx5A8NyW1A%2FV22
> pn8LmJbYgs4o%3D&reserved=0
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> ana.org%2Fassignments%2Fxml-
> registry&data=02%7C01%7Cstephen.banghart%40nist.gov%7Cad949b8d26b9
> 4ec30eeb08d55a0ec56b%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0
> %7C636513941862927764&sdata=l0g6NBxSIpWbgKsWsnmjzIPglcsQE%2BKwG
> P5X1DL7jII%3D&reserved=0
> 
> See also
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.i
> ana.org%2Fassignments%2Fxml-
> registry%2Fschema%2Fatomsynd.rnc&data=02%7C01%7Cstephen.banghart
> %40nist.gov%7Cad949b8d26b94ec30eeb08d55a0ec56b%7C2ab5d82fd8fa4797
> a93e054655c61dec%7C1%7C0%7C636513941862927764&sdata=KbDDdXOiN2f
> VMJ5hzA4rB3Z5ia%2BvYlQuwosjsmvfkKw%3D&reserved=0
> 
> thanks,
> 
> Amanda Baber
> > > [email-masked]; mile- [email-masked]; [email-masked]
> > > Subject: [IANA #992871] Protocol Action: 'Resource-Oriented
> > > Lightweight Information Exchange' to Proposed Standard
> > > (draft-ietf-mile-rolie-
> > > 16.txt)
> > >
> > > Dear Authors,
> > >
> > > While we're waiting for your response regarding the schema, could
> > > you review the other actions in this document and confirm they have
> > > been completed correctly?
> > >
> > > draft-ietf-mile-rolie-16
> > >
> > > ACTION 1:
> > >
> > > We've added the following entry to the IETF URN Sub-namespace for
> > > Registered Protocol Parameter Identifiers registry
> > >
> > > We've created the following registries under the heading "Resource
> > > Oriented Lightweight Information Exchange (ROLIE) URN Parameters"
> > >
> > > https://na01.safelinks.protection.outlook.com/?url=www.iana.org&data
> > >
> =02%7C01%7Cstephen.banghart%40nist.gov%7Cad949b8d26b94ec30eeb08d
> 55a0
> > >
> ec56b%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C6365139418629
> 2776
> > >
> 4&sdata=SzX2%2BdXo%2BTuXvgwVBU7vwafs7s13%2Bo52zvSFid0q%2F%2Fk
> %3D&res
> > > erved=0%2Fassignments%2Frolie%2Frolie.xhtml%23information-
> > >
> > > property:content-author-name
> > > urn:ietf:params:rolie:property:content-
> > > author-
> > > Once we receive your confirmation, we'll notify the RFC Editor that
> > > the actions are complete. If a team of authors is responsible for
> > > the document, and the actions have been performed correctly, please
> > > send a single confirmation message.
> >
> > > We'll update any references to this document in the registries when
> > > the RFC Editor notifies us that they've assigned an RFC number.
> > >
> > > Best regards,
> > >
> > > Sabrina Tanamal
> > > IANA Services Specialist
> >