Subject: Re: [mile] revising the charter text

From: Bret Jordan <[email-masked]>
Date: Tue, 4 Sep 2018 21:36:33 -0600

Take,

It seems like there are a few additions to this charter beyond defining how one could use ROLIE to transport STIX content. Can you call out / highlight the differences between the current charter and what is being proposed. 

Maybe I am wrong, but I felt from our last meeting in Montreal that the WG was winding down but we wanted to extend the scope of charter to address the STIX over ROLIE issue. Basically one more work item.  However, I feel like the new proposed charter might be a bit of a walk into extending the charter even further to address other new work?  Maybe I am wrong, if so, I sincerely apologize. 

Thanks,
Bret
PGP Fingerprint: 63B4 FC53 680A 6B7D 1447  F2C0 74F8 ACAE 7415 0050
"Without cryptography vihv vivc ce xhrnrw, however, the only thing that can not be unscrambled is an egg."

> On Aug 30, 2018, at 3:54 AM, Takeshi Takahashi <[email-masked]> wrote:
> 
> Hello all,
> 
> Thank you very much for your kind feedbacks.
> Based on them, the chairs have revised the document.
> The attached file is the revision.
> 
> We would like to welcome any feedback.
> If we hear no objection by September 15th, we would like to submit the revised charter text to our area director.
> 
> Thank you, and best regards,
> Take
> 
> 
> From: mile <[email-masked]> On Behalf Of John Field
> Sent: Tuesday, August 21, 2018 3:07 AM
> To: Roman Danyliw <[email-masked]>
> Cc: MILE IETF <[email-masked]>; Nancy Cam-Winget (ncamwing) <ncamwing=[email-masked]>
> Subject: Re: [mile] revising the charter text
> 
>> 
>> 
>> we are looking to
>> Document how MILE’s transport protocols could carry other exchange formats (STIX being one such other example with ROLIE….).
>> 
> 
> Understood.  Makes perfect sense.
> 
> John
> 
> On Mon, Aug 20, 2018 at 1:08 PM, Roman Danyliw <mailto:[email-masked]> wrote:
> Hello!
> 
> +1.  I support the proposed changes to the charter. It captures our discussion in Montreal to transport additional data formats.
> 
> Roman
> 
> From: mile [mailto:mailto:[email-masked]] On Behalf Of Nancy Cam-Winget (ncamwing)
> Sent: Friday, August 17, 2018 12:26 PM
> To: John Field <mailto:[email-masked]>; Banghart, Stephen A. (Fed) <mailto:[email-masked]>
> 
> Cc: MILE IETF <mailto:[email-masked]>
> Subject: Re: [mile] revising the charter text
> 
> Hi John,
> Thanks for the feedback!  To be clear, STIX as an exchange format is not in scope but we are looking to 
> Document how MILE’s transport protocols could carry other exchange formats (STIX being one such other example with ROLIE….).
> 
> Warm regards, Nancy
> From: mile <mailto:[email-masked]> on behalf of John Field <mailto:[email-masked]>
> Date: Friday, August 17, 2018 at 07:53
> To: "Banghart, Stephen A. (Fed)" <mailto:[email-masked]>
> Cc: MILE IETF <mailto:[email-masked]>
> Subject: Re: [mile] revising the charter text
> 
> +1  
> 
> ....and good to see the mention of STIX as potentially in scope for future work.
> 
> John  
> 
> On Thu, Aug 16, 2018 at 12:25 PM, Banghart, Stephen A. (Fed) <mailto:[email-masked]> wrote:
> Nancy, Take,
> 
> The proposed charter looks really good, thanks for putting this together. Agree with Adam, it’s tightly scoped and very understandable, avoids some of the pitfalls I’ve seen other chartering efforts fall into.
> 
> In regards to Kathleen’s comment on ROLIE/RID, ROLIE includes optional support for RID messages, that is, a ROLIE endpoint can be integrated with existing RID endpoints (thru the “/” resource, Section 5.5). Additionally, Course of Action is one of the extensions I’ve been thinking about putting together for native ROLIE support. 
> 
> With that in mind, I agree with Kathleen. We should call out RID as existing work that we are going to learn from and build on (especially re: security policy and requirements), but that’s it’s not necessarily a target transport mechanism for MILE as we move forward with new work.
> 
> -Stephen
> 
> From: mile <mailto:[email-masked]> On Behalf Of Nancy Cam-Winget (ncamwing)
> Sent: Thursday, August 16, 2018 11:29 AM
> To: Adam Montville <mailto:[email-masked]>; Kathleen Moriarty <mailto:[email-masked]>
> 
> Cc: MILE IETF <mailto:[email-masked]>
> Subject: Re: [mile] revising the charter text
> 
> Thanks Adam….and yes, we’ll definitely clean up grammatical and other editorial nits/comments before final copy!
> 
> Best, Nancy
> 
> From: mile <mailto:[email-masked]> on behalf of Adam Montville <mailto:[email-masked]>
> Date: Thursday, August 16, 2018 at 06:57
> To: Kathleen Moriarty <mailto:[email-masked]>
> Cc: MILE IETF <mailto:[email-masked]>
> Subject: Re: [mile] revising the charter text
> 
> I'm not as familiar with RID as Kathleen and others... Aside from Kathleen's comments, I think the charter looks pretty good - grammatical issues will be cleaned up eventually right? It seems like a tightly scoped effort, which is good. 
> 
> Kind regards,
> 
> Adam
> 
> On Aug 16, 2018, at 8:41 AM, Kathleen Moriarty <mailto:[email-masked]> wrote:
> 
> Hello Take, 
> 
> The update looks very good.  Thanks to you and the chairs for the first draft.  There are a few grammar nits to clean up and I just have one edit suggestion.
> 
> The first place where RID appears has not been expanded because of the editing.
> 
> I think RID is useful as a reference and to incorporate the policy and security aspects at this point rather than actually using it as a transport protocol (it's of course possible, but there are better solutions as RID development started a long time ago)..  It probably doesn't make sense to expand too much that thinking into the charter and the point is hit on in a sentence that remains on it containing policy.  The ability to include courses of actions in RID (I believe that was carried into ROLIE, but am not positive off hand) and some of the other action handling is useful as the requirements development for RID was quite an effort.  In other words, it has a lot of lessons learned so we don't leave something out or unnecessarily reinvent the wheel.  It also handled multi-party authentication and there may be some information gleaned from that work (that had lots of review) to do that in follow on protocols looking for that capability using JOSE or COSE for example.
> 
> If I find a little time, I may try to add subtle wording suggestions to make sure the usefulness of RID is understood and that it is not overstated as it's SOAPy and we have better answers now for transport.  The security requirements and solution development for policy and security controls I think is where it is still useful.
> 
> Best regards,
> Kathleen
> 
> 
> 
> On Thu, Aug 16, 2018 at 12:11 AM, Takeshi Takahashi <mailto:takeshi_takahashi@nict..go.jp> wrote:
> Hi all,
> 
> During the MILE session @ IETF102 in Montreal, we agreed to modify the
> charter text.
> Based on the discussion during the session, the co-chairs (Nancy, Dave, and
> I) have drafted a revision.
> Please see the attached files.
> 
> MILEcharterv2.docx: the revised text with change records
> MILEcharterv2_clean.txt: the revised text without change records
> 
> We would like to hear your opinion on this revised text.
> If you have any concerns, corrections, or additions, please kindly let us
> know.
> 
> Thanks,
> Take
> 
> 
> 
> _______________________________________________
> mile mailing list
> mailto:[email-masked]
> https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fmile&data=02%7C01%7Cstephen.banghart%40nist.gov%7Cceacad5d962848cef62408d6038cfd97%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636700301416938592&sdata=nxXxCMsm5rl%2FlMw%2FZc8OXNb9I4ZulxwVaFqULA7uyYQ%3D&reserved=0
> 
> 
> 
> 
> -- 
> 
> Best regards,
> Kathleen
> _______________________________________________
> mile mailing list
> mailto:[email-masked]
> https://www.ietf.org/mailman/listinfo/mile
> 
> 
> _______________________________________________
> mile mailing list
> mailto:[email-masked]
> https://www.ietf.org/mailman/listinfo/mile
> 
> 
> 
> 
> -- 
> John P. Field | Product Lead - Security and Compliance | Pivotal 
> Direct: (908) 962-3394 | mailto:[email-masked]://pivotal.io  
> 
> _______________________________________________
> mile mailing list
> mailto:[email-masked]
> https://www.ietf.org/mailman/listinfo/mile
> 
> 
> 
> 
> -- 
> John P. Field | Product Lead - Security and Compliance | Pivotal 
> Direct: (908) 962-3394 | mailto:[email-masked]://pivotal.io  
> <MILEcharterv4.docx>_______________________________________________
> mile mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mile

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Wed, 5 Sep 2018 14:16:44 +0900

Hi Bret and all,

The attached file records all the changes from the original version of the charter.
You could see that quite a lot of sentences were modified, so it could be confusing.

The fundamental changes we have made were allowing MILE transport protocols to exchange non-IODEF contents, including STIX contents (in XML and JSON).
In addition to that, we have changed sentences so that the charter will reflect the current status of MILE WG.
These edits are based on the result of the discussion during the Montreal meeting and the feedbacks on this mailing list.

For our perusal, the following four itemized bullet points(highlighted in the attached file) state the work MILE will address from now on.

- Revise the IODEF document to incorporate enhancements and extensions based on operational experience.
- Provide guidance on the implementation and use of IODEF to facilitate interoperability.
- Update and enhance these transport protocols to optimize their performance and representations. More explicitly, documenting how ROLIE can transport JSON representations.
- Define and document how these transport protocols can also be used to support other security information exchange formats. For example, documenting how ROLIE can transport STIX (Secure Threat Intelligence eXchange) data.

If further addition is preferred or necessary, we still can discuss it here.
So, any feedback or proposal is very much appreciated.

Thank you, and kind regards,
Take

From: Bret Jordan <[email-masked]> 
Sent: Wednesday, September 5, 2018 12:37 PM
To: Takeshi Takahashi <[email-masked]>
Cc: MILE IETF <[email-masked]>
Subject: Re: [mile] revising the charter text

Take,

Thanks,
Bret

On Aug 30, 2018, at 3:54 AM, Takeshi Takahashi <mailto:[email-masked]> wrote:

Hello all,

From: mile <mailto:[email-masked]> On Behalf Of John Field
Sent: Tuesday, August 21, 2018 3:07 AM
To: Roman Danyliw <mailto:[email-masked]>
Cc: MILE IETF <mailto:[email-masked]>; Nancy Cam-Winget (ncamwing) <mailto:ncamwing=[email-masked]>
Subject: Re: [mile] revising the charter text

we are looking to

John

Roman

Hi John,

Warm regards, Nancy

+1  

John  

-Stephen

Best, Nancy

To: Kathleen Moriarty <mailto:kathleen.moriarty...mailto:[email-masked]>

Kind regards,

Adam

Hello Take, 

Best regards,
Kathleen

On Thu, Aug 16, 2018 at 12:11 AM, Takeshi Takahashi <mailto:takeshi_takahashi@nict..http://go.jp> wrote:
Hi all,

Thanks,
Take

-- 

Best regards,
Kathleen

---

From: Takeshi Takahashi <[email-masked]>
Date: Thu, 20 Sep 2018 12:49:03 +0900

Hi all,

We have received several supports, and we have received no objection
on the revised charter text.
Thank you very much for those of you who kindly reviewed the text.

We'll submit the revised text to the AD then.

Cheers,
Take

2018-09-05 14:16 GMT+09:00 Takeshi Takahashi <[email-masked]>:
> .....and good to see the mention of STIX as potentially in scope for future work.
>
> John
>

-- 
--
Takeshi Takahashi, Ph.D., CISSP, PMP
"Practice makes perfect!"