Subject: Re: [mile] review request on the json IODEF draft at https://github.com/milewg/draft-ietf-mile-jsoniodef

From: Takahiko Nagata <[email-masked]>
Date: Thu, 20 Dec 2018 16:49:31 +0900

Hi Take

 > (2) [Question]DomainData, Address of Node should be exist
 > at the same time?

Sorry, this comment is unnecessary.
Because of my misunderstood "xs:choice".

"xs:choice" with maxOccurs="unbounded" can select
element at each reptition.

So, DomainData and Address can exists at same time.
And, I also confirm this XML Schema with XML validators(xmllint, msv).

Finally, my comment is only this one.

(1) Should apply ErrataID: 5398 (AlternativeIndicatorID)

Errata ID: 5398
https://www.rfc-editor.org/errata/eid5398

CDDL in latest draft says:
```
AlternativeIndicatorID = {
   ? restriction: restriction .default "private"
   ? ext-restriction: text
   IndicatorReference: [+ IndicatorReference]
}
```

It should say:
```
AlternativeIndicatorID = {
   ? restriction: restriction .default "private"
   ? ext-restriction: text
   IndicatorID: [+ IndicatorID]
}
```

Best Regards,
Takahiko Nagata

---

From: "Takeshi Takahashi" <[email-masked]>
Date: Tue, 25 Dec 2018 18:54:18 +0900

Hi Takahiro,

Thank you very much for your kind reviews.

The latest version of the draft on the github reflected your kind comments.
The table in Section 3.1 and the CDDL data model/json schema were corrected.

https://github.com/milewg/draft-ietf-mile-jsoniodef

Thank you, and kind regards,
Take

-----Original Message-----
From: mile <[email-masked]> On Behalf Of Takahiko Nagata
Sent: Thursday, December 20, 2018 4:50 PM
To: MILE IETF <[email-masked]>
Subject: Re: [mile] review request on the json IODEF draft at
https://github.com/milewg/draft-ietf-mile-jsoniodef

Hi Take

 > (2) [Question]DomainData, Address of Node should be exist  > at the same
time?

"xs:choice" with maxOccurs="unbounded" can select element at each reptition.

Errata ID: 5398

CDDL in latest draft says:
```
AlternativeIndicatorID = {
   ? restriction: restriction .default "private"
   ? ext-restriction: text
   IndicatorReference: [+ IndicatorReference] } ```

It should say:
```

Best Regards,
Takahiko Nagata

_______________________________________________
mile mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mile