Subject: Re: [mile] Alissa Cooper's No Objection on draft-ietf-mile-xmpp-grid-09: (with COMMENT)

From: "Nancy Cam-Winget (ncamwing)" <[email-masked]>
Date: Mon, 4 Mar 2019 21:47:00 +0000

Thanks Alissa and Alexey.  We discussed this in the group and couldn't really reach consensus given that we
Do have some normative language to guide towards interoperability and address security considerations.

That said Alissa is right to clarify that "typical" is meant to mean the minimal workflow to adhere to, so we will update that in the draft as well.

Warm regards, Nancy
On 1/24/19, 06:42, "Alexey Melnikov" <[email-masked]> wrote:

    Hi Alissa,
    
    Thank you for your comments.  Quick comments on a part of your review.
    
    On Wed, Jan 23, 2019, at 4:24 PM, Alissa Cooper wrote:
    > ----------------------------------------------------------------------
    > COMMENT:
    > ----------------------------------------------------------------------
    > 
    > Please respond to the Gen-ART review.
    
    Yes, I will chase that.
    
    > I'm not quite seeing what part of this is a standards-track specification. The
    > workflow in Section 4 is described as "typical" but not normative and the
    > exchanges listed in sections 5 and 6 are listed as examples. For a
    > standards-track specification I would have expected something more like
    > "Implementations of XMPP-Grid adhere to the following workflow ..." and for
    > service discovery and pub-sub to be described as *the* way to do those things
    > in XMPP-Grid, not just illustrated by examples. Otherwise this seems like it
    > could be an informational document.
    
    I need to discuss this with the WG, but I think I agree that the document needs an editorial pass to make sure that it is either purely Informative or that it clearly states extra requirements as suitable for a Proposed Standard.
    
    Thank you,
    Alexey

---

From: Peter Saint-Andre <[email-masked]>
Date: Mon, 4 Mar 2019 19:42:54 -0700

If the WG didn't have consensus that the document needs to be on the
standards track (I defer to the chairs and AD), then informational might
be more appropriate. As a co-author, I'm fine with either.