Subject: RE: [Mip4] RFC3012bis: Proposal for Issue2-Change5

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 4 Sep 2003 16:02:57 -0500

Hi, Pete,

Regards,
Ahmad

> 
> 
> Hi, Ahmad,
> 
> Ahmad Muhanna writes:
>  > > -----Original Message-----
>  > > From: Pete McCann [mailto:[email-masked]] 
>  > > Sent: Wednesday, September 03, 2003 5:03 PM
>  > > To: Bharatia, Jayshree [RICH1:2H13:EXCH]
>  > > Cc: [email-masked]'
>  > > Subject: RE: [Mip4] RFC3012bis: Proposal for Issue2-Change5  > > 
>  > >  > >  > > 
>  > >  > >  > > After that, we could add, "To meet the 
> security obligations 
>  > >  > >  > > outlined in Section 12, the FA SHOULD use one 
> of the already 
>  > >  > >  > > stored, previously unused challenges when 
> responding to an 
>  > >  > >  > > unauthenticated Registration Request or Agent 
> Solicitation."  > 
>  > If we are trying to prevent such DOS attack by NOT 
> INVALIDATING the  > challenge received in RRQ, why not 
> sending that challenge (still valid) back  > in RRP. Is there 
> a problem with that?
> 
> That behavior is allowed by the text above, assuming that the 
> challenge received in the RRQ is stored in the data 
> structures given in Appendix E.  If not, then what you 
> describe would not be ok, because you would be forcing the FA 
> to use a challenge that it didn't necessarily generate.
> 

Is there any scenario that we may be missing and FA may no longer having a
valid unused challenges for a certain MN?

> My view is that it should also be legal to return any of the 
> other previously unused challenges from the data structure.  
> This allows for maximum implementation flexibility.  The DoS 
> attack is prevented as long as you don't invalidate existing 
> previously unused challenges.
> 
> -Pete
> 
>

---

From: Pete McCann <[email-masked]>
Date: Thu, 4 Sep 2003 18:04:08 -0500

Hi, Ahmad,

 > valid unused challenges for a certain MN?

Ah, very good question.  I think we had some text to cover this case
in one of the proposals, but I subsequently deleted it.

How about:

  To meet the security obligations outlined in Section 12, the FA
  SHOULD use one of the already stored, previously unused challenges
  when responding to an unauthenticated Registration Request or Agent
  Solicitation.  If none of the already stored challenges are
  previously unused, the FA SHOULD generate a new challenge, include
  it in the response, and store it in the per-MN data structure.

-Pete

 > > previously unused challenges.

_______________________________________________
Mip4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip4

---

From: Henrik Levkowetz <[email-masked]>
Date: Fri, 5 Sep 2003 02:48:50 +0200

Thursday  4 September 2003, Pete wrote:
>  > >  > > Subject: RE: [Mip4] RFC3012bis: Proposal for Issue2-Change5
>  > >  > >  > >  > > 
>  > >  > >  > >  > > After that, we could add, "To meet the security
>  > >  > >  > >  > > obligations outlined in Section 12, the FA SHOULD
>  > >  > >  > >  > > use one of the already stored, previously unused
>  > >  > >  > >  > > challenges when responding to an unauthenticated
>  > >  > >  > >  > > Registration Request or Agent Solicitation."
>  > >  > INVALIDATING the challenge received in RRQ, why not 
>  > >  > sending that challenge (still valid) back in RRP. Is there 
>  > >  > a problem with that?
>  > > 
>  > Is there any scenario that we may be missing and FA may no longer
>  > having a valid unused challenges for a certain MN?
> 

I think this text is clear and correct. I propose we include this in
Appendix E, as proposed.

	Henrik