Subject: RE: [Mip4] RFC3012bis: Proposal for Issue2-Change5

From: "Ahmad Muhanna" <[email-masked]>
Date: Thu, 4 Sep 2003 15:56:20 -0500

Hi, Pete,

Regards,
Ahmad

> -----Original Message-----
> From: Pete McCann [mailto:[email-masked]] 
> Sent: Thursday, September 04, 2003 12:42 PM
> To: Muhanna, Ahmad [RICH2:2Q30:EXCH]
> Cc: Bharatia, Jayshree [RICH1:2H13:EXCH]; [email-masked]'
> Subject: RE: [Mip4] RFC3012bis: Proposal for Issue2-Change5
> 
> 
> 
> Hi, Ahmad,
> 
> Ahmad Muhanna writes:
>  > Hi, Pete,
>  > 
>  > The scenario I was concerned about does not use the 
> bad-authenticator in its  > response and therefore it is no 
> issue.  > I agree with your text below:  > 
>  > >  Note that an active attacker may try to prevent successful 
>  > >  registrations by sending a large number of Agent 
>  > >  Solicitations or bogus Registration Requests, each of which 
>  > >  could cause the FA to respond with a fresh challenge, 
>  > >  invalidating the challenge that the MN is currently trying to 
>  > >  use. To prevent such attacks, the FA MUST NOT invalidate 
>  > >  previously unused challenges when responding to 
>  > >  unauthenticated Registration Requests or Agent 
> Solicitations.  > 
>  > With respect to the following text. I do not think that it 
> is necessary.  > It is probably redandfant information.  > >  
> In addition, the FA MUST NOT allocate new storage when 
>  > >  responding to such messages, because this would also create 
>  > >  the possibility of denial of service.
> 
> Are you saying that if the FA doesn't invalidate previously 
> unused challenges, then it will not allocate more storage?  
> That doesn't necessarily follow.

Then, can you elaborate more on how this does not necessarily follow.
> -Pete

---

From: Pete McCann <[email-masked]>
Date: Thu, 4 Sep 2003 18:06:55 -0500

Hi, Ahmad,

 > Then, can you elaborate more on how this does not necessarily follow.

If we remove the restriction, then it would be legal to implement an
FA that created a new challenge whenever it received an
un-authenticated RRQ or Agent Solicitation, and that allocated new
storage for each challenge.  This would have the property of not
invalidating old challenges (because they would still be kept in
storage) but would allow unauthenticated messages to exhaust the
resources of the FA, which would be bad.

-Pete

_______________________________________________
Mip4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip4