Subject: [Mip4] [Issue 20] Missing description - FA rejection code when MN-HA auth.ext.invalid

From: Pete McCann <[email-masked]>
Date: Mon, 2 Feb 2004 17:45:47 -0600

I re-read the issue and I don't understand what it is saying.  I think
it may have been mistakenly attributed to me or incorrectly
transcribed.

I think it is fine to reject this, barring a more cogent statement of
the issue.  Maybe it had something to do with the FA modifying
rejection codes, interfering with the MN-HA authentication extension,
which is the topic of the new draft you are working on.

-Pete

Charles E. Perkins writes:
 > 
 > Hello folks,
 > 
 > Please refer to previous discussion at the following URL:
 >         http://www.mip4.org/issues/tracker/mip4/issue20
 > as necessary.
 > 
 > The suggestion was to mandate some action on the part of
 > a foreign agent if no MN-HA authentication extension is
 > present.  Presumably, this really means, to reject in case
 > there is no authorization-enabling extension.  But this
 > should anyway be a rare case, and there is little danger
 > since the home agent or other authorizing agent will
 > reject the Request.
 > 
 > I propose that no action be taken, and that the
 > suggestion to change the specification be rejected.
 > 
 > Comments?
 > 
 > Regards,
 > Charlie P.
 > 
 > -- 
 > Mip4 mailing list
 > [email-masked]
 > https://www.ietf.org/mailman/listinfo/mip4

-- 
Mip4 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip4

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 02 Feb 2004 16:10:02 -0800

Hello Pete,

There are two separate issues that could be discussed:

- What happens if the FA _knows_ that the Registration Request
   is guaranteed to be rejected because there isn't any MN-HA
   extension?

- What happens when the FA wants to insert an error code into
   a Registration Reply?

The latter question should be answered by the FA error extension
draft which is, I think, basically about done and ready to be
disseminated as a new Internet Draft.

Regards,
Charlie P.

---

From: Pete McCann <[email-masked]>
Date: Mon, 2 Feb 2004 18:12:57 -0600

Hi, Charlie,

 >    is guaranteed to be rejected because there isn't any MN-HA

I agree this aspect should be rejected.  We should not have the FA
checking extensions for which it is not responsible.

 > disseminated as a new Internet Draft.

Yup.

-Pete