Subject: Re: [Mip4] [Issue 20] Missing description - FA rejection code whenMN-HA auth.ext.invalid

From: Pete McCann <[email-masked]>
Date: Mon, 15 Mar 2004 13:37:09 -0600

Hi, Charlie,

My personal opinion is that we should go ahead and insert the
normative reference.  I also support adopting the faerr draft as a
working group document.

-Pete

Charles E. Perkins writes:
 > 
 > Hello folks,
 > 
 > I am in the process of attending to all remaining
 > comments for the rfc3344bis document, so that I
 > can go ahead and send in the new draft.
 > 
 > With the submission of the "faerr" document,
 >      draft-perkins-mip4-faerr-00.txt
 > I propose that this issue be marked as
 > "closed".
 > 
 > The only remaining point is whether or not
 > the "faerr" document should be mentioned
 > within rfc3344bis.  Overall, it seems to me
 > that it should be as a normative reference,
 > but then that introduces a dependency which
 > may be unwanted.
 > 
 > Regards,
 > Charlie P.
 > 
 > 
 > 
 > Pete McCann wrote:
 > > 
 > > Hi, Charlie,
 > > 
 > > Charles E. Perkins writes:
 > >  >
 > >  > Hello Pete,
 > >  >
 > >  > There are two separate issues that could be discussed:
 > >  >
 > >  > - What happens if the FA _knows_ that the Registration Request
 > >  >    is guaranteed to be rejected because there isn't any MN-HA
 > >  >    extension?
 > > 
 > > I agree this aspect should be rejected.  We should not have the FA
 > > checking extensions for which it is not responsible.
 > > 
 > >  > - What happens when the FA wants to insert an error code into
 > >  >    a Registration Reply?
 > >  >
 > >  > The latter question should be answered by the FA error extension
 > >  > draft which is, I think, basically about done and ready to be
 > >  > disseminated as a new Internet Draft.
 > > 
 > > Yup.
 > > 
 > > -Pete
 > > 
 > >  > Regards,
 > >  > Charlie P.
 > >  >
 > >  >
 > >  > Pete McCann wrote:
 > >  >
 > >  > >I re-read the issue and I don't understand what it is saying.  I think
 > >  > >it may have been mistakenly attributed to me or incorrectly
 > >  > >transcribed.
 > >  > >
 > >  > >I think it is fine to reject this, barring a more cogent statement of
 > >  > >the issue.  Maybe it had something to do with the FA modifying
 > >  > >rejection codes, interfering with the MN-HA authentication extension,
 > >  > >which is the topic of the new draft you are working on.
 > >  > >
 > >  > >-Pete
 > >  > >
 > >  > >
 > >  > >Charles E. Perkins writes:
 > >  > > >
 > >  > > > Hello folks,
 > >  > > >
 > >  > > > Please refer to previous discussion at the following URL:
 > >  > > >         http://www.mip4.org/issues/tracker/mip4/issue20
 > >  > > > as necessary.
 > >  > > >
 > >  > > > The suggestion was to mandate some action on the part of
 > >  > > > a foreign agent if no MN-HA authentication extension is
 > >  > > > present.  Presumably, this really means, to reject in case
 > >  > > > there is no authorization-enabling extension.  But this
 > >  > > > should anyway be a rare case, and there is little danger
 > >  > > > since the home agent or other authorizing agent will
 > >  > > > reject the Request.
 > >  > > >
 > >  > > > I propose that no action be taken, and that the
 > >  > > > suggestion to change the specification be rejected.
 > >  > > >
 > >  > > > Comments?
 > >  > > >
 > >  > > > Regards,
 > >  > > > Charlie P.

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 15 Mar 2004 14:18:52 -0800

Hello Pete,

If this is done, then a reasonable associated action would
be to remove certain error codes from consideration for
use within the Registration Request.

Also, I am wondering about rfc3344bis going to Draft
Status when it contains a normative reference to something
that isn't yet a working group document.  When it gets to
be a working group document, it will take a while before it
is standardized.  After <faerr> is Proposed Standard, it will
take a "<IETF-patented>_long time_" before it is Draft.

Is that "O.K."?

Regards,
Charlie P.

Pete McCann wrote:
> --DS-7754947213702225121
> --DS-7754947213702225121--

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 12 Mar 2004 13:09:02 -0800

Hello folks,

Regards,
Charlie P.

Pete McCann wrote:
>  > > > Mip4 mailing list
>  > > > [email-masked]
>  > > > https://www.ietf.org/mailman/listinfo/mip4
>  > >
>  > >
>  > >
>  > >
>  >
> 
> --
> Mip4 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mip4