Subject: Re: [Mip4] Request to onsider "faerr" specification as a working group document

From: Kent Leung <[email-masked]>
Date: Tue, 16 Mar 2004 12:33:23 -0800

Hi Charlie.  Just some thoughts on the draft ..

1) In section 4, should the allowable code be just generically in
     the range of  64-127 (Error Codes from the Foreign Agent)?
     This avoids having to selectively choose which defined error
     code is admissible in this extension?  Does it make sense
     for any code that exists today or will be added in the future
     to not be carried in the extension?   What happens when
     event happens with error code that is not allowed, should FA
     not add the extension or map to some allowable code?

2) Should there be a MN Considerations section to specify that
     MN should deregister an accepted registration (status code
     0 or 1 from HA) which contains this FA error extension?  This
     would clean up such condition when HA thinks everything
     is OK but FA disagree.  Silence by MN provides implicit
     acknowledgement to HA that FA and MN are OK with the
     accepted registration reply.  Else MN would notify the HA
     that FA had problem with the reply.  Should the specifics of the
     FA error code be conveyed to HA by MN? This would allow MN,
     FA, and HA to log the same error condition.

Kent

At 12:57 PM 3/12/2004 -0800, Charles E. Perkins wrote:

>Hello folks,
>
>I have submitted the following document,
>     "Foreign Agent Error Extension for Mobile IPv4",
>draft-perkins-mip4-faerr-00.txt,
>previous to the last IETF as a proposal for
>solving some problems raised in issues 9,
>18, and 20 (see http://www.mip4.org/issues/tracker/mip4/).
>
>I would like to request that this document be considered
>as a working group document.
>
>Regards,
>Charlie P.
>
>--
>Mip4 mailing list: [email-masked]
>     Web interface: https://www.ietf.org/mailman/listinfo/mip4
>      Charter page: http://www.ietf.org/html.charters/mip4-charter.html
>Supplemental site: http://www.mip4.org/

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 12 Mar 2004 12:57:59 -0800

Hello folks,

Regards,
Charlie P.