Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Thu, 1 Dec 2005 18:28:45 -0800

Hi Vijay.
 
> the changes I proposed include 2. the changes I suggested do 
> the following
> 
> - clarify that the MN MUST NOT include the challenge extension
> - clarify that in the absence of the FA, there is no 
> challenge generated by the network.

Also, MN sets the challenge value to zero in the MN-AAA authenticator
computation.  

> - clarify that in the absence of a challenge, replay 
> protection is provided by the identification field.
> 

I don't think this is necessary, but doesn't matter too much to me
either.

Kent

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 01 Dec 2005 18:57:56 -0800

> Also, MN sets the challenge value to zero in the MN-AAA authenticator

hmm.. how about the MN does not use any challenge value
(whether 0 or anything else)? it calculates the MN-AAA
authenticator without any challenge field. one the basic
clarifications that is needed is that there is no
challenge to use when there is no FA.

> I don't think this is necessary, but doesn't matter too much to me

well, folks inside Nokia who implement mobile nodes were
very confused by RFC 3012. it would be good to make this
explicit.

Vijay