Subject: RE: [Mip4] review: draft-ietf-mip4-rfc3012bis-04.txt

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Thu, 1 Dec 2005 18:13:01 -0800

Hi Charlie.  Comments below.

> 
> What if the draft allows the Generalized Authentication 
> extension for mobile nodes with CCoA, but does not allow the 
> challenge extension?  I don't see what's wrong with this, 
> since the draft is "about" a foreign agent protocol.
> 

But that means the Generalized Authentication is split into 2 separate
drafts (this one for FA CoA mode and a new draft for CCoA mode).  BTW, I
think this was proposed in the thread but not warmly received.

> Then, enabling the Generalized Authentication extension for 
> co-located CoA just amounts to reasonable practice, not 
> refocussing the document on colocated CoA.
> 

I don't think adding a couple of sentences to specify that MFCE is not
needed in CCoA mode is refocussing this draft.

Kent

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 01 Dec 2005 18:17:39 -0800

>think this was proposed in the thread but not warmly received.
No, I think it's fine if the same draft mentions that the extension is
legitimate for use by mobile nodes with co-located CoA.

>needed in CCoA mode is refocussing this draft.
This is fine with me.  I guess you inferred that I am against mentioning
co-located CoA in this draft.  I am not against that, and I did not mean
to imply that.    I am only against specifying a way to use the challenge
extension with co-located CoA.

Regards,
Charlie P.