Subject: RE: [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Tue, 1 Aug 2006 15:52:20 -0700

Hi Eva.  Comments below.

________________________________

	From: Eva Fogelström [mailto:[email-masked]] 
	Sent: Tuesday, August 01, 2006 4:39 AM
	To: Jari Arkko
	Cc: [email-masked]
	Subject: [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt

	<snip>
	 
	 This seems to suggest a model where those who employ this
	mechanism may end up preventing regular Mobile IP clients
	from getting service. I do not see why we would have to make this
	so. I wonder if it would be better to require both a regular address
	and gateway address (possibly all-ones) to be advertised? You could
	still require that mobile nodes compliant to reg-tunnel use
	dynamic assignment.
	  Yes. I believe the original intention was to support FAs with private addresses in regional registrations. However, unless someone has a real need for this feature, we can skip it and instead make it so that regular MIP4 clients can always get service, according to your suggestion. Comments? 

		[Kent Leung (kleung)] FAs with private addresses (CoA) can still be supported via RFC 3519. In this case,
		it's no different than the scenario covered in that RFC.  BTW, this assumes that the MN is smart enough
		to use the FA's private or public CoA instead of the all 1's CoA received from the Agent Advertisement. :)
		 
		Couple of other clarifications seeked after a quick scan:
		1)  Is the Hierarchical Foreign Agent Type skippable or non-skippable?
		2) Is the Replay Protection Style Type skippable or not?
		Kent

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Eva Fogelström <[email-masked]>
Date: Wed, 02 Aug 2006 09:32:00 +0200

Hi Kent,

Comments below.

Kent Leung (kleung) wrote:

> Hi Eva.  Comments below.
>
>     ------------------------------------------------------------------------
>     *From:* Eva Fogelström [mailto:[email-masked]]
>     *Sent:* Tuesday, August 01, 2006 4:39 AM
>     *To:* Jari Arkko
>     *Cc:* [email-masked]
>     *Subject:* [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt
>
>     <snip>
>      
>       Yes. I believe the original intention was to support FAs with
>     private addresses in regional registrations. However, unless
>     someone has a real need for this feature, we can skip it and
>     instead make it so that regular MIP4 clients can always get
>     service, according to your suggestion. Comments?
>

The draft currently defines the following (IANA Considerations section):
- GFA IP address (non-skippable)
- Hierarchical FA (skippable)
- Replay protection style (skippable)

I'll clarify.

Eva