Subject: RE: [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt

From: "Kent Leung \(kleung\)" <[email-masked]>
Date: Thu, 3 Aug 2006 08:11:31 -0700

Yes, I think using the GFA-Lifetime extension is better for separation of registration lifetime maintenance.
 
Kent

________________________________

	From: Tsirtsis, George [mailto:[email-masked]] 
	Sent: Thursday, August 03, 2006 3:37 AM
	To: Eva Fogelström
	Cc: Jari Arkko; Kent Leung (kleung); [email-masked]
	Subject: RE: [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt

	The reason I think the GFA should be able to have a different lifetime than the HA is because I anticipate regional registration to be deployed in the context of roaming between domains/operators. i.e., a mobile has an HA in its home operator. When it moves to another operator it uses a GFA for local mobility management. The GFA is provided by the local operator and has its own requirements. It is typically in the industry that each domain/operator has control over its own infrastructure and does not depend on configuration in a third operator (unless absolutely necessary). Such refresh lifetimes is one such parameter that they can control.

	I will also reiterate that your draft supports this concept already, since the GFA can impose its own lifetime *after* a handoff takes place. All I am saying is that if the GFA needs to impose its own lifetime it should be able to impose it immediately.

	As to the solution I suggested, it is just one solution. Another, possibly better solution, would be to define a GFA-Lifetime extension which the GFA can include in the Registration Reply during the initial MN-FA-GFA-HA registration. This does what I am suggesting without requiring a regional registration with the GFA. 

	George

________________________________

	From: Eva Fogelström [mailto:[email-masked]] 
	Sent: Thursday, August 03, 2006 3:11 AM
	To: Tsirtsis, George
	Cc: Jari Arkko; Kent Leung (kleung); [email-masked]
	Subject: Re: [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt

	Hi George,
	
	I understand what you want to do, but I don't understand the motivation for it. In particular, I don't understand why being able to define a separate lifetime at the GFA (compared to the HA) would motivate a mandatory double registration (home + regional registration) each time the MN registers with its HA.
	
	Eva
	
	Tsirtsis, George wrote:

	In line...

________________________________

	From: Eva Fogelström [mailto:[email-masked]] 
	Sent: Wednesday, August 02, 2006 10:59 AM
	To: Tsirtsis, George
	Cc: Jari Arkko; Kent Leung (kleung); [email-masked]
	Subject: Re: [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt

	Hi George,
	...

	Since you are making some changes I also have one more suggestion. According to the draft, the mobile first registers with the HA using regular registrations (+some extensions) and then uses regional registrations to the GFA if it handoffs within the area covered by the local GFA. The draft does not currently require the mobile to register with the GFA until it hands off. This creates the following issues which is a bit strange. Once the mobile hands-off and uses regional registration, the GFA can define a Lifetime that is equal to or smaller than the Lifetime defined by the HA. This makes sense but the strange thing is that the GFA can not impose its desired lifetime for regional registrations until the mobile hands-off in its region.

	I think this can be trivially fixed by requiring that the mobile uses regional registration immediately after normal registration when a GFA is present, and even if the mobile does not hand-off. 

	Thoughts?

	George

	I'm not sure I follow. When the MN does a home registration with its HA, the GFA acts as foreign agent towards the HA. The registration request goes as follows: MN-FA-GFA-HA. Ok?

	GT> Yes

	The GFA is a foreign agent, as defined in RFC3344, with some additions. In my understanding, this means that if the GFA does not approve of the lifetime in the registration request when it receives it, it can simply deny the home registration with error code 69 (requested lifetime too long).

	GT> Yes, but what you describe would result in the lower Lifetime be forced to the Home Agent too, which is not ideal. What I am looking for here is separation of the refresh requirements imposed by the Home and the Foreign domains. The GFA should be able to require a Lifetime that is different (i.e., lower) than the lifetime required by the HA, without affecting what the HA requires. Note that your draft already allows for that but the mobile has to first perform a handoff. At that point the GFA can return a Lifetime that is independent from the lifetime returned by the HA. Is this clearer?

	George

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Eva Fogelström <[email-masked]>
Date: Fri, 18 Aug 2006 13:18:08 +0200

Hi George,

I have added an optional regional registration lifetime extension to the 
draft.

Eva

Kent Leung (kleung) wrote:

>     ------------------------------------------------------------------------
>     *From:* Tsirtsis, George [mailto:[email-masked]]
>     *Sent:* Thursday, August 03, 2006 3:37 AM
>     *To:* Eva Fogelström
>     *Cc:* Jari Arkko; Kent Leung (kleung); [email-masked]
>     *Subject:* RE: [Mip4] Re: AD review of
>     draft-ietf-mip4-reg-tunnel-02.txt
>
>     The reason I think the GFA should be able to have a different
>     lifetime than the HA is because I anticipate regional registration
>     to be deployed in the context of roaming between
>     domains/operators. i.e., a mobile has an HA in its home operator.
>     When it moves to another operator it uses a GFA for local mobility
>     management. The GFA is provided by the local operator and has its
>     own requirements. It is typically in the industry that each
>     domain/operator has control over its own infrastructure and does
>     not depend on configuration in a third operator (unless absolutely
>     necessary). Such refresh lifetimes is one such parameter that they
>     can control.
>
>      
>
>     I will also reiterate that your draft supports this concept
>     already, since the GFA can impose its own lifetime **after** a
>     handoff takes place. All I am saying is that if the GFA needs to
>     impose its own lifetime it should be able to impose it immediately.
>
>      
>
>     As to the solution I suggested, it is just one solution. Another,
>     possibly better solution, would be to define a GFA-Lifetime
>     extension which the GFA can include in the Registration Reply
>     during the initial MN-FA-GFA-HA registration. This does what I am
>     suggesting without requiring a regional registration with the GFA.
>
>      
>
>     George
>
>      
>
>     ------------------------------------------------------------------------
>
>     *From:* Eva Fogelström [mailto:[email-masked]]
>     *Sent:* Thursday, August 03, 2006 3:11 AM
>     *To:* Tsirtsis, George
>     *Cc:* Jari Arkko; Kent Leung (kleung); [email-masked]
>     *Subject:* Re: [Mip4] Re: AD review of
>     draft-ietf-mip4-reg-tunnel-02.txt
>
>      
>
>     Hi George,
>
>     I understand what you want to do, but I don't understand the
>     motivation for it. In particular, I don't understand why being
>     able to define a separate lifetime at the GFA (compared to the HA)
>     would motivate a mandatory double registration (home + regional
>     registration) each time the MN registers with its HA.
>
>     Eva
>
>     Tsirtsis, George wrote:
>
>     In line...
>
>      
>
>     ------------------------------------------------------------------------
>
>     *From:* Eva Fogelström [mailto:[email-masked]]
>     *Sent:* Wednesday, August 02, 2006 10:59 AM
>     *To:* Tsirtsis, George
>     *Cc:* Jari Arkko; Kent Leung (kleung); [email-masked]
>     <mailto:[email-masked]>
>     *Subject:* Re: [Mip4] Re: AD review of
>     draft-ietf-mip4-reg-tunnel-02.txt
>
>      
>
>     Hi George,
>     ...
>
>     Since you are making some changes I also have one more suggestion.
>     According to the draft, the mobile first registers with the HA
>     using regular registrations (+some extensions) and then uses
>     regional registrations to the GFA if it handoffs within the area
>     covered by the local GFA. The draft does not currently require the
>     mobile to register with the GFA until it hands off. This creates
>     the following issues which is a bit strange. Once the mobile
>     hands-off and uses regional registration, the GFA can define a
>     Lifetime that is equal to or smaller than the Lifetime defined by
>     the HA. This makes sense but the strange thing is that the GFA can
>     not impose its desired lifetime for regional registrations until
>     the mobile hands-off in its region.
>
>      
>
>     I think this can be trivially fixed by requiring that the mobile
>     uses regional registration immediately after normal registration
>     when a GFA is present, and even if the mobile does not hand-off.
>
>      
>
>     Thoughts?
>
>     George
>
>
>     I'm not sure I follow. When the MN does a home registration with
>     its HA, the GFA acts as foreign agent towards the HA. The
>     registration request goes as follows: MN-FA-GFA-HA. Ok?
>
>     GT> Yes
>
>
>     The GFA is a foreign agent, as defined in RFC3344, with some
>     additions. In my understanding, this means that if the GFA does
>     not approve of the lifetime in the registration request when it
>     receives it, it can simply deny the home registration with error
>     code 69 (requested lifetime too long).
>
>     GT> Yes, but what you describe would result in the lower Lifetime
>     be forced to the Home Agent too, which is not ideal. What I am
>     looking for here is separation of the refresh requirements imposed
>     by the Home and the Foreign domains. The GFA should be able to
>     require a Lifetime that is different (i.e., lower) than the
>     lifetime required by the HA, without affecting what the HA
>     requires. Note that your draft already allows for that but the
>     mobile has to first perform a handoff. At that point the GFA can
>     return a Lifetime that is independent from the lifetime returned
>     by the HA. Is this clearer?
>
>     George
>

---

From: "Tsirtsis, George" <[email-masked]>
Date: Fri, 18 Aug 2006 05:05:57 -0700

Thanks Eva,

It is appreciated.

Regards

George

From: Eva Fogelström [mailto:[email-masked]] 
Sent: Friday, August 18, 2006 7:18 AM
To: Tsirtsis, George
Cc: Kent Leung (kleung); Jari Arkko; [email-masked]
Subject: Re: [Mip4] Re: AD review of draft-ietf-mip4-reg-tunnel-02.txt

Hi George,

I have added an optional regional registration lifetime extension to the draft.

Eva

Kent

	George

	Hi George,

	Eva
	
	Tsirtsis, George wrote:

	In line...

	Hi George,
	...

	Thoughts?

	George

	GT> Yes

	George