Subject: [Mip4] Working Group Last Call on draft-ietf-mip4-fmipv4-01.txt

From: Pete McCann <[email-masked]>
Date: Tue, 05 Sep 2006 11:25:25 -0500

This message announces a WG last call on:

  "Mobile IPv4 Fast Handovers"
  - draft-ietf-mip4-fmipv4-01.txt

The last call will conclude at 24:00 UTC on Tuesday, 19 September 2006.

"Mobile IPv4 Fast Handovers" describes new messages and procedures
for allowing a mobile node to regain connectivity at a new point
of attachment prior to completing an end-to-end MIPv4 registration.

A URL for this Internet-Draft is:

<http://www.ietf.org/internet-drafts/draft-ietf-mip4-fmipv4-01.txt>

Please respond to this WG last call:

* If you have no comments on the draft, and support its advancement,
   simply respond with a line containing something like

    "I support the advancement of this document to the IESG with a
     request for publication as proposed standard."

   If you have comments, please use a line similar to the one above, and
   supplement this with your comments.

* If you *don't* support its advancement, respond with a line containing
   something like the following, supplemented by your comments -

    "I don't support the advancement of this document to the IESG with
     a request for publication as proposed standard, for the following
     reasons:"
    ...

     Pete & Henrik

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 19 Sep 2006 23:12:33 -0700

>   - draft-ietf-mip4-fmipv4-01.txt

I support the advancement of this document to the IESG
with a request for publication as experimental standard.

I have a few comments though.

section 2 needs to be re-written to have separate
sections on FA CoA mode and co-located CoA mode. the
protocol operation was not clear to me in the FA CoA
mode. more specifically

- in a predictive FBU in FA CoA mode, isn't the PCoA
same as PAR? if yes, will the source and the
destination address on the FBU be set to the same
address?
- when is the home address field in the FBU set to the
PCoA and when is it set to the MN's home address?

in section 2.1,
>    The Handover Initiate (HI) and Handover Acknowledge (HAck) messages
>    serve to establish a tunnel between the routers to support packet
>    forwarding for PCoA. The tunnel itself is established as a response
>    to the FBU message.  Furthermore, when the MN obtains a NCoA from
>    NAR, the reverse tunnel to the PAR is not necessary; the MN would
>    reverse tunnel to the Home Agent directly using its NCoA.

the reserve tunneling to the home agent can only be
done after registration request/reply exchange with
the home agent right?

in section 4.4,
>    New CoA Option
>                   MAY be present when PrRtAdv is sent
>                   unsolicited. PAR MAY compute new CoA using NAR's
>                   prefix information and the MN's L2 address, or by
>                   any other means.

you might to delete the second sentence. :)

Vijay