Subject: RE: [Mip4] WGLC for draft-ietf-mip4-nemo-v4-base-02.txt

From: "McCann Peter-A001034" <[email-masked]>
Date: Tue, 2 Oct 2007 13:09:57 -0400

Reminder: this WGLC ends tomorrow, October 3rd.  Please
send statements of support / non-support for this draft
to the list.

If we do not see sufficient consensus in the WG the draft 
will not be advanced.  So far we have only gotten 1 comment
in support of the draft.

-Pete

McCann Peter-A001034 wrote:
> This message announces a 2-week working group last call on:
> 
> "Network Mobility (NEMO) Extensions for Mobile IPv4"
> draft-ietf-mip4-nemo-v4-base-02.txt
> 
> The last call will end at 24:00 UTC on Wednesday, October 3rd 2007.
> 
> This document describes a protocol for supporting Mobile Networks
> between a Mobile Router and a Home Agent by extending the Mobile IPv4
> protocol.  A Mobile Router is responsible for the mobility of one or
> more network segments or subnets moving together.  The Mobile Router
> hides its mobility from the nodes on the mobile network.  The nodes
> on the Mobile Network may be fixed in relationship to the Mobile
> Router and may not have any mobility function.      
> 
> Extensions to Mobile IPv4 are introduced to support Mobile Networks.
> 
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-ietf-mip4-nemo-v4-base-02.txt
> 
> Please respond to this working group last call:
> 
> * If you have no comments on the draft, and support its advancement,
>   simply respond with a line containing something like
> 
>     "I support the advancement of this document to the IESG with a
>      request for publication as a Proposed Standard RFC."
> 
>    If you have comments, please use a line similar to the one above,
>    and supplement this with your comments.
> 
> 
> * If you *don't* support its advancement, respond with a line
>   containing something like the following, supplemented by your
>   comments -
> 
>     "I don't support the advancement of this document to the IESG with
>      a request for publication as a Proposed Standard RFC, for the
>      following reasons:"
>     ...
> 
> Please direct all replies to the Mobile IPv4 mailing list,
> [email-masked]. 
> 
> -Pete & Henrik

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www1.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 3 Oct 2007 08:05:18 +0800

I support the advancement of this document to the IESG with a
request for publication as a Proposed Standard RFC."

-Hui

---

From: "Yoshi Tsuda (yotsuda)" <[email-masked]>
Date: Wed, 3 Oct 2007 14:44:13 +0800

Hi WG chair,

Thanks.
-Yoshi

> -----Original Message-----
> From: McCann Peter-A001034 [mailto:[email-masked]] 
> Sent: Tuesday, October 02, 2007 10:10 AM
> To: [email-masked]
> Subject: RE: [Mip4] WGLC for draft-ietf-mip4-nemo-v4-base-02.txt 
> 
> Reminder: this WGLC ends tomorrow, October 3rd.  Please send 
> statements of support / non-support for this draft to the list.
> 
> > hides its mobility from the nodes on the mobile network.  
> The nodes on 
> > the Mobile Network may be fixed in relationship to the Mobile

---

From: <[email-masked]>
Date: Wed, 3 Oct 2007 10:32:10 +0200

I support advancing this draft.

Cheers,
	Jouni

> Sent: Tuesday, October 02, 2007 8:10 PM
> To: [email-masked]

---

From: Hans Sjöstrand <[email-masked]>
Date: Thu, 04 Oct 2007 14:40:52 +0200

I support the advancement of this document to the IESG with a request for publication as a Proposed Standard RFC when the following comment is addressed. 

- The issue about foreign agent care of mode must be clarified. 

As it is now, it's ambiguous whether foreign agent care of mode is supported with the mechanisms in this document. Further, if it is supported, if it's mandatory double tunneling or something like draft-ietf-mip4-nemov4-fa that applies. 

Sorry for being late

best regards
/// Hasse

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 04 Oct 2007 16:14:35 +0200

Hans Sjöstrand wrote:
> I support the advancement of this document to the IESG with a request
>  for publication as a Proposed Standard RFC when the following
> comment is addressed. - The issue about foreign agent care of mode
> must be clarified. As it is now, it's ambiguous whether foreign agent
> care of mode is supported with the mechanisms in this document.
> Further, if it is supported, if it's mandatory double tunneling or
> something like draft-ietf-mip4-nemov4-fa that applies. Sorry for
> being late

Hasse, ChristopheJ, thanks for the follow-up.

How about this introductory text:
> This document describes protocol extensions to Mobile IPv4 as per 
> [RFC3344] and its update [2], to enable support for Mobile Networks.
> This draft addresses mainly the co-located Care-of Address mode.
> Foreign Agent Care-of Address mode (with 'legacy' Foreign Agents, RFC
> 3344) are supported but without optimization, double encapsulation
> being used.  For an optimization of this mode, the gentle reader is
> directed to [1].

Instead of:
> This document describes protocol extensions to Mobile IPv4 
> ([RFC3344]) to enable support for Mobile Networks.  This draft 
> addresses only co-located Care-of Address mode (not Foreign Agent 
> Care-of Address mode, for which the gentle reader is directed to 
> [1]).

And this (check last 3 lines):
> This document specifies an additional tunnel between Mobile Router's
> Home Address and the Home Agent.  This tunnel is encapsulated within
> the normal tunnel between the Care-of Address (CoA) and Home Agent.
> In Foreign Agent CoA mode, the tunnel between the Mobile Router and
> Home Agent is needed to allow the Foreign Agent to direct the
> decapsulated packet to the proper visiting Mobile Router.  However,
> in Collocated CoA mode, the additional tunnel is not essential and
> could be eliminated because the Mobile Router is the recipient of the
> encapsulated packets for the Mobile Network.

Instead of (check last 3 lines):
> This document specifies an additional tunnel between Mobile Router's 
> Home Address and the Home Agent.  This tunnel is encapsulated within 
> the normal tunnel between the Care-of Address (CoA) and Home Agent. 
> In Foreign Agent CoA mode, the tunnel between the Mobile Router and 
> Home Agent is needed to allow the Foreign Agent to direct the 
> decapsulated packet to the proper visiting Mobile Router.  However, 
> in Collocated CoA mode, the additional tunnel is not essential and 
> can be eliminated because the Mobile Router is the recipient of the 
> encapsulated packets for the Mobile Network.

Finally, if the following paragraph disturbs then I can remove it 
altogether:
>    For optimization, the Home Agent SHOULD only encapsulate the packet
>    with the tunnel header (source IP address set to Home Agent and
>    destination IP address set to CoA) for Collocated CoA mode.

Is there any other text occurence that disturbs?

Alex

> best regards /// Hasse
>> between a Mobile Router and a Home Agent by extending the Mobile
>> IPv4 protocol.  A Mobile Router is responsible for the mobility of
>> one or more network segments or subnets moving together.  The
>> Mobile Router hides its mobility from the nodes on the mobile
>> network.  The nodes on the Mobile Network may be fixed in
>> relationship to the Mobile Router and may not have any mobility
>> function.
>> 
>> * If you have no comments on the draft, and support its
>> advancement, simply respond with a line containing something like
>> 
>> following reasons:" ...

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________

---

From: Christophe Janneteau <[email-masked]>
Date: Thu, 04 Oct 2007 17:19:31 +0200

Hi Alex,

Please see my comments inline.

Alexandru Petrescu wrote:
[snip]
>> This document describes protocol extensions to Mobile IPv4 ([RFC3344])
>> to enable support for Mobile Networks.  This draft addresses only
>> co-located Care-of Address mode (not Foreign Agent Care-of Address
>> mode, for which the gentle reader is directed to [1]).

I agree. I guess this addresses quite well the issue I raised.

>> the normal tunnel between the Care-of Address (CoA) and Home Agent. In
>> Foreign Agent CoA mode, the tunnel between the Mobile Router and Home
>> Agent is needed to allow the Foreign Agent to direct the decapsulated
>> packet to the proper visiting Mobile Router.  However, in Collocated
>> CoA mode, the additional tunnel is not essential and can be eliminated
>> because the Mobile Router is the recipient of the encapsulated packets
>> for the Mobile Network.

OK.

>>    destination IP address set to CoA) for Collocated CoA mode.

I am fine with this text and keeping it inside the draft.

Thanks
Christophe

>>> If you have comments, please use a line similar to the one above, and
>>> supplement this with your comments.
>>>
>>>
>>> containing something like the following, supplemented by your comments -
>>>
>>> "I don't support the advancement of this document to the IESG with a
>>> request for publication as a Proposed Standard RFC, for the following
>>> reasons:" ...
>>>

---

From: "Tsirtsis, George" <[email-masked]>
Date: Thu, 4 Oct 2007 08:40:47 -0700

Alex, sorry I have still not managed to review the document but in any case I did in the past and I do not remember any outstanding issues, so the WG should not wait for my review. I wanted to make one comment below, however,...

-----Original Message-----
From: Christophe Janneteau [mailto:[email-masked]] 
Sent: Thursday, October 04, 2007 4:20 PM
To: Alexandru Petrescu
Cc: Hans Sjöstrand; [email-masked]
Subject: Re: [Mip4] WGLC for draft-ietf-mip4-nemo-v4-base-02.txt

Hi Alex,

GT> Yes this is clearer, but can the reference to an Internet-draft survive the conversion of this doc to an RFC?

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 04 Oct 2007 22:49:30 +0200

Tsirtsis, George wrote:
> Alex, sorry I have still not managed to review the document but in 
> any case I did in the past and I do not remember any outstanding 
> issues, so the WG should not wait for my review.

So you
> request for publication as a Proposed Standard RFC."
?

> I wanted to make one comment below, however,...
> 
> -----Original Message----- From: Christophe Janneteau 
> [mailto:[email-masked]] Sent: Thursday, October 
> 04, 2007 4:20 PM To: Alexandru Petrescu Cc: Hans Sjöstrand; 
> [email-masked] Subject: Re: [Mip4] WGLC for 
> Alexandru Petrescu wrote: [snip]
>>>  [RFC3344] and its update [2], to enable support for Mobile 
>>> Networks. This draft addresses mainly the co-located Care-of 
>>> Address mode. Foreign Agent Care-of Address mode (with 'legacy' 
>>> Foreign Agents, RFC 3344) are supported but without optimization,
>>>  double encapsulation being used.  For an optimization of this 
>>> mode, the gentle reader is directed to [1].
>> Instead of:
> GT> Yes this is clearer, but can the reference to an Internet-draft 
> survive the conversion of this doc to an RFC?

Usually no, I don't remember having seen an RFC with references to
drafts, or not common.  During later editing steps we could either 
remove that "for which the gentle reader is directed to [1]" or replace 
it with something else; let's watch that space.

Alex

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Sun, 14 Oct 2007 21:02:20 -0700

> it with something else; let's watch that space.

Since this is only an informative reference, using a draft as a reference is fine and should have no impact on getting published as an RFC.  So, I don't think we need to revise the text. 

Regards,
Vidya