Subject: [Mip4] Working Group Last Call on draft-ietf-mip4-nemov4-dynamic-04.txt

From: Pete McCann <[email-masked]>
Date: Wed, 13 Apr 2011 14:27:32 -0500

This message announces a WG last call on:

"Dynamic Prefix Allocation for NEMOv4"
draft-ietf-mip4-nemov4-dynamic-04.txt

The base NEMOv4 specification defines extensions to Mobile IPv4 for
mobile networks.  This specification defines a dynamic prefix
allocation mechanism.

This draft is intended for publication as a Proposed Standard.
The last call will conclude at 24:00 UTC on Wednesday, April 27, 2011.

A URL for this Internet-Draft is:

<http://www.ietf.org/internet-drafts/draft-ietf-mip4-nemov4-dynamic-04.txt>

Please respond to this WG last call:

* If you have no comments on the draft, and support its advancement,
  simply respond with a line containing something like

"I support the advancement of this document to the IESG with a request
 for publication as proposed standard."

If you have comments, please use a line similar to the one above, and
supplement this with your comments.

* If you *don't* support its advancement, respond with a line containing
  something like the following, supplemented by your comments -

"I don't support the advancement of this document to the IESG with a
request for publication as proposed standard, for the following reasons:" ...

-Pete

---

From: Pete McCann <[email-masked]>
Date: Wed, 27 Apr 2011 15:24:06 -0400

Hi, All,

This WGLC is ending tonight.  So far we have received no comments,
but I think the draft is short and straightforward and we all understand
it.

I read it over this afternoon and the only comment I have is to change
the term "mobile client" to "Mobile Router" to be consistent with the
terms in 5177 (note the capitalization).

-Pete

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Wed, 27 Apr 2011 12:33:04 -0700

Hi Pete. I agree and will make the suggested changes before publishing the next version.

Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Pete McCann
Sent: Wednesday, April 27, 2011 12:24 PM
To: [email-masked]
Subject: Re: [Mip4] Working Group Last Call ondraft-ietf-mip4-nemov4-dynamic-04.txt

Hi, All,

-Pete

-- 
Mip4 mailing list: [email-masked]
    Web interface: https://www.ietf.org/mailman/listinfo/mip4
     Charter page: http://www.ietf.org/html.charters/mip4-charter.html
Supplemental site: http://www.mip4.org/

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 28 Apr 2011 17:08:39 +0200

Draft looks ok.

Reference to Mobile IPv4 should be updated (rfc5944 obsoletes rfc3344).

Are there prototype implementations about it?

We could discuss new reply codes (i.e. MR requests a prefix allocation
but HA refuses).

"extensiona" is a, typo should be
"extension"

We could specify the MR such that when it receives such a prefix from
its HA then it writes it in its local dhcpd.conf, or otherwise put, it
uses that MNP for serving autoconfiguration purposes of the LFNs
attaching to it.  The goal proper of this draft is this.

What happened to
http://tools.ietf.org/html/draft-johnson-dhc-subnet-alloc-00 ?  If there
exist a DHCP implementation doing this subnet allocation then it makes
sense to document it for NEMO.

Otherwise the behaviour in the draft seems ok.

Alex

Le 27/04/2011 21:33, Kent Leung (kleung) a écrit :
> -----Original Message----- From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Pete McCann Sent:
> Wednesday, April 27, 2011 12:24 PM To: [email-masked] Subject: Re:
> [Mip4] Working Group Last Call
> ondraft-ietf-mip4-nemov4-dynamic-04.txt
>
> Hi, All,
>
> but I think the draft is short and straightforward and we all
> understand it.
>
> I read it over this afternoon and the only comment I have is to
> change the term "mobile client" to "Mobile Router" to be consistent
> with the terms in 5177 (note the capitalization).
>
> -Pete
>
> On Wed, Apr 13, 2011 at 3:27 PM, Pete McCann<[email-masked]>
> wrote:
>> This draft is intended for publication as a Proposed Standard. The
>> last call will conclude at 24:00 UTC on Wednesday, April 27, 2011.
>>
Please
respond to this WG last call:
>>
>>
>>
>> * If you have no comments on the draft, and support its
>> advancement, simply respond with a line containing something like
>>
>> "I support the advancement of this document to the IESG with a
>> request for publication as proposed standard."
>>
>> If you have comments, please use a line similar to the one above,
>> and supplement this with your comments.
>>
>>
>> * If you *don't* support its advancement, respond with a line
>> containing something like the following, supplemented by your
>> comments -
>>
>> "I don't support the advancement of this document to the IESG with
>> a request for publication as proposed standard, for the following
>> reasons:" ...
>>
>> -Pete
>>

---

From: "Kent Leung (kleung)" <[email-masked]>
Date: Thu, 28 Apr 2011 14:38:56 -0700

Hi Alex.  Thanks for the review. I'll fix the reference and typo.  I'm not aware implementation of this specific draft.  Although there are deployments using this method.  I don't know of any implementation or deployment using the DHCP approach. 

Kent

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alexandru Petrescu
Sent: Thursday, April 28, 2011 8:09 AM
To: [email-masked]
Subject: Re: [Mip4] Working Group LastCall ondraft-ietf-mip4-nemov4-dynamic-04.txt

Draft looks ok.

What happened to

Alex

Please

---

From: Pete McCann <[email-masked]>
Date: Fri, 29 Apr 2011 16:33:53 -0400

Hi, Kent,

Ok, go ahead and upload v05 and I will submit it.

-Pete

On Fri, Apr 29, 2011 at 11:05 AM, Kent Leung (kleung) <[email-masked]> wrote:
> I'm not sure it's necessary to say much more.  The protocol is between MR and HA.  Whatever MR do with the prefixes is implementation dependent.
>
> I think the draft v05 is ready to go to IESG..
>
> Kent
>
> From: Pete McCann [mailto:[email-masked]]
> Sent: Thursday, April 28, 2011 4:11 PM
> To: Kent Leung (kleung)
> Maybe we should just put somewhere that the MR can allocate
> addresses from the prefixes it has been assigned to nodes on its
> Mobile Network using means outside the scope of this specification.
> I don't think we should get into the details of DHCP options.
>
> -Pete
>
> On Thu, Apr 28, 2011 at 5:38 PM, Kent Leung (kleung) <[email-masked]> wrote: