Subject: RE: [Mip6] MIPv6 issue #197, I-D version -20.txt

From: "Barany, Pete" <[email-masked]>
Date: Mon, 8 Dec 2003 14:33:58 -0800

Vijay,

Thanks for the reply. I was just about to send the e-mail out again with
a clarification to my question.

The clarification is as follows: Did the WG ever consider the use of RFC
3123 (APL RR)? I know it is experimental, but it seems to be supported
in BIND 9.x.

Regards,

Pete

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Vijay Devarapalli
Sent: Monday, December 08, 2003 2:36 PM
To: Barany, Pete
Cc: [email-masked]
Subject: Re: [Mip6] MIPv6 issue #197, I-D version -20.txt

hi Pete,

appendix B.5 assumes the mobile node knows neither the home prefix
nor the prefix length of the home prefix.

for the Home Agents anycast address, it says

    2.  Query DNS for an anycast address associated with the FQDN of the
        home agent(s).

the mobile node does not construct the anycast address by itself.

Appendix B.5 is just a suggestion. I dont think anyone has
implemented it.

Vijay

Barany, Pete wrote:
> Regarding Appendix B.5 of the MIPv6 I-D (version -24.txt), if the MN
> obtains a list of HAs using anycast (RFC 2526) for dynamic HA
discovery,
> won't it have to know the prefix (and prefix length) of its home
subnet
> in order to properly format the anycast address? If so, why is the
> procedure defined in Appendix B.5 of the MIPv6 I-D limited to the
> situation where the home prefix is 64 bits? Thanks.
> 
> Pete
> 
> NOTE: Original issue discussed in MIPv6 issue #197, I-D version
-20.txt.
> 
> =======
> 
> http://users.piuha.net/jarkko/publications/mipv6/issues/issue197.txt
> 
> Vijay Devarapalli responds to Jari Arkko:
> 
> 
>>- Configure one home address based on the selected home
>>  agent's subnet prefix and the interface identifier of the
>>  mobile node.
> 
> 
> I am not sure the above step will work. the MN does not know the 
> prefix length of the home agent's subnet prefix. so it cannot 
> figure out the home prefix based on just the home agent's address.
> 
> right?
> 
> -----
> 
> Jari Arkko responds to Vijay Devaparalli: Right, but I'm not sure I
> see a way around this. I'll add a note to the beginning of B.5:
> 
>    "This procedure is restricted to those situations where the
>     home prefix is 64 bits and the mobile node knows its own interface
>     identifier of also 64 bits."
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 08 Dec 2003 14:48:50 -0800

Barany, Pete wrote:

> 3123 (APL RR)? 

AFAIK, no.

Vijay