Subject: Re: [Mip6] processing of unsolicited advertisements

From: Jari Arkko <[email-masked]>
Date: Wed, 03 Dec 2003 13:50:39 +0200

Catching up with old e-mail...

Vijay Devarapalli wrote:

>> Then why would the HA ever send unsolicited Mobile Prefix Ads (as 
>> specified in section 10.6.2 of the draft) if the MN is not to process 
>> them?
> 
> 
> to inform the mobile node that something has changed with respect
> to the prefixes being advertised on the home link.

Right.

> the Home Agent stops sending unsolicited prefix advertisements
> once it gets a solicitation from the mobile node.
> 
> I dont remember why it was decided that the Mobile Node should
> not process unsolicited advertisements. I need to sift through the
> issues list. the list of issues are at
> http://users.piuha.net/jarkko/publications/mipv6/MIPv6-Issues.html

I don't recall this exactly either, but I think it was to provide
a weak form of protection against random MPA messages sent from
the Internet, or replayed MPAs protected by manually-keyed IPsec.

--Jari

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Jari Arkko <[email-masked]>
Date: Wed, 03 Dec 2003 13:51:46 +0200

Vijay Devarapalli wrote:

>> The confusion, I think, results from the statement that
>>
>>         Otherwise, the advertisement is unsolicited, and MUST be 
>> silently discarded.
>>
>> Immediately followed by
>>
>>         In this case the mobile node SHOULD send a Mobile Prefix 
>> Solicitation.
>>
>> The latter hardly agrees with the accepted definition of "silently 
>> discarded."  But I suppose everyone will know what is intended and 
>> will ignore the first MUST...?
> 
> 
> I guess. the text should have said an unsolicited advertisement
> is ignored and the mobile node SHOULD send a Mobile Prefix
> Solicitation.

This is what it does say. Or that's at least how I read
it.

--Jari

---

From: Frank Quick <[email-masked]>
Date: Wed, 03 Dec 2003 08:12:38 -0600

At 01:51 PM 12/3/2003 +0200, Jari Arkko wrote:
>>>discarded."  But I suppose everyone will know what is intended and will 
>>>ignore the first MUST...?
>>

We can hope everyone will read it that way; or change the wording to remove 
"silently discarded" and replace with the correct behavior.

>--Jari

Frank Quick
office   +1-858-658-3608 fax +1-858-651-1940
portable +1-619-890-5749
paging   [email-masked]
RSA: 29EA D619 31F2 B4D3  8815 3D59 4340 FA43
D-H: 2A24 131C D38F 12E6 4D6A  46EE 8BBF B50A 754E F63D

---

From: Jari Arkko <[email-masked]>
Date: Wed, 03 Dec 2003 22:45:32 +0200

Frank Quick wrote:

> We can hope everyone will read it that way; or change the wording to 
> remove "silently discarded" and replace with the correct behavior.

Ah, now I finally see what you mean. So its not silently discarded
because you initiate an action and send a message as a result,
even if the incoming message really is discarded and its contents
not looked at.

How about deleting the word 'silently', making it:

       Otherwise, the advertisement is unsolicited, and MUST be
       discarded.  In this case the mobile node SHOULD send a Mobile
       Prefix Solicitation.

I think this is small enough change to make in AUTH48.

--Jari

---

From: Frank Quick <[email-masked]>
Date: Wed, 03 Dec 2003 15:14:15 -0600

I believe that would make it much clearer.  Thanks.

Frank Quick