Subject: [Mip6] Is there an implementation of Mobile IPv6 for the ns-2 , OPNET or OMNET++ simulator ?

From: zhang liansheng <[email-masked]>
Date: Thu, 4 Dec 2003 06:45:44 -0800 (PST)

Hi all,
Is there an implementation of Mobile IPv6 over IEEE 802.11 WLAN for the ns-2 , OPNET or OMNET++ simulator ? I need it for my future work. thanks in advance!
                                                                                zhangliansheng

---------------------------------
Do you Yahoo!?
Free Pop-Up Blocker - Get it now

---

From: Matthias Waehlisch <[email-masked]>
Date: Fri, 5 Dec 2003 13:30:05 +0100 (CET)

hi,

On Thu, 4 Dec 2003, zhang liansheng wrote:

> Is there an implementation of Mobile IPv6 over IEEE 802.11 WLAN for the
> ns-2 , OPNET or OMNET++ simulator ? I need it for my future work.
>
  To my knowledge there is no implementation for ns-2. In OPNET there is
only mobile IPv4 implemented, I think:

> Date: Thu, 11 Sep 2003 13:27:55 -0400
> To: <[email-masked]>, <[email-masked]>
> From: Jay J Lee <[email-masked]>
>
> OPNET standard model library now includes the Mobile IP model.
> "http://www.opnet.com/products/library/standard.html"

  OMNeT++ will getting a MIPv6 model soon from the Monash University
(http://ctieware.eng.monash.edu.au/twiki/bin/view/Simulation/IPv6Suite).

bye
  matthias

::::::::::::::::::
Matthias Waehlisch
HRZ - FHTW Berlin
mailto:[email-masked]
http://www.rz.fhtw-berlin.de

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Thierry Ernst <[email-masked]>
Date: Sat, 6 Dec 2003 00:16:34 +0900

Hi,

> only mobile IPv4 implemented, I think:

The mobiwan package for ns-2.1b6 has Mobile IPv6, based on draft-14, and developped in years 1999-2001:
http://www.inrialpes.fr/planete/pub/mobiwan/

The code comes as is, i.e. with bugs and missing functionalities.
Usually,  I don't advertised this too much because I don't have time to
answer the questions nor to improve the code or to port it to a later
version of NS. But anyone is free to do this, the code is in the public
domain. 

Thierry.

---

From: "denghui" <[email-masked]>
Date: Sat, 6 Dec 2003 13:09:10 +0800

Hi,

We modify lots of your work to support our simulation.
It costs a lot, but finally, it can be used.

thanks

Denghui

----- Original Message ----- 
From: "Thierry Ernst" <[email-masked]>
To: <[email-masked]>
Sent: Friday, December 05, 2003 11:16 PM
Subject: Re: [Mip6] Is there an implementation of Mobile IPv6 for the ns-2 , OPNET or OMNET++ simulator ?

> version of NS. But anyone is free to do this, the code is in the public
Šž¦j)bž	b²Ó"§¨žµú+‚m¦ÏÿÃ"z×è®æj)fjåŠËbú?š*z