Subject: RE: [Mip6] rr weaknesses?

From: Soliman Hesham <[email-masked]>
Date: Mon, 16 Feb 2004 19:46:58 -0500

> > => The vulnerability of RR is simple: If an attacker
 > > gets hold of HOT and COT, it's over he can do whatever
 > > he wants. In other words if he can generate HOTI and COTI
 > > (which is easy) and be able to receive HOT and COT then
 > > he could do whatever he wants. This is more than what can be 
 > > done today in v4 or v6 because the attacker can move and 
 > > continue to steal/bomb for the lifetime of the token. 
 > 
 > True, but it would be useful to compare this to other attacks
 > that the same mitm can do. For instance, ARP spoofing, sending
 > TCP RSTs, messing with TCP ACKs, dropping packets.

=> Sure, I do think it is more vulnerable than the two
cases you mention above because: a) it is not limited
to the local link (the attacker need not be a neighbour)
and b) the attacker can move and cause damage for some 
time (albeit less 10 min). Also the attack is not 
limited to certain types of upper layers like TCP-based
attacks. So that's why it's more significant I think.
Also we have a cure for the equivalent of ARP spoofing 
now in IPv6 (SEND).
Having said all that, deep down ;), I don't take MiTM
attacks too seriously unless MiTM is on the same link
as the CN. So I think in theory RR is certainly weak, 
but in practice it's vulnerability is probably limited
to attacks by neighbours on the CN's link.

 > 
 > > => Efficiency is not an absolute thing. We need to know
 > > efficient for what? In scenarios where there is frequent
 > > mobility I don't think it's efficient in terms of air interface
 > > use or tolerable for most apps.
 > 
 > I hate to press you for more information since I basically
 > agree that we need additional optimized mechanisms. But can
 > you say more about the specific requirements that you
 > are looking for "most apps"? Is there a paper somewhere that
 > has simulated mobility in some environment that shows how much
 > time you are spending on RR signaling vs. other movement related
 > tasks? How does home registration compare, what about IPv6 network
 > attachment? How about 1X/11i tasks? Or link layer attachment?

=> Wow :)  I've seen a few papers, I'll try to find them and 
send them to you offline. In many cases each paper only 
addresses one part of the delay, unfortunately. But let me 
clarify what I was saying. I think that RR is not efficient for 
frequently moving MNs. This immediately excludes
the 802.11 family from this discussion because, lets face it, 
how often are you going to handover with 802.11? I'm thinking
more of cellular networks where every base station is a router
(or even where a few base stations belong to the same router)
and handover can be very frequent. Also, the signalling messages
sizes can be come a major issue during handovers. In this case,
it's almost unworkable to have to send RR signalling + HA signalling...etc
Not to mention the effects of having dual stacked MNs. 

So in a way, it is inefficent independently of the application
being used. This is of course in the context of frequent
mobility. But In 802.11 type deployments, or for multihomed 
nodes it's probably not that bad. I think movement detection
is the key issue for those types of access networks.

Hope this helps.

Hesham

 > --Jari

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Rajeev Koodli <[email-masked]>
Date: Mon, 16 Feb 2004 17:26:36 -0800

> frequently moving MNs. This immediately excludes

It would be good to consolidate the current understanding on
this topic. Could you post a pointer the references ? It would be
useful for Mobopts as well.

One could also look at the effect of RR, alongside its frequency,
on applications. I hope someone will simulate various scenarios!

> how often are you going to handover with 802.11? I'm thinking

In some cases (e.g., campus WLAN networks), it could be as
often as when someone leaves a building for another!

-Rajeev

---

From: Jari Arkko <[email-masked]>
Date: Tue, 17 Feb 2004 10:04:52 +0200

> to attacks by neighbours on the CN's link.

This is roughly my feeling as well. And attacks by neighbors
on the link are already pretty bad (even with SEND).

 > to the local link (the attacker need not be a neighbour)

All the attacks that I listed are possible for the whole
path, i.e. not just on the local link.

 > time (albeit less 10 min). Also the attack is not

All of the attacks I mentioned also cause a disruption
that lasts longer than a single packet. Exactly how long...
depends on the specific attack.

 > limited to certain types of upper layers like TCP-based

Some attacks on plain IPv4/IPv6 are related to applications,
but not all. ARP/ND, ICMP, just dropping packets, looking
inside the packets, etc.

Then we have a couple of interesting cases regarding the
use of e2e security. When that is in place, be it RR/CGA/HIP,
attackers can at most cause denial of service, not more.
With IPsec e2e, presumably the RR signaling would be protected
as well => no attack. With TLS e2e, RR would still be vulnerable,
but as mentioned above the effect would be at most denial-of-service.
TLS, however, is denial-of-service vulnerable in any case.

 > Also we have a cure for the equivalent of ARP spoofing

In conclusion, I'd still like you or someone to write that
paper that describes the issues and compares them to the
issues with existing issues that mitms on the path can
cause. I mean its easy for us to make short comments on
the mailing list, but I think this matter is so important
that it needs to be described well. And be reviewed!

Don't get me wrong. I want to create new route optimization
security mechanisms that are better than RR. But I just think
there is a big difference in "nice to have" vs. "must have
because of serious problems". Clearly we have seen and will
see folks who claim the latter to market their method; it
would be extremely useful to understand where we are in
reality, however.

--Jari

---

From: Francis Dupont <[email-masked]>
Date: Tue, 17 Feb 2004 11:22:18 +0100

In your previous mail you wrote:

=> I agree, for instance a reflection attack works very well
(no defense at all).

=> I believe you'd like to mean RO signaling.

=> I agree, and as the RO signaling is at the network layer IPsec
is the solution of choice.

   Don't get me wrong. I want to create new route optimization
   security mechanisms that are better than RR.

=> IMHO we need stronger assumptions to do that. For instance (again)
if strong authentication is available for MN and CN, IPsec is a
solution.

   But I just think
   
=> I have a concern here: some documents or implementations can
make "better" RO security mechanisms impossible to use. We have
to be very careful as perhaps there are some such mechanisms not
yet discovered/invented.

Regards

[email-masked]

PS: we should publish all the previous documents about the subject
as information RFCs ASAP (i.e., put them in the RFC editor queue
waiting for draft-24).

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Feb 2004 10:15:42 -0800

> often as when someone leaves a building for another!

The primary determinating factor would seem to be the access network
configuration. If the access network is configured with many APs per subnet,
then the MN only pays the L3 handover cost very rarely, and mostly not at
all if the coverage area of the subnet is such as to handle 80-90% of the
handovers in-subnet.

As a practical matter, most 802.11 and 3G cellular deployments today are so
configured, so the L2 handover cost is really the determining factor.
However, that is not to say that this will always remain so. Future wireless
link protocols may result in a lower AP to subnet ratio.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Feb 2004 10:27:40 -0800

> if strong authentication is available for MN and CN, IPsec is a

Agree, but there is still the issue of bombing attacks by an MN sending a
CoA that it is not at to the CN. This practically assures that the CoTI/CoT
sequence will be required for any protocol that does end to end route
optimization (MIP RO, HIP, etc.) and even for moving an IPsec SAs ala
MOBIKE. So there is a practical limit to how much signaling delay can be
eliminated for end to end host-based authentication. The only way I can see
removing that limit is somehow getting the last hop router involved, but I
don't want to go there.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Feb 2004 10:22:41 -0800

> would be extremely useful to understand where we are in

Yes, I agree. A review paper with measurements in it would be a great place
to start, along with an analysis of what is not understood and needs to be
measured.

            jak

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 17 Feb 2004 11:06:15 -0800

> all if the coverage area of the subnet is such as to handle 80-90% of the

I think this is an administrative issue. In a campus, different
business units, different academic departments tend to have
subnets of their own. Perhaps for good reasons. So, I tend to believe
that you can circumvent the subnet handover problem up to a certain
point.

> link protocols may result in a lower AP to subnet ratio.

On the other hand, if the range is increased by an order of magnitude,
there could be fewer subnet handovers.

-Rajeev

---

From: Francis Dupont <[email-masked]>
Date: Tue, 17 Feb 2004 20:15:39 +0100

Agree, but there is still the issue of bombing attacks by an MN sending a
   CoA that it is not at to the CN.

=> you should read my draft about 3rd party bombing.

   This practically assures that the CoTI/CoT
   sequence will be required for any protocol that does end to end route
   optimization (MIP RO, HIP, etc.) and even for moving an IPsec SAs ala
   MOBIKE.

=> this is sure way to kill performance as you add a RTT.

   So there is a practical limit to how much signaling delay can be
   eliminated for end to end host-based authentication. The only way I can see
   removing that limit is somehow getting the last hop router involved, but I
   don't want to go there.
   
=> perhaps you suggest something like AAA which as far as I know the
only reasonnable way to make more than to trust the MN to put its real
care-of address or some kind of return routability check (AAA is both
stronger and more efficient).

Thanks

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Feb 2004 11:21:30 -0800

> there could be fewer subnet handovers.

Sure. But there's a problem with line of sight as the frequency goes up.
This isn't the right mailing list to get into that, though.

            jak

---

From: "James Kempf" <[email-masked]>
Date: Tue, 17 Feb 2004 11:23:11 -0800

> => you should read my draft about 3rd party bombing.

OK.

> stronger and more efficient).

That's one possibility. Another might be a routing header with a signature
from the last hop router, if the last hop router has a certificate (re.
SEND).

But, like I said, I'd rather not go there.

            jak