Subject: RE: [Mip6] I-D ACTION:draft-ietf-mip6-mipv6-mib-01.txt

From: "Karen E. Nielsen (AH/TED)" <[email-masked]>
Date: Wed, 25 Feb 2004 15:53:07 +0100

Hi,

I (still) find it diffecult to understand the 
mipv6nodetraffic counters and why they are part of 
the generic group, 

I do not suppose that these counters are relevant
for a MN which is not a HA or a CN - ?

Further It is unclear to me what
the counters exactly cover.

For the mipv6NodeInpkts, the phrase
"The mipv6 packets received _for_ the mobile node" 
confuses me - does this refer to the packets which are intercepted
on behalf of the mobile node (HA intercept) ?
or packets egressing the MN=HA tunnel ?
or simply packets received _from_ the MN ?

Similar, wrt mipv6NodeOutOctets what does the phrase
"The number of mipv6Node octets sent to the mobile node"
mean - does it refer to ockets sent with routing header to the mobile node 
or ?

Thanks,
Karen

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> [email-masked]
> Sent: 18. februar 2004 15:59
> Cc: [email-masked]
> Subject: [Mip6] I-D ACTION:draft-ietf-mip6-mipv6-mib-01.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> This draft is a work item of the Mobility for IPv6 Working 
> Group of the IETF.
> 
> 	Title		: The Mobile IPv6 MIB
> 	Author(s)	: G. Keeni, K. Nagami, K. Koide, S. Gundavelli
> 	Filename	: draft-ietf-mip6-mipv6-mib-01.txt
> 	Pages		: 59
> 	Date		: 2004-2-18
> 	
> This memo defines a portion of the Management Information 
> Base (MIB), the the Mobile-IPv6 MIB, for use with network 
> management protocols in the Internet community. In 
> particular, Mobile-IPv6 MIB will be used to monitor and 
> control Mobile Node, Home Agent and Correspondent Node 
> functions of an MIPv6 entity.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-mip6-mipv6-mib-01.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body 
> of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login 
> with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-mip6-mipv6-mib-01.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-mip6-mipv6-mib-01.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant 
> mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

This communication is confidential and intended solely for the addressee(s). Any unauthorized review, use, disclosure or distribution is prohibited. If you believe this message has been sent to you in error, please notify the sender by replying to this transmission and delete the message without disclosing it. Thank you.

E-mail including attachments is susceptible to data corruption, interruption, unauthorized amendment, tampering and viruses, and we only send and receive e-mails on the basis that we are not liable for any such corruption, interception, amendment, tampering or viruses or any consequences thereof.

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: Sri Gundavelli <[email-masked]>
Date: Wed, 25 Feb 2004 15:53:27 -0800 (PST)

> mipv6nodetraffic counters and why they are part of

The group is anchored under the stats sub group and that is a generic
group for counters.

> for a MN which is not a HA or a CN - ?
These counters are relevant from the point of view of a home agent. It
reflects the traffic between the HA and the MN.

> or simply packets received _from_ the MN ?

These are the packets intercepted by the HA for the MN.
There is some terminology problem and we will fix that in our next
submission. We tried to fix it in this version, but could not complete it.

> mean - does it refer to ockets sent with routing header to the mobile node

All traffic from HA to the MN. Thanks for your review. We will fix the
terminology and add more description to some of these objects.

Thanks !
Sri/