Subject: [Mip6] Comments on draft-le-aaa-mipv6-requirements-03

From: Giaretta Gerardo <[email-masked]>
Date: Wed, 18 Feb 2004 14:45:14 +0100

Hi,

I read draft-le-aaa-mipv6-requirements-03 and have the following questions:

1) In the draft are you providing requirements on a specific a Diameter Mobile IPv6 Application to be developed (as explicitely mentioned in the abstract and in the introduction) or are you referring to general requirements on the interaction between AAA and MIPv6?

2) In the introduction it is stated that Mobile IPv6 does not have the equivalent of a Foreign Agent and as a result does not offer any mechanism by which the visited network can authenticate and authorize user access. As a consequence it is suggested the specification of a new Diameter Mobile IPv6 Application supporting, among the other features, also local and remote network access control. This is certainly an option that may be useful in certain enviroments. Nevertheless, I think that an additional requirement for a solution to integrate AAA and MIPv6 should be the easy deployability in existing network infastructures, where user authentication and authorization is commonly performed relying on mechanisms that are not related at all with Mobile IPv6 (e.g. EAP, cellular protocols). In such situations, it might be useful to continue to handle user access authorization with the already deployed mechanisms and exploit the MIPv6 Diameter extentions only for MIPv6 service authorization and configuration.

Comments?

--Gerardo

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please contact us by
replying to [email-masked]. Thank you
====================================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mip6

---

From: [email-masked]
Date: Wed, 18 Feb 2004 16:28:00 -0600

Hello Gerardo,

Thank you for your comments, please find some below.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of ext
> Giaretta Gerardo
> Sent: 18 February, 2004 07:45 AM
> To: [email-masked]
> Cc: Guardini Ivano
> Subject: [Mip6] Comments on draft-le-aaa-mipv6-requirements-03
> 
> 
> 
> Hi,
> 
> 1) In the draft are you providing requirements on a specific 
> a Diameter Mobile IPv6 Application to be developed (as 
> explicitely mentioned in the abstract and in the 
> introduction) or are you referring to general requirements on 
> the interaction between AAA and MIPv6?

The goal of the MIPv6 AAA Requirements draft is to identify and describe the requirements that the Mobile IPv6 protocol needs from the AAA infrastructure. The requirements are therefore not specific to any application but generic. 
The intent is to reuse as much as possible of existing AAA application solutions. If an existing Diameter Application can fulfill all the identified requirements, it should be used. Otherwise a new Diameter Application can be considered

> 2) In the introduction it is stated that Mobile IPv6 does not 
> have the equivalent of a Foreign Agent and as a result does 
> not offer any mechanism by which the visited network can 
> authenticate and authorize user access. As a consequence it 
> is suggested the specification of a new Diameter Mobile IPv6 
> Application supporting, among the other features, also local 
> and remote network access control. This is certainly an 
> option that may be useful in certain enviroments. 
> Nevertheless, I think that an additional requirement for a 
> solution to integrate AAA and MIPv6 should be the easy 
> deployability in existing network infastructures, where user 
> authentication and authorization is commonly performed 
> relying on mechanisms that are not related at all with Mobile 
> IPv6 (e.g. EAP, cellular protocols). In such situations, it 
> might be useful to continue to handle user access 
> authorization with the already deployed mechanisms and 
> exploit the MIPv6 Diameter extentions only for MIPv6 service 
> authorization and configuration.

We agree that an easy to deploy solution should be prefered. This aspect should however not result in the sacrifice of some required features. 
Ease of deployability is a generic requirement for any protocol or product and hence cannot be made a specific requirement in this case. If you want, we could add a new requirement "The solution should require, if possible, minimal modification/dsiruption to current existing infrastructure".

Franck