Subject: Re: [Mip6] Draft agenda of MIP6 WG meeting at IETF61

From: Thierry Ernst <[email-masked]>
Date: Mon, 1 Nov 2004 17:03:05 +0900

Dear all,

Of course, I second this. I would like to add that the ability to manage
multiple interfaces is very important, particularly for mobile nodes.
Now that the important work on the MIPv6 spec is behind us, I think it's
the right time to bring the "multiple interfaces management" issue back
on the table, before people implement non-compatible solutions.

Note that the ability to manage multiple interfaces is probably the
feature that would motivate the need for MIP6 (I cannot see the need to
perform MIP6 between 2 WIFI hot-spots since the opportunity seldomly
appear; however, I would definitely use MIP6 on a daily-base if I could
switch between WIFI and 3G|AirH|B-mobile|GPRS.

So, it's a good timing to question if the MIP6 working group wants to
add this as a WG item. If yes, we need more thought on the problem
statement and to discuss the potential interactions with the NEMO WG (cf
draft-ietf-nemo-multihoming-issues). If not, we may seriously think
about setting up a new WG, but I would rather leave it as a second
option if the conclusion of the meeting is that MIP6 is not the right WG
for it.

We probably need a 10mins discussion in order to reach a conclusion (I
don't think we need to discuss the motivations, the existing drafts do
it already).

Thierry.

On Fri, 29 Oct 2004 11:47:21 +0200
Nicolas Montavont <[email-masked]> wrote:

> Dear Basavaraj and folks,
> 
> We just published a new version of our draft on Multihoming analysis in 
> MIPv6. You can find the new version at
>  http://www.ietf.org/internet-drafts/draft-montavont-mobileip-multihoming-pb-statement-02.txt
> 
> This draft analyses the MIP6 behavior when a MN is multihomed and 
> classifies the different cases when a MN is multihomed. It completes the 
> generic draft 
> (http://www.ietf.org/internet-drafts/draft-ernst-generic-goals-and-benefits-00.txt) 
> which explains the goals and benefits we can expect from the multihoming 
> of host.
> 
> It would be good to have feedback from the working group on this work.
> 
> We would like to request a short slot to discuss the interest of the 
> Working Group on the multihoming. It is a long time that several drafts 
> deal with MIPv6 and multihoming. Our two drafts could be the starting 
> point to add a new item to the WG charter. These two drafts may define 
> the problem statement of MN multhoming.
> 
> Once more, please don't hesitate to comment both the drafts and the 
> proposition to add a new item in the WG charter.
> 
> Regards,
> 
> Nicolas
> 
> [email-masked] wrote:
> 
> ><Draft Agenda - 10/27>
> >
> >Time and Date of WG meeting at IETF61: TBD
> >Duration: 2.5 hours
> >
> >Agenda
> >======
> >
> >1. Agenda, Bluesheets, Note-takers and Jabber scribes	5 Mins
> >
> >2. WG status update		    Chairs		10 Mins
> >
> >3. MIP6 Operation with IKEv2 and the revised IPsec Arch.  10 Mins
> >   I-D: draft-ietf-mip6-ikev2-ipsec-00.txt
> >   Vijay Devarapalli
> >
> >
> >4. a. Using IPsec to protect signaling between MN and CN   5 Mins
> >      I-D: draft-dupont-mipv6-cn-ipsec-01.txt
> >   b. Care-of address test procedure using a state cookie  5 Mins
> >      I-D: Annex of draft-dupont-mipv6-cn-ipsec-01.txt
> >   Francis Dupont
> >
> >5. MIPv6 Authorization and Configuration based on EAP    10 Mins
> >   I-D: draft-giaretta-mip6-authorization-eap-02.txt
> >   Giaretta Gerardo      
> >
> >6. Application Master Session Key (AMSK) for Mobile IPv6   5 Mins
> >   I-D: draft-giaretta-mip6-amsk-00.txt
> >   Giaretta Gerardo   
> >
> >7. Goals for AAA-HA interface				  10 Mins
> >   I-D: draft-giaretta-mip6-aaa-ha-goals-00.txt
> >   Giaretta Gerardo   
> >
> >8. AAA Mobile IPv6 Application Framework	          10 Mins
> >   I-D: draft-yegin-mip6-aaa-fwk-00.txt
> >   Alper Yegin
> >
> >9. Diameter Mobile IPv6 Bootstrapping Application using PANA  10 Mins
> >    I-D: draft-jee-mip6-bootstrap-pana-00.txt
> >    Junghoon Jee
> >
> >10. Mobile IPv6 Bootstrapping Architecture Using DHCP	  15 Mins
> >   I-D: draft-ohba-mip6-boot-arch-dhcp-00
> >   Yoshihiro Ohba
> >
> >11. Precomputable Binding Management Key Kbm for Mobile IPv6 5 Mins
> >    I-D: draft-ietf-mip6-precfgkbm-01.txt
> >    Charles Perkins
> >
> >12. Improvement of Return Routability Protocol		   10 Mins
> >    I-D: draft-qiu-mip6-rr-improvement-00.txt
> >    Jianying ZHOU
> >
> >
> >13. Next steps			Chairs			   5 Mins
> >
> >_______________________________________________
> >Mip6 mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/mip6
> >  
> >
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Koojana Kuladinithi" <[email-masked]>
Date: Mon, 1 Nov 2004 15:03:32 +0100

Hi all,

Just to remind you all about the history of this issue: We had several
discussions in mip6 ML regarding multiple interface management based on
several related drafts. Later, we agreed to address this issue with a PB
draft to show the possibilities of using multiple interfaces in mip6,
before going in to the details of how to do it.

I too agree with this (well, I "third it"). We have a few public
projects in which this capability is needed. 

So, I too agree that the WG should think about bringing this topic up.

Kind regards

Koojana

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On 
>Behalf Of Thierry Ernst
>Sent: Monday, November 01, 2004 9:03 AM
>To: [email-masked]
>Cc: [email-masked]; Ryuji Wakikawa; Nicolas 
>Montavont; [email-masked]
>Subject: Re: [Mip6] Draft agenda of MIP6 WG meeting at IETF61
>
>
>
>Dear all,
>
>Of course, I second this. I would like to add that the ability 
>to manage multiple interfaces is very important, particularly 
>for mobile nodes. Now that the important work on the MIPv6 
>spec is behind us, I think it's the right time to bring the 
>"multiple interfaces management" issue back on the table, 
>before people implement non-compatible solutions.
>
>Note that the ability to manage multiple interfaces is 
>probably the feature that would motivate the need for MIP6 (I 
>cannot see the need to perform MIP6 between 2 WIFI hot-spots 
>since the opportunity seldomly appear; however, I would 
>definitely use MIP6 on a daily-base if I could switch between 
>WIFI and 3G|AirH|B-mobile|GPRS.
>
>So, it's a good timing to question if the MIP6 working group 
>wants to add this as a WG item. If yes, we need more thought 
>on the problem statement and to discuss the potential 
>interactions with the NEMO WG (cf 
>draft-ietf-nemo-multihoming-issues). If not, we may seriously 
>think about setting up a new WG, but I would rather leave it 
>as a second option if the conclusion of the meeting is that 
>MIP6 is not the right WG for it.
>
>We probably need a 10mins discussion in order to reach a 
>conclusion (I don't think we need to discuss the motivations, 
>the existing drafts do it already).
>
>Thierry.
>