Subject: [Mip6] RE: Comments on draft-kempf-mip6-ha-alert-00

From: Gerardo Giaretta <[email-masked]>
Date: Wed, 09 Mar 2005 23:26:53 +0100

James,

see below..

> 
> Gerardo,
> 
> Thanx for the comments.
> 
> first of all, I completely agree we need such a feature in MIP6. Just
> two brief comments before the discussion during MIP6 session:
> 
> - I think it could be useful that the HAU includes a "remaining
> lifetime" field. What I expect is that for a short period of time (if
> possible) the MN is served by two Home Agents (i.e. the new 
> and the old
> one), ending the communications it has in place using the old HoA and
> starting new applications using the new HoA. The remaining lifetime
> information could be useful for the MN in order to implement 
> this smooth
> change between the old and the new HA. Does this make sense?
> 
> jak>>> Yes. We'll look at this for the next draft version.
> 
> - as you mention, this draft have impacts also in 
> bootstrapping problem
> since the MN is expected to bootstrap again when its HA is 
> unavailable.
> This could be an important issue for solutions based on AAA 
> and tied to
> network access authentication (e.g. EAP, PANA) since the MN 
> will not be
> able to bootstrap until he performs a (re)authentication for network
> access.
> 
> jak>>> Any suggestions about how this might impact the HA 
> Unavailability
> message?
>

When the MN receives the HA Unavailability message it must find a new
HA, get a new HoA and bootstrap a SA with another HA. 
In the I-ASP scenario, if we assume that the bootstrapping solution used
is based on AAA for network access, there could be issues for the new
bootstrapping procedure that the MN must do after receiving the HAU. I
think there are two possibilities:
- the MN supports only another bootstrapping method (e.g. IKEv2+EAP)
- the MN waits for a reauthentication event or triggers a
reauthentication event (this is possible in PANA for example) in order
to bootstrap MIPv6 again.

The second one is not a clean approach IMO.
The first one might be better but the MN must discover the new HA. The
DNS or DHCP solutions could not be feasible for the I-ASP scenario. For
this reason I think that it could be useful if the HAU may include one
or more new HA addresses.

--Gerardo

>             jak

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "James Kempf" <[email-masked]>
Date: Wed, 9 Mar 2005 18:45:28 -0800

> DNS or DHCP solutions could not be feasible for the I-ASP scenario. For
t> his reason I think that it could be useful if the HAU may include one
> or more new HA addresses.

Sure. If the HA belongs to an IASP, then it must have a policy to put at
least one HA address in.

            jak