Subject: [Mip6] Privacy requirements for Mobile IPv6

From: Gopal Dommety <[email-masked]>
Date: Mon, 07 Mar 2005 21:05:35 -0800

Hello Rajeev and Bill,

	Based on interest of the MIP6 WG, we would like the MOBOPTS WG to work on 
the issue of IP Address
Privacy in the context of MIPv6. We are thinking that this could be done in 
2 steps.

1. Define the scope of the problem. After this step MIP6 WG will review the 
document and provide feedback.
2. Subsequently MOBOPTS could work on Solutions to the problem

Regards,
-Gopal

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Jean-Michel COMBES <[email-masked]>
Date: Tue, 08 Mar 2005 17:52:13 +0100

Hi,

IMHO, I don't think that MIP6 is the right place to do the works on 
Privacy. I think, it would be better to set up a new WG regarding 
Privacy because privacy issues are not only linked to MIPv6 but to all 
MIPv6 based protocols (ie. HMIPv6, FMIPv6, NEMO) and so linked to WGs 
like mipshop WG and nemo WG. There is a link with multi-homing too and 
so with multi6 WG. So it would be more efficient to do the works only 
one time for all these WGs.

Regards.

JMC.

Gopal Dommety wrote:

> Hello Rajeev and Bill,
>
>     Based on interest of the MIP6 WG, we would like the MOBOPTS WG to 
> work on the issue of IP Address
> Privacy in the context of MIPv6. We are thinking that this could be 
> done in 2 steps.
>
> 1. Define the scope of the problem. After this step MIP6 WG will 
> review the document and provide feedback.

---

From: Gopal Dommety <[email-masked]>
Date: Tue, 08 Mar 2005 09:41:47 -0800

JMC,

         The Intent is to focus on privacy issues dealing with MIPv6. I 
agree there are other issues which can be addressed by other WGs.

-Gopal

At 05:52 PM 3/8/2005 +0100, Jean-Michel COMBES wrote:
>Privacy. I think, it would be better to set up a new WG regarding Privacy 
>because privacy issues are not only linked to MIPv6 but to all MIPv6 based 
>protocols (ie. HMIPv6, FMIPv6, NEMO) and so linked to WGs like mipshop WG 
>and nemo WG. There is a link with multi-homing too and so with multi6 WG. 
>So it would be more efficient to do the works only one time for all these WGs.
>
>Regards.
>
>JMC.
>
>Gopal Dommety wrote:
>
>>Hello Rajeev and Bill,
>>
>>Privacy in the context of MIPv6. We are thinking that this could be done 
>>in 2 steps.
>>
>>1. Define the scope of the problem. After this step MIP6 WG will review 
>>the document and provide feedback.

---

From: Thierry Ernst <[email-masked]>
Date: Wed, 9 Mar 2005 04:41:03 +0900

Hi,

Sorry to pop up in the discussion.

While I agree that MIP6 is the right WG to discuss MIP6 specific issues,
who is going to look at the whole picture ?  I agree with the comment
from JMC that it might be valuable to work on it in an independent WG so
that the work could span other mobility protocols. 

Note that regarding NEMO, location privacy is cited in the design goals
under section 3.10 of
http://www.ietf.org/internet-drafts/draft-ietf-nemo-requirements-04.txt

Thierry

On Tue, 08 Mar 2005 09:41:47 -0800
Gopal Dommety <[email-masked]> wrote:

> >Privacy  because privacy issues are not only linked to MIPv6 but to
> >all MIPv6 based  protocols (ie. HMIPv6, FMIPv6, NEMO) and so linked
> >to WGs like mipshop WG  and nemo WG. There is a link with
> >multi-homing too and so with multi6 WG.  So it would be more
> >efficient to do the works only one time for all these WGs.
> >
> >Regards.
> >
> >JMC.
> >
> >Gopal Dommety wrote:
> >
> >>Hello Rajeev and Bill,
> >>
> >>     Based on interest of the MIP6 WG, we would like the MOBOPTS WG
> >to  > work on the issue of IP Address
> >done  >in 2 steps.
> >review  >the document and provide feedback.

---

From: Wassim Haddad <[email-masked]>
Date: Tue, 8 Mar 2005 22:03:32 +0200 (EET)

On Wed, 9 Mar 2005, Thierry Ernst wrote:

> who is going to look at the whole picture?

=> Please take a look to the momipriv work, which addresses a broader
scope.

> I agree with the comment from JMC that it might be valuable to work on
> it in an independent WG so that the work could span other mobility
> protocols.

Regards,

Wassim H.

> > >efficient to do the works only one time for all these WGs.
Â> > >Regards.
> Mobopts mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mobopts
>
>

---

From: Gopal Dommety <[email-masked]>
Date: Tue, 08 Mar 2005 12:15:49 -0800

Thierry,

         If there is interest for an independent WG to look at the whole 
picture, we should consider that as a separate issue. In this
effort we are trying to understand the implications for MIPv6.

-Gopal

---

From: Jari Arkko <[email-masked]>
Date: Tue, 08 Mar 2005 22:33:50 +0200

>that the work could span other mobility protocols. 
General work on the *problem* of privacy is very useful.
As has been discussed at length in the past, it doesn't
help much to have privacy for an IP layer protocol X if
the link layer uses fixed MAC addresses, for instance.
Overviews of the situation and finding the most urgent
problem areas would be useful.

However, I wouldn't attempt to build general privacy
*solutions* as the privacy problems of protocol X are
very tightly tied to the protocol X and the identities used
in it. For instance, IP layer identity privacy solutions do not
help much in MAC layer problems. Also, all mobility protocols
that I know of are using their own definition of stable
identifiers, so it would seem that addressing their
privacy issues probably requires different solutions.
(Particularly when the current state of identity privacy
support in the different protocols is quite different.)

--Jari

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 08 Mar 2005 12:52:19 -0800

completely agree with Jari.

Vijay

---

From: Wassim Haddad <[email-masked]>
Date: Wed, 9 Mar 2005 00:17:47 +0200 (EET)

> problem areas would be useful.

=> Agree. MoMiPriv first step is about describing problems and threats on
MAC and IP layers and the interdependency.

> in it.

=> Agree. But it should be noted also that an identifier used in Protocol
X may disclose another one related to another layer.

> For instance, IP layer identity privacy solutions do not
> help much in MAC layer problems.

=> Agree.

Regards,

Wassim H.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 09 Mar 2005 14:28:31 +0200

>X may disclose another one related to another layer.
Yes.

--Jari

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 09 Mar 2005 09:06:27 -0800

> problem areas would be useful.

This sort of resembles the security problem. Would it be
enough if there is L2 security for IP? Probably not, although
depending on the particular scenario, it may be acceptable.
The observation is that privacy spans multiple layers, and
one size fits all solution is infeasible if you go with the
security experience.

> support in the different protocols is quite different.)
Agreed. However, "points to keep in mind" could be useful.

-Rajeev

---

From: Wassim Haddad <[email-masked]>
Date: Wed, 9 Mar 2005 21:39:21 +0200 (EET)

> Also, all mobility protocols that I know of are using their own
> definition of stable identifiers, so it would seem that addressing
> their privacy issues probably requires different solutions.

=> The only "stable" identifiers I can see in momipriv are the MAC
and IP identifiers. Any privacy solution should know how and when to
replace both identifiers since the two identifiers should be seen as
the input for the same problem.

Based on that, I am not sure if this means that we need "different
solutions" (i.e.,  one solution for each identifier).

Regards,

Wassim H.

---

From: Jari Arkko <[email-masked]>
Date: Wed, 09 Mar 2005 23:59:09 +0200

>solutions" (i.e.,  one solution for each identifier).
That's a good point. There certainly needs to be some
synchronization in the changing of the identifiers at
different layers. I'm hoping this is more of an issue
for coordination among different layers in an implementation
than something that requires cross-layer protocol
mechanisms, particularly when the endpoints in the
different layers are in different places. But it does need
to be considered when you look at the whole problem for
identity privacy.

--Jari