Subject: RE: [Mobopts] Re: [Mip6] Privacy requirements for Mobile IPv6

From: Wassim Haddad <[email-masked]>
Date: Tue, 8 Mar 2005 23:48:45 +0200 (EET)

On Tue, 8 Mar 2005 [email-masked] wrote:

> Within the IEEE 802 the issues of link level privacy are also being
> discussed. The issue of "identifier" and "address" spaces for each
> protocol being different is one area where it would be good to
> coordinate.

=> We have submitted two drafts related to privacy on IP and MAC
layer for mobility and multi-homing (and the interdependency probem).
The two drafts are:

- draft-haddad-momipriv-problem-statement-01
- draft-haddad-momipriv-threat-model-00

Regards,

Wassim H.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of ext Vijay Devarapalli
> Sent: Tuesday, March 08, 2005 12:52 PM
> To: Jari Arkko
> Cc: Gopal Dommety; [email-masked]; [email-masked]
> Subject: Re: [Mobopts] Re: [Mip6] Privacy requirements for Mobile IPv6
>
> completely agree with Jari.
>
> Vijay
>
> Jari Arkko wrote:
> >
> >> While I agree that MIP6 is the right WG to discuss MIP6 specific
> >> issues, who is going to look at the whole picture ?  I agree with the
>
> >> comment from JMC that it might be valuable to work on it in an
> >> independent WG so that the work could span other mobility protocols.
> >>
> > General work on the *problem* of privacy is very useful.
> > As has been discussed at length in the past, it doesn't help much to
> > have privacy for an IP layer protocol X if the link layer uses fixed
> > MAC addresses, for instance.
> > Overviews of the situation and finding the most urgent problem areas
> > would be useful.
> >
> > However, I wouldn't attempt to build general privacy
> > *solutions* as the privacy problems of protocol X are very tightly
> > tied to the protocol X and the identities used in it. For instance, IP
>
> > layer identity privacy solutions do not help much in MAC layer
> > problems. Also, all mobility protocols that I know of are using their
> > own definition of stable identifiers, so it would seem that addressing
>
> > their privacy issues probably requires different solutions.
> > (Particularly when the current state of identity privacy support in
> > the different protocols is quite different.)
> >
> > --Jari
> >
> >
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
>
>
>
> _______________________________________________
> Mobopts mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mobopts
>
> _______________________________________________
> Mobopts mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mobopts
>
>

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: [email-masked]
Date: Tue, 8 Mar 2005 13:24:07 -0800

Suggest we work together, on producing something that works for both L2
& L3 mobility privacy if possible. It seems intuitive that first hop L3
privacy would be related to first link privacy. 

IEEE 802.21 is interested in facilitating fast handover, so to the
extent that managing the privacy of identifiers and addresses is
potentially a bottleneck to seamless handover, either in terms of basic
continuity or in performance, they would be interested in being part of
a practical solution.

Best Regards,
Michael Williams
IEEE 802.21 Vice Chair
-----Original Message-----

Vijay