Subject: Re: [Momipriv] RE: [Mobopts] Re: [Mip6] Privacy requirements for Mobile IPv6

From: Greg Daley <[email-masked]>
Date: Fri, 11 Mar 2005 19:50:32 +0000 (GMT)

Hi Wassim and Michael, 

----- Original Message -----
From: Wassim Haddad <[email-masked]>
Date: Thursday, March 10, 2005 2:27 pm
Subject: [Momipriv] RE: [Mobopts] Re: [Mip6] Privacy requirements for
Mobile IPv6

> On Wed, 9 Mar 2005 [email-masked] wrote:
> 
> > The cross protocol mechanism you mention has been identified in the
> > 802.21 work as potentially useful. Yes, some tunnels/layers end in
> > different stacks. The layers that "stack" together at the 
> endpoints and
> > first point of attachment tend to be what are used to 
> manage/influence> full path behavior.
> >
> > The privacy issue is one manifestation of a lack of cross protocol
> > coordination.
> 
> => I tend to agree. Achieving anonymity is mainly about managing
> pseudo-identities at different (i.e., concerned) layers. IMHO, such
> management may be easier to perform via cross layer coordination.

I guess I tend to think of things in an
All-or-nothing approach which would suit a 
co-ordinated solution well.

There's actually some value though, in 
dealing strictly with L3 issues at L3. 

I'm not sure that IETF can do appropriate work
at L2, or the other way around for IEEE.

The capabilities at lower layers may need careful
attention at L3 though, for example because 
continued use of a particular MAC address beyond
the lifetime of an Private IP address can be used
to associate them.

Therefore, I guess that determining needs for L2
from L3, or for L3 from L2 will need coordination,
without necessarily having one complete silution
including L2, L3(, L4??)

Just an idea,

Greg Daley

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Wassim Haddad <[email-masked]>
Date: Mon, 14 Mar 2005 23:32:23 +0200 (EET)

Hi Greg,

> co-ordinated solution well.

=> Two things:

- In the momipriv context, having coordination between layers is not a
feature/option . It is needed otherwise any privacy solution will disclose
an identity, which may in turn break the unlinkability feature.

- An All-or-nothing approach, which addresses all privacy issues is too
much complicated. IMHO, starting with the MAC and IP layers (i.e., as
described in the momipriv work) makes sense.
The remaining issues and the privacy in the network can/should be
addressed first in an IRTF WG.

> dealing strictly with L3 issues at L3.

=> Please check the momipriv drafts.

> without necessarily having one complete silution

=> Again: please check the momipriv drafts :)

Regards,

Wassim H.