Subject: RE: [Mip6] FW: Internal WG Review: Recharter of Mobility for IPv4(mip4)

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 15 Jun 2006 14:23:16 -0700

> > FYI -- MIP4 wants to recharter to include work on dual stack
 > > Mobile IPv4 support (item 10 below). Given that MIP6 also
 > > works on related issues I wanted to point you to this update.
 > > Comments welcome.
 > 
 > Is there a well-defined problem statement for item 10?

=> There is a problem statement in MIP6 that covers both groups. 
Unfortunately it has just expired, We'll submit another one for this 
meeting. This problem statement drove the work in MIP6 and MIP4.

Hesham

 > 
 > Thomas
 > 
 > _______________________________________________
 > Mip6 mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mip6
 > 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Michael Ye <[email-masked]>
Date: Fri, 16 Jun 2006 16:08:58 +0800

I think the current draft in the WG can solve some problems, but it can
not solve all problems.
The current assumptions require that all HA and MN must have an stable
ipv4 address at home network.This is reasonable in some scenarios. 
But there are some other scenarios. In these scenarios home network does
not support  ipv4 protocol.It is reasonable too. 
In some countries, ipv4 address is a scarce resource, so it may be
impossible for HA to assign a stable ipv4 address to MN.
In these scenarios, current solution does not work. 
So I think there may be some additional work in the v4 traversal field
in the mip6 WG. solutions on these scenarios can be a complementarity to
the dsmip6 protocol which is now work in the design team.
 
How do you think my draft on the other DS scenarios? I think they are
different works and  maybe my solution can be a  complementarity to the
dsmip6 protocol. The two solutions will not contradict with each other
because their assumptions are different.
 
On the topic whether the mip4 WG should work on ds solution, I have no
idea now.