Subject: RE: [Mip6] Experimental and Vendor specific messages

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 19 Jun 2006 16:27:57 -0700

> I think the experimental and vendor specific message/options would be
> useful. The drafts talk about node behavior when the node 
> does not understand
> these messages. How about some texts about node behavior when these
> option types are unrecognized ? I assume they will be skipped.

there is some text on this.

   Home agent or
   correspondent node implementations that do not recognize the mobility
   message type, discard the message and send Binding Error message as
   described in [2], with the Status field set to 2 (unrecognized MH
   Type value).  Mobile nodes that do not recognize the mobility message
   type should discard the message and send an ICMP Parameter problem
   with code 0.

   Mobility options, by definition, can be skipped if an implementation
   does not recognize the mobility option type [2].

Vijay

> 
> -Samita
> 
> On 6/15/06, Vijay Devarapalli <[email-masked]> wrote:
> > hello,
> >
> > the following two drafts specify experimental and vendor
> > specific mobility header messages and options.
> >
> > 
> http://www.ietf.org/internet-drafts/draft-devarapalli-mip6-exp
erimental-messages-00.txt
> > 
> http://www.ietf.org/internet-drafts/draft-devarapalli-mip6-vsm-00.txt
> >
> > the motivation behind these drafts is that they would
> > encourage experiments and protocol extensions to Mobile
> > IPv6. comments would be much appreciated.
> >
> > Vijay
> >
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mip6
> >
> 

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Samita Chakrabarti" <[email-masked]>
Date: Mon, 19 Jun 2006 16:37:51 -0700

>   type should discard the message and send an ICMP Parameter problem

Yes, I saw that in the two drafts.  I was referring to the option
types, not MH types.

>   does not recognize the mobility option type [2].

Ahh... I missed this line somehow. Looks fine.

Thanks,
-Samita