Subject: [Mip6] RE: +AFs-Mip6+AF0- RE: I-D ACTION:draft-ietf-mip6-ha-switch-00.txt

From: "+ACI-DENG, HUI -HCHBJ+ACI-" <[email-masked]>
Date: Fri, 23 Jun 2006 21:19:37 +0800

Hi, Kilian,

I start to understood what you mean here,
You would like to do geographical different home prefix load balance,
I am a little thinking about this usage in the real word.

but one thing interested me is that
your session is still kept in the previous home agent, is it called load balance?

Secondly, how could MN notify CN about its HoA changing.

I suggest that if possible you could write up your solution.
Then we could figure out its applicability.

Thanks

-Hui

> -----Original Message-----
> From: Kilian Weniger [mailto:[email-masked]] 
> Sent: 2006年6月23日 16:04
> To: DENG, HUI -HCHBJ; Kilian Weniger; Brian Haley
> Cc: [email-masked]
> Subject: RE: [Mip6] RE: I-D ACTION:draft-ietf-mip6-ha-switch-00.txt
> 
> 
> Hi Hui,
> 
> The MN would setup Ipsec SAs using IKE with the second HA 
> (which is located on a different link than the first HA). The 
> new Ipsec Sas would be based on the new HoA (whose prefix is 
> not served by the first HA). The IPSec Sas with the first 
> (old) HA are still setup based on the old HoA. Can you 
> elaborate what would be the issue with that?
> 
> -Kilian
> 
> > -----Original Message-----
> > From: "DENG, HUI -HCHBJ" [mailto:[email-masked]]
> > Sent: Freitag, 23. Juni 2006 09:41
> > To: Kilian Weniger; Brian Haley
> > Cc: [email-masked]
> > Subject: RE: [Mip6] RE: I-D ACTION:draft-ietf-mip6-ha-switch-00.txt
> > 
> > 
> > Could you help to elaborate how IKE/IPsec SA could work in
> > this scenario?
> > is that session based or address based?
> > 
> > -Hui
> > 
> > > -----Original Message-----
> > > From: Kilian Weniger [mailto:[email-masked]]
> > > Sent: 2006年6月23日 15:34
> > > To: Brian Haley
> > > Cc: [email-masked]
> > > Subject: RE: [Mip6] RE: I-D 
> ACTION:draft-ietf-mip6-ha-switch-00.txt
> > > 
> > > 
> > > Brian,
> > > 
> > > In my last mail I described scenarios that the current draft
> > > does not support (see snippet below) and sketched an 
> > > extension to support such scenarios. What do you and the 
> > > authors of the draft think about this? For instance, 
> > > shouldn't load balancing between HAs serving different links 
> > > be supported? MN could obtain a new HoA from the new HA and 
> > > keep the old HA/HoA as secondary for existing sessions only 
> > > (e.g., old IPv6 HoA is moved to deprecated state, new one to 
> > > preferred state)? 
> > > 
> > > - Kilian
> > > 
> > > 
> > > > Scenarios
> > > > I have in mind are that the network (i.e., HA) can direct
> > the MN to
> > > > another HA on a different link (e.g., to a more local
> > HA), which is
> > > > better with respect to optimized routing or for load
> > > balancing between
> > > > HAs on different links. ...
> > > > The modification I had in mind just extends the
> > applicability of the
> > > > switch mechanism by allowing the HA to send switch messages
> > > to direct
> > > > the MN to a HA serving a different link and continue to 
> serve as 
> > > > secondary HA.
> > > > 
> > > 
> > > 
> > > 
> > > 
> > > _______________________________________________
> > > Mip6 mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/mip6
> > > 
> > Disclaimer:
> > The contents of this e-mail, and its attachments, if any, are
> > confidential and may be protected
> > by law against any unauthorized use.  If you have received 
> > this e-mail by mistake or have
> > reason to believe that you are not the intended recipient, 
> > please notify the sender by reply
> > e-mail as soon as possible and delete it from your computer 
> > system immediately thereafter.
> > If you are not the intended recipient, you must not copy this 
> > e-mail or attachment or disclose
> > the contents to any other person.  While we have made every 
> > effort to keep our network virus free,
> > we take no responsibility for any computer virus which might 
> > be transferred by way of this e-mail.
> > 
> > 
> 
> 
Disclaimer:
The contents of this e-mail, and its attachments, if any, are confidential and may be protected
by law against any unauthorized use.  If you have received this e-mail by mistake or have
reason to believe that you are not the intended recipient, please notify the sender by reply
e-mail as soon as possible and delete it from your computer system immediately thereafter.
If you are not the intended recipient, you must not copy this e-mail or attachment or disclose
the contents to any other person.  While we have made every effort to keep our network virus free,
we take no responsibility for any computer virus which might be transferred by way of this e-mail.

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Brian Haley <[email-masked]>
Date: Fri, 23 Jun 2006 10:21:36 -0400

Kilian,

This is starting to sound something like HA-HA,
draft-wakikawa-mip6-nemo-haha-01.txt.

The scenario you describe isn't restricted by RFC 3775, you can have
multiple home addresses with multiple HAs if you like.  You could then
use different HoAs for talking to different CNs based on some
preferences you have configured.

As Hui mentioned - if you could write this up it would help us
understand what you're trying to do and determine if the HA-switch draft
is the right place to do it.

Thanks,

-Brian

---

From: "Kilian Weniger" <[email-masked]>
Date: Tue, 27 Jun 2006 10:40:11 +0200

Hi Brian,

> From: Brian Haley [mailto:[email-masked]] 
> Sent: Freitag, 23. Juni 2006 16:22
> To: Kilian Weniger
> Cc: "DENG, HUI -HCHBJ"; [email-masked]
> Subject: Re: [Mip6] RE: I-D ACTION:draft-ietf-mip6-ha-switch-00.txt
> 
> Kilian,
> 

this draft is going much further (proxy HAs, synchronising BCs between HAs, tunneling between HAs etc.)

> preferences you have configured.

yes, using multiple HoA is possible. But the problem is that only the HAs know when they are overloaded. Consequently, some signaling (such as a switch message) is necessary to inform the MN that it should change the HA and possibly the primary HoA for load balancing reasons.

> is the right place to do it.

see my last mail

-Kilian

> > we take no responsibility for any computer virus which 
> might be transferred by way of this e-mail.
> 
>

---

From: Brian Haley <[email-masked]>
Date: Tue, 27 Jun 2006 12:02:13 -0400

> this draft is going much further (proxy HAs, synchronising BCs between HAs, tunneling between HAs etc.)

Agree, but some of it does apply, that was my point.

> yes, using multiple HoA is possible. But the problem is that only the HAs know when they are overloaded. Consequently, some signaling (such as a switch message) is necessary to inform the MN that i…

The HA-switch message is just a mechanism to have a MN remove it's
binding with a HA and move it elsewhere, the draft is not going to solve
any load-balancing issues - that is outside the scope of the document:

 6. Operational Considerations

   This document does not specify how an operator might use the Home
   Agent Switch message in its network.

>> is the right place to do it.

I think what Hui and I were getting at was that you need to write a
draft about load-balancing and how it might be achieved given HAs on the
same (or different) links, messaging, etc.  We've done that in an
expired draft already :)

-Brian