Subject: RE: [dhcwg] RE: [Mip6] [Updated] DHCP Option for Home InformationDiscovery inMIPv6

From: "Vijay Devarapalli" <[email-masked]>
Date: Fri, 23 Jun 2006 08:34:32 -0700

dropped the DHC WG from the cc list.
 
> Sorry, I am not getting this. Why are we dragging WiMAX and 3GPP2
> references to justify the need for basic DHCP op-codes for HoA/HL/HA
> info?

well, some folks were trying to justify 
draft-jang-mip6-hiopt-00.txt by mentioning WiMAX.
perhaps you should go through the entire thread.

> draft-jang-mip6-hiopt-00.txt defines the DHCPv6 op-codes for 
> HA, HoA and
> HL info.

it does more. it tries to also specify a DHCP based
MIP6 bootstrapping protocol.

> draft-ietf-mip6-bootstrapping-integrated-dhc-01.txt is the MIP6
> bootstrapping solution that leverages DHCPv6 for HA/HL bootstrapping. 

yes. my point exactly.

> There are tons of I-Ds and solutions in IETF that leverage other I-Ds.
> So, what is so special here? The decision to NOT merge these I-Ds was
> taken in the bootstrap DT. Why are we wasting people's time here to
> revisit basic decisions?

uh?? we *couldn't* reach a conclusion. check the
archives. we decided to come back to this later.

big concern is that there can't be two drafts that
both specify how to use DHCP for MIP6 bootstrapping.
my suggestion is to fold the DHCP options into the
current working document and have WiMAX and 3GPP2 
refer to this draft. 

Vijay

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 23 Jun 2006 09:50:24 -0700 (PDT)

----- Original Message ----
From: Vijay Devarapalli <[email-masked]>
To: "Chowdhury, Kuntal" <[email-masked]>; Behcet Sarikaya <[email-masked]>
Cc: [email-masked]; Heejin Jang <[email-masked]>
Sent: Friday, June 23, 2006 10:34:32 AM
Subject: RE: [dhcwg] RE: [Mip6] [Updated] DHCP Option for Home InformationDiscovery inMIPv6

yes. my point exactly.

==> Or come up with a different solution and don't bother merging, like in HA Reliability DT. 
==>Regards,
==>--behcet

Vijay

---

From: Heejin Jang <[email-masked]>
Date: Mon, 26 Jun 2006 16:55:10 +0900

Hi, Vijay

What does "it does more" mean?

The idea of this draft is simply "using DHCP in order to provide HA/HL/HoA"
as the same way 
as providing other parameters such as IP addresses or DNS/NTP servers.
Though the draft 
allows bootstrapping, it does not specify or is limited to any mechanism or
procedure for bootstrapping. 

For e.g., the idea is also appicable in HMIPv6 map discovery. It can be used
where the mobile node 
is required to discover the MAP (a special home agent) that is located
multiple hops away from the 
mobile node's attachment point.

If the use cases are not limited to only bootstrapping, why should the draft
be merged?
I hope we let the draft standalone so that operators can utililze it for
various applicable use cases. 

Thanks for your interest. 

Regards,
Heejin.

-----Original Message-----
From: Vijay Devarapalli [mailto:[email-masked]] 
Sent: Saturday, June 24, 2006 12:35 AM
To: Chowdhury, Kuntal; Behcet Sarikaya
Cc: [email-masked]; Heejin Jang
Subject: RE: [dhcwg] RE: [Mip6] [Updated] DHCP Option for Home
InformationDiscovery inMIPv6

> references to justify the need for basic DHCP op-codes for HoA/HL/HA 

well, some folks were trying to justify draft-jang-mip6-hiopt-00.txt by
mentioning WiMAX.
perhaps you should go through the entire thread.

> draft-jang-mip6-hiopt-00.txt defines the DHCPv6 op-codes for HA, HoA 
> and HL info.

yes. my point exactly.

> taken in the bootstrap DT. Why are we wasting people's time here to 

uh?? we *couldn't* reach a conclusion. check the archives. we decided to
come back to this later.

big concern is that there can't be two drafts that both specify how to use
DHCP for MIP6 bootstrapping.
my suggestion is to fold the DHCP options into the current working document
and have WiMAX and 3GPP2 refer to this draft. 

Vijay

---

From: Vijay Devarapalli <[email-masked]>
Date: Mon, 26 Jun 2006 15:51:10 -0700

> What does "it does more" mean?

see my reply to Kent.

> procedure for bootstrapping. 

this *is* the problem. we can't have two drafts that both describe
how to use DHCPv6 for MIP6 bootstrapping.

> mobile node's attachment point.

MIP6 charter does not address HMIPv6 map discovery.

> If the use cases are not limited to only bootstrapping, 

what other use cases? are those use cases specific to Mobile IPv6?
do they fit into the MIP6 WG charter?

Vijay