Subject: RE: [Mip6] On a network-mobility solution based on Mobile IPv6

From: "Faccin, Stefano M" <[email-masked]>
Date: Tue, 26 Sep 2006 01:51:40 -0700

George,
I guess it is a matter of point of view. What you negatively label as
"broken" can be positively enable as "enhanced for additional use
cases". That's the aims here.

Stefano

-----Original Message-----
From: Tsirtsis, George [mailto:[email-masked]] 
Sent: Thursday, September 21, 2006 8:50 AM
To: Faccin, Stefano M; [email-masked]
Subject: RE: [Mip6] On a network-mobility solution based on Mobile IPv6

I oppose the idea of defining a PMIP solution in this WG.

Just from IETF procedure point of view I am not sure how MIP6 WG can
develop PMIPv6 while NETLMM WG exists. I do not see how the IETF can
justify the existence of two parallel efforts for the development of a
network based mobility management solution.

Besides, I am not sure why the IETF would compound one error (creation
of NETLMM WG) with another (starting PMIPv6 work in MIPv6 WG), when a
lot of people in the IETF believe that NETLMM solutions should not exist
at all (see draft-soliman-netlmm-harmful-00.txt)

I have no idea why MIP6 WG would be willing to create a broken version
of its own protocol. People are free to create a proxy version of any
protocol they like and the Internet is full of such contraptions, but
that does not mean that the IETF should go out and bless every one of
them.  PMIPv4 is a perfect example. PMIPv4 is being used in the industry
but the IETF has nothing to do with it.

George

> -----Original Message-----
> From: Faccin, Stefano M [mailto:[email-masked]]
> Sent: Wednesday, September 20, 2006 9:59 PM
> To: [email-masked]
> Subject: [Mip6] On a network-mobility solution based on Mobile IPv6
> 
> Hello all,
> 
> I'm sending this e-mail to start a thread of discussion on the need
and
> opportunities for a network-mobility solution based on Mobile IPv6.
> 
> As a result of offline discussions between interested parties, we
would
> like to submit the following to begin a discussion on this mailing
list.
> 
> =================================================================
> Recent developments in network architectures in SDOs such as WiMAX
forum
> and 3GPP2 have identified a need to support IP mobility for hosts
> without the host playing a role in managing mobility. Significant
> interest exists for a network based IP mobility solution based on
Mobile
> IPv6. The choice of Mobile IPv6 as the mobility protocol for IPv6 is
> driving the need to have a solution for network based mobility that is
> also based on or derived from MIPv6. One of the key benefits that been
> identified for a network based MIP6 solution (referred to as Proxy
MIP6)
> is the optimized use of the air interface resulting from no MIP6
> signaling and no tunneling of packets over the air interface.
> 
> The WiMAX network architecture currently supports Proxy MIP4 for
> enabling mobility for hosts that may not have a MIP4 client. MIPv6 has
> been adopted as the mobility solution for IPv6. There exists a
> requirement to support mobility for IPv6 hosts without having any
> explicit expectations of the host IPv6 capability. Proxy MIP6 is a
> solution that is aligned with the architectural direction of WiMAX,
> given the specification of Proxy MIP4 for IPv4 mobility and hence a
> similar approach for IPv6 mobility.
> 
> In 3GPP, there has been some degree of interest in Proxy MIPv6 as
well,
> primarily in the SAE (System Architecture Evolution) work item. No
> decision or protocol choices have been made yet.
> 
> 3GPP2 has expressed some interest in pursuing a network-based IP
> mobility protocol in order to support hosts with no mobility stack
> (those that use Simple IP) to take advantage of some form of mobility
> provided by the same entities that handle host-based (MIPv6-based)
> mobility. No decision on the specific protocol has been finalized yet,
> although a network-based IP mobility solution based on MIP6 has been
> identified as a viable option.
> 
> There are several key benefits to using PMIPv6 as the network-based
> mobility management protocol:
> - The same MIPv6 home agent can be used be used at the same time with
> little or no modifications for clients that support MIPv6 and for
> clients that don't have host mobility software and would like the
> network to handle mobility for them.
> - Re-use of supporting work that has been done for MIPv6. This
includes
> the ability to establish security associations, RADIUS and Diameter
> extensions, bootstrapping, dual stack support, reliability, fail over
> and HA switching.
> 
> So we would like to propose adding a new item to the MIP6 WG charter
to
> standardize proxy MIPv6. The goal of this work would be to specify a
> simple extension to MIPv6 that would support network based mobility
for
> IPv6 hosts and reuses MIP6 signaling and features. It is not intended
to
> be a new network-based mobility protocol solution.
> 
> A couple of I-Ds specifying network-based mobility management protocol
> derived from MIPv6 exist today and can be used as the baseline for the
> work.
> 
> In conclusion, we think that the MIP6 WG should take on this work in
> order to meet a requirement of networks that will be deployed in the
> near future.
> 
>
========================================================================
> 
> Comments are welcome.
> Stefano
> 
> _______________________________________________
> Mip6 mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mip6

_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Tsirtsis, George" <[email-masked]>
Date: Tue, 26 Sep 2006 09:03:11 -0700

Stefano,

It is indeed a matter of opinion, although some principles on how the
Internet should work may make some opinions to be more correct,
according to such principles, than others.

I have to admit that IMO, if any network mobility management protocol
should be defined, it should indeed be based on Mobile IP. Now, why
NETLMM does not do that is a matter for them to explain. 

This decision, however, does not justify your attempt to bypass NETLMM
WG and define yet another network mobility management protocol here. As
others have already argues, such an attempt will clearly result in some
SDOs picking NETLMM and some SDOs picking PMIP which is what you claim
to be trying to prevent.
 
George

> Sent: Tuesday, September 26, 2006 4:52 AM
> To: Tsirtsis, George; [email-masked]

---

From: Julien Laganier <[email-masked]>
Date: Wed, 27 Sep 2006 17:52:39 +0200

Hi George,

Adding my 2 cents below:

On Tuesday 26 September 2006 18:03, Tsirtsis, George wrote:
>
> I have to admit that IMO, if any network mobility management
> protocol should be defined, it should indeed be based on Mobile IP.

Do you mean that it should use the mobility header format, or the 
Mobile IP protocol?

If the latter I don't understand why: Mobile IP provides host-based 
mobility management. IMO reusing the protocol for a different purpose 
(network-based mobility) would overload the semantic of the protocol, 
and I don't think that would be good (for example it might create 
risk of ambiguity.)

> Now, why NETLMM does not do that is a matter for them to explain.

Agree that syntax of bits-on-the-wire needed to realize network-based 
mobility should be realized in a WG chartered to develop 
network-based mobility.

> This decision, however, does not justify your attempt to bypass
> NETLMM WG and define yet another network mobility management
> protocol here. As others have already argues, such an attempt will
> clearly result in some SDOs picking NETLMM and some SDOs picking
> PMIP which is what you claim to be trying to prevent.

+1

Best,

--julien

---

From: Jari Arkko <[email-masked]>
Date: Thu, 28 Sep 2006 00:56:06 +0300

All,

I am very sensitive to hearing about the current
industry needs. And I worry about how the IETF
not doing what is requested could lead to
fragmentation of the standards in this space.

However, I wanted to bring up a couple of notes
and provide some information about ongoing
activities.

First of all, I think it would be valuable to focus
the discussion on requirements ("what cannot
we do today?") rather than on solutions. And
requirements written in a document are easier
to deal with than a long thread of e-mails.

Second, the IETF does have a working group,
NETLMM, in the network-based mobility space.
If what you want to do is close but not quite
what they are doing, please take your
concerns directly to NETLMM. They do not have
an official WG solution specification yet, but
they will soon and I don't think they
expect to keep in the WG process for too
long after that. If you want to have an effect
the time to voice your opinion is now.

Third, the scope of the NETLMM is restricted
to IPv6 and local mobility. But we received a BOF
proposal for the San Diego IETF requesting
the extension of these to IPv4 and roaming
between domains. The BOF proposal was
eventually withdrawn after discussion, but I
stated that smaller charter extensions such as v4
support are expected once the work progresses
a bit further. And that larger extensions, such
as roaming/global support is something that
we could at least consider when the base is
done -- perhaps in the form of a rechartering
or a BOF in IETF-68. Extending the scope this
way would require IETF-wide agreement that
its a good idea, but what I wanted to say was
that NETLMM might be developed beyond its
current charter limitations.

Finally, the set of solutions in the mobility
space as well as in the local mobility space
is already quite fragmented. It is possible
that we need even further new mechanisms,
but the bar for chartering such new work
is rather high. For instance, we'd have to
be certain that there is no way we can
accommodate multiple requirements with
the same solutions, that there is indeed
significant long-term demand for the new
mechanism, etc.

--Jari