Subject: [Mip6] Should we add the requirements that arise from RFC 4285 in the draft-ietf-mip6-aaa-ha-goals-03?

From: "Gopal Dommety \(gdommety\)" <[email-masked]>
Date: Sat, 11 Nov 2006 10:44:00 -0800

Hello All,
 
    Wanted to get the MIP6 Working groups preference on whether we
should we add the requirements that arise from RFC 4285 in the
draft-ietf-mip6-aaa-ha-goals-03
 
We would like to hear the Working Groups opinion of the following
question:
 
Should we add the requirements that arise from RFC 4285 in the
draft-ietf-mip6-aaa-ha-goals-03?
 
 Please answer "yes" or "no" PS: In the IETF Mip6 WG meeting there were
14 people for "yes" and 5 for "No".
 
Cheers,
Gopal and Raj
_______________________________________________
Mip6 mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mip6

---

From: "Narayanan, Vidya" <[email-masked]>
Date: Sat, 11 Nov 2006 13:04:26 -0800

Even though draft-ietf-mip6-aaa-ha-goals-03 is slated to only becoming
an informational RFC, I suppose we will looking for a PS document that
really provides the AAA solution based on these goals. Having said that,
it would be a problem to have a normative reference to RFC4285 in those
AAA solution documents anyway.  
 
Aside from that, I vote "no" at the moment. There are many issues with
RFC4285 and I'm not really sure we want to go down the path of fixing
those. And, without fixing those, it doesn't quite make sense to do more
work based on that. 
 
Vidya

________________________________

	From: Gopal Dommety (gdommety) [mailto:[email-masked]] 
	Sent: Saturday, November 11, 2006 10:44 AM
	To: [email-masked]
	Subject: [Mip6] Should we add the requirements that arise from
RFC 4285 inthe draft-ietf-mip6-aaa-ha-goals-03?

	Hello All,
	 
	    Wanted to get the MIP6 Working groups preference on whether
we should we add the requirements that arise from RFC 4285 in the
draft-ietf-mip6-aaa-ha-goals-03
	 
	We would like to hear the Working Groups opinion of the
following question:

	 Please answer "yes" or "no" PS: In the IETF Mip6 WG meeting
there were 14 people for "yes" and 5 for "No".

	Cheers,
	Gopal and Raj

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Sun, 12 Nov 2006 09:32:44 -0600

Hi Vidya,
 
It is probably a good idea if you highlight these issues related to
RFC4285. I am personally interested.
Many thanks. 

Regards, 
Ahmad 

	From: Narayanan, Vidya [mailto:[email-masked]] 
	Sent: Saturday, November 11, 2006 3:04 PM
	To: Gopal Dommety (gdommety); [email-masked]
	Subject: RE: [Mip6] Should we add the requirements that arise
from RFC 4285 inthe draft-ietf-mip6-aaa-ha-goals-03?

	Even though draft-ietf-mip6-aaa-ha-goals-03 is slated to only
becoming an informational RFC, I suppose we will looking for a PS
document that really provides the AAA solution based on these goals.
Having said that, it would be a problem to have a normative reference to
RFC4285 in those AAA solution documents anyway.  
	 
	Aside from that, I vote "no" at the moment. There are many
issues with RFC4285 and I'm not really sure we want to go down the path
of fixing those. And, without fixing those, it doesn't quite make sense
to do more work based on that. 
	 
	Vidya

		From: Gopal Dommety (gdommety)
[mailto:[email-masked]] 
		Sent: Saturday, November 11, 2006 10:44 AM
		To: [email-masked]
		Subject: [Mip6] Should we add the requirements that
arise from RFC 4285 inthe draft-ietf-mip6-aaa-ha-goals-03?

		Hello All,
		 
		    Wanted to get the MIP6 Working groups preference on
whether we should we add the requirements that arise from RFC 4285 in
the   draft-ietf-mip6-aaa-ha-goals-03

		Should we add the requirements that arise from RFC 4285
in the  draft-ietf-mip6-aaa-ha-goals-03?
		 
		 Please answer "yes" or "no" PS: In the IETF Mip6 WG
meeting there were 14 people for "yes" and 5 for "No".

		Cheers,
		Gopal and Raj

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 14 Nov 2006 11:18:00 -0600

YES.

Regards, 
Ahmad 

	From: Gopal Dommety (gdommety) [mailto:[email-masked]] 
	Sent: Saturday, November 11, 2006 12:44 PM
	To: [email-masked]
	Subject: [Mip6] Should we add the requirements that arise from
RFC 4285 in the draft-ietf-mip6-aaa-ha-goals-03?

	Hello All,

	 

	
	Cheers,
	Gopal and Raj

---

From: Vijay Devarapalli <[email-masked]>
Date: Tue, 14 Nov 2006 10:25:31 -0800

Gopal,

lets step back a bit. what is the point of adding
of 4285-specific requirements in
draft-ietf-mip6-aaa-ha-goals? is it just for basic
4285 operation where the HA-AAAH interface is used
for MN authentication? or does it include
bootstrapping for 4285 too?

will the requirements be added to
draft-ietf-mip6-aaa-ha-goals-03 just to capture
all the requirements in one place with no binding
to develop any solutions yet?

other bootstrapping related questions, do we want
to standardize bootstrapping solutions for 4285
too? has the DIME WG agreed to developing
solutions for 4285-based MIP6 operation?

Vijay

Gopal Dommety (gdommety) wrote:
> We would like to hear the Working Groups opinion of the following question:
>  
> ------------------------------------------------------------------------
>

---

From: Madjid Nakhjiri <[email-masked]>
Date: Tue, 14 Nov 2006 15:13:34 -0800

I disagree with this. I don't really think there are "issues" with 4285. I
just want the group to go through the exercise of defining the related
requirements (which I think would be only support for related attributes)
and then make the decision based on those explicit requirements.

Madjid

  _____  

From: Narayanan, Vidya [mailto:[email-masked]] 
Sent: Saturday, November 11, 2006 1:04 PM
To: Gopal Dommety (gdommety); [email-masked]
Subject: RE: [Mip6] Should we add the requirements that arise from RFC
4285inthe draft-ietf-mip6-aaa-ha-goals-03?

Even though draft-ietf-mip6-aaa-ha-goals-03 is slated to only becoming an
informational RFC, I suppose we will looking for a PS document that really
provides the AAA solution based on these goals. Having said that, it would
be a problem to have a normative reference to RFC4285 in those AAA solution
documents anyway.  

Aside from that, I vote "no" at the moment. There are many issues with
RFC4285 and I'm not really sure we want to go down the path of fixing those.
And, without fixing those, it doesn't quite make sense to do more work based
on that. 

Vidya

  _____  

From: Gopal Dommety (gdommety) [mailto:[email-masked]] 
Sent: Saturday, November 11, 2006 10:44 AM
To: [email-masked]
Subject: [Mip6] Should we add the requirements that arise from RFC 4285
inthe draft-ietf-mip6-aaa-ha-goals-03?

Hello All,

    Wanted to get the MIP6 Working groups preference on whether we should we
add the requirements that arise from RFC 4285 in the
draft-ietf-mip6-aaa-ha-goals-03

 Please answer "yes" or "no" PS: In the IETF Mip6 WG meeting there were 14
people for "yes" and 5 for "No".

Cheers,

Gopal and Raj

---

From: "Ram O V Vishnu-A14676" <[email-masked]>
Date: Wed, 15 Nov 2006 19:14:33 +0800

yes.

Regards,
Vishnu.

Motorola
+91 9844178052
[*] General
[] Motorola Internal Use Only

	-----Original Message-----
	From: Gopal Dommety (gdommety) [mailto:[email-masked]] 
	Sent: Sunday, November 12, 2006 12:14 AM
	To: [email-masked]
	Subject: [Mip6] Should we add the requirements that arise from

	Hello All,

	 

	
	Cheers,
	Gopal and Raj

---

From: Basavaraj Patil <[email-masked]>
Date: Wed, 15 Nov 2006 15:26:38 -0600

Vijay,

Inline:

> bootstrapping for 4285 too?

Bootstrapping for RFC4285 is not in the scope of the MIP6 WG charter at this
time and hence the AAA requirements are just for the basic 4285 operation.

> to develop any solutions yet?

Yes.

> solutions for 4285-based MIP6 operation?

We do not have consensus to develop bootstrapping solutions for RFC4285 mode
of operation. The view is that we do not really need to standardize such a
solution. People who are interested in using RFC4285 with MIP6 may have
their own means for bootstrapping and hence the need for the WG to specify
such bootstrapping is not essential.

The DIME WG is working on bootstrapping solution based on the current
bootstrapping solutions in the MIP6 WG which does not include bootstrapping
for RFC4285. 

-Raj

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 15 Nov 2006 15:04:01 -0800

thanks for the clarification.

allow me to rephrase Gopal's question to the mailing
list then.

Should we add the requirements that arise from the use RFC
4285 for Mobile IPv6 in draft-ietf-mip6-aaa-ha-goals-03?
This does not include RFC 4285-based bootstrapping.

my answer is Yes to the above question.

Vijay