Subject: Re: [MEXT] Home Link Detection

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 25 Mar 2008 14:42:20 -0700 (PDT)

Julien, your scenario is not according to SDO links. I think that the home link operation work item should concentrate on p2t SDO  home link operation and should complement previous bootstrapping work.

Please see my comment inline below.

Behcet

----- Original Message ----
From: Vijay Devarapalli <[email-masked]>
To: Julien Laganier <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, March 19, 2008 7:41:24 PM
Subject: Re: [MEXT] Home Link Detection

Julien Laganier wrote:
> Vijay,
> 
> Still <chair hat off>:
> 
> Vijay Devarapalli wrote:
>> Julien Laganier wrote:
>>> Vijay Devarapalli wrote:
>>>> In RFC 3775 and 3963, it is assumed that the mobile node is
>>>> pre-configure with the home prefix. So when it sees a router
>>>> advertisement with the same prefix, it knows it is on the home
>>>> link.
>>> When RFC 5026 is used, the MN has no pre-configured home prefix but
>>> get it dynamically in the MIP6_HOME_PREFIX attribute obtained via
>>> the IKEv2 exchange of the bootstrapping mechanism. Then it simply
>>> behave as usual, i.e., quoting you "when it sees a router
>>> advertisement with the same prefix, it knows it is on the home
>>> link."
>> The sequence of steps when the MN boots up on the home link would be
>> the other way around. The MN would first boot up, setup the link and
>> then run IKEv2 with the home agent. Not run IKEv2 with the home agent
>> and then send a router solicitation on the home link to trigger a
>> router advertisement.
> 
> This isn't what I had in mind. What I had in mind is:
> 
> 1) MN would boot up
> 2) Setup the link:
>     -  send an RS on the link
>     -  receives an RA with PIO from the link
>     -  configures a CoA for the link
> 3) Run IKEv2:
>     - receives MIP6_HOME_PREFIX
> 4) Compare MIP6_HOME_PREFIX and PIO
>     - same: conclude it's at home
>     - different: conclude it's not at home

Ok.
[behcet] Not OK. According to http://tools.ietf.org/id/draft-ietf-dime-mip6-split-07.txt
IKEv2 happens with EAP in authentication phase which in SDOs happens when immediately MN enters the network.
So home prefix assignment occurs after CFG_REQUEST is received. http://tools.ietf.org/id/draft-ietf-dime-mip6-split-07.txt lacks any discussion on how the home prefix is assigned

>>> I don't see what requires additional specification.

[behcet] Sorry, I do think it requires additional specification.

>> There is nothing that specifies that the mobile node should first
>> setup a the p2p link that connects it to the home agent, then run
>> IKEv2 from the home link and obtain the home prefix, then compare
>> the prefix obtained from IKEv2 with the prefix obtained from the p2p
>> link setup and finally conclude it is on the home link. This is not
>> obvious. The MIP6_HOME_PREFIX attribute was designed for home address
>> auto-configuration. Not for home link detection.
> 
> I don't see what isn't obvious, 

:) Well, if it is obvious for everyone, we are done.

> and it doesn't matter what the 
> MIP6_HOME_PREFIX was "designed" for.

It does. Implementing the MIP6_HOME_PREFIX attribute is optional,
since it is supposed to be used for home address auto-configuration.
If you are not supporting home address auto-configuration in your
system (for various reasons), then you don't even have to implement
this attribute.

Vijay

> The prefix received in the RA's PIO is an on-link prefix. If the 
> MIP6_HOME_PREFIX from which the MN configures a home address is the 
> same as the RA's PIO, then the home address belongs to the RA's PIO, 
> therefore the home address is on-link, therefore the MN is at home.
> 
> --julien

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: Julien Laganier <[email-masked]>
Date: Wed, 26 Mar 2008 11:36:10 +0100

Behcet,

On Tuesday 25 March 2008, Behcet Sarikaya wrote:
> Julien, your scenario is not according to SDO links. I think that the
> home link operation work item should concentrate on p2t SDO  home
> link operation and should complement previous bootstrapping work.

I don't understand what you mean. More below:

> [behcet] Not OK. According to
> http://tools.ietf.org/id/draft-ietf-dime-mip6-split-07.txt IKEv2
> happens with EAP in authentication phase which in SDOs happens when
> immediately MN enters the network. So home prefix assignment occurs
> after CFG_REQUEST is received.

I don't understand why you're bringing in DIME drafts in this 
discussion. DIME stuff shall be discussed in DIME. This discussion is 
about Home Link Detection, i.e. how does the MN knows it's at home. If 
you want to discuss something different, please make sure you change 
the subject line.

Regarding the home prefix, of course it comes as part of a configuration 
payload in the IKEv2 exchange, nobody is discussing that. And, if you 
look at the steps I listed above, this is exactly what I sketched above 
(i.e. MIP6_HOME_PREFIX comes as part of the IKEv2 exchange.)

--julien

---

From: <[email-masked]>
Date: Wed, 26 Mar 2008 11:48:53 +0100

Hi all,
 
I think that we cannot speak about CoA or HoA before discovering if we are in a home network or in a foreign network. I think that it will be made as follows:

At bootstrap step (this means that the MN has neither HoA, nor HA-address...) the MN connects to a network, discovers a link-prefix and configures an address (MN-address). At this point it does not know if this address is a HoA or a CoA. The MN has to discover a HA and home-prefixes (prefixes for which the HA acts as Home Agent):

If the link-prefix (= MN-prefix) belongs to the home-prefixes then the MN is in a home network and the HoA = MN-address (MN-home-prefix = MN-prefix).

If the link-prefix does not belong to the home-prefixes then the MN is in a foreign network and the CoA = MN-address. In this case, the MN asks for a HoA from the HA in the first BU.

At a handover step (this means that the MN was connected to a network and moves to another network) the MN has already a HoA, a HA address, may be a CoA.... When the MN connects to a network and discovers a link-prefix it compares this prefix to the MN-home-prefix:

If the same then the MN is in its home network and sends a BU to HA (if necessary).

If not then the MN is in a foreign network. It will configure a CoA and send a BU to HA.

Kassi

________________________________

De : [email-masked] [mailto:[email-masked]] De la part de Behcet Sarikaya
Envoyé : mardi 25 mars 2008 22:42
À : Vijay Devarapalli; Julien Laganier
Cc : [email-masked]
Objet : Re: [MEXT] Home Link Detection

Behcet

----- Original Message ----
From: Vijay Devarapalli <[email-masked]>
To: Julien Laganier <[email-masked]>
Cc: [email-masked]
Sent: Wednesday, March 19, 2008 7:41:24 PM
Subject: Re: [MEXT] Home Link Detection

Ok.

Vijay