Subject: [MEXT] (no subject)

From: "Desire Oulai" <[email-masked]>
Date: Mon, 1 Dec 2008 15:45:51 -0500

Hi Ahmad, All,

 The Binding revocation draft does not mention revocation related to
NEMO. If used as is, the BRI will revoke the binding between the MR's
HoA and CoA. I think it's woth adding another level of revocation:
revocation of Mobile Network Prefixes. A HA may decide to stop
forwarding data to the CoA for certain MNPs and BR could be used for
that. Here is a proposed text for a new section:
"In case of NEMO protocol, the HA follows the same procedure as MIPv6 if
the goal is to revoke the binding between the Mobile Router's HoA and
CoA. It is also possible to have finer granularity of revocation
targeting the Mobile Network Prefixes assigned to the Mobile Router. In
this case, the HA sends a BRI message including one or more MNP options
with the A bit set and the Revocation Trigger set to a proper value,
e.g. Administrative Reasons. When receiving this BRI, the MR deletes the
MNP(s) from the Prefix Information field in the Binding Update List and
responds with a BRA message. The BRA MUST include the MNP(s) contained
in the BRI."
Also, Mobile network Prefix should be addes as valid option in section
"6.2. Binding Revocation Acknowledgement Message".
BR
Desire

_______________________________________________
MEXT mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/mext

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Mon, 1 Dec 2008 21:22:35 -0600

Hi Desire,
 
Added a relative subject.
 
I guess the usecase is clear and it makes sense to me. 
We can add some text similar to yours to capture this functionality
under the HA and MN operations after the conclusion of the WGLC..
 
BTW: Is there anyone who thinks that we should not add this usecase?

Regards, 
Ahmad 

________________________________

	From: Desire Oulai [mailto:[email-masked]] 
	Sent: Monday, December 01, 2008 2:46 PM
	To: [email-masked]
	Cc: Muhanna, Ahmad (RICH1:2H10)
	Subject: 

	Hi Ahmad, All, 

	 The Binding revocation draft does not mention revocation
related to NEMO. If used as is, the BRI will revoke the binding between
the MR's HoA and CoA. I think it's woth adding another level of
revocation: revocation of Mobile Network Prefixes. A HA may decide to
stop forwarding data to the CoA for certain MNPs and BR could be used
for that. Here is a proposed text for a new section:

	"In case of NEMO protocol, the HA follows the same procedure as
MIPv6 if the goal is to revoke the binding between the Mobile Router's
HoA and CoA. It is also possible to have finer granularity of revocation
targeting the Mobile Network Prefixes assigned to the Mobile Router. In
this case, the HA sends a BRI message including one or more MNP options
with the A bit set and the Revocation Trigger set to a proper value,
e.g. Administrative Reasons. When receiving this BRI, the MR deletes the
MNP(s) from the Prefix Information field in the Binding Update List and
responds with a BRA message. The BRA MUST include the MNP(s) contained
in the BRI."

	Also, Mobile network Prefix should be addes as valid option in
section "6.2. Binding Revocation Acknowledgement Message".

	BR 
	Desire

---

From: "fan zhao" <[email-masked]>
Date: Tue, 2 Dec 2008 09:57:04 -0800

Hi Ahmad,

I think this should be documented.

Sincerely,
fan

On Mon, Dec 1, 2008 at 7:22 PM, Ahmad Muhanna <[email-masked]> wrote:
> We can add some text similar to yours to capture this functionality under
> the HA and MN operations after the conclusion of the WGLC..
>
>  The Binding revocation draft does not mention revocation related to NEMO.
> If used as is, the BRI will revoke the binding between the MR's HoA and CoA.
> I think it's woth adding another level of revocation: revocation of Mobile
> Network Prefixes. A HA may decide to stop forwarding data to the CoA for
> certain MNPs and BR could be used for that. Here is a proposed text for a
> new section:
>
> "In case of NEMO protocol, the HA follows the same procedure as MIPv6 if the
> goal is to revoke the binding between the Mobile Router's HoA and CoA. It is
> also possible to have finer granularity of revocation targeting the Mobile
> Network Prefixes assigned to the Mobile Router. In this case, the HA sends a
> BRI message including one or more MNP options with the A bit set and the
> Revocation Trigger set to a proper value, e.g. Administrative Reasons. When
> receiving this BRI, the MR deletes the MNP(s) from the Prefix Information
> field in the Binding Update List and responds with a BRA message. The BRA
> MUST include the MNP(s) contained in the BRI."
>
> Also, Mobile network Prefix should be addes as valid option in section "6.2.
> Binding Revocation Acknowledgement Message".
>
> BR
> Desire
>

---

From: "fan zhao" <[email-masked]>
Date: Tue, 2 Dec 2008 10:19:35 -0800

Hi Desire,

I support adding this case. Nevertheless, please see some comments below.

On Mon, Dec 1, 2008 at 12:45 PM, Desire Oulai <[email-masked]> wrote:
> certain MNPs and BR could be used for that.
This could be one of reasons to trigger the binding revocation of mobile network
prefixes. However, when the binding revocation is used in this case, only
the binding cache entry is modified and the MNP is not explicitly released.
That is, after the binding revocation, the packets to such MNP is not tunneled
by the HA. To release the MNP, I think it is better to use the method similar
to how the MNP is obtained. This, IMO, would avoid messing up state machines.

> Here is a proposed text for a
> new section:
>
I reword it a little bit:
"BRI message carrying one or more or even all MNPs allocated before in
the MNP option(s)
with the A bit set and the"

That is, if the HA wants to remove all the MNPs from the BCE and still keep
the binding between the CoA and the HoA, it includes all the MNPs.
If the HA wants to remove the whole binding cache enry including the MNPs,
it does not need to indicate the MNPs.

> MUST include the MNP(s) contained in the BRI."
I also want to add:
If the home address is part of the mobile network prefix(es) to be revoked,
the mobile router can still use such home address after such revocation of MNPs.

Sincerely,
fan

---

From: "Desire Oulai" <[email-masked]>
Date: Tue, 2 Dec 2008 14:31:50 -0500

Hi fan,

 I added the subject of the related thread. See inline.

BR

Desire

> -----Original Message-----
> From: fan zhao [mailto:[email-masked]] 
> Sent: December 2, 2008 1:20 PM
> To: Desire Oulai
> Cc: [email-masked]
> Subject: Re: [MEXT] (no subject)
> 
> Hi Desire,
> 
> related to NEMO.
> > I think it's woth adding another level of revocation: revocation of 
> > Mobile Network Prefixes. A HA may decide to stop forwarding data to 
> > the CoA for certain MNPs and BR could be used for that.
> This could be one of reasons to trigger the binding 
> revocation of mobile network prefixes. However, when the 
> binding revocation is used in this case, only the binding 
> cache entry is modified and the MNP is not explicitly released.
> That is, after the binding revocation, the packets to such 
> MNP is not tunneled by the HA. To release the MNP, I think it 
> is better to use the method similar to how the MNP is 
> obtained. This, IMO, would avoid messing up state machines.
[Desire]: For sure, we need to be consistent. If the HA is the one that
assigns the prefixes, BRI/BRA seems to me a good and sufficient approach
to release the MNP. If the MNP was assigned by an external  entity, the
MN or HA can start other procedure after BRI/BRA.
> > "In case of NEMO protocol, the HA follows the same 
> procedure as MIPv6 
> > if the goal is to revoke the binding between the Mobile 
> Router's HoA 
> > and CoA. It is also possible to have finer granularity of 
> revocation 
> > targeting the Mobile Network Prefixes assigned to the 
> Mobile Router. 
> > In this case, the HA sends a BRI message including one or more MNP 
> > options with the A bit set and the
> "BRI message carrying one or more or even all MNPs allocated 
> before in the MNP option(s) with the A bit set and the"
> 
> That is, if the HA wants to remove all the MNPs from the BCE 
> and still keep the binding between the CoA and the HoA, it 
> includes all the MNPs.
> If the HA wants to remove the whole binding cache enry 
> including the MNPs, it does not need to indicate the MNPs.
[Desire]: That sounds good.
> 
> > Revocation Trigger set to a proper value, e.g. 
> Administrative Reasons. 
> > When receiving this BRI, the MR deletes the MNP(s) from the Prefix 
> > Information field in the Binding Update List and responds 
> with a BRA 
> > message. The BRA MUST include the MNP(s) contained in the BRI."
> I also want to add:
> If the home address is part of the mobile network prefix(es) 
> to be revoked, the mobile router can still use such home 
> address after such revocation of MNPs.
[Desire]: I don't know if we need this clarification but I see no
problem with the text.

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 2 Dec 2008 11:52:59 -0800 (PST)

Hi Ahmad,
  Can you please explain how MNP is related to your draft? MNP is something that MR needs and is specific to Nemo operation not to MN-HA relationship and the binding that comes with it. 
  So I don't see any binding to revocate with MNPs?

Regards,

Behcet

________________________________
From: Ahmad Muhanna <[email-masked]>
To: Desire Oulai <[email-masked]>; [email-masked]
Sent: Monday, December 1, 2008 9:22:35 PM
Subject: Re: [MEXT] Binding Revocation for IPv6 Mobility Supports NEMO usecase

Hi 
Desire,
 
Added 
a relative subject.
 
I 
guess the usecase is clear and it makes sense to me. 
We can 
add some text similar to yours to capture this functionality under the HA and MN 
operations after the conclusion of the WGLC..
 
BTW: 
Is there anyone who thinks that we should not add this 
usecase?
Regards, 
Ahmad 

Hi Ahmad, All, 
 The Binding  revocationdraft does  not mention revocation related to NEMO. If used as is, the BRI will revoke the  binding between the MR's HoA and CoA. I think it's woth adding another level  of revocation: revocation of Mobile Network Prefixes. A HA may decide to stop  forwarding data to the CoA for certain MNPs and BR could be used for that.  Here is a proposed text for a new section:
"In case of NEMO protocol, the HA  follows the same procedure as MIPv6 if the goal is to revoke the binding  between the Mobile Router's HoA and CoA. It is also possible to have finer  granularity of revocation targeting the Mobile Network Prefixes assigned to  the Mobile Router. In this case, the HA sends a BRI message including one or  more MNP options with the A bit set and the Revocation Trigger set to a proper  value, e.g. Administrative Reasons. When receiving this BRI, the MR deletes  the MNP(s) from the Prefix Information field in the Binding Update List and  responds with a BRA message. The BRA MUST include the MNP(s) contained in the  BRI."
Also, Mobile network Prefix should  be addes as valid option in section "6.2.  Binding Revocation Acknowledgement Message".
BR 
Desire

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Tue, 2 Dec 2008 15:33:14 -0600

Hi Behcet,
 
That is why I asked the if there is anyone against adding this use case.

If the wg think that this usecase should not be added or addressed by
binding revocation, I am absolutely fine with that. or to be precise, we
need to have the wg to agree to add this usecase.

Regards, 
Ahmad 

	From: Behcet Sarikaya [mailto:[email-masked]] 
	Sent: Tuesday, December 02, 2008 1:53 PM
	To: Muhanna, Ahmad (RICH1:2H10)
	Cc: [email-masked]
	Subject: Re: [MEXT] Binding Revocation for IPv6 Mobility
Supports NEMO usecase

	Hi Ahmad,
	  Can you please explain how MNP is related to your draft? MNP
is something that MR needs and is specific to Nemo operation not to
MN-HA relationship and the binding that comes with it. 
	  So I don't see any binding to revocate with MNPs?
	
	Regards,
	
	Behcet

	From: Ahmad Muhanna <[email-masked]>
	To: Desire Oulai <[email-masked]>; [email-masked]
	Sent: Monday, December 1, 2008 9:22:35 PM
	Subject: Re: [MEXT] Binding Revocation for IPv6 Mobility
Supports NEMO usecase

	Hi Desire,

	I guess the usecase is clear and it makes sense to me. 
	We can add some text similar to yours to capture this
functionality under the HA and MN operations after the conclusion of the
WGLC..
	 
	BTW: Is there anyone who thinks that we should not add this
usecase?

	Regards, 
	Ahmad 

		Hi Ahmad, All, 

		 The Binding revocation draft does not mention
revocation related to NEMO. If used as is, the BRI will revoke the
binding between the MR's HoA and CoA. I think it's woth adding another
level of revocation: revocation of Mobile Network Prefixes. A HA may
decide to stop forwarding data to the CoA for certain MNPs and BR could
be used for that. Here is a proposed text for a new section:

		"In case of NEMO protocol, the HA follows the same
procedure as MIPv6 if the goal is to revoke the binding between the
Mobile Router's HoA and CoA. It is also possible to have finer
granularity of revocation targeting the Mobile Network Prefixes assigned
to the Mobile Router. In this case, the HA sends a BRI message including
one or more MNP options with the A bit set and the Revocation Trigger
set to a proper value, e.g. Administrative Reasons. When receiving this
BRI, the MR deletes the MNP(s) from the Prefix Information field in the
Binding Update List and responds with a BRA message. The BRA MUST
include the MNP(s) contained in the BRI."

		Also, Mobile network Prefix should be addes as valid
option in section "6.2. Binding Revocation Acknowledgement Message".

		BR 
		Desire

---

From: "fan zhao" <[email-masked]>
Date: Tue, 2 Dec 2008 13:41:56 -0800

Hi Behcet,

The binding revocation is designed for DSMIPv6 and DSMIPv6 supports
both mobile host
and mobile router. I do not see any issue.

Sincerely,
fan

On Tue, Dec 2, 2008 at 11:52 AM, Behcet Sarikaya
<[email-masked]> wrote:
> Hi Ahmad,
>   Can you please explain how MNP is related to your draft? MNP is something
> that MR needs and is specific to Nemo operation not to MN-HA relationship
> and the binding that comes with it.

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 2 Dec 2008 14:50:56 -0800 (PST)

Hi Fan,
  Prefix delegation/authorization function should take care of this. In DHCP PD there is a way to release the prefixes.

Regards,

Behcet

________________________________
From: fan zhao <[email-masked]>
To: Behcet Sarikaya <[email-masked]>
Cc: Ahmad Muhanna <[email-masked]>; [email-masked]
Sent: Tuesday, December 2, 2008 3:41:56 PM
Subject: Re: [MEXT] Binding Revocation for IPv6 Mobility Supports NEMO usecase

Hi Behcet,

Sincerely,
fan

---

From: "fan zhao" <[email-masked]>
Date: Tue, 2 Dec 2008 15:47:35 -0800

Hi Behcet,

There is a difference between binding revocation for MNPs and
MNP release.
When the binding revocation for MNPs is performed, the MNP
information stored in the binding cache entry for the MR is
removed, which means that the packets for such MNP will not
be tunneled by the HA; however, such MNP is not explicitly
released by the binding revocation. This is needed because
the mobile network nodes connecting to the MR before
may handover to their home network (such as wimax) while
the MR still stays in its foreign link (since for example the MR
does not have the wimax interface); therefore, such MNP
should still be made valid for such mobile network nodes.

To release such MNP, the same method to allocate the
MNP should be used. For example, if the MNP is allocated
by using DHCP, then DHCP needs to be used again to remove
such MNP. This is similar to the MIPv6 case where the MN
sends the BU with the lifetime=zero or the HA sends the BRI
to remove the binding, the home address on the other hand
needs to remove by deleting the IPsec SA if this is detach.

It makes sense to me using the BR to remove the MNP from
the BCE since such MNP is registered by using BU and
BR is the opposite way to BU.

Sincerely,
fan

On Tue, Dec 2, 2008 at 2:50 PM, Behcet Sarikaya
<[email-masked]> wrote:
> Hi Fan,
>   Prefix delegation/authorization function should take care of this. In DHCP
> PD there is a way to release the prefixes.
>
> Regards,
>
> Behcet
>
>> the
>> "6.2.

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 3 Dec 2008 09:59:51 -0800 (PST)

Sent: Tuesday, December 2, 2008 5:47:35 PM

Hi Behcet,

[behcet ] So it is the MR that knows thesituation and MR should initiate MNP release. Doing it with BR would be server-initiated which is something to be considered for prefix renumbering which has nothing to do with the release. 

Sincerely,
fan

---

From: "Ahmad Muhanna" <[email-masked]>
Date: Fri, 5 Dec 2008 09:02:10 -0600

Hi Behcet,
 
Just to clarify one thing here. It seems that we overlooked this use
case by not mentioning it in the draft.
Looking at the presentation that we made at IETF-70 and IETF-71 it
clearly list HA->MR as one of the usecases.
Since that was the basis for this draft that was adopted as a wg
document, I believe we need to include this in the draft.
 
Please find the Binding Revocation slides for IETF-70 & 71 at the below
links:
 
http://www.ietf.org/proceedings/08mar/slides/mext-9.pdf
http://www.ietf.org/proceedings/07dec/slides/mext-4.pdf

Regards, 
Ahmad 

	From: [email-masked] [mailto:[email-masked]] On
Behalf Of Behcet Sarikaya
	Sent: Wednesday, December 03, 2008 12:00 PM
	To: fan zhao
	Cc: [email-masked]
	Subject: Re: [MEXT] Binding Revocation for IPv6 Mobility
Supports NEMOusecase

	
	Hi Behcet,

	
	
	[behcet ] So it is the MR that knows the situation and MR should
initiate MNP release. Doing it with BR would be server-initiated which
is something to be considered for prefix renumbering which has nothing
to do with the release. 
	
	Sincerely,
	fan
	
	> PD there is a way to release the prefixes.
Supports NEMO
	> usecase
is something
	>>  So I don't see any binding to revocate with MNPs?
Supports NEMO
	>> usecase
functionality under
usecase?
related to NEMO.
	>> If used as is, the BRI will revoke the binding between the
MR's HoA and
	>> CoA.
	>> goal is to revoke the binding between the Mobile Router's HoA
and CoA. It
	>> is
	>> Network Prefixes assigned to the Mobile Router. In this case,
the HA sends
	>> a
	>> Revocation Trigger set to a proper value, e.g. Administrative
Reasons.
	>> When

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 5 Dec 2008 08:18:47 -0800 (PST)

Hi Ahmad,
  Currently your draft does not talk about Nemo. If you wish to include MR, I think it is easy: You can say that MIP6, DSMIP6 cases apply to MR acting as MN.
PMIP6 case also applies to MR acting as MR not as MAG.
BRI sending entity has to make sure that MNPs are removed from the binding cache before sending the revocation.

  Profiting the occasion, I found a few typos in your draft :

typos: sends a BRA message to the LMA following the rules describes
-->described
3.4.3.  Mobile Access Gateway Revoke Bulk PMIPv6 Bindings

-> Revokes

Regards,

Behcet

________________________________
From: Ahmad Muhanna <[email-masked]>
To: Behcet Sarikaya <[email-masked]>; fan zhao <[email-masked]>
Cc: [email-masked]
Sent: Friday, December 5, 2008 9:02:10 AM
Subject: RE: [MEXT] Binding Revocation for IPv6 Mobility Supports NEMOusecase

Hi 
Behcet,
 
Just 
to clarify one thing here. It seems that we overlooked this use case by not 
mentioning it in the draft.
Looking at the presentation that we made at IETF-70 and IETF-71 it 
clearly list HA->MR as one of the usecases.
Since 
that was the basis for this draft that was adopted as a wg document, I believe 
we need to include this in the draft.
 
Please 
find the Binding Revocation slides for IETF-70 & 71 at the below 
links:

________________________________
 From: [email-masked]  [mailto:[email-masked]] On Behalf Of Behcet  Sarikaya
Sent: Wednesday, December 03, 2008 12:00 PM
To: fan zhao
Cc: [email-masked]
Subject: Re: [MEXT] Binding  Revocation for IPv6 Mobility Supports NEMOusecase

Hi Behcet,

Sincerely,
fan

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Mon, 15 Dec 2008 21:19:41 -0500

Hi Ahmad and others,

Its not clear what would cause the home agent to stop forwarding for a
particular mobile network prefix and revoke that prefix using a BRI
message. It can done, but is it really required?

If the mobile network prefix is assigned to the mobile router using
binding acknowledgement, then I can see the BRI message being used to
revoke a particular prefix. But if DHCP prefix delegation is used for
assigning the prefixes, does it make sense to the BRI message for
revoking a prefix?

Vijay  

> Behalf Of Ahmad Muhanna
> Sent: Monday, December 01, 2008 7:23 PM
> To: Desire Oulai; [email-masked]
> functionality under the HA and MN operations after the 
> conclusion of the WGLC..
>  
> revocation related to NEMO. If used as is, the BRI will 
> revoke the binding between the MR's HoA and CoA. I think it's 
> woth adding another level of revocation: revocation of Mobile 
> Network Prefixes. A HA may decide to stop forwarding data to 
> the CoA for certain MNPs and BR could be used for that. Here 
> is a proposed text for a new section:
> 
> procedure as MIPv6 if the goal is to revoke the binding 
> between the Mobile Router's HoA and CoA. It is also possible 
> to have finer granularity of revocation targeting the Mobile 
> the HA sends a BRI message including one or more MNP options 
> with the A bit set and the Revocation Trigger set to a proper 
> value, e.g. Administrative Reasons. When receiving this BRI, 
> the MR deletes the MNP(s) from the Prefix Information field 
> in the Binding Update List and responds with a BRA message. 
> The BRA MUST include the MNP(s) contained in the BRI."
>

---

From: "Desire Oulai" <[email-masked]>
Date: Tue, 16 Dec 2008 10:17:53 -0500

Hi Vijay,

 See inline!

BR

Desire

> From: Vijay Devarapalli [mailto:[email-masked]] 
> Sent: December 15, 2008 9:20 PM
> To: Ahmad Muhanna; Desire Oulai; [email-masked]
> Its not clear what would cause the home agent to stop 
> forwarding for a particular mobile network prefix and revoke 
> that prefix using a BRI message. It can done, but is it 
> really required?
[Desire]: An example could be that the HA want to assign an unused MNP
to another MR. Another possibility is that the HA want to stop serving
as a NEMO HA for the MR without stopping normal MIPv6 services for the
MR. In this case, the HA can revoke all the MNPs. 
> 
> If the mobile network prefix is assigned to the mobile router 
> using binding acknowledgement, then I can see the BRI message 
> being used to revoke a particular prefix. But if DHCP prefix 
> delegation is used for assigning the prefixes, does it make 
> sense to the BRI message for revoking a prefix?
[Desire]: I agree that using BRI for MNP revocation is more evident when
the MNP is assigned using BAck. However, there could be a case where
DHCP is used but the selected HA is not the DHCP server or delegating
router in case of PD. In this scenario, the HA can send the BRI to
revoke the MNP then the MN can start DHCP operation to release the
prefix. 
> > From: [email-masked] [mailto:[email-masked]] 
> On Behalf 
> > Of Ahmad Muhanna
> revocation related to 
> > options with the A bit set and the Revocation Trigger set 
> to a proper 
> > value, e.g. Administrative Reasons. When receiving this BRI, the MR 
> > deletes the MNP(s) from the Prefix Information field in the Binding 
> > Update List and responds with a BRA message.

---

From: "Vijay Devarapalli" <[email-masked]>
Date: Tue, 16 Dec 2008 11:55:06 -0500

Hi Desire, 

> forwarding for a 

> [Desire]: An example could be that the HA want to assign an 
> unused MNP to another MR. 

Unused MNP? Once a MNP is allocted to the mobile router, it is free to
use it as it wants. There is no such thing as an unued NMP. The home
agent does not re-cycle that.

> Another possibility is that the HA 
> want to stop serving as a NEMO HA for the MR without stopping 
> normal MIPv6 services for the MR. In this case, the HA can 
> revoke all the MNPs. 

Switching from NEMO HA to MIPv6 HA shouldn't be allowed. If this
happens, the mobile router should be forced to bootstrap an appropriate
HA again.  Not force the mobile router to operate as a mobile node.

Vijay

> [Desire]: I agree that using BRI for MNP revocation is more 
> evident when the MNP is assigned using BAck. However, there 
> could be a case where DHCP is used but the selected HA is not 
> the DHCP server or delegating router in case of PD. In this 
> scenario, the HA can send the BRI to revoke the MNP then the 
> MN can start DHCP operation to release the prefix.
> > 
> > Vijay
> > 
> functionality