Subject: Re: RE: Re: [MIPSHOP-MIH-DT] Work items breakdown

From: Heejin Jang <[email-masked]>
Date: Mon, 25 Jun 2007 11:11:51 +0000 (GMT)

Hi, Sam.
See my inline. 

------- Original Message -------
Sender : sam xia<[email-masked]>
Date   : 2007-06-22 18:11
Title  : RE: Re: [MIPSHOP-MIH-DT] Work items breakdown

Hi heejin,

see my comments inline.

Hi. folks
At least I think that the following cases need to be supported in section 3.
Is there any other case to be covered?

In MIH Function discovery;

case 1) The node A discovers the transport address of MIHF entity based on
MIHF ID of node B (MIH Function discovery) 
Sam> What's MIHF ID? MIHF ID can be used to help discovery transport
address?
           I agree. but I doubt.

case 2) The node A discovers the transport address(es) of the available MIHF
entities through L3 broadcast (actually multicast such as DHCPv6).
In this case, the capabilities (IS/ES/CS) can be discovered as well. (MIH
Function discovery). 

SAM>I do agree DHCP can be used to discovery transport address. How to
generate MIHF ID for this transport address?
         As i know,  there are more than several hundred capabilities for
IS/ES/CS. Do you think that we should register them in DHCP server or else?

Heejin> Here I didn't mean that DHCPv6 can be used though it can be. 
What I meant is L3 broadcast discovery can be actually "multicasted" such as DHCPv6 discovery. 
(In IPv6 sense, the terminology 'multicast' covers 'broadcast' as well). 
And It is not necessary to register capabilities in the server, but at least the replying MIHF entities 
need to reply with the available services (IS/ES/CS) it can provide.
Otherwise, the node A which wants to contact the IS server cannot find the proper one.

In MIH Capability discovery;

case 3) The node A discovers the capabilities (IS/ES/CS) of the node B based
on MIHF ID (which needs to be resolved to the transport address through MIH
Function discovery) or transport address of the node B.

I do agree.

In MIH Capability & Function discovery at the same time

case 4) The node A discovers the MIHF entity which has ability to provide
the specific capabilies (IS/ES/CS) it wants to be served.
I agree.

I don't think that MIH capability discovery need to be de-coupled with MIH
function discovery but MIH capability discovery should be performed after
MIH function discovery or concurrently.

Sam> I doubt. Should we support capability discovery in transport stratum?
Even we have a lot of choice, why not to select the best one?  
            What &#39;s the sequence of messages for MIHF management service? My
real question is that who is prior to who between capability discovery and
authentication.

- Regards,
Heejin.

------- Original Message -------
Sender : Subir Das<[email-masked]>
Date   : 2007-06-22 07:19
Title  : Re: [MIPSHOP-MIH-DT] Work items breakdown

I sent a detailed mail and hopefully that will clarify things. I have quoted
from your earlier mail on service discovery. As long as MIH peer node
discovery is service discovery, I am fine. Yes, let&&#35;39;s use the .21
terminology for the time being. In .21, it is called MIH Function discovery.

-Subir

sam xia wrote:
> Sorry, I don&&#35;39;t understand your question. Maybe we should form the 
> consistent terminology. Let us the terminology defined in .21.
> Once again, my understanding is that what we are discovering in the 
> transportation stratum is equal to MIHF function discovery specified in
.21.
>
> BTW, in my last mail, service discovery is equal to MIH node discovery 
> just as your said(also equal to MIHF function discovery).
> I don&&#35;39;t know what the sentence means(MIH services discovery is 
> capability discovery).
>
>
> BestRegards;
> Sam(Zhongqi)Xia;
> -----Original Message-----
> From: Subir Das [mailto:[email-masked]]
> Sent: Friday, June 22, 2007 5:15 AM
> To: sam xia
> Cc: [email-masked]; [email-masked]
> Subject: Re: [MIPSHOP-MIH-DT] Work items breakdown
>
> That means you are saying MIH node discovery is service discovery and 
> MIH services discovery is capability discovery. Am I correct?
>
> -Subir
>
> sam xia wrote:
>   
>> hi Subir and John,
>> My understanding is that service discovering is equal to MIHF 
>> function discovery specified in .21. And capability discovery is 
>> specified in .21. The difference between them is apparent. Service 
>> discovery means to discover the MIHF entities in the network.
>> From the perspective of MIHF protocol, what to be discovered is MIHF 
>> ID; but the MIHF ID is unuseful for transport protocol. So, from the 
>> perspective of transport protocol, what to be discovered is transport 
>> address.
>> In order to scale our designing, i don&&#35;39;t think that it is good to 
>> support capability discovery in the transportation stratum. My 
>> understanding is that capability discovering is just a talking 
>> between two MIHF entitis. And apparently, service discovery is not. 
>> On the other hand, if we save the capability of MIHF to othter 
>> database than MIHF entity itself, we can do capability discovery just 
>> as service discovering. But what about its scalability?
>>
>> BestRegards;
>> Sam(Zhongqi)Xia;
>>
>>
>> ---------------------------------------------------------------------
>> -
>> --
>> *From:* [email-masked] [mailto:[email-masked]]
>> *Sent:* Friday, June 22, 2007 2:42 AM
>> *To:* [email-masked]; [email-masked]
>> *Cc:* [email-masked]; [email-masked]
>> *Subject:* RE: [MIPSHOP-MIH-DT] Work items breakdown
>>
>> I agree with Subir here. We need to discuss discovery a little more, 
>> breaking it down so we can understand what functions are done where.
>> Perhaps someone can breakdown discovery a bit, like I did for 
>> security. I can try to do this tomorrow, if noone else does.
>>
>> john
>>
>> This Message Sent by Nokia Intellisync Mobile Suite.
>> -----Original Message-----
>> From: ext Subir Das
>> Sent: 21/06/2007 6:36:39 PM
>> To: ext Subir Das;sam xia
>> Cc: Loughney John (Nokia-NRC/PaloAlto);[email-masked]
>> Subject: Re: [MIPSHOP-MIH-DT] Work items breakdown
>>
>>
>> I am little bit confused here. Without a transport protocol, MoS or 
>> MIHF protocol can not function. Now what are we discovering? Even if 
>> we discover transport address that is meant for MoS or MIHF protocol.
>> So essentially, we are discovering MIHF transport address. So I do 
>> not understand the separation. Also what do you mean by service
discovery?
>> What is the difference between service and capability discovery?
>>
>> -Subir
>>
>> sam xia wrote:
>>     
>>> One thing is to decouple the transportation protocol from the MIHF
>>>       
>> protocol.
>>     
>>> Otherwise, the transportation protocol needs to read the content of
>>>       
>> payload
>>     
>>> to be transported.
>>> the other is that capability discovery require a sesscion between
>>>       
>> MIHF peers
>>     
>>> while service discovery does not, unless that we save the capability
>>>       
>> of MIHF
>>     
>>> into another database other than MIHF peer itself.
>>>
>>>
>>> BestRegards;
>>> Sam(Zhongqi)Xia;
>>> -----Original Message-----
>>> From: [email-masked] [mailto:[email-masked]]
>>> Sent: Thursday, June 21, 2007 11:30 PM
>>> To: [email-masked]; [email-masked]
>>> Cc: [email-masked]
>>> Subject: RE: [MIPSHOP-MIH-DT] Work items breakdown
>>>
>>> Sam,
>>>
>>>
>>>       
>>>> yes. we need to discover MIHF ID and transport address.
>>>> And i think the capability discovering should be performed by MIHF 
>>>> protocol itself, not by the transportation protocol.
>>>>
>>>>         
>>> Just out of curiousity, can you explain why you think it should be
>>>       
>> done by
>>     
>>> the protocol?
>>>
>>> John
>>>
>>>       

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: "sam xia" <[email-masked]>
Date: Wed, 27 Jun 2007 00:04:05 +0800

hi heejin, 

BestRegards;
Sam(Zhongqi)Xia;
-----Original Message-----
From: Heejin Jang [mailto:[email-masked]] 
Sent: Monday, June 25, 2007 7:12 PM
To: sam xia
Cc: 'Subir Das'; [email-masked]
Subject: Re: RE: Re: [MIPSHOP-MIH-DT] Work items breakdown

Hi, Sam.
See my inline. 

------- Original Message -------

Hi heejin,

see my comments inline.

Hi. folks

Heejin> Here I didn't mean that DHCPv6 can be used though it can be. 
What I meant is L3 broadcast discovery can be actually "multicasted" such as
DHCPv6 discovery. 
(In IPv6 sense, the terminology 'multicast' covers 'broadcast' as well). 
And It is not necessary to register capabilities in the server, but at least
the replying MIHF entities need to reply with the available services
(IS/ES/CS) it can provide.
Otherwise, the node A which wants to contact the IS server cannot find the
proper one.

SAM> I am fine.

I do agree.

Sam> I doubt. Should we support capability discovery in transport stratum?
Even we have a lot of choice, why not to select the best one?  
            What &#39;s the sequence of messages for MIHF management
service? My real question is that who is prior to who between capability
discovery and authentication.

- Regards,
Heejin.

------- Original Message -------

-Subir

sam xia wrote:
> Sorry, I don&&#35;39;t understand your question. Maybe we should form 
> the consistent terminology. Let us the terminology defined in .21.
.21.
>> In order to scale our designing, i don&&#35;39;t think that it is 
>> good to support capability discovery in the transportation stratum. 
>> My understanding is that capability discovering is just a talking 
discovery?