Subject: Re: RE: [MIPSHOP-MIH-DT] Work items breakdown

From: Heejin Jang <[email-masked]>
Date: Fri, 22 Jun 2007 05:35:57 +0000 (GMT)

Sam, Service discovery seems to be somewhat confusing terminology.
In 21 spec, there are MIH Function discovery & MIH Capability discovery and they are defined cleary as follows.
 
"MIH Function discovery can acquire a list of peers that support the MIH Function.
In certain instances, the MIH node may have a pre-configured peer. In order to know the
services that are supported by an MIH peer, the MIH node performs MIH Capability discovery." (sec 6.1)
....
"MIH capability discovery is used by an MIHF entity to discovery the peer MIHF's capability
in terms of MIH services (ES, CS, IS)" (sec 6.1.4)
  
I think there is no room to be confused here.
 
- Regards, 
Heejin.

------- Original Message -------
Sender : sam xia<[email-masked]>
Date   : 2007-06-22 06:29
Title  : RE: [MIPSHOP-MIH-DT] Work items breakdown

Sorry, I don&#39;t understand your question. Maybe we should form the consistent
terminology. Let us the terminology defined in .21.
Once again, my understanding is that what we are discovering in the
transportation stratum is equal to MIHF function discovery specified in .21.

BTW, in my last mail, service discovery is equal to MIH node discovery just
as your said(also equal to MIHF function discovery).
I don&#39;t know what the sentence means(MIH services discovery is capability
discovery).

BestRegards;
Sam(Zhongqi)Xia;
-----Original Message-----
From: Subir Das [mailto:[email-masked]] 
Sent: Friday, June 22, 2007 5:15 AM
To: sam xia
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Work items breakdown

That means you are saying MIH node discovery is service discovery and MIH
services discovery is capability discovery. Am I correct?

-Subir

sam xia wrote:
> hi Subir and John,
> My understanding is that service discovering is equal to MIHF function 
> discovery specified in .21. And capability discovery is specified in 
> .21. The difference between them is apparent. Service discovery means 
> to discover the MIHF entities in the network.
> From the perspective of MIHF protocol, what to be discovered is MIHF 
> ID; but the MIHF ID is unuseful for transport protocol. So, from the 
> perspective of transport protocol, what to be discovered is transport 
> address.
> In order to scale our designing, i don&#39;t think that it is good to 
> support capability discovery in the transportation stratum. My 
> understanding is that capability discovering is just a talking between 
> two MIHF entitis. And apparently, service discovery is not. On the 
> other hand, if we save the capability of MIHF to othter database than 
> MIHF entity itself, we can do capability discovery just as service 
> discovering. But what about its scalability?
>
> BestRegards;
> Sam(Zhongqi)Xia;
>
>
> ----------------------------------------------------------------------
> --
> *From:* [email-masked] [mailto:[email-masked]]
> *Sent:* Friday, June 22, 2007 2:42 AM
> *To:* [email-masked]; [email-masked]
> *Cc:* [email-masked]; [email-masked]
> *Subject:* RE: [MIPSHOP-MIH-DT] Work items breakdown
>
> I agree with Subir here. We need to discuss discovery a little more, 
> breaking it down so we can understand what functions are done where.
> Perhaps someone can breakdown discovery a bit, like I did for 
> security. I can try to do this tomorrow, if noone else does.
>
> john
>
> This Message Sent by Nokia Intellisync Mobile Suite.
> -----Original Message-----
> From: ext Subir Das
> Sent: 21/06/2007 6:36:39 PM
> To: ext Subir Das;sam xia
> Cc: Loughney John (Nokia-NRC/PaloAlto);[email-masked]
> Subject: Re: [MIPSHOP-MIH-DT] Work items breakdown
>
>
> I am little bit confused here. Without a transport protocol, MoS or 
> MIHF protocol can not function. Now what are we discovering? Even if 
> we discover transport address that is meant for MoS or MIHF protocol. 
> So essentially, we are discovering MIHF transport address. So I do not 
> understand the separation. Also what do you mean by service discovery?
> What is the difference between service and capability discovery?
>
> -Subir
>
> sam xia wrote:
> > One thing is to decouple the transportation protocol from the MIHF
> protocol.
> > Otherwise, the transportation protocol needs to read the content of
> payload
> > to be transported.
> > the other is that capability discovery require a sesscion between
> MIHF peers
> > while service discovery does not, unless that we save the capability
> of MIHF
> > into another database other than MIHF peer itself.
> >
> >
> > BestRegards;
> > Sam(Zhongqi)Xia;
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Thursday, June 21, 2007 11:30 PM
> > To: [email-masked]; [email-masked]
> > Cc: [email-masked]
> > Subject: RE: [MIPSHOP-MIH-DT] Work items breakdown
> >
> > Sam,
> >
> >
> >> yes. we need to discover MIHF ID and transport address.
> >> And i think the capability discovering should be performed by MIHF 
> >> protocol itself, not by the transportation protocol.
> >>
> >
> > Just out of curiousity, can you explain why you think it should be
> done by
> > the protocol?
> >
> > John
> >
>

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: "sam xia" <[email-masked]>
Date: Fri, 22 Jun 2007 16:54:54 +0800

BestRegards;
Sam(Zhongqi)Xia;
-----Original Message-----
From: Heejin Jang [mailto:[email-masked]] 
Sent: Friday, June 22, 2007 1:36 PM
To: sam xia
Cc: 'Subir Das'; [email-masked]
Subject: Re: RE: [MIPSHOP-MIH-DT] Work items breakdown

Sam, Service discovery seems to be somewhat confusing terminology.
In 21 spec, there are MIH Function discovery & MIH Capability discovery and
they are defined cleary as follows.
 
"MIH Function discovery can acquire a list of peers that support the MIH
Function.
In certain instances, the MIH node may have a pre-configured peer. In order
to know the services that are supported by an MIH peer, the MIH node
performs MIH Capability discovery." (sec 6.1) ....
"MIH capability discovery is used by an MIHF entity to discovery the peer
MIHF's capability in terms of MIH services (ES, CS, IS)" (sec 6.1.4)

Sam> sorry that I bring some confusion to guys.  :-(
 
- Regards,
Heejin.

------- Original Message -------

Sorry, I don&#39;t understand your question. Maybe we should form the
consistent terminology. Let us the terminology defined in .21.
Once again, my understanding is that what we are discovering in the
transportation stratum is equal to MIHF function discovery specified in .21.

BTW, in my last mail, service discovery is equal to MIH node discovery just
as your said(also equal to MIHF function discovery).
I don&#39;t know what the sentence means(MIH services discovery is
capability discovery).

BestRegards;
Sam(Zhongqi)Xia;
-----Original Message-----
From: Subir Das [mailto:[email-masked]]
Sent: Friday, June 22, 2007 5:15 AM
To: sam xia
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Work items breakdown

-Subir