Subject: [MIPSHOP-MIH-DT] Input for tomorrow

From: Telemaco Melia <[email-masked]>
Date: Thu, 26 Jul 2007 00:02:54 +0200

Guys,

Please carefully consider the list of issues and let's be constructive during tomorrow's wrap up session.
Bear in mind that we need to go back home with well identified tasks and fixed deadlines. The chair today was
very firm on the proposed time line.

Comment asap.

Cheers,
Tele 

Issues list
===========

+ Transport:

- Discussion with Nada on which scenarios they should consider/simulate. We agreed that TCP +.21 w/o ACK and UDP + .21 ACK 
are the 2 options to be considered. (This was also discussed with transport area people)
- Identified metrics to take a decision are: congestion control, latency, TCP over wireless and link diversity, setup time, 
location of the MoS
- This input should be given to Nada's team to investigate 
- Identify possibilities, and eventually to mandate a solution (this point has to be clarified and agreed by all)

+ Discovery

- The assumption is that the scenarios in the slides have to be addressed (agreement on whether we should support discovery of MoS3 while @home?)
- Recommend extensions/options for DHCP and DNS
	o for DHCP seems reasonable to provide an option for the MIH domain name (port and transport protocol not being options)
	o for DNS (SRV or NAPTR?) need to specify tag(s) (clarify if we want to distinguish multiple services or not e.g. IS, ES, CS or simple MIH)

Time line
=========
It seems appropriate to produce a -00 version in August. The chairs are strongly pushing for it.

Structure of the doc
=====================
We proposed a first TOC. We need to agree and comment the proposal.
To make things easier at the beginning I would like to produce a document with all included. 
We can decide later if we need to split and if yes how.

Admin
======
Schedule AC every 1/2 week. Who can offer a bridge?
Assign sections during the wrap up session and decide next deadlines.

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: <[email-masked]>
Date: Wed, 25 Jul 2007 19:14:27 -0500

Regarding transport:

I do not think mandating a transport is the right way forward. I could
certainly see .21 mandating the use of ack with udp (and no ack for tcp)
and writing an informational_doc/guideline pointing to pros and cons of
using mih with each transport. But let the mih service providers to
decide which transport to use (and provision dns accordingly). This is
in line with how transport for other applications is currently defined.

I think we need to come up with the following documents:
- dns service tag definition and usage
- mih transport considerations
- dhcp options

 gabor

-----Original Message-----
From: ext Telemaco Melia [mailto:[email-masked]] 
Sent: Wednesday, July 25, 2007 3:03 PM
To: [email-masked]
Subject: [MIPSHOP-MIH-DT] Input for tomorrow

Guys,

Please carefully consider the list of issues and let's be constructive
during tomorrow's wrap up session.
Bear in mind that we need to go back home with well identified tasks and
fixed deadlines. The chair today was very firm on the proposed time
line.

Comment asap.

Cheers,
Tele 

Issues list
===========

+ Transport:

- Discussion with Nada on which scenarios they should consider/simulate.
We agreed that TCP +.21 w/o ACK and UDP + .21 ACK are the 2 options to
be considered. (This was also discussed with transport area people)
- Identified metrics to take a decision are: congestion control,
latency, TCP over wireless and link diversity, setup time, location of
the MoS
- This input should be given to Nada's team to investigate
- Identify possibilities, and eventually to mandate a solution (this
point has to be clarified and agreed by all)

+ Discovery

- The assumption is that the scenarios in the slides have to be
addressed (agreement on whether we should support discovery of MoS3
while @home?)
- Recommend extensions/options for DHCP and DNS
	o for DHCP seems reasonable to provide an option for the MIH
domain name (port and transport protocol not being options)
	o for DNS (SRV or NAPTR?) need to specify tag(s) (clarify if we
want to distinguish multiple services or not e.g. IS, ES, CS or simple
MIH)

Time line
=========
It seems appropriate to produce a -00 version in August. The chairs are
strongly pushing for it.

Structure of the doc
=====================
We proposed a first TOC. We need to agree and comment the proposal.
To make things easier at the beginning I would like to produce a
document with all included. 
We can decide later if we need to split and if yes how.

Admin
======