Subject: [MIPSHOP-MIH-DT] RE: [802.21] IETF MIPSHOP MIH L3 transport - Internet draft

From: <[email-masked]>
Date: Tue, 25 Sep 2007 20:27:17 -0500

While comments are welcome, I think we have received enough comments to
generate a new version. 

So, I propose: 
1) that we look for a new terminology which would replace MoS.
2) point out that scenario 4 applies only to IS. This is easy
3) we get rid of 5.3 and fall back to the original approach, i.e. that
there is one discovery approach when MN wants an MoS at home, another
one when it wants an MoS in the visited and then scenario 4
Here we can also think of some text on how should the MN decide whether
it wants to use an MoS at home or in visited (scenario 4 is again
special, and applies only to IS anyways)
4) security: change recommend to MUST and add some more reasoning why we
mandate TSL and DTLS instead of anything else (middlebox traversal is
good enough reason)
5) we mandate one protocol at the server side, but allow other
transports, which can be discovered using DNS (if I captured the
comments right)
6) clarify the rate of ES/CS messages

I can handle 3) and maybe 5). I guess Subir can do 4) and Nada 6)
Anyone else interested in proposing text to any of the points?

It would be good if we could generate a new version within a week or so.

- gabor

-----Original Message-----
From: ext Zuniga, Juan Carlos
[mailto:[email-masked]] 
Sent: Tuesday, September 25, 2007 1:59 PM
To: [email-masked]
Subject: [802.21] IETF MIPSHOP MIH L3 transport - Internet draft

Hello guys,

As Gabor mentioned in his presentation last week in the 802.21 meeting,
the MIPSHOP MIH Transport Design Team has just produced a first draft
for the solution of the L3 transport of the 802.21 MIH protocol.

Please take a look at the document and provide your comments on both
IEEE 802.21 and IETF MIPSHOP lists so that we can move forward in having
a final solution.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-melia-mipshop-mstp-solution-00
.txt

Best regards,

Jc

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: Sam Xia <[email-masked]>
Date: Wed, 26 Sep 2007 10:01:22 +0800

> 1) that we look for a new terminology which would replace MoS.

Updating MoS using an alternative should be a serious thing.   If we do it,
we have to update [PS] which has alread been WG draft.  I think that we have
to wait for reply from Tele and mipshop chairs. And I remember that [PS] has
been sent to IESG for reviewing.  Please be careful.

> 3) we get rid of 5.3 and fall back to the original approach, 
> i.e. that there is one discovery approach when MN wants an 
> MoS at home, another one when it wants an MoS in the visited 
> and then scenario 4 Here we can also think of some text on 
> how should the MN decide whether it wants to use an MoS at 
> home or in visited (scenario 4 is again special, and applies 
> only to IS anyways)
> 4) security: change recommend to MUST and add some more 
> reasoning why we mandate TSL and DTLS instead of anything 
> else (middlebox traversal is good enough reason)
> 5) we mandate one protocol at the server side, but allow 
> other transports, which can be discovered using DNS (if I 
> captured the comments right)
> I can handle 3) and maybe 5). I guess Subir can do 4) and 
> Nada 6) Anyone else interested in proposing text to any of the points?
> 
> As Gabor mentioned in his presentation last week in the 
> 802.21 meeting, the MIPSHOP MIH Transport Design Team has 
> just produced a first draft for the solution of the L3 
> transport of the 802.21 MIH protocol.
> 
> Please take a look at the document and provide your comments 
> on both IEEE 802.21 and IETF MIPSHOP lists so that we can 
> move forward in having a final solution.
>

---

From: Subir Das <[email-masked]>
Date: Thu, 27 Sep 2007 00:00:36 -0400

Yes, we can start updating the document. However, I would prefer to wait 
for a few
days regarding terminology issue (as Sam mentioned) and bootstrapping 
one. Let's
have some more discussions on these topics.

I can take care of security section.

-Subir

---

From: <[email-masked]>
Date: Wed, 26 Sep 2007 23:55:17 -0500

Yes, the terminology is tricky. Mobility_service/mobility_server are
overloaded terms, they are used in the integrated/split scenario drafts,
but mean different thing. Handover server might be more appropriate. The
fact that nobody commented this while the ps draft was in wglc shows the
interest in mipshop towards mih transport :)

- gabor

-----Original Message-----
From: ext Subir Das [mailto:[email-masked]] 
Sent: Wednesday, September 26, 2007 9:01 PM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] RE: [802.21] IETF MIPSHOP MIH L3 transport
- Internet draft

Yes, we can start updating the document. However, I would prefer to wait
for a few days regarding terminology issue (as Sam mentioned) and
bootstrapping one. Let's have some more discussions on these topics.

-Subir

[email-masked] wrote:
> While comments are welcome, I think we have received enough comments 
> to generate a new version.
>
> So, I propose: 

> one when it wants an MoS in the visited and then scenario 4 Here we 
> can also think of some text on how should the MN decide whether it 
> wants to use an MoS at home or in visited (scenario 4 is again 
> 4) security: change recommend to MUST and add some more reasoning why 
> we mandate TSL and DTLS instead of anything else (middlebox traversal 
> is good enough reason)
> As Gabor mentioned in his presentation last week in the 802.21 
> meeting, the MIPSHOP MIH Transport Design Team has just produced a 
> first draft for the solution of the L3 transport of the 802.21 MIH
protocol.
> IEEE 802.21 and IETF MIPSHOP lists so that we can move forward in 
> having a final solution.
>

---

From: Sam Xia <[email-masked]>
Date: Thu, 27 Sep 2007 14:25:05 +0800

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Thursday, September 27, 2007 12:55 PM
> To: [email-masked]
> Subject: RE: [MIPSHOP-MIH-DT] RE: [802.21] IETF MIPSHOP MIH 
> L3 transport -Internet draft
> 
> Yes, the terminology is tricky. 
> Mobility_service/mobility_server are overloaded terms, they 
> are used in the integrated/split scenario drafts, but mean 
> different thing. 

Yes, in both drafts, "mobility service" is used which is different.   Why
MUST the terminoligy be modified, even it is not very good, but it is ok?

>Handover server might be more appropriate. 
> The fact that nobody commented this while the ps draft was in 
> wglc shows the interest in mipshop towards mih transport :)
> 
> - gabor
> 
> Yes, we can start updating the document. However, I would 
> prefer to wait for a few days regarding terminology issue (as 
> Sam mentioned) and bootstrapping one. Let's have some more 
> discussions on these topics.
> 
> reasoning why

---

From: Telemaco Melia <[email-masked]>
Date: Thu, 27 Sep 2007 10:16:39 +0200

Hi guys,

Of course we can update the document and produce soon a new version. 
However, I would support Subir's suggestion
and fix the terminology and bootstrapping issue.
Do you think having an AC would help?

Sam, where did you get the information that the PS draft was sent to the 
IESG for review?
Maybe Stefano could say something about this.

tele
Subir Das wrote:
> Yes, we can start updating the document. However, I would prefer to 
> wait for a few
>> So, I propose: 1) that we look for a new terminology which would 
>> replace MoS.
>> [mailto:[email-masked]] Sent: Tuesday, September 
>> 25, 2007 1:59 PM

-- 
Dr. Telemaco Melia			[email-masked]
Senior Research Staff Member		Tel: +49 (0) 6221 4342- 142
NEC Europe Ltd.
NEC Laboratories Europe
Network Division			
Kurfürsten-Anlage 36		
69115 Heidelberg
GERMANY	  

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Sam Xia <[email-masked]>
Date: Thu, 27 Sep 2007 16:42:12 +0800

> However, I would support Subir's suggestion and fix the 
> terminology and bootstrapping issue.
> Sam, where did you get the information that the PS draft was 
> sent to the IESG for review?

Sam>  I remember that Viday said this will be done soon.  

> reasoning why we
> 802.21 meeting,
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria 
> Road, London W3 6BL | Registered in England 2832014 
> 
>

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Thu, 27 Sep 2007 13:55:11 -0400

Gabor, all,

Here are some inputs for points 5) and 6)

[JCZ] Yoshi's concern was that "having multiple mandatory protocols
(e.g., one reliable transport and one unreliable transport) on the PoS
side and having no mandatory protocol on the MN side could support wider
deployment scenarios while still providing interoperability." Hence, he
is suggesting mandating for instance TCP and UDP at the server side, and
not mandating anything at the MN side. We can still allow other
transports that can be discovered via DNS, but that is besides the
point.

[JCZ] I verified with our design team and the rate would be in average
about 1 sec, with peaks at 250 ms (so up to 250 ms).

Jc

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: September 25, 2007 9:27 PM
To: Zuniga, Juan Carlos
Cc: [email-masked]
Subject: RE: [802.21] IETF MIPSHOP MIH L3 transport - Internet draft

So, I propose: 

- gabor

-----Original Message-----

Hello guys,

Best regards,

Jc

---

From: Nada Golmie <[email-masked]>
Date: Thu, 27 Sep 2007 14:30:25 -0400

Hello All,

> transports that can be discovered via DNS, but that is besides the
That does sound like a good idea....
> about 1 sec, with peaks at 250 ms (so up to 250 ms).
Looks like the statement of one ES/CS message in hundreds of 
milliseconds seems to be still OK - I did not mean exactly 100 ms but 
more like few hundreds of milliseconds. Sorry if that caused confusion ;-) 
Having said that I stand ready for any modifications that are deemed 
necessary.

-Nada