Subject: [MIPSHOP-MIH-DT] To be discussed in the AC -- section 5.x

From: Telemaco Melia <[email-masked]>
Date: Wed, 12 Sep 2007 15:16:53 +0200

[to be inserted before 5.1]

In case MoS assignment is provided locally (S1 and S2) [draft-gabor-dhcp] and [draft-gabor-dns] could be used to transfer 
MoS information from the network to the MN (via DHCP or DNS). In case MoS assignment is provided in the home while the 
MN is attached in visited (S3) an interaction between the DHCP and AAA infrastructure is required similarly to 
what specified in [draft-bootstrapping-integrated]. It is assumed therefore that MoS assignment is performed 
during access authentication and authorization.

[Note on the DHCP options defined in the bootstrapping integrated scenario]

I am not sure we can reuse completely the options specified in draft-ietf-mip6-hiopt-06:

o Home Network Identifier Option
This option is used to indicate the target home network requested by
the mobile node to the DHCP server.  The mobile node MUST include
this option along with its Option Request option in its request.

o MIP6 Relay Agent Option
This option carries the RADIUS or Diameter attributes that are
received at the NAS from the AAAH.  The DHCP relay agent sends this
option to the DHCP server in the Relay-Forward message.

o Home Network Information Option
This option is used to carry home network information to a mobile
node in the form of one or more of home subnet prefix(es), home agent
address(es) and home agent FQDN(s).

Gabor, what do you suggest? Update your document with similar content?

[Question/Doubt about 5.1]
We say that when the MN is attached in home it SHOULD use DNS since home domain are pre-configured in the MN.
Should we also talk about assignment? If yes then we should specify how to do it with both DNS (possible?) and 
DHCP. For DHCP we should then modify figure 6b to have an interface between DHCPrelay/NAS with the AAAh who is 
getting MN's profile and giving the MoS address via AAA to the DHCPrelay/NAS and further to the DHCP server.
In this way the scenario is consistent to figure 8.

[Question/Doubt about 5.2]
The recommentdation is that when the MN is in visited and it wants the MoS in visited it should use DHCP.
Again I guess something similar to the bootstrapping integrated scenario applies. In fact I would update figure
7a as we did for figure 6b.

[About 5.3]

Current text<<<<<
To discover an MoS in the roaming network when services are provided
by the home network MN SHOULD use the DHCP option along with network
access authnetication (e.g.  DHCP/AAA).  MN SHOULD use the dhcp
options for MoS discovery [I-D.bajko-mos-dhcp-options] immediately
after the network access authentication.  Figure 8 describes the such
a model.

Proposed text<<<<<<<<

To discover an MoS in the roaming network when services are provided
by the home network MN SHOULD use the DHCP option along with network
access authentication.

Upon network access authentication and interaction with the NAS the AAAh verifies in the AAA profile
that the MN is allowed to use the MoS in home. The AAAh assigns the MoS in the home and sends back the 
information to the NAS. MN sends a DHCP information request as per RFC3315 containing 
Home Network Identifier Option indicating the the need to allocate the MoS in the home.

The relay agent intercepts the Information request from the MN and it forwards to the DHCP server
inserting the MIP6 Relay Agent Option containing the info received by the AAAh. The DHCP server can then 
reply to the MN by sending the Home Network Information Option. The MN receives the HA address.
It should be noted that the AAAh does not know what are the preferences of the MN, i.e. whether the MoS
should be allocated in the home or in visited. The MoS info is stored at the relay agent and forwarded 
to the MN according to the flags in the Home Network Identifier Option. Figure 8 describe such a model.

cheers
tele

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: Subir Das <[email-masked]>
Date: Wed, 12 Sep 2007 09:52:54 -0400

Resending it again since forgot to copy all the DT members.

I personally think that we should allow the integrated scenario since 
this is not only a practical scenario,
but it has a few advantages. I would like to hear Gabor's opinion as 
well. Some responses below.

-Subir

-Subir

Telemaco Melia wrote:
> In case MoS assignment is provided locally (S1 and S2) 
> [draft-gabor-dhcp] and [draft-gabor-dns] could be used to transfer MoS 
> information from the network to the MN (via DHCP or DNS). In case MoS 
> assignment is provided in the home while the MN is attached in visited 
> (S3) an interaction between the DHCP and AAA infrastructure is 
> required similarly to what specified in 
> [draft-bootstrapping-integrated]. It is assumed therefore that MoS 
> assignment is performed during access authentication and authorization.
>

SD>     I would think we can use the same framework and refer to the 
above draft. But we need to
   define them in our context. This way folks in DHCP and AAA will 
realize that we are not
   proposing anything completely new.

> option to the DHCP server in the Relay-Forward message.
    SD> This should be MIH relay Agent Option
> address(es) and home agent FQDN(s).
    SD> This should include MoS address(es) and MOS FQDN (s).
> We say that when the MN is attached in home it SHOULD use DNS since 
> home domain are pre-configured in the MN.
> Should we also talk about assignment? If yes then we should specify 
> how to do it with both DNS (possible?) and DHCP. For DHCP we should 
> then modify figure 6b to have an interface between DHCPrelay/NAS with 
> the AAAh who is getting MN's profile and giving the MoS address via 
> AAA to the DHCPrelay/NAS and further to the DHCP server.
   SD> I did not get your point here. If it is pre-configured, it can 
happen in many ways. For example, over the air activation.
          Why do we need AAAh here? This is not an integrated scenario. 
Are you suggesting that we should show how
          DHCP server receives the information. DHCP server can be 
pre-configured manually, for example.
> Again I guess something similar to the bootstrapping integrated 
> scenario applies. In fact I would update figure
   SD> IMO, this is not necessary as long as we separate integrated 
scenario with the normal scenario.
> that the MN is allowed to use the MoS in home. The AAAh assigns the 
> MoS in the home and sends back the information to the NAS. MN sends a 
> DHCP information request as per RFC3315 containing Home Network 
> Identifier Option indicating the the need to allocate the MoS in the 
> home.
>
> inserting the MIP6 Relay Agent Option containing the info received by 
> the AAAh. The DHCP server can then reply to the MN by sending the Home 
> Network Information Option. The MN receives the HA address.
    SD> Replace "HA" with "MOS"

> It should be noted that the AAAh does not know what are the 
> preferences of the MN, i.e. whether the MoS
> should be allocated in the home or in visited. The MoS info is stored 
> at the relay agent and forwarded to the MN according to the flags in 
> the Home Network Identifier Option. Figure 8 describe such a model.
>
> cheers
> tele
>
>

---

From: <[email-masked]>
Date: Wed, 12 Sep 2007 09:51:37 -0500

I agree with Subir. We should allow the integrated scenario, but I still
feel we are not quite ready with the text yet.
And yes, we should use the same framework in our context.

I am still analysing the text provided by Tele, but 1-2 hours might not
be enough for me to conclude on it. I still think that leaving section
5.3 out from version -00 and take 2-3 weeks to work it out and submit a
version -01 would be the best.

- gabor 

-----Original Message-----
From: ext Subir Das [mailto:[email-masked]] 
Sent: Wednesday, September 12, 2007 6:53 AM
To: Telemaco Melia
Cc: [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] To be discussed in the AC -- section 5.x

I personally think that we should allow the integrated scenario since
this is not only a practical scenario, but it has a few advantages. I
would like to hear Gabor's opinion as well. Some responses below.

-Subir

-Subir

> the mobile node to the DHCP server.  The mobile node MUST include this

> option along with its Option Request option in its request.
>
> This option is used to carry home network information to a mobile node

> in the form of one or more of home subnet prefix(es), home agent
> The recommentdation is that when the MN is in visited and it wants the

> MoS in visited it should use DHCP.
> scenario applies. In fact I would update figure 7a as we did for 
> figure 6b.
> Upon network access authentication and interaction with the NAS the 
> AAAh verifies in the AAA profile that the MN is allowed to use the MoS

> in home. The AAAh assigns the MoS in the home and sends back the 
> information to the NAS. MN sends a DHCP information request as per 
> RFC3315 containing Home Network Identifier Option indicating the the 
> need to allocate the MoS in the home.
>
> The relay agent intercepts the Information request from the MN and it 
> forwards to the DHCP server inserting the MIP6 Relay Agent Option 
> containing the info received by the AAAh. The DHCP server can then 
> reply to the MN by sending the Home Network Information Option. The MN

> receives the HA address.

> preferences of the MN, i.e. whether the MoS should be allocated in the

> home or in visited. The MoS info is stored at the relay agent and 
> forwarded to the MN according to the flags in the Home Network 
> Identifier Option. Figure 8 describe such a model.
>
> cheers
> tele
>
>