Subject: [MIPSHOP-MIH-DT] [Fwd: New Version Notification for draft-melia-mipshop-mstp-solution-00]

From: Telemaco Melia <[email-masked]>
Date: Fri, 21 Sep 2007 12:10:59 +0200

tele

Subject: New Version Notification for draft-melia-mipshop-mstp-solution-00
From: IETF I-D Submission Tool <[email-masked]>
To: [email-masked]
Cc: [email-masked], [email-masked], [email-masked], [email-masked]
Date: Fri, 21 Sep 2007 06:04:56 -0400

A new version of I-D, draft-melia-mipshop-mstp-solution-00.txt has been successfuly submitted by Telemaco Melia and posted to the IETF repository.

Filename:	 draft-melia-mipshop-mstp-solution
Revision:	 00
Title:		 Mobility Services Transport Protocol Design
Creation_date:	 2007-09-18
WG ID:		 Independent Submission
Number_of_pages: 21

Abstract:
To be edited.

The IETF Secretariat.

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: <[email-masked]>
Date: Fri, 21 Sep 2007 15:01:19 -0500

Folks,

I talked to Srini about scenario 3 and we figured out one problem: at
network access authentication phase, the HAAA does not know if the MN
wants any MoS, and if yes, which one, thus why would it send it over to
the visited AAA. Also, once network access auth has happened and the MN
did not get an MoS address, it is not possible to discover MoS in home
without doing a network access auth. The main point, there is a
difference between requiring the address of an entity you need (HA) and
an optional one (MoS). The solution: after network access authentication
use DNS based discovery and forget about the integrated scenario
solution.

Comments?

- gabor

---

From: Sam Xia <[email-masked]>
Date: Mon, 24 Sep 2007 09:46:34 +0800

hi Gabor,
see my comments inline.
> 
> Folks,
> 
> I talked to Srini about scenario 3 and we figured out one 
> problem: at network access authentication phase, the HAAA 
> does not know if the MN wants any MoS, and if yes, which one, 
> thus why would it send it over to the visited AAA.

My understanding is that HAAA just pushes default MoS  informaiton for MN in
home network  to visisted AAA.  Do you mean that even MN is in home, maybe
MN uses MoS not provided by home network? or There are more than one MoS in
home network?  In both situations, HAAA just push default MoS information to
AAAV.
I agree with you that HAAA does not know which MoS is wanted by MN.   HAAA
just push default MoS information to AAAV, nothing more.  It's MN who makes
the final choice which MoS is selected. By the way, even the HAAA push the
default AAA to AAAV, it is very possbile that MN uses the other MoS, instead
of home one(s).

> Also, once 
> network access auth has happened and the MN did not get an 
> MoS address, it is not possible to discover MoS in home 
> without doing a network access auth. 

If MN did not get an MoS address of home (preferred) after network access
auth, MN SHOULD resort to the others(local MoS or the third party). It's not
necessary to inquiry home network again and again. What i want to express is
that the discovering procedure should be very flexible. One fails, the other
works. If all fails, MoS could not be gotten. Do you think that once MN uses
MoS in home, MN has always to use MoS in home ?

>The main point, there is 
> a difference between requiring the address of an entity you 
> need (HA) and an optional one (MoS). 

I think that i am more famliar with Mobile IP.  In fact, HA could be
deployed in both home and visited network. So the address of HA is optional
and uncertain. During the procedure of discovering HA adress, HAAA just push
HA address in home to AAAV. It is MN who makes the final choice(maybe MN
want to use local HA in visited network).

>The solution: after 
> network access authentication use DNS based discovery and 
> forget about the integrated scenario solution.

Personnel opinion:  if MoS(es) is(are) stable while MN is moving, DNS is
very good choice.  In the case MoS(es) is dynamic, DHCP is a good one.  When
MN is moving away from home,  it is usual for MoS to be changed from one
place to the other.

---

From: <[email-masked]>
Date: Mon, 24 Sep 2007 13:28:26 -0500

Inline: 

-----Original Message-----
From: ext Sam Xia [mailto:[email-masked]] 
Sent: Sunday, September 23, 2007 6:47 PM
To: Bajko Gabor (Nokia-SIR/MtView); [email-masked];
[email-masked]
Subject: RE: [MIPSHOP-MIH-DT] Scenario 3

hi Gabor,
see my comments inline.
> problem: at network access authentication phase, the HAAA does not 
> know if the MN wants any MoS, and if yes, which one, thus why would it

> send it over to the visited AAA.

My understanding is that HAAA just pushes default MoS  informaiton for
MN in home network  to visisted AAA.  Do you mean that even MN is in
home, maybe MN uses MoS not provided by home network? or There are more
than one MoS in home network?  In both situations, HAAA just push
default MoS information to AAAV.
I agree with you that HAAA does not know which MoS is wanted by MN.
HAAA
just push default MoS information to AAAV, nothing more.  It's MN who
makes the final choice which MoS is selected. By the way, even the HAAA
push the default AAA to AAAV, it is very possbile that MN uses the other
MoS, instead of home one(s).

<gabor> it is bad design to push that information without knowing if the
MN needs it or not.

> Also, once
> network access auth has happened and the MN did not get an MoS 
> address, it is not possible to discover MoS in home without doing a 
> network access auth.

If MN did not get an MoS address of home (preferred) after network
access auth, MN SHOULD resort to the others(local MoS or the third
party). It's not necessary to inquiry home network again and again. What
i want to express is that the discovering procedure should be very
flexible. One fails, the other works. If all fails, MoS could not be
gotten. Do you think that once MN uses MoS in home, MN has always to use
MoS in home ?

>The main point, there is
> a difference between requiring the address of an entity you  need (HA)

>and an optional one (MoS).

I think that i am more famliar with Mobile IP.

<gabor> glad to hear that.

In fact, HA could be deployed in both home and visited network. So the
address of HA is optional and uncertain. During the procedure of
discovering HA adress, HAAA just push HA address in home to AAAV. It is
MN who makes the final choice(maybe MN want to use local HA in visited
network).

<gabor> the thing is, that the MN always needs an HA, whether at home or
in visited. The same is not true for MoS.

>The solution: after
> network access authentication use DNS based discovery and  forget 
>about the integrated scenario solution.

Personnel opinion:  if MoS(es) is(are) stable while MN is moving, DNS is
very good choice.  In the case MoS(es) is dynamic, DHCP is a good one.
When MN is moving away from home,  it is usual for MoS to be changed
from one place to the other.

<gabor> we have both the DNS and DHCP options. But involving AAA infra
to send MoS address to the DHCP/NAS in the visited network is not
necessary, it is needless. So, we merge back section 5.3 with section
5.1 and use DNS based discovery regardless whether the MN is at home or
visiting. What matters is that the MN wants to discover MoS at home.

- gabor

---

From: Sam Xia <[email-masked]>
Date: Tue, 25 Sep 2007 10:08:28 +0800

inline

 Best Regards, Sam Xia 

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Tuesday, September 25, 2007 2:28 AM
> To: [email-masked]; [email-masked]; [email-masked]
> My understanding is that HAAA just pushes default MoS  
> informaiton for MN in home network  to visisted AAA.  Do you 
> mean that even MN is in home, maybe MN uses MoS not provided 
> by home network? or There are more than one MoS in home 
> network?  In both situations, HAAA just push default MoS 
> information to AAAV.
> just push default MoS information to AAAV, nothing more.  
> It's MN who makes the final choice which MoS is selected. By 
> the way, even the HAAA push the default AAA to AAAV, it is 
> very possbile that MN uses the other MoS, instead of home one(s).
> 
> <gabor> it is bad design to push that information without 
> knowing if the MN needs it or not.

Sam> sounds reasonable.

> If MN did not get an MoS address of home (preferred) after 
> network access auth, MN SHOULD resort to the others(local MoS 
> or the third party). It's not necessary to inquiry home 
> network again and again. What i want to express is that the 
> discovering procedure should be very flexible. One fails, the 
> other works. If all fails, MoS could not be gotten. Do you 
> think that once MN uses MoS in home, MN has always to use MoS 
> in home ?
> 
> >The main point, there is
>  need (HA)
> In fact, HA could be deployed in both home and visited 
> network. So the address of HA is optional and uncertain. 
> During the procedure of discovering HA adress, HAAA just push 
> HA address in home to AAAV. It is MN who makes the final 
> choice(maybe MN want to use local HA in visited network).
> 
> <gabor> the thing is, that the MN always needs an HA, whether 
> at home or in visited. The same is not true for MoS.

Sam> I agree partly.  While handover would happen, MoS is always needed even
MoS could be discovered after authentication and attachment. 

> Personnel opinion:  if MoS(es) is(are) stable while MN is 
> moving, DNS is very good choice.  In the case MoS(es) is 
> dynamic, DHCP is a good one.
> When MN is moving away from home,  it is usual for MoS to be 
> changed from one place to the other.
> 
> <gabor> we have both the DNS and DHCP options. But involving 
> AAA infra to send MoS address to the DHCP/NAS in the visited 
> network is not necessary, it is needless. So, we merge back 
> section 5.3 with section
> 5.1 and use DNS based discovery regardless whether the MN is 
> at home or visiting. What matters is that the MN wants to 
> discover MoS at home.

Sam> I agree that if MN makes sure that it wants MoS home, DNS method is ok.
But I am thinking the way you are not. 
>From the text in section 5, we have made an assumption that MN knows which
MoS should be required if DNS method is used.
The crux is that while MN is moving far from home, it is very possible that
MN does not know which MoS should be used because MN's preferred MoS maybe
does not work in the visited network. So while MN is roaming, it is usual
and reasonable for MN to be assigned MoS by visited network.
So my personnel opinions are as follows:
1: while MN is at home or nearby, both DNS and DHCP could be used(the
precondition is that MoS discovered by DNS MUST work).
2: while MN is roaming far away from home, DHCP method is preferred.
3: while MN makes sure that it wants a designated MoS, such as home MoS and
the third party, without any knowledge about whether its preferd MoS works
or not in visied network, DNS method could be  
    used.
4: while MN wants the preferrd MoS(home and the third), but not sure whether
the preferred MoS does works, DHCP method should be used.  If DHCP method
returns MN's preferred MoS, it indicates that MN's preferred MoS does work
implicity.  If DHCP method returns the other MoS, it indicates that MN's
prefered MoS does not work here.

I don't object to merging section 5.3 with 5.1.  But the more imortant is
that we should clarify when to use DNS method and when to use DHCP method,
not just what and how DNS can do and what and how DHCP can do.
not sure whether it is good to involve AAA infra to send MoS address. Let's
wait for reply from wg.

---

From: Subir Das <[email-masked]>
Date: Wed, 26 Sep 2007 23:54:31 -0400

This is a bootstrapping scenario and HAAA will send information that are 
relevant
to the MN in that visited network. This is true for MobileIP 
bootstrapping  as well.
Am I missing something here?

-Subir

---

From: <[email-masked]>
Date: Wed, 26 Sep 2007 23:49:40 -0500

The question is, why would the HAAA send the MoS address to the visited
network while it does not know whether the MN needs it or not?

The difference between MIPv6 bootstrapping and this one is, that in
MIPv6 bootstrapping the MN needs an HA, whether that is at home or in
visited. In our case, the MN may not want to use any MoS, or it may but
the one in visited. Network access authentication happens all the time,
but how often would an MN need an MoS@home address? I do not think it is
feasible to send over AAA a bunch of staff which may not be needed, and
go over the pain of defining radius, diameter and dhcp relay options.
And there are lots of error cases which can not be dealt with. Using DNS
is way much easier.

-gabor 

-----Original Message-----
From: ext Subir Das [mailto:[email-masked]] 
Sent: Wednesday, September 26, 2007 8:55 PM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Scenario 3

This is a bootstrapping scenario and HAAA will send information that are
relevant to the MN in that visited network. This is true for MobileIP
bootstrapping  as well.
Am I missing something here?

-Subir

[email-masked] wrote:
> wants any MoS, and if yes, which one, thus why would it send it over 
> to the visited AAA. Also, once network access auth has happened and 
> the MN did not get an MoS address, it is not possible to discover MoS 
> in home without doing a network access auth. The main point, there is 
> and an optional one (MoS). The solution: after network access 
> authentication use DNS based discovery and forget about the integrated

> scenario solution.

---

From: Telemaco Melia <[email-masked]>
Date: Thu, 27 Sep 2007 10:06:11 +0200

Guys,

I think that it is a policy decision (and not in scope of our work) to 
decide whether the terminal should be provided with MoS information
via AAA during bootstrapping. I believe this information (policies) 
should be stored in the AAA and retrieved accordingly during network 
authentication.
There might be a flag indicating "User xyz prefers MoS in the home" or 
something similar. I think it is a possibility we should not discard.
And I do not think it is bad design pushing to the visited network 
information that might not be used by the MN.
It is rather bad design to assume that the MN should always be the 
decision point.

my 2 cents
Tele

-- 
Dr. Telemaco Melia			[email-masked]
Senior Research Staff Member		Tel: +49 (0) 6221 4342- 142
NEC Europe Ltd.
NEC Laboratories Europe
Network Division			
Kurfürsten-Anlage 36		
69115 Heidelberg
GERMANY	  

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: <[email-masked]>
Date: Thu, 27 Sep 2007 12:21:15 -0500

But why do we need to involve AAA at all? what's wrong with the DNS based discovery, that would work fine.
and besides, the discovery should not depend on the location of the MN (roaming or not): the MN should discover MoS@home in the same way whether it is attached to home link or a visited link (MoS@home is still the same entity).
 
- gabor

________________________________

From: ext Telemaco Melia [mailto:[email-masked]] 
Sent: Thursday, September 27, 2007 1:06 AM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Scenario 3

Guys,

I think that it is a policy decision (and not in scope of our work) to decide whether the terminal should be provided with MoS information 
via AAA during bootstrapping. I believe this information (policies) should be stored in the AAA and retrieved accordingly during network authentication.
There might be a flag indicating "User xyz prefers MoS in the home" or something similar. I think it is a possibility we should not discard.
And I do not think it is bad design pushing to the visited network information that might not be used by the MN.
It is rather bad design to assume that the MN should always be the decision point.

my 2 cents
Tele

	
	
	-gabor 
	
	-----Original Message-----
	From: ext Subir Das [mailto:[email-masked]] 
	Sent: Wednesday, September 26, 2007 8:55 PM
	To: Bajko Gabor (Nokia-SIR/MtView)
	Cc: [email-masked]; [email-masked]
	Subject: Re: [MIPSHOP-MIH-DT] Scenario 3

	-Subir

		Folks,

	

		scenario solution.
		
		Comments?
		
		- gabor

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Thu, 27 Sep 2007 13:40:15 -0400

Gabor, Tele,

But wasn't the DHCP option anyway the way for the MN to request for MoS 'after' the first bootstrapping (i.e. once you have been assigned a domain and you re-requested the MIH option)? If that is the case, scenario 3 could still be applicable. 

I think that the difference relies on when we consider the bootstrap and authentication processes start and finish. For instance, the MN could be first authenticated and then it could request the MoS which would require communicating with the AAA once again. If that were the case, you wouldn't send the information every time but only on demand.

Jc

From: [email-masked] [mailto:[email-masked]] 
Sent: September 27, 2007 1:21 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [MIPSHOP-MIH-DT] Scenario 3

- gabor

Guys,

my 2 cents
Tele

 
 
-gabor 
 
-----Original Message-----
From: ext Subir Das [mailto:[email-masked]] 
Sent: Wednesday, September 26, 2007 8:55 PM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Scenario 3

-Subir

	Folks,

 

	scenario solution.
	 
	Comments?
	 
	- gabor

---

From: <[email-masked]>
Date: Thu, 27 Sep 2007 14:54:40 -0500

The DNS based discovery works in any scenario. The DHCP option is there just for convenience. If you need to make a DHCP query anyways (eg because you just attached to a new link and you need IP address and maybe some other things too) you may use the MIH options. Otherwise simply use the DNS.
 
I didn't get this:
> For instance, the MN could be first authenticated and then it could request the MoS which would require communicating with the AAA once again.
If you do not get the MoS during the network access auth procedure, then (according to the scenario currently present in 5.3) you can NOT request it afterwards. There is no communication with the AAA 'once again'. That scenario can not support the on demand case, that is one of my problems with it.
 
Again, what is the problem of decoupling discovery from network access auth? Do the auth first, then use DNS to discover MoS. That was the original proposal, which was modified and I am still trying to find out the reasons ...
 
- gabor

From: ext Zuniga, Juan Carlos [mailto:[email-masked]] 
Sent: Thursday, September 27, 2007 10:40 AM
To: Bajko Gabor (Nokia-SIR/MtView); [email-masked]
Cc: [email-masked]
Subject: RE: [MIPSHOP-MIH-DT] Scenario 3

Gabor, Tele,

Jc

- gabor

Guys,

my 2 cents
Tele

 
 
-gabor 
 
-----Original Message-----
From: ext Subir Das [mailto:[email-masked]] 
Sent: Wednesday, September 26, 2007 8:55 PM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Scenario 3

-Subir

	Folks,

 

	scenario solution.
	 
	Comments?
	 
	- gabor

---

From: Subir Das <[email-masked]>
Date: Fri, 28 Sep 2007 10:52:06 -0400

Whenever HAAA pushes any such info, it knows what info is required. Yes, 
not all MN require
the MOS but it has to be determined by the service registration or 
policy.  IMO, this is no difference
between mobility service that requires HA and MIH services that requires 
MOS.

-Subir

---

From: Subir Das <[email-masked]>
Date: Fri, 28 Sep 2007 11:21:09 -0400

If the network access provider and the MIH service provider are the 
same, it may be easier for them
to provide such information during network access authentication. Of 
course, DNS based discovery
would work, but we are enumerating/enabling different use cases. Is it 
not that the bootstrapping scenario
can work for both home and visited networks?

-Subir

[email-masked] wrote:
> and besides, the discovery should not depend on the location of the MN 
> (roaming or not): the MN should discover MoS@home <mailto:MoS@home> in 
> the same way whether it is attached to home link or a visited link 
> (MoS@home <mailto:MoS@home> is still the same entity).
>  
> - gabor
>
> ------------------------------------------------------------------------
> *From:* ext Telemaco Melia [mailto:[email-masked]]
> *Sent:* Thursday, September 27, 2007 1:06 AM
> *To:* Bajko Gabor (Nokia-SIR/MtView)
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [MIPSHOP-MIH-DT] Scenario 3
>
> Guys,
>

---

From: <[email-masked]>
Date: Fri, 28 Sep 2007 14:36:18 -0500

Well, if the network access provider and the MIH service provider are the same, then that is a different use case, the MoS is not at home in this case.

For the MN roaming and discovering MoS at home, we do not need to define lots of extensions to different protocols, but just simply use DNS. That's what I am saying.

- gabor 

-----Original Message-----
From: ext Subir Das [mailto:[email-masked]] 
Sent: Friday, September 28, 2007 8:21 AM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Scenario 3

If the network access provider and the MIH service provider are the same, it may be easier for them to provide such information during network access authentication. Of course, DNS based discovery would work, but we are enumerating/enabling different use cases. Is it not that the bootstrapping scenario can work for both home and visited networks?

-Subir

[email-masked] wrote:
>> The question is, why would the HAAA send the MoS address to the 
>> visited network while it does not know whether the MN needs it or not?
>>
>> visited. In our case, the MN may not want to use any MoS, or it may 
>> but the one in visited. Network access authentication happens all the 
>> time, but how often would an MN need an MoS@home address? I do not 
>> think it is feasible to send over AAA a bunch of staff which may not 
>> be needed, and go over the pain of defining radius, diameter and dhcp relay options.
>> And there are lots of error cases which can not be dealt with. Using 
>> DNS is way much easier.
>>
>> -gabor
>>
>> This is a bootstrapping scenario and HAAA will send information that 
>> are relevant to the MN in that visited network. This is true for 
>> MobileIP bootstrapping  as well.
>>> I talked to Srini about scenario 3 and we figured out one problem: 
>>> at network access authentication phase, the HAAA does not know if 
>>> the MN wants any MoS, and if yes, which one, thus why would it send 
>>> it over to the visited AAA. Also, once network access auth has 
>>> happened and the MN did not get an MoS address, it is not possible 
>>> to discover MoS in home without doing a network access auth. The 
>>> main point, there is a difference between requiring the address of 
>>> an entity you need (HA) and an optional one (MoS). The solution: 
>>> after network access authentication use DNS based discovery and 
>>> forget about the integrated
>>>     
>>
>>   
>>> scenario solution.
>>>
>>> Comments?
>>>
>>> - gabor
>>>
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, 
> London W3 6BL | Registered in England 2832014

---

From: Sam Xia <[email-masked]>
Date: Sat, 29 Sep 2007 09:46:19 +0800

Gabor and Subir:
I want to say something from the other perspective.

I admit that DNS method discovering home MoS is very simple. I also think
that DHCP method is more sophisticated. My understanding is as follows:

1: DHCP discovering is a kind of method based on network. The network has
high priority to determine which MoS should be used.  For example, the
visited network can select the local MoS, or  home network can select other
MoS different than that known by MN. Even MN wants home MoS firstly, network
should have right to modify it. And i think that it is very reasonable that
network side discovering method should support all scenarios just as dns
method does so. (i have the same feeling with Tele's)

2: DNS method is determined completely by terminal. Terminal has no
knowledge about  the relation between homenetwork and visited network. Maybe
home Mos does not work at visted network. DHCP method can tell MN that point
implicitly; but DNS can not.

 Best Regards, Sam Xia 

> Sent: Saturday, September 29, 2007 3:36 AM
> To: [email-masked]
> Well, if the network access provider and the MIH service 
> provider are the same, then that is a different use case, the 
> MoS is not at home in this case.
> 
> For the MN roaming and discovering MoS at home, we do not 
> need to define lots of extensions to different protocols, but 
> just simply use DNS. That's what I am saying.
> 
> - gabor 
> 
> If the network access provider and the MIH service provider 
> are the same, it may be easier for them to provide such 
> information during network access authentication. Of course, 
> DNS based discovery would work, but we are 
> enumerating/enabling different use cases. Is it not that the 
> bootstrapping scenario can work for both home and visited networks?
> 
> -Subir
> 
> problem: