Subject: RE: [MIPSHOP-MIH-DT] Scenario 3

From: <[email-masked]>
Date: Thu, 11 Oct 2007 19:03:01 -0500

Folks,

Can we finally have an agreement on this piece? Yoshi's comment was also in
line with my proposal. 

We should also try to fight the inertia and make an update to the draft, it
is taking way too long for the next step. If there is not gonna be any
activity started, I will go ahead and update the draft myself, addressing
Yoshi's and .21's comments.

Regarding the PS draft, I am not an author, thus I do not care what you guys
do with it. Sorry Sam.

- gabor

-----Original Message-----
From: ext [email-masked]
[mailto:[email-masked]] 
Sent: Friday, September 28, 2007 12:36 PM
To: [email-masked]
Cc: [email-masked]
Subject: RE: [MIPSHOP-MIH-DT] Scenario 3

Well, if the network access provider and the MIH service provider are the
same, then that is a different use case, the MoS is not at home in this
case.

For the MN roaming and discovering MoS at home, we do not need to define
lots of extensions to different protocols, but just simply use DNS. That's
what I am saying.

- gabor 

-----Original Message-----
From: ext Subir Das [mailto:[email-masked]]
Sent: Friday, September 28, 2007 8:21 AM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]; [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Scenario 3

If the network access provider and the MIH service provider are the same, it
may be easier for them to provide such information during network access
authentication. Of course, DNS based discovery would work, but we are
enumerating/enabling different use cases. Is it not that the bootstrapping
scenario can work for both home and visited networks?

-Subir

[email-masked] wrote:
> But why do we need to involve AAA at all? what's wrong with the DNS 
> based discovery, that would work fine.
> and besides, the discovery should not depend on the location of the MN 
> (roaming or not): the MN should discover MoS@home <mailto:MoS@home> in 
> the same way whether it is attached to home link or a visited link 
> (MoS@home <mailto:MoS@home> is still the same entity).
>  
> - gabor
>
> ----------------------------------------------------------------------
> --
> *From:* ext Telemaco Melia [mailto:[email-masked]]
> *Sent:* Thursday, September 27, 2007 1:06 AM
> *To:* Bajko Gabor (Nokia-SIR/MtView)
> *Cc:* [email-masked]; [email-masked]
> *Subject:* Re: [MIPSHOP-MIH-DT] Scenario 3
>
> Guys,
>
> I think that it is a policy decision (and not in scope of our work) to 
> decide whether the terminal should be provided with MoS information 
> via AAA during bootstrapping. I believe this information (policies) 
> should be stored in the AAA and retrieved accordingly during network 
> authentication.
> There might be a flag indicating "User xyz prefers MoS in the home" or 
> something similar. I think it is a possibility we should not discard.
> And I do not think it is bad design pushing to the visited network 
> information that might not be used by the MN.
> It is rather bad design to assume that the MN should always be the 
> decision point.
>
> my 2 cents
> Tele
>
> [email-masked] wrote:
>> The question is, why would the HAAA send the MoS address to the 
>> visited network while it does not know whether the MN needs it or not?
>>
>> The difference between MIPv6 bootstrapping and this one is, that in
>> MIPv6 bootstrapping the MN needs an HA, whether that is at home or in 
>> visited. In our case, the MN may not want to use any MoS, or it may 
>> but the one in visited. Network access authentication happens all the 
>> time, but how often would an MN need an MoS@home address? I do not 
>> think it is feasible to send over AAA a bunch of staff which may not 
>> be needed, and go over the pain of defining radius, diameter and dhcp
relay options.
>> And there are lots of error cases which can not be dealt with. Using 
>> DNS is way much easier.
>>
>> -gabor
>>
>> -----Original Message-----
>> From: ext Subir Das [mailto:[email-masked]]
>> Sent: Wednesday, September 26, 2007 8:55 PM
>> To: Bajko Gabor (Nokia-SIR/MtView)
>> Cc: [email-masked]; [email-masked]
>> Subject: Re: [MIPSHOP-MIH-DT] Scenario 3
>>
>> This is a bootstrapping scenario and HAAA will send information that 
>> are relevant to the MN in that visited network. This is true for 
>> MobileIP bootstrapping  as well.
>> Am I missing something here?
>>
>> -Subir
>>
>> [email-masked] wrote:
>>   
>>> Folks,
>>>
>>> I talked to Srini about scenario 3 and we figured out one problem: 
>>> at network access authentication phase, the HAAA does not know if 
>>> the MN wants any MoS, and if yes, which one, thus why would it send 
>>> it over to the visited AAA. Also, once network access auth has 
>>> happened and the MN did not get an MoS address, it is not possible 
>>> to discover MoS in home without doing a network access auth. The 
>>> main point, there is a difference between requiring the address of 
>>> an entity you need (HA) and an optional one (MoS). The solution:
>>> after network access authentication use DNS based discovery and 
>>> forget about the integrated
>>>     
>>
>>   
>>> scenario solution.
>>>
>>> Comments?
>>>
>>> - gabor
>>>
>>> _______________________________________________
>>> MIPSHOP-MIH-DT mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt
>>>   
>>>     
>
>
> -- 
> Dr. Telemaco Melia			[email-masked]
> Senior Research Staff Member		Tel: +49 (0) 6221 4342- 142
> NEC Europe Ltd.
> NEC Laboratories Europe
> Network Division			
> Kurfürsten-Anlage 36		
> 69115 Heidelberg
> GERMANY	  
>
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, 
> London W3 6BL | Registered in England 2832014

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt
_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: Sam Xia <[email-masked]>
Date: Fri, 12 Oct 2007 09:03:24 +0800

Best Regards, Sam Xia 

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Friday, October 12, 2007 8:03 AM
> To: [email-masked]
> Can we finally have an agreement on this piece? Yoshi's 
> comment was also in line with my proposal. 
> 
> We should also try to fight the inertia and make an update to 
> the draft, it is taking way too long for the next step. If 
> there is not gonna be any activity started, I will go ahead 
> and update the draft myself, addressing Yoshi's and .21's comments.
> 
> Regarding the PS draft, I am not an author, thus I do not 
> care what you guys do with it. Sorry Sam.
> 
> - gabor
> 
> Well, if the network access provider and the MIH service 
> provider are the same, then that is a different use case, the 
> MoS is not at home in this case.
> 
> For the MN roaming and discovering MoS at home, we do not 
> need to define lots of extensions to different protocols, but 
> just simply use DNS. That's what I am saying.
> 
> - gabor 
> 
> If the network access provider and the MIH service provider 
> are the same, it may be easier for them to provide such 
> information during network access authentication. Of course, 
> DNS based discovery would work, but we are 
> enumerating/enabling different use cases. Is it not that the 
> bootstrapping scenario can work for both home and visited networks?
> 
> -Subir
>

---

From: Sam Xia <[email-masked]>
Date: Fri, 12 Oct 2007 09:09:35 +0800

Hi Gabor,

Do you see the comments from DNS guys?  There are some negative comments on
DNS discovery. Could you discuss with them before you update our drafts?

 Best Regards, Sam Xia

---

From: <[email-masked]>
Date: Thu, 11 Oct 2007 20:37:58 -0500

I already started discussing those comments, but I do not think those impact
draft-melia. We are clarifying the usability of dhcp for naptr input, but I
am confident things are right in the draft.

- gabor 

-----Original Message-----
From: ext Sam Xia [mailto:[email-masked]] 
Sent: Thursday, October 11, 2007 6:10 PM
To: Bajko Gabor (Nokia-SIR/MtView)
Cc: [email-masked]
Subject: RE: [MIPSHOP-MIH-DT] Scenario 3

Hi Gabor,

 Best Regards, Sam Xia 

> Can we finally have an agreement on this piece? Yoshi's comment was 
> also in line with my proposal.
> 
> We should also try to fight the inertia and make an update to the 
> draft, it is taking way too long for the next step. If there is not 
> gonna be any activity started, I will go ahead and update the draft 
> myself, addressing Yoshi's and .21's comments.
> 
> Regarding the PS draft, I am not an author, thus I do not care what 
> you guys do with it. Sorry Sam.
> 
> - gabor
> 
> Well, if the network access provider and the MIH service provider are 
> the same, then that is a different use case, the MoS is not at home in 
> this case.
> 
> For the MN roaming and discovering MoS at home, we do not need to 
> define lots of extensions to different protocols, but just simply use 
> DNS. That's what I am saying.
> 
> - gabor
> 
> If the network access provider and the MIH service provider are the 
> same, it may be easier for them to provide such information during 
> network access authentication. Of course, DNS based discovery would 
> work, but we are enumerating/enabling different use cases. Is it not 
> that the bootstrapping scenario can work for both home and visited 
> networks?
> 
> -Subir
>

---

From: Telemaco Melia <[email-masked]>
Date: Fri, 19 Oct 2007 16:34:16 +0200

Gabor,

Sorry for taking longer than expected to come back on the matter 
(swamped with other personal and non personal issues...)
Let's try to update draft-melia and draft-bajko accordingly so that the 
design is consistent. Would you agree?

I am going through the several mails received...I ll compile a list and 
post it on the list.

Thanks for your patience

Tele

[email-masked] wrote:
> ------------------------------------------------------------------------
>

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Telemaco Melia <[email-masked]>
Date: Fri, 19 Oct 2007 16:53:27 +0200

> Regarding the PS draft, I am not an author, thus I do not care what you guys

Fair enough...I guess that Sam did not want to ask non authors to work 
on it....

tele