Subject: RE: [MIPSHOP-MIH-DT] Work for version -01

From: Sam Xia <[email-masked]>
Date: Mon, 05 Nov 2007 15:54:59 +0800

> -----Original Message-----
> From: Telemaco Melia [mailto:[email-masked]] 
> Sent: Wednesday, October 31, 2007 11:10 PM
> To: [email-masked]
> Subject: Re: [MIPSHOP-MIH-DT] Work for version -01
> 
> Guys,
> 
> I started with version -01. Yoshi's and David's comments have 
> been accounted for.
> The issues not solved are listed below. I need now to 
> thoroughly process the paper from NIST people.
> Please let's agree on the open issues via mail if we cannot 
> setup an AC in a reasonable time.
> The deadline is submission for -01 version.
> 
> Comments?
> 
> Tele
> 
> 
> Technical issues
> ================
> 
> - MIHFID issue raised by Yoshi (MIHFID recomendations for the 
> MoS but not for the MN)

[Sam] but NAI could be MIHF ID of MN.

> 
> - Mandating only TCP and UDP (I agree on Gabor's comment that 
> we cannot give too may options for transport)
> 
> - Use of DHCP vs. DNS for discovery (previously mentioned in my email)

[Sam]  I would suggest that both DHCP and DNS can work for all scenarios.

> 
> - Flow -- relation between MIH user and DHCP client (issue 
> raised by Yoshi)

[Sam] I think that this is just an internal implementation. No matter who
triggers the DHCP discovering, it is always DCHP packets seen on the link.
It is possbile that MIH user triggers the DHCP discovery procedure directly.
And that local MIHF provides MIH user with an interface to trigger DHCP
discovery is another option.

> 
> - make this example Section 7.1, and then create a Section 
> 7.2 to include a CS/ES example as well, in which UDP is used for
> 
> transport and another MoS location scenario is in effect.
> 
> - link layer security where DHCP is used might be better 

[Sam] agree. it seems that DNS Sec is not used widely.

> 
> - explanation on the TLS/DTLS/IPsec usage and terminology
> 
> Editorial issues
> ================
> 
> - Terminology defintions (one sentence for each of them)
> 
> - Use PoSh, PoSv, PoS3 instead of MoSv, MoSh, MoS3.
> 
> 
> 
> Telemaco Melia wrote:
> > Dear all,
> >
> > Since it seems pretty much difficult to get everybody for the AC I 
> > propose the following.
> > I already started to review the document (version -01) based on the 
> > received comments.
> > I will incorporate the editorial comments and compile a list of 
> > technical issues for you to comment via email. (this week)
> >
> > To start with I would like to clarify the DHCP vs. DNS discovery 
> > procedure.
> > First question I have is whether we should compare the HA discovery 
> > and the MoS discovery. In my opinion we should.
> > Second question is why we do not support DHCP only in S1, 
> S2, S3 and 
> > DNS only in S4.
> > We should remember that IETF does not accept a document with 2 
> > solutions to the same problem.
> >
> > Gabor I know that at this point in time you might be 
> disappointed, but 
> > we should also consider that the DHCP solution helps the network to 
> > perform assignment. If we run discovery via DNS, MoS 
> assignment cannot 
> > be done, and we should provide it by other means.
> > So I guess that the implicit question is whether assignment is a 
> > requirement for us or not. I would say yes.
> >
> > Subir, JC, all can you please comment on the above?
> >
> > Let me know
> > Tele
> >
> >
> >
> >
> >
> >
> >
> 
> 
> -- 
> Dr. Telemaco Melia			[email-masked]
> Senior Research Staff Member		Tel: +49 (0) 6221 4342- 142
> NEC Europe Ltd.
> NEC Laboratories Europe
> Network Division			
> Kurfürsten-Anlage 36		
> 69115 Heidelberg
> GERMANY	  
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria 
> Road, London W3 6BL | Registered in England 2832014 
> 
> 

_______________________________________________
MIPSHOP-MIH-DT mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop-mih-dt

---

From: <[email-masked]>
Date: Tue, 6 Nov 2007 09:07:51 -0600

Tele,

Do you have a copy of the 01 version of the draft which tracks the changes from version 00? Side-by-side comparison is pretty painful ...

At least I saw that you left the assignment procedure in 5.3. Note, that Yoshi also commented that DNS should be used in that scenario too, which practically means there is no assignment, but discovery. I think it is important to solve this issue, and you know my opinion on this.
We should try to set up a conf call for the end of the week.

Some more comments below:

-----Original Message-----
From: ext Telemaco Melia [mailto:[email-masked]] 
Sent: Wednesday, October 31, 2007 8:10 AM
To: [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Work for version -01

Guys,

I started with version -01. Yoshi's and David's comments have been accounted for.
The issues not solved are listed below. I need now to thoroughly process the paper from NIST people.
Please let's agree on the open issues via mail if we cannot setup an AC in a reasonable time.
The deadline is submission for -01 version.

Comments?

Tele

Technical issues
================

- MIHFID issue raised by Yoshi (MIHFID recomendations for the MoS but not for the MN)

- Mandating only TCP and UDP (I agree on Gabor's comment that we cannot give too may options for transport)

<gb> we could say that udp and tcp are mandatory in the server side. In the DNS discovery draft I could add SCTP as supported protocol, whose support can be discovered.

<gb> this was commented by Stefano. His comments was also in line of keeping both. 

- Flow -- relation between MIH user and DHCP client (issue raised by Yoshi)

- make this example Section 7.1, and then create a Section 7.2 to include a CS/ES example as well, in which UDP is used for

Editorial issues
================

Telemaco Melia wrote:
> Second question is why we do not support DHCP only in S1, S2, S3 and 
> DNS only in S4.
> Gabor I know that at this point in time you might be disappointed, but 
> perform assignment. If we run discovery via DNS, MoS assignment cannot 

NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: <[email-masked]>
Date: Tue, 6 Nov 2007 09:13:40 -0600

Hi,

<gb> this statement is a bit broad. DHCP can not be used in scenario s4. Using it in scenario s3, leads to this assignment issue. I am not sure if it is a good idea to go down the path that using dhcp you are assigned an MoS, while using DNS you actually discover the DNS. We should only talk about discovery.

> - Flow -- relation between MIH user and DHCP client (issue raised by 

[Sam] I think that this is just an internal implementation. No matter who triggers the DHCP discovering, it is always DCHP packets seen on the link.
It is possbile that MIH user triggers the DHCP discovery procedure directly.
And that local MIHF provides MIH user with an interface to trigger DHCP discovery is another option.

<gb> I tend to agree with this.

- gabor

> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, 
> London W3 6BL | Registered in England 2832014
> 
>

---

From: Telemaco Melia <[email-masked]>
Date: Tue, 06 Nov 2007 18:08:28 +0100

Guys,

I did not read the technical answers...but I agree with Gabor on the 
need for the AC before next week.
Friday I am out. What about Thursday? 18:00 or 19:00 CET? Subir/Juan 
Carlos can you offer the bridge?

Tele

---

From: <[email-masked]>
Date: Tue, 6 Nov 2007 12:07:16 -0600

Thursday 18.00 CET works for me. Bridge should not be an issue, if Subir/JC can not set it up, I could do it.
 
- gabor

________________________________

From: ext Telemaco Melia [mailto:[email-masked]] 
Sent: Tuesday, November 06, 2007 9:08 AM
To: Bajko Gabor (Nokia-SIR/MtView); Subir Das; Zuniga, Juan Carlos
Cc: [email-masked]
Subject: Re: [MIPSHOP-MIH-DT] Work for version -01

Guys,

I did not read the technical answers...but I agree with Gabor on the need for the AC before next week.
Friday I am out. What about Thursday? 18:00 or 19:00 CET? Subir/Juan Carlos can you offer the bridge?

Tele

	Tele,

	

	-----Original Message-----
	From: ext Telemaco Melia [mailto:[email-masked]] 
	Sent: Wednesday, October 31, 2007 8:10 AM
	To: [email-masked]
	Subject: Re: [MIPSHOP-MIH-DT] Work for version -01
	
	Guys,

	Comments?
	
	Tele

	Technical issues
	================

	

	

	

	Editorial issues
	================

	
	Telemaco Melia wrote:

		Dear all,

		

		Let me know
		Tele

---

From: Nada Golmie <[email-masked]>
Date: Tue, 06 Nov 2007 13:11:42 -0500

Thursday 18.00 CET works for me too.
-Nada

[email-masked] wrote:
> Thursday 18.00 CET works for me. Bridge should not be an issue, if 
> Subir/JC can not set it up, I could do it.
>  
> - gabor
>
> ------------------------------------------------------------------------
> *From:* ext Telemaco Melia [mailto:[email-masked]]
> *Sent:* Tuesday, November 06, 2007 9:08 AM
> *To:* Bajko Gabor (Nokia-SIR/MtView); Subir Das; Zuniga, Juan Carlos
> *Cc:* [email-masked]
> *Subject:* Re: [MIPSHOP-MIH-DT] Work for version -01
>
> Guys,
>
> ------------------------------------------------------------------------
>

-- 
Nada Golmie, Ph.D. 
Manager, High Speed Network Technologies Group
National Institute of Standards and Technology
100 Bureau Dr. Stop 8920
Gaithersburg, MD 20899
Email: [email-masked]
Phone: (301) 975-4190
Fax:   (301) 590-0932
Web: http://w3.antd.nist.gov

---

From: "Zuniga, Juan Carlos" <[email-masked]>
Date: Tue, 6 Nov 2007 13:17:30 -0500

Wednesday was better for me, but if Thursday is a better day for the rest of the team I can join too (although I might have to leave the call earlier).

Would the call be one hour long?

Jc

---

From: Subir Das <[email-masked]>
Date: Tue, 06 Nov 2007 14:29:03 -0500

Sorry folks. I was out for last two weeks except .21 ad hoc. I am fine 
with the time and 
can also set up a bridge.

-Subir

---

From: Telemaco Melia <[email-masked]>
Date: Wed, 07 Nov 2007 10:21:38 +0100

Thanks for the reply.
Let's fix the AC on Thursday 18:00 CET. Subir can you send around the 
details to dial in?

Tele

Subir Das wrote:
> with the time and can also set up a bridge.
>
> -Subir
>
>> Wednesday was better for me, but if Thursday is a better day for the 
>> rest of the team I can join too (although I might have to leave the 
>> call earlier).
>>
>> From: Nada Golmie [mailto:[email-masked]] Sent: November 6, 
>> 2007 1:12 PM
>>>> Do you have a copy of the 01 version of the draft which tracks the 
>>>> changes from version 00? Side-by-side comparison is pretty painful ...
>>>>
>>>> At least I saw that you left the assignment procedure in 5.3. Note, 
>>>> that Yoshi also commented that DNS should be used in that scenario 
>>>> too, which practically means there is no assignment, but discovery. 
>>>> I think it is important to solve this issue, and you know my 
>>>> opinion on this.
>>>> From: ext Telemaco Melia [mailto:[email-masked]] Sent: 
>>>> Wednesday, October 31, 2007 8:10 AM
>>>> - Mandating only TCP and UDP (I agree on Gabor's comment that we 
>>>> cannot give too may options for transport)
>>>>
>>>> <gb> we could say that udp and tcp are mandatory in the server 
>>>> side. In the DNS discovery draft I could add SCTP as supported 
>>>> protocol, whose support can be discovered.
>>>>
>>>> - make this example Section 7.1, and then create a Section 7.2 to 
>>>> include a CS/ES example as well, in which UDP is used for
>>>>
>>>>> I already started to review the document (version -01) based on 
>>>>> the received comments.
>>>>> First question I have is whether we should compare the HA 
>>>>> discovery and the MoS discovery. In my opinion we should.
>>>>> Second question is why we do not support DHCP only in S1, S2, S3 
>>>>> and DNS only in S4.
>>>>> Gabor I know that at this point in time you might be disappointed, 
>>>>> but we should also consider that the DHCP solution helps the 
>>>>> network to perform assignment. If we run discovery via DNS, MoS 
>>>>> assignment cannot be done, and we should provide it by other means.

---

From: Subir Das <[email-masked]>
Date: Wed, 07 Nov 2007 08:39:24 -0500

AC Bridge details:

Time:  18:00 CET,  12 Noon EST (US), 9 am  PST (US)
Dial in: (+1) 732 336 6000
Pin: 2483

Subir 

Telemaco Melia wrote:
>> Sorry folks. I was out for last two weeks except .21 ad hoc. I am 
>> fine with the time and can also set up a bridge.
>>
>> -Subir
>>
>>>> Friday I am out. What about Thursday? 18:00 or 19:00 CET? 
>>>> Subir/Juan Carlos can you offer the bridge?
>>>>
>>>> Tele
>>>>
>>>>
>>>>> At least I saw that you left the assignment procedure in 5.3. 
>>>>> Note, that Yoshi also commented that DNS should be used in that 
>>>>> scenario too, which practically means there is no assignment, but 
>>>>> discovery. I think it is important to solve this issue, and you 
>>>>> know my opinion on this.
>>>>>> Since it seems pretty much difficult to get everybody for the AC 
>>>>>> I propose the following.
>>>>>> disappointed, but we should also consider that the DHCP solution 
>>>>>> helps the network to perform assignment. If we run discovery via 
>>>>>> DNS, MoS assignment cannot be done, and we should provide it by 
>>>>>> other means.
>>>> Network Division           Kurfürsten-Anlage 36       69115 Heidelberg
>>>> GERMANY     NEC Europe Limited | Registered Office: NEC House, 1 
>>>> Victoria Road, London W3 6BL | Registered in England 2832014

---

From: Sam Xia <[email-masked]>
Date: Thu, 08 Nov 2007 14:59:36 +0800

> Subject: RE: [MIPSHOP-MIH-DT] Work for version -01
> 
> Hi,
>  
> 
> 
> <gb> this statement is a bit broad. DHCP can not be used in 
> scenario s4. Using it in scenario s3, leads to this 
> assignment issue. I am not sure if it is a good idea to go 
> down the path that using dhcp you are assigned an MoS, while 
> using DNS you actually discover the DNS. We should only talk 
> about discovery.

[Sam] Maybe my understanding about discovery is differend with yours.  I
don't see any official standard specifying that discovery is only scoped to
MN discovering MoS in networks.  So, both DHCP and DNS could be kinds of
decovery methods.  

BTW, from .21 standard,  i see that MIHF could be applied to Proxy MIP. In
proxy mip, MN is not involved in layer 3 mobility management. I conclude
that discovery is not just MN's issue.

> [Sam] I think that this is just an internal implementation. 
> No matter who triggers the DHCP discovering, it is always 
> DCHP packets seen on the link.
> And that local MIHF provides MIH user with an interface to 
> trigger DHCP discovery is another option.
> 
> discovery

---

From: Subir Das <[email-masked]>
Date: Thu, 08 Nov 2007 12:05:45 -0500

We are on the call..