Subject: Re: [Mipshop] Information contained in FBU (FMIPv6-06)

From: "Bryan Hartwell" <[email-masked]>
Date: Mon, 11 Aug 2003 22:59:34 -0400

Just some random thoughts, perhaps you can put
me straight.

FBU only contains PCoA, and it initiates HI/HACK.
How can PAR establish a tunnel with NAR without
even at least the LL address contained in RtSolPr?
Does the PAR store the RtSolPr, and assumes
which NAR the MN wants upon receiving the FBU? 

With network initated, there will be alot of L2
signals. Just send PrRtAdv so the MN can auto-
configure, and then do HI/HACK. 

In 802.11, a handoff can only be detect by L2
signals. Why not send a RtSolPr with LLA option,
PAR does RtSolPr and HI/HACK at the same time,
and that's it.

Why the need for FBU? When L2 hits, handoff is
underway... there really isn't time to to wait for
extra signalling.

> > > BTW, as per Section 6.4.1, the FBU does not contain the NCoA.
> > > The question is, in the network-initiated HO case,
> > > "How can the PAR know the NCoA configured by MN ?"
>
> > since PAR was tunneling to NAR's address, it was not necessary to
> > know new CoA. BTW, in the new version of the draft, it should be
> > better clarified.
>
> Even in case that PAR is tunneling to NAR's address,
> the PAR may need to know NCoA, if HI has a"new CoA option"
> for NCoA confirmation by NAR.
>

Agreed. I think the expectation was that if the MN didn't
formulate NCoA as instructed in PrRtAdv, it could risk
losing "service" using NCoA.

-Rajeev

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 12 Aug 2003 15:38:06 -0700

Hello Bryan,

few brief replies.

Bryan Hartwell wrote:

> Just some random thoughts, perhaps you can putme straight. FBU only
> contains PCoA, and it initiates HI/HACK.How can PAR establish a tunnel
> with NAR withouteven at least the LL address contained in RtSolPr?Does
> the PAR store the RtSolPr, and assumeswhich NAR the MN wants upon
> receiving the FBU?
> FBU should contain the target address to which PCoA
> is bound. The current status is that it includes NCoA.
>
>  With network initated, there will be alot of L2signals. Just send
> PrRtAdv so the MN can auto-configure, and then do HI/HACK. In 802.11,
> a handoff can only be detect by L2signals. Why not send a RtSolPr with
> LLA option,PAR does RtSolPr and HI/HACK at the same time,and that's
> it. Why the need for FBU? When L2 hits, handoff isunderway... there
> really isn't time to to wait forextra signalling.
> If FBU cannot be sent from the old link, it can be sent
> from the new link. After much discussion, we have arrived
> at the point where we specify IP messages and stay away from
> L2-specific signals/messages.
>
> Regards,
>
> -Rajeev
>
>
>
>
>
>
>
>
>
>

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop