Subject: RE: On the NECESSITY of MIP for LMM (was Re: [Mipshop] WG Last Ca ll comments ...)

From: Soliman Hesham <[email-masked]>
Date: Thu, 30 Oct 2003 08:10:08 -0500

Pekka, 

Some of your comments seem like "rejection
of realities" to me. For instance:

 > Yes, I disagree with the chartering of this WG.  In my humble
 > (or not) opinion it is foolish to base LMM on MIP.

=> and

 > As I have umpteen times written, in my opinion MIPv6 is flawed.
 > MIPv4 had good reasons for its design, that is fine.  But
 > carrying over the exactly same design to IPv6 was a big technical
 > mistake.  Maybe I will write a paper about this sometime.

=> I'm not sure what you expect this WG to do. Did you raise 
your objections to the charter before it was approved? 

 > But leaving that aside, what I am seeing happening is a multitude
 > of (roughly) IP layer mobility mechanisms that could benefit from
 > LMM.  MIP and HIP are only two of those; others include the new
 > initiatives of including some mobility functions to IKEv2,
 > the work on multi6 group such as MAST, and the new approaches
 > on the research side like FARA, I^3, etc.
 > 
 > All of these would benefit from LMM.  Basing LMM unnecessarily
 > on MIP may, IMHO, may bring package that will not be needed.

=> And it may bring a package that is needed, so where 
does this leave us? you're not giving me much to understand
where you're coming from! We will _never_ produce a "future
proof" protocol. I think we can agree on that. 

 > What comes to the SW reuse benefits of reusing MIP for both
 > macro mobility and LMM, I will believe when I see complete
 > code, together with the required security solutions.  The fact
 > that we are still lacking proper security is, IMHO, a clear
 > indication that the current solutions may be far from optimal ones.

=> As an author of one of this WG's drafts I'd like to
know what the security flaws in HMIPv6 are, i.e. additional
ones to MIPv6. I want to know this even if it's not in 
the charter. So if you have comments please let us know.
Until then, I can't agree with your assessment.

Hesham

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Pekka Nikander <[email-masked]>
Date: Thu, 30 Oct 2003 15:26:02 +0200

Soliman Hesham wrote:
> Did you raise  your objections to the charter before it was approved? 

I did rise my objections; I can dig up the messages if you wish.
But that wouldn't be useful.

> I'm not sure what you expect this WG to do. 

I do expect this working group to fulfil its charter,
at minimum.

What I am wishing is that some of the work done in this WG
would be useful also elsewhere or beyond the current charter.
This requirements work could be, but as it stands now, it
isn't.  But maybe this is wishful thinking and complete
waste of time.  Gab, please, your opinion?

I think this all discussion has been about why I would like
the LMM requirements document to take a broader scope, and
why I think that it would be possible even within the charter.

The charter is what we have.  I am not arguing with that.

> Until then, I can't agree with your assessment.

I have to confess that I haven't read the latest versions
of HMIPv6 drafts.  However, those ones that I did read,
were based on IPsec.  Requiring IPsec SAs, and hence IKE,
for LMM, may be a bit _heavy_.  No security flaws.  Just
impractical performance expectations and bloat of code.

Our HIP implementatation, including security and mobility,
is less than 15000 lines of code.  Take a typical IKE,
racoon, with 40000 loc, and typical MIPv6, MIPL, with
about 20000 loc.  Simplicity where, heh?  Besides, we do
not necessarily need the complexity of HIP or IKE based
security for LMM.  Given operational requirements, both
of them are pretty bad fits.

But, Hesham, do we need to take all these detours?  I have
promised, time permitting, to produce a version of the LMM
draft that has a broader scope.  Once I have completed that
(if I do), we could continue, couldn't we?

--Pekka Nikander