Subject: [Mipshop] Re: [Mip6] Mobile IPv6 Interop Testing Draft

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 24 Oct 2003 12:17:18 -0700 (PDT)

> Section 8 proposes the method for mobile node implementers to test
> 'returning to home' with other home agent vendor's implementation,
> even when the mobile node cannot access the real home link of the home
> agent.
> 
> My question is, how is a home agent (and a home link) configured?

We need to discuss more and flush out the configuration of HA and
virtual home tunnel without changing the HA implementation. Working
group comments would be helpful for this.

> 
> I imagined the following network, for example.
> 
> 
>       ----+----------  home link P::/64
>   	  |
>           |P::1 (home agent address)
>        IF1|200.0.0.1
>        +--+-+
>        | HA |    IF3(200.0.0.1 - 100.0.0.1)
>        +--+-+
>        IF2| 
> 	  |
>      ((Internet))
> 	  |
> 	  |
>        ---+---------+------------ visited link of MN tester Q::/64
> 	      	    |
> 	      	    |Q::100 (care-of address)
> 	      	 IF1|100.0.0.1
> 	      	 +--+-+
>        	       	 | MN |   IF2(100.0.0.1-200.0.0.1)
> 		 +----+
> 
> HA has physically two interfaces, IF1 and IF2.  In this case, IF2 has
> nothing to do with this scenario, I ignore it.  HA also has one tunnel
> interface IF3 between 200.0.0.1 and 100.0.0.1.
> 
> MN has physically one interface IF1, and one tunnel interface IF2
> between 100.0.0.1 and 200.0.0.1.
> 
> The draft says, MN receives a router advertisement for home link from
> HA via the tunnel interface IF2.  However I think it is difficult,
> since HA must have two different interfaces and those interfaces must
> be assigned the same prefix (in this case, P::/64).  This means HA is
> required to support a kind of multi-link subnet technology.  (Or did I
> misread?)
> 

I think the draft meant virtual tunnel interface. The idea is that the
MN would setup the tunnel when it thinks it comes back home and when it is
away, it should disable the tunnel and thus not receive any HA adv.
It would require some special configuration on HA side. I don't know if that
is not possible or complicated - TJ and others in the design team may have
comments on that.

> If there is no physical home link, I think it is possible to configure.
> For example,
> 
>        +--+-+  IF1(200.0.0.1 - 100.0.0.1)
>        | HA |       P::1/64 (home address)
>        +--+-+
>        IF2|200.0.0.1 
> 	  |
>      ((Internet))
> 	  |
> 	  |
>        ---+---------+------------ visited link of MN tester Q::/64
> 	      	    |
> 	      	    |Q::100 (care-of address)
> 	      	 IF1|100.0.0.1
> 	      	 +--+-+
>        	       	 | MN |   IF2(100.0.0.1-200.0.0.1)
> 		 +----+
> 
> In this case, I see no problem.  However, this scenario requires as
> many home subnets as the number of mobile nodes, since HA must arrange
> different tunnel interface and home prefix for each mobile node.
> 

This scenario looks ok to me for adv. But not sure how HA would receive
packets from CN to relay to MN on a different tunnel.

Thanks,
-Samita

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "Ed Remmell" <[email-masked]>
Date: Fri, 24 Oct 2003 12:22:39 -0700

Gee, it seems like it will be difficult to test the "MN return-to-home"
and/or "MN move-from-home" scenarios this way, but no biggie, I'd prefer
if MIPv6 was deployed using virtual home networks implemented internal
to the HA anyways since that's a big simplification to MIPv6 protocol
operation. So, we probably won't test MN operation on the home link via
this remote testing, instead our MN will always be attached to a foreign
link. Still, you can get some good test coverage this way.

Thanks.
- Ed

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Samita Chakrabarti
> Sent: Friday, October 24, 2003 12:17 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Mip6] Mobile IPv6 Interop Testing Draft
> 
> 
> 
> 
> We need to discuss more and flush out the configuration of HA 
> and virtual home tunnel without changing the HA 
> implementation. Working group comments would be helpful for this.
> 
> > 
> I think the draft meant virtual tunnel interface. The idea is 
> that the MN would setup the tunnel when it thinks it comes 
> back home and when it is away, it should disable the tunnel 
> and thus not receive any HA adv. It would require some 
> special configuration on HA side. I don't know if that is not 
> possible or complicated - TJ and others in the design team 
> may have comments on that.
> 
> > If there is no physical home link, I think it is possible to 
> > configure. For example,
> > 
> This scenario looks ok to me for adv. But not sure how HA 
> would receive packets from CN to relay to MN on a different tunnel.
> 
> Thanks,
> -Samita
> 
> 
> Mip6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mip6
> 
> ---
> Incoming mail is certified Virus Free.
> Checked by AVG anti-virus system (http://www.grisoft.com).
> Version: 6.0.522 / Virus Database: 320 - Release Date: 9/29/2003
>  
> 

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.522 / Virus Database: 320 - Release Date: 9/29/2003

---

From: Keiichi SHIMA / 島慶一 <[email-masked]>
Date: Wed, 29 Oct 2003 18:56:20 +0900 (JST)

Hello,

From: Samita Chakrabarti <[email-masked]>
Subject: Re: [Mip6] Mobile IPv6 Interop Testing Draft
Date: Fri, 24 Oct 2003 12:17:18 -0700 (PDT)

> group comments would be helpful for this.

Yes, I agree that we need more discussion of the technology for
emulating home networks over the Internet.

> packets from CN to relay to MN on a different tunnel.

Are you considering any confliction between the tunnel described above
and a tunnel which is used for non-route optimized traffic?

If so, I think there is no problem.  Logically, MN and HA will have
two tunnel interfaces, one is for non route optimized traffic which is
IPv6 over IPv6 (which is not described in the figure above), the other
is for emulating a home network which is IPv6 over IPv4 (in the above
case.)

Best Regards,
---
Keiichi SHIMA
IIJ Research Laboratory <[email-masked]>
KAME Project <[email-masked]>