Subject: RE: On the NECESSITY of MIP for LMM (was Re: [Mipshop] WG Last Ca ll comments ...)

From: Soliman Hesham <[email-masked]>
Date: Thu, 30 Oct 2003 08:46:38 -0500

> The charter is what we have.  I am not arguing with that.

=> Ok, good to get this out of the way.

 > I have to confess that I haven't read the latest versions
 > of HMIPv6 drafts.  However, those ones that I did read,
 > were based on IPsec.  Requiring IPsec SAs, and hence IKE,
 > for LMM, may be a bit _heavy_.  No security flaws.  Just
 > impractical performance expectations and bloat of code.
 > 
 > Our HIP implementatation, including security and mobility,
 > is less than 15000 lines of code.  Take a typical IKE,
 > racoon, with 40000 loc, and typical MIPv6, MIPL, with
 > about 20000 loc.  Simplicity where, heh?  

=> Just to make sure we're not comparing apples and oranges.
MIPv6 is not actually required to get HMIPv6 to work.
A nomad can simply rely on HMIPv6 only (BU and BA +
understanding the MAP option is all you need in the 
MN, i.e. maybe a thousand lines of code). 

I agree that IKE's implementation is heavy, 
but we could easily use CGAs for HMIPv6 as well. We 
used IKE because it was the only available standard.

 > But, Hesham, do we need to take all these detours?  I have
 > promised, time permitting, to produce a version of the LMM
 > draft that has a broader scope.  Once I have completed that
 > (if I do), we could continue, couldn't we?

=> Sure. It's up to Gab to decide on the future of 
the requirements doc. But I don't have a problem
with continuing the discussion later.

Hesham

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: gabriel montenegro <[email-masked]>
Date: Fri, 31 Oct 2003 18:51:22 +0100

> with continuing the discussion later.

[Coming back online...]

Hmmm... It's up to the WG, not me. The WG decided already to work
on MIP based solutions, as we all know. This is why Pekka's clarification
regarding the title of the LMM document (adding "Mobile IP" or some such)
is very appropriate.

Beyond that, working on non-MIP solutions is very interesting (not being
sarcastic), but is not quite what we set out to do. Yes, we could recharter
and start down this path, but then any chances of making our already aggressive
schedule of milestones would go from slim to laughably negligible. I fear
that producing such an initial expanded document is not the issue (and may take Pekka
a few days, yes), but that getting folks to agree on it, on the terminology
used, the model, the tradeoffs with respect to the current proposals,
the security implications, etc, is the hidden pitfall that could take
a very long time to negotiate.

As WG member, I'd prefer to stick to the schedule (after all that's why
we have this IETF process of chartering and then doing the work).

Particularly, as Pekka's list of potential technologies that might
come in mind in the broadened discussion (MAST, I^3, an "upcoming
paper", etc) seems to be much much closer to research than to
engineering. And we happen to have a perfectly good venue for those
discussions:

   https://www1.ietf.org/mailman/listinfo/irtf-mobility-charter

That charter is now being discussed, the group is being formed, etc.
That is a much better place to work on such a framework document and I
urge you to do so.

So my take would be to recommend that folks do the general LMM work in the
aforementioned IRTF group.

Of course, if the MIPSHOP WG feels this is what it wants to do,
it's certainly possible, but we will have to recharter
and go through our AD's (who may have issues with such a proposal).

Other opinions?

-gabriel