Subject: [Mipshop] Why MAP tunnels packets to MN

From: "Sha Liu" <[email-masked]>
Date: Fri, 10 Oct 2003 14:55:14 +0800

Hi,
    In HMIPv6 draft, the MAP is required to tunnel packets that are sent to RCoA to LCoA. Why not just extend Type 2 Routing Header to contain RCoA and HoA? That is, when the MAP receives packets sent to RCoA, it change the destination address in IPv6 header to LCoA, add RCoA before HoA in the extended Type 2 Routing Header, and just forward these packets.
    Your comments will be highly appreciated!

Sha Liu
Oct 10, 20032*l†Šfj)bž	b²Ó"¦Èh¦'~Šà†Ûi³ÿðÃ
bz×è®æj)fjåŠËbú?š*l†Š

---

From: Soliman Hesham <[email-masked]>
Date: Fri, 10 Oct 2003 09:56:25 -0400

In HMIPv6 draft, the MAP is required to tunnel packets 
 > that are sent to RCoA to LCoA. Why not just extend Type 2 
 > Routing Header to contain RCoA and HoA? That is, when the 
 > MAP receives packets sent to RCoA, it change the destination 
 > address in IPv6 header to LCoA, add RCoA before HoA in the 
 > extended Type 2 Routing Header, and just forward these packets.

=> Routers are not allowed to modify packets en route. 
So the MAP cannot modify the content of the packet. 
This is a general architectural assumption in the Internet 
and breaking that can have ramifications that we may not be able to
know right now. In addition, if the packet is integrity
protected (e.g. AH) this approach won't work. 

Hesham

 > 
 > Sha Liu
 > Oct 10, 20032*l?Sfj)bz	b²Ó"¦Èh¦'~Sà?Ûi³ÿðÃ
 > bz×è®æj)fjåSËbú?s*l
 > 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop