Subject: RE: [Mipshop] 2 more WG LC comments on hmipv6

From: Soliman Hesham <[email-masked]>
Date: Tue, 25 Nov 2003 20:38:05 -0500

> Hesham,
 > 
 > I think I understand now what you are getting at, but there 
 > is still one
 > point:
 > 
 > > => I hope I clarified that part above. Basically any address
 > > is ok provided that no one else is using it. Therefore
 > > there is no need for special authorisation to use a particular
 > > address. This is because RCoAs are not stable addresses that MNs
 > > need to use to be reachable, it's just a CoA (effectively).
 > >
 > 
 > So what does the MAP use to determine the MN's identity? It has to be
 > something in the certificate and it has to be something 
 > that's in the BU so
 > it can be validated when the BU arrives. The HoA?

=> When it comes to authorisation, the MAP only needs the MN's 
identity for *one* reason: To know whether this MN can use 
the MAP "service" at all. The MAP does *not* need to know 
the MN's identity in order to authorise the use of an RCoA. 
Authorising the use of an RCoA depends on only one factor:
Is this RCoA already being used by someone? If yes
then no one can use it. If no, then anyone can use it.  

So to know that the MN can use the MAP "service" the
MAP can use the id in the certificate. However, 
to authorise the use of an RCoA, as I said, no identity
needs to be known. 

The MAP knows nothing about the MN's HoA.

Hesham

 >             jak

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Wed, 26 Nov 2003 11:29:22 -0800

> The MAP knows nothing about the MN's HoA.

I think this is a simple, sensible policy alternative, but it isn't clear to
me at this point that it is an alternative that every network provider would
want to follow. However, the topic about how to provide policy flexibility
for RCoA assignment isn't something we need to resolve now, so I'm not
opposed to having the document progress based on this, provided we record
this issue for investigation in MOBOPTS.

            jak