Subject: RE: [Mipshop] RE: [Mip6] Mobile IPv6 Interop Testing Draft

From: "Bound, Jim" <[email-masked]>
Date: Thu, 6 Nov 2003 10:37:21 -0500

This is fine optimization for lab or testing but don't expect production
MN's to do this or assume it in any specs std or operational.

/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Samita Chakrabarti
> Sent: Monday, October 27, 2003 2:27 PM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Mipshop] RE: [Mip6] Mobile IPv6 Interop Testing Draft
> 
> 
> 
> 
> > 
> >    5.3.1. Home Agent
> > 
> >     -  Company and contact information
> > 
> >     -  Home agent IPv6 address and the corresponding IPv4 
> addresses (if
> >        dual stack)
> > 
> > --> Is there more than one corresponding IPv4 address for one IPv6
> > address ?
> > 
> 
> 
> Actually listing IPv4 addresses are not necessary. But 
> sometimes knowing the corresponding IPv4 address helps in 
> finding out whether the node is dead or having trouble with 
> IPv6 connection. Thus one IPv4 address on the node should be 
> fine, I think.
>  
> >     -  List of home-addresses it assigns.  This list must 
> also indicate
> >        which home-addresses are presently used and which 
> are available.
> >        Example:
> >        HOA1 (used by KEIO Univ.- contact name)
> >        HOA2 (available)
> >        HOA3 (available)
> > 
> > --> Is there more than one home-address for one home agent ?
> > 
> 
> Yes. It depends on the administrator of the home-agent. I 
> assume, usually they would allow multiple mobile-nodes for testing.
> 
> 
> -Samita
> 
> 
> > 
> > -----Original Message-----
> > From: Samita Chakrabarti [mailto:[email-masked]]
> > Sent: 20 October 2003 19:54
> > To: [email-masked]; [email-masked]
> > Subject: [Mip6] Mobile IPv6 Interop Testing Draft
> > 
> > 
> > 
> > As per Basavaraj Patil's recommendation, a mip6-interop design team 
> > has been formed and the team has worked on producing the 
> first draft 
> > on the Mobile IPv6 remote interop testing requirements, 
> scenarios and 
> > procedures.
> > 
> > The draft has been submitted as an individual draft for
> > now, but it is targeting to be a working group draft in
> > the next revision. It is available through T.J Kniveton's webpage 
> > until the draft becomes available at the IETF directory.
> > 
> > 
> http://www.mipv6.org/specs/draft-kniveton->
mipv6-remote-testing-00.txt
> > 
> > 
> > Thanks.
> > 
> > The mip6-interop design team.
> > T.J Kniveton,
> > Basavaraj Patil,
> > Hesham Soliman,
> > Henrik Petander,
> > Samita Chakrabarti
> > 
> > 
> > _______________________________________________
> > Mip6 mailing list
> > [email-masked]
> > https://www.ietf.org/mailman/listinfo/mip6
> > 
> > _______________________________________________
> > Mipshop mailing list
> > [email-masked] https://www1.ietf.org/mailman/listinfo/mipshop
> > 
> 
> 
> _______________________________________________
> Mipshop mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mipshop
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 6 Nov 2003 10:19:06 -0800 (PST)

> MN's to do this or assume it in any specs std or operational.

Agreed. The draft only talks about the testing scenario. Perhaps it can
be clarified further in the document to avoid any confusion.

Thanks,
-Samita

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 6 Nov 2003 14:41:23 -0500

I don't think that is required I hope.  But we have a lot of people
banging on IPv6 issues that are good operational issues for
configuration and use that are not relative to the standard for writing
the code. But, is good input to implementors, and this point is very
useful.  We will never ship standards on time if we try to solve world
hunger and dictate to implementation (which will usually be ignored). We
have enough work to get the standards functions done correctly.  The
other thing is in my work from now on if I put little hints in specs
that are not really part of the standard I am going to put clear huge
text that this is not part of the standard but information for
implementors and operators.  Or something.

thanks
/jim

> Sent: Thursday, November 06, 2003 1:19 PM
> To: Bound, Jim
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [Mipshop] RE: [Mip6] Mobile IPv6 Interop Testing Draft
> 
> 
> 
> 
> > This is fine optimization for lab or testing but don't expect 
> > production MN's to do this or assume it in any specs std or 
> > operational.
> > 
> 
> Agreed. The draft only talks about the testing scenario. 
> Perhaps it can be clarified further in the document to avoid 
> any confusion.
> 
> Thanks,
> -Samita
> 
> 
> now, but 
> > > > it is targeting to be a working group draft in the next 
> revision. 
> > > > It is available through T.J Kniveton's webpage until the draft 
> > > > becomes available at the IETF directory.
> > > > 
> > > >