Subject: RE: [Mipshop] Last Call Comments on draft-ietf-mishop-hmipv6-00.t xt

From: Soliman Hesham <[email-masked]>
Date: Tue, 18 Nov 2003 21:13:22 -0500

> Ah, now I understand what you meant about location privacy.
 > 
 > Suppose the MN reverse tunnels to the MAP, with the outer 
 > packet having the
 > LCoA as the source, and the inner packet having the RCoA as 
 > the source. This
 > would achieve the same effect without the possibility of compromising
 > ingress filtering. 

=> This _is_ the way it works, but the flags are there to
tell the MN whether it is allowed to do so and how. 
You're advocating a single way of doing it. What do others think?

Hesham

This exposes the LCoA to eavesdroppers within the
 > administrative domain, however, the problem is no worse than 
 > with standard
 > MIPv6 in that regard between the HA and MH.
 > 
 > If the MN has done route optimization using the RCoA with 
 > the CN, there
 > should be not be a problem with double tunnel overhead, though on the
 > initial contact through the HA there might be if RO is not 
 > done immediately.
 > 
 >             jak
 > 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Greg Daley <[email-masked]>
Date: Wed, 19 Nov 2003 16:47:29 +1100

Hi Hesham,

> You're advocating a single way of doing it. What do others think?

While I guess that it won't take much to get the
P and I bits worked out (with text to clarify the
domain change), I'm not sure that it's giving as much
as it did before RR was a required part of the CN BU
solution.

If we're using HMIPv6 we'll often be using RO with CN's
because HMIPv6 is so much better for RO than MIPv6.
In this case, as was mentioned on MIP6 list today, there's
not as much to be gained using altcoa or RCoA as source address.

The protocol is an experimental one, but it's useful to
know what's core, and what's not. The reverse tunneling
solution is very close to the MIPv6 solution (good or bad).

So obviously it's up to you (and you may have further
reasons than I), but in my guess reverse tunneling is
both necessary and sufficient.

Greg.

---

From: "James Kempf" <[email-masked]>
Date: Wed, 19 Nov 2003 08:44:23 -0800

> both necessary and sufficient.

Correction, it is up to the Working Group. The Working Group has the last
word on what goes into a Working Group draft, and the chair is responsible
for calling concensus on it if the resolution of the issue isn't completely
obvious to the editor and the rest of the working group members.

            jak