Subject: Re: On the NECESSITY of MIP for LMM (was Re: [Mipshop] WG Last Call comments ...)

From: "James Kempf" <[email-masked]>
Date: Mon, 3 Nov 2003 10:00:01 -0800

Carl,

I'll restate my question to Gab: if the LMM requirements are not intended to
guide the IRTF work or the work in IETF, then what is the point of doing
them? If they are, and, as Gab has said, the IRTF work is intended to take a
wide view than just MIP, then what is the purpose of making the requirements
MIP specific?

            jak

----- Original Message ----- 
From: "Carl Williams" <[email-masked]>
To: <[email-masked]>
Sent: Friday, October 31, 2003 10:59 AM
Subject: Re: On the NECESSITY of MIP for LMM (was Re: [Mipshop] WG Last Call
comments ...)

>
> LMM requirement analysis was conducted in the MIP working
> group starting about Spring 2001.  Such analysis was focused
> on analysis of MIP signaling.  The discussion also was (at
> least) partially motivated by examination of existing LMM
> solutions that had been proposed at that time. Little (if
> any) discussion on LMM requirement analysis took into account
> a framework not based on MIP.  The resulting requirements
> evolved from these discussions.  Ref [1] in the requirement
> document captures and expands (greatly) from the discussion
> that the MIP group had on LMM requirements (it is also
> based on a MIP based framework).
>
> At around this time as well discussion on micro-mobility
> was happening in the seamoby working group. Documents
> were drafted there as well.
>
> While we can remove MIP specific language from the current
> LMM (MIP) requirement document, I wonder if that would
> result in a complete set of requirements that have been
> well thought out to take into account local mobility management
> schemes that are not based on MIP.
>
> I presented a couple of times in the IRTF generic LMM problem
> statement.  There are also many academic papers (Columbia
> University) that dig into this as well.  I talked with
> Thomas back in IETF (SLC) about the need for IRTF review
> of some of these issues and what was not happening in MIP
> working group.
>
> My recommendation is similar to Gabriel's in that I think that
> that the IRTF should do some work (at least scoping out the
> issues) and then proceed to make a recommendation to the
> IETF.  Such a recommendation may mean forming a new
> working group or re-chartering an existing working group(s)
> to take on work that is being recommended (if that is the outcome).
> The reason for taking this process is that I still have questions
> if the IETF has something to be engineer in mipshop
> other than what was already been worked on for past 3 (maybe
> 4 years). At that time LMM really was more experimental but
> IRTF had no group working on it.  Thus, it was done in
> the IETF MIP group. Also, micro-mobility was moved from MIP to
> seamoby to IRTF.  I think some initial recommendation from IRTF can
> happen in short order because much was done in the community
> already.
>
>

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 6 Nov 2003 10:40:37 -0500

Pekka,

Your logic truth table is valid.  But there is no point of LMM without
MIP?

/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Pekka Nikander
> Sent: Thursday, October 30, 2003 6:44 AM
> To: Soliman Hesham
> Cc: [email-masked]; [email-masked]
> Subject: On the NECESSITY of MIP for LMM (was Re: [Mipshop] 
> WG Last Call comments ...)
> 
> 
> Hesham,
> 
> >  > If I understand this correctly, this basically says that 
> the  > LMM 
> > protocol does not necessarily have anything to do with Mobile IP.
>                             ^^^^^^^^^^^
> > 
> > => I'm not sure that this implies that it has nothing to
> > do with MIP.
> 
> Please read more carefully.  It does say that the solution 
> does not *necessarily* have anything to do with Mobile IP.  
> In other words, that requirement makes it *possible* to 
> create solutions that have nothing to do with MIP.  (not 
> necessarily A implies possibly not A)
> 
> I did not say that it implies that it has nothing to do with 
> MIP; it only implies that there *exists* solutions that 
> fulfil the requirements but have nothing to do with MIP.
> 
> > It simply says that you should not modify
> > the HA and CN. At least, from memory, that was the intention.
> 
> Right.  And that requirement implies that there *exists* 
> solutions that are compatible with the requirements but have 
> nothing to do
> with MIP.   (Am I repeating myself, aren't I? :-)
> 
> In other words, since HA and CN must not be modified, and 
> since if a protocol is modified then both communicating 
> parties must be modified, the requirement says that MIP must 
> not be modified. Consequently, if MIP must not be modified, 
> there exist solutions that have nothing to do with MIP.  I 
> could make this argument formal, but it would not be easy to read.
> 
> >  > While it is certainly possible to fulfil this 
> requirement in  > a 
> > way that is very Mobile IP dependent, it is also certainly  
> > possible 
> > to fulfil this requirement with a protocol that does not  > 
> depend on 
> > Mobile IP at all.
> > 
> > => Of course.
> 
> So you agree with me above.
> 
> > But I guess you'd agree that when one writes
> > a document/paper the context is assumed from the title/intro. Which 
> > would mean that you don't have to restate that context in every 
> > sentence. That would make the document unreadable and 
> boring. So if we 
> > modify the title to one of Gab's suggestions and the abstract/intro 
> > already has the right context then I think that should be 
> sufficient.
> 
> I don't really understand what you are arguing.
> 
> What I am saying is basically what James and I tried to say 
> already before, even in a draft.
> 
>    WE SHOULD NOT RESTRICT OURSELVES to the Mobile IP blinders
>    when we are dealing with LMM.
> 
> Now even the requirements draft says that MIP must not be 
> modified by the LMM solutions, therefore making strictly less 
> reason to think narrowly and look at MIP based solutions.
> 
> In other words:
> 
>    There is no whatsover *technical* ground to require that the
>    IETF endorsed LMM solution MUST be MIP based.
> 
> It MAY be MIP based, of course.  There are no technical 
> reasons that prevent that.  OTOH, if there are simpler 
> solutions that have nothing to do with MIP, why don't we use them?
> 
> (Note that I am not advocating HIP here.  HIP is most 
> probably too heavy for LMM.  As is IPsec and AAA, too.  What 
> I have in mind is much simpler, to hopefully appear as a 
> paper soon. However, it would be waste of time to discuss it 
> here unless people get rid of their narrow-minded MIP-focused 
> blinders.)
> 
> --Pekka Nikander
> 
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Thu, 6 Nov 2003 10:58:00 -0500

James,

They are useful to guide vendors building MIPv6 total solutions in the
market too. Hence, important to mipshop now and fine if useful to IRTF.
But we need them here to support the real customer of the IETF and that
is the market.

/jim

> On Behalf Of James Kempf
> Sent: Monday, November 03, 2003 1:00 PM
> To: [email-masked]; [email-masked]
> Subject: Re: On the NECESSITY of MIP for LMM (was Re: 
> [Mipshop] WG Last Call comments ...)
> 
> 
> Carl,
> 
> I'll restate my question to Gab: if the LMM requirements are 
> not intended to guide the IRTF work or the work in IETF, then 
> what is the point of doing them? If they are, and, as Gab has 
> said, the IRTF work is intended to take a wide view than just 
> MIP, then what is the purpose of making the requirements MIP specific?
> 
>             jak
> 
> Subject: Re: On the NECESSITY of MIP for LMM (was Re: 
> [Mipshop] WG Last Call comments ...)
> 
> 
> >
> > LMM requirement analysis was conducted in the MIP working group 
> > starting about Spring 2001.  Such analysis was focused on 
> analysis of 
> > MIP signaling.  The discussion also was (at
> > least) partially motivated by examination of existing LMM solutions 
> > that had been proposed at that time. Little (if
> > any) discussion on LMM requirement analysis took into account a 
> > framework not based on MIP.  The resulting requirements 
> evolved from 
> > these discussions.  Ref [1] in the requirement document 
> captures and 
> > expands (greatly) from the discussion that the MIP group had on LMM 
> > requirements (it is also based on a MIP based framework).
> >
> LMM (MIP) 
> > requirement document, I wonder if that would result in a 
> complete set 
> > of requirements that have been well thought out to take 
> into account 
> > local mobility management schemes that are not based on MIP.
> >
> > of some of these issues and what was not happening in MIP working 
> > group.
> >
> > My recommendation is similar to Gabriel's in that I think that that 
> > the IRTF should do some work (at least scoping out the
> IETF.  Such a 
> > recommendation may mean forming a new working group or 
> re-chartering 
> > an existing working group(s) to take on work that is being 
> recommended 
> > (if that is the outcome). The reason for taking this 
> process is that I 
> > still have questions if the IETF has something to be engineer in 
> > mipshop other than what was already been worked on for past 3 (maybe

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 7 Nov 2003 11:53:37 -0500

gabriel,

thanks.  I agree IP layering is out of context.

/jim

> From: gabriel montenegro [mailto:[email-masked]] 
> Sent: Friday, November 07, 2003 11:51 AM
> To: Bound, Jim
> Cc: James Kempf; [email-masked]; [email-masked]
> Bound, Jim wrote:
> > LMM should be a living and learning document?  Is that your 
> point? If 
> > so I agree?
> 
> Sort of, yes. There's the lmm document under discussion which 
> we could add some caveats and limitations to before 
> publishing. Then there's other more general IP layer mobility 
> thinking, but I'm not convinced that should be initiated in the IETF.
> 
> -gabriel
> 
>