Subject: [Mipshop] Errata & Questions for Fast Handoff Draft Version 08.

From: [email-masked]
Date: Fri, 07 Nov 2003 21:53:01 +0800

1. Errata:
 
    Page 18, ICMP Fields/Code: should be 0, 1, 2, 3;
    Page 27, 6.3.3 "Type value for FBACK is 10", should be changed to
                           "Type value for FNA is 10";
 
2. Questions, welcome any comments. :)
 
   Page 19, Code Value =0, isn't it a must to provide New Prefix Information?
                 otherwise, no way to construct New CoA.
 
   Page 30, The LLA option, if the length is in 8 octets, there is no way to figure
                 out the valid length of link-layer length. for example, 802.3, link-layer
                 addr length is 6 octets, the valid length of the entire option is 9 octets,
                 but the length field must be filled with 2, because 9 is not a multiple of
                 8. Shouldn't we use PAD options, instead of  specify the link layer length
                 in this way?

   Page 31 6.4.4. for NAACK options,  if new Care-of address is supplied,
                is it implies that the nCoa's life-time is the same
                as the life time for the Prefix in the router advertisement?
                If so, I think it's better to state that.
 
--------------------------------------
Sun Peng (Ph.D)
Associate Scientist
Networking Department
Institute for Infocomm Research,
Republic of Singapore

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 11 Nov 2003 12:24:14 -0800

Hello Sun Peng,

thank you for the corrections. I have incorporated them
for the next version. Some replies below for your questions.

>                  otherwise, no way to construct New CoA.

Yes, we should change SHOULD to MUST.

>                  8. Shouldn't we use PAD options, instead of  specify the link layer length

Good point. Actually, I think none of the options need the Length field in the units of 8
octets.
So, we could change them all to octets if there are no objections.

>                 If so, I think it's better to state that.

Ok.
BTW, is a status of 0 necessary for NAACK, since it is expected to be sent
only when there is a collision ?

Thanks,

-Rajeev