Subject: RE: [Mipshop] The proposal for more generic LMM requirements

From: "Bound, Jim" <[email-masked]>
Date: Thu, 6 Nov 2003 11:10:19 -0500

this is useful to position your view too good job.  can you keep the
diff link alive for a bit so we can digest it is still useful (very
useful).  HIPI its still at BOF stage how can we put it in a spec?
peer entities ...........hmmmm need to think about that.  

did carl agree to work on this with you?

thanks
/jim

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Pekka Nikander
> Sent: Thursday, November 06, 2003 8:07 AM
> To: MIPSHOP WG
> Subject: [Mipshop] The proposal for more generic LMM requirements
> 
> 
> I promised some time ago to produce a set of "trivial"
> changes to Carl's LMM Requirements draft, to show that it
> is possible to produce a more generic draft that still 
> essentially has all the same requirements.  Now I managed to 
> make the most important changes, but unfortunately I am not 
> able to carefully proof read the result today, due to 
> personal reasons.
> 
> Anyway, the first attempt is available at the URLs below. 
> Probably the most important one is the first one, which is an 
> HTML file showing the two document side by side, with 
> differences highlighted.  Don't get scared awat by the high 
> amount of difference shown; the actual differences are small, 
> but the diff algorithm is stupid.  I am sorry but I don't 
> have any better tool at hand.
> 
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-p
re-Nov06-diff.html
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-p
re-Nov06.html
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-p
re-Nov06.txt
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-p
re-Nov06.xml

--Pekka Nikander

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "[email-masked]" <[email-masked]>
Date: Thu, 6 Nov 2003 18:10:08 -0500

I also have no strong preference either and I think we can
incorporate in the intro section some background 
behind of forming these requirements (goals) as was also
a suggestion by Gab.    

The other comment is that as we proceed to advance
HIPv6 to experimental (and in the future maybe PS?:)
this document gives some context to discussions we
had about LMM - even though those discussions had
MIP as a backdrop. The LMM requirements (goals) document
is advancing to informational RFC and as such can
server useful purposes - some of which Jim Bound
stated. 

Carl

Original Message:
-----------------
From: James Kempf [email-masked]
Date: Thu, 6 Nov 2003 15:01:56 -0800
To: [email-masked], [email-masked], [email-masked]
Subject: Re: [Mipshop] The proposal for more generic LMM requirements

Carl,

> My only comment with Pekka's document is that I still
> prefer to call these "requirements" and not "goals".
>

I have no strong preference either way, but if the document is not meant to
somehow be binding on future development in MOBOPTS, as Gab's comments have
indicated and as I believe would be prudient, then I think "goals" would be
a more accurate term. Requirements typically tend to imply binding
constraints on a design.

            jak

--------------------------------------------------------------------
mail2web - Check your email from the web at
http://mail2web.com/ .

---

From: "Bound, Jim" <[email-masked]>
Date: Fri, 7 Nov 2003 00:43:40 -0500

I will support you carl but have my doubts if the diffs add value.  I
agree on requirements. I want to see more of a commitment than just
goals is my reason.  

/jim

> On Behalf Of [email-masked]
> Sent: Thursday, November 06, 2003 5:57 PM
> To: [email-masked]; [email-masked]; 
> [email-masked]
> Pekka's changes are focused on making the requirements
> non-MIP specific - so the diffs give you an idea of
> how small those changes are.   There were a number of Last Call
> comments such as dealing with the security consideration 
> section that aren't dealt with here. 
> 
> I think if the working group is ok with making the
> document non-MIP specific then we should use this
> document to incorporate the other last call comments.
> 
> Date: Thu, 6 Nov 2003 14:42:44 -0800
> To: [email-masked], [email-masked]
> I looked through the diffs and they look fine to me. There 
> are a couple places where some minor editorial work might be useful.
> 
> I've got two comments on substance.
> 
> 1) The definition of the term "peer entities" doesn't quite 
> match what I think characterizes the HA in MIP. I would 
> recommend something like "potential participants in the 
> mobility management protocol", since that is what is really 
> at issue. The current definition applies to any node 
> exchanging IP packets with the mobile node, and some of those 
> may not in fact be participants in the mobility management 
> protocol (for example, a CN that doesn't implement RO).
> 
> 2) I still feel the security requirements are inadequate, but 
> I don't believe that should be dealt with in this draft. 
> However, I do believe the draft should make clear that more 
> work is required on security, with perhaps a qualifying 
> paragraph in the "Security Considerations" section to that effect.
> 
>             jak
> 
> ----- Original Message ----- 
> From: "Pekka Nikander" <[email-masked]>
> To: "MIPSHOP WG" <[email-masked]>
> Sent: Thursday, November 06, 2003 5:06 AM
> > I promised some time ago to produce a set of "trivial" changes to 
> > Carl's LMM Requirements draft, to show that it is possible 
> to produce 
> > a more generic draft that still essentially has all the same 
> > requirements.  Now I managed to make the most important 
> changes, but 
> > unfortunately I am not able to carefully proof read the 
> result today, 
> > due to personal reasons.
> >
> Probably the 
> > most important one is the first one, which is an HTML file 
> showing the 
> > two document side by side, with differences highlighted.  Don't get 
> > scared awat by the high amount of difference shown; the actual 
> > differences are small, but the diff algorithm is stupid.  I am sorry
> > but I don't have any better tool at hand.
> >
> >
> http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-
goals-00-pre-N
ov06-diff.html
re-N
ov06.html
re-N
ov06.txt
re-N
ov06.xml
> [email-masked] https://www1.ietf.org/mailman/listinfo/mipshop
>

--------------------------------------------------------------------
mail2web - Check your email from the web at http://mail2web.com/ .

---

From: Soliman Hesham <[email-masked]>
Date: Fri, 7 Nov 2003 04:03:03 -0500

> Anyway, it would also be OK without any other
 > specific example, just generic description of how
 > various solutions work.

=> If the WG sees benefit in throwing some ideas around
in the intro to open the reader's mind, I'd prefer your
suggestion above as opposed to picking a particular
solution (whatever it is) that is not an existing RFC.

 > 
 > > The use of the term peer entities is fine with me. 
 > 
 > James didn't like it.  Maybe "peer mobility entity"?

=> Ok, I really don't have a strong opinion on this. To
me it's the same because they are peers as far as the
mobility protocol is concerned (i.e. the context of the
draft).

Hesham

---

From: "[email-masked]" <[email-masked]>
Date: Fri, 7 Nov 2003 17:15:33 -0500

The requirement analysis discussions with respect
to LMM were very useful. I think that we should
not generalize what to do in IETF as a whole in
terms of requirements.  That should be left to
the individual working group and area.

It so happens that it worked out well with LMM.
The only issue here at the present is that 
MIP LMM is not being proposed to move on the
standards track and there is other related (non-MIP)
work going on in IRTF.  That is the only dilemma
we have at this point in terms of how to proceed.

Carl

Original Message:
-----------------
From: Vijay Devarapalli [email-masked]
Date: Fri, 07 Nov 2003 12:25:25 -0800
To: [email-masked], [email-masked],
[email-masked], [email-masked]
Subject: Re: [Mipshop] The proposal for more generic LMM requirements

agree strongly. infact I think we should discourage doing requirements
in any WG. if the problem statement is clear enough, I think there
is no need for a requirements document.

Vijay