Subject: RE: [Mipshop] RE: Last Call Comments on draft-ietf-mishop-hmipv6- 00.txt

From: Soliman Hesham <[email-masked]>
Date: Thu, 20 Nov 2003 23:21:35 -0500

> > => There is a default algorithm in the spec that you can
 > > use. The algorithm picks the furthest available MAP by default.
 > >
 > 
 > But I can't see any case where anything other than the 
 > default would be
 > picked. Can you give me an example?

=> I thought I did that already. When designing a system
(e.g. PPor PP2 or something else...) people can make 
use of this function based on their knowledge of the 
coverage areas and speed detection of the MN (i.e. utilising
the knowledge from their link layer) to design a specific
algorithm for their system. Therefore, having this field
there makes sense for these types of optimisations that 
can be done on a per-link basis. 

 > > => fast depends on the link layer/system that you're
 > > using and its coverage area size. To optimise any of
 > > this stuff people would need to optimise on a per-link
 > > basis. If an implementer can't/don't know how to/ disagree ...etc
 > > they can always stick with the default. The Dist is a tool
 > > that can be used for further optimisations when people
 > > are building systems.
 > >
 > 
 > Yes, that's my point. A mobile moving between networks can't 
 > formulate the
 > right decision criteria in the absence of this kind of 
 > information,   so it
 > would always use the default. 

=> So? if the information is absent they can do the default.
I really don't understand the problem here.

  I suppose one could obtain it 
 > with CARD, but
 > that would require an extension.

=> I'm not sure what is the relationship with CARD here. 

 > > => I don't understand this, there is zero chance of
 > > interoperability problems here. This is a configuration
 > > issue. What interoperability problem do you see?
 > >
 > 
 > Not that interoperability would fail, but simply that it would not be
 > possible for an operator to achieve the right partitioning 
 > of load because
 > there is not enough information conveyed by the function. A 
 > mobile from one
 > manufactuerer might have different rules for selecting a MAP 
 > than another.

=> As long as the actual number (for Dist) doesn't mean 
anything and only the relative values mean something within
the same operator network, I can't see how having different
algorithms would make things worse. If you have a specific
case you can share it so we can address this.

 > 
 > Anyway, I agree with Gab that this preference number 

=> I thought you're talking about Dist!!! Not the Pref???
Based on the discussion so far I can't see any reason for
removing the Dist field. Definitely no such comment was made
on the Pref field... I don't know which one you are talking
about now though.

   should 
 > be dropped for
 > now if it would not be too difficult to include it back in 
 > later when it is
 > better defined. I believe it would be a worthwhile effort to 
 > try to figure
 > out how one could provide a mobile with enough information 
 > to achieve a
 > proper load balancing, perhaps through a CARD extension or 
 > something like
 > that, but that should be done in MOBOPTS.

=> I'm extremely confused by your remarks on load balancing
in reference to the Dist field. The two have nothing to do with
each other. Please be clear about the field you are talking about. 
I'm also just as confused about the remarks related to CARD when it 
comes to anything in the MAP option (or HMIPv6 for that matter). 

Hesham

 >             jak

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Fri, 21 Nov 2003 10:22:47 -0800

Hesham,

Sorry, I misstated. Yes, I did mean that I agree with Gab's comments on the
Dist field, not preferences.

Since the extent of WG concensus on this issue is not clear to me, I'd like
for the Chair to do a WG concensus call on this issue once discussion has
been concluded.

Thanx.

            jak

----- Original Message ----- 
From: "Soliman Hesham" <[email-masked]>
To: "'James Kempf'" <[email-masked]>; "'gabriel montenegro'"
<[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, November 20, 2003 8:21 PM
Subject: RE: [Mipshop] RE: Last Call Comments on
draft-ietf-mishop-hmipv6-00.txt