Subject: Re: [Mipshop] The proposal for more generic LMM requirements

From: "[email-masked]" <[email-masked]>
Date: Thu, 6 Nov 2003 17:57:12 -0500

Pekka's changes are focused on making the requirements
non-MIP specific - so the diffs give you an idea of
how small those changes are.   There were a number of Last Call
comments such as dealing with the security consideration
section that aren't dealt with here. 

I think if the working group is ok with making the
document non-MIP specific then we should use this
document to incorporate the other last call comments.

My only comment with Pekka's document is that I still
prefer to call these "requirements" and not "goals".

Carl

Original Message:
-----------------
From: James Kempf [email-masked]
Date: Thu, 6 Nov 2003 14:42:44 -0800
To: [email-masked], [email-masked]
Subject: Re: [Mipshop] The proposal for more generic LMM requirements

I looked through the diffs and they look fine to me. There are a couple
places where some minor editorial work might be useful.

I've got two comments on substance.

1) The definition of the term "peer entities" doesn't quite match what I
think characterizes the HA in MIP. I would recommend something like
"potential participants in the mobility management protocol", since that is
what is really at issue. The current definition applies to any node
exchanging IP packets with the mobile node, and some of those may not in
fact be participants in the mobility management protocol (for example, a CN
that doesn't implement RO).

2) I still feel the security requirements are inadequate, but I don't
believe that should be dealt with in this draft. However, I do believe the
draft should make clear that more work is required on security, with perhaps
a qualifying paragraph in the "Security Considerations" section to that
effect.

            jak

----- Original Message ----- 
From: "Pekka Nikander" <[email-masked]>
To: "MIPSHOP WG" <[email-masked]>
Sent: Thursday, November 06, 2003 5:06 AM
Subject: [Mipshop] The proposal for more generic LMM requirements

> I promised some time ago to produce a set of "trivial"
> changes to Carl's LMM Requirements draft, to show that it
> is possible to produce a more generic draft that still
> essentially has all the same requirements.  Now I managed
> to make the most important changes, but unfortunately I
> am not able to carefully proof read the result today, due
> to personal reasons.
>
> Anyway, the first attempt is available at the URLs below.
> Probably the most important one is the first one, which
> is an HTML file showing the two document side by side,
> with differences highlighted.  Don't get scared awat by
> the high amount of difference shown; the actual differences
> are small, but the diff algorithm is stupid.  I am sorry
> but I don't have any better tool at hand.
>
>
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-pre-N
ov06-diff.html
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-pre-N
ov06.html
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-pre-N
ov06.txt
http://www.tml.hut.fi/~pnr/MIPSHOP/draft-nikander-mipshop-lmm-goals-00-pre-N
ov06.xml
>
> --Pekka Nikander
>
>
> _______________________________________________
> Mipshop mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/mipshop
>

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

--------------------------------------------------------------------
mail2web - Check your email from the web at
http://mail2web.com/ .

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Thu, 6 Nov 2003 15:01:56 -0800

Carl,

> prefer to call these "requirements" and not "goals".

I have no strong preference either way, but if the document is not meant to
somehow be binding on future development in MOBOPTS, as Gab's comments have
indicated and as I believe would be prudient, then I think "goals" would be
a more accurate term. Requirements typically tend to imply binding
constraints on a design.

            jak

---

From: Vijay Devarapalli <[email-masked]>
Date: Fri, 07 Nov 2003 12:25:25 -0800

agree strongly. infact I think we should discourage doing requirements
in any WG. if the problem statement is clear enough, I think there
is no need for a requirements document.

Vijay