Subject: Re: On the NECESSITY of MIP for LMM (was Re: [Mipshop] WG Last Call comments...)

From: Pekka Nikander <[email-masked]>
Date: Fri, 31 Oct 2003 12:01:26 +0200

Carl and Jean-Michel,

Just to clarify:  I am not asking the requirements
draft to be extended to consider sub-IP mobility or
other micro-mobility schemes.

I am still talking about plain, IP layer mobility.
My point is that Mobile IP is only one IP layer mobility
method, admittedly the most mature one today, but not
the only one.

What I have been asking for is to *possibly* rewrite
the requirements document so that it would not mandate
MIP based solutions.  The main motivation is to allow
recycling of the requirements document for other work,
for *example*, MAST or HIP based LMM.  A related but
lesser motivation is that maybe we could later get IP
level LMM schemes that are not based on MIP but better
suited for the job at hand.  However, I am very well
aware that such work will not happen within the
current charter of this working group.

Anyway, I do definitely want the LMM requirements document
to say that the solution MUST be compatible with MIP, and
that the solutions considered MUST work at the IP layer
(and not below it).  The *only* thing that I do not like
is the requirements document to be solution specific from
the outset.  That limits its scope unnecessarily.

[Nit picking:  The keyword here is "necessity".  What
I tried to argue for is that there are no technical
reasons that necessitate the requirements document to say
that the solution MUST be based on MIP.  (The charter says
otherwise, and I am OK with the charter.)  Therefore it
is *unnecessary* to state that the solutions MUST be
based on MIP.  I argued that it would be trivial to
rewrite the document so that it allows other solutions.
I still aim to do that, time permitting.]

> I think (my opinion) is that we should move forward with
> the LMM requirements draft as is (given editorial changes
> suggested so far).  My concern is that a general requirements
> draft isn't as straight forward as is being stated.  The
> goal here is in advancing LMM in the context of mipshop
> - which has a charter based on MIP solutions.
> 
> But I am open to working with Pekka on generic requirements
> document if that is what the decision is. 

Very much now depends on the understanding of "generic".
To me it is generic in the sense that it does not limit
solutions to Mobile IP, but still works at the IP layer
and not by going below it.  MAST, HIP, LIN6 etc all
work, in this sense, at the IP layer.

--Pekka Nikander

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: gabriel montenegro <[email-masked]>
Date: Mon, 03 Nov 2003 06:45:01 +0100

Pekka Nikander wrote:
> ...I argued that it would be trivial to

Yes, you have. Perhaps sending those diffs to the lmm
document would be a more productive way out? We seem to
be caught in a loop.

With the diffs in front of us, the WG can decide how
minor or radical the changes are, whether the resultant
document still serves the original purpose, etc.

tnx,

-gabriel

---

From: Pekka Nikander <[email-masked]>
Date: Mon, 03 Nov 2003 08:38:58 +0200

gabriel montenegro wrote:

> document would be a more productive way out?

I agree.  I will send the diffs later this week.

To save everybody's work, I will first convert the
current draft from Word format to xml2rfc format,
taking care of the ID nits, and provide the result
to Carl.  (I am doing that right now.)  It is unclear
whether he or I will edit in the resolution for the
agreed upon last call issues, most probably he.

I will then produce a diff towards that version;
xml2rfc allows me to produce an HTML page that
shows the original and the modified draft, side
by side, with visual aides to see the diffs.

--Pekka Nikander

---

From: gabriel montenegro <[email-masked]>
Date: Mon, 03 Nov 2003 08:50:38 +0100

> by side, with visual aides to see the diffs.

Excellent, thanks. That means I don't have to send out the 9k worth
of nits output from checkpage.awk's look at the lmm
doc.

-gabriel