Subject: [Mipshop] a question about Fast MIPv6

From: "Makinen Juha" <[email-masked]>
Date: Tue, 09 Dec 2003 05:34:05 +0200

Hi,

I have a question about Fast MIPv6 draft.
According to section 6.3.2, destination IP address of FBack message is �gThe 
NCoA�h.
But, if NCoA contained in FBU is invalid and another NCoA (assigned by NAR) 
is included in FBack, which one is used as destination address, NCoA 
contained in FBU or NCoA contained in FBack (HAck)? I suppose neither of two 
can reach the MN.
Which address should I use?

--Juha

_________________________________________________________________
The new MSN 8: smart spam protection and 2 months FREE*  
http://join.msn.com/?page=features/junkmail

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Fri, 12 Dec 2003 16:52:26 -0800

Hi,

Makinen Juha wrote:

> According to section 6.3.2, destination IP address of FBack message is ?gThe
> NCoA?h.

In this case, since the MN has not received the FBack, it will send
FNA to NAR with the "tentative" NCoA, and receive an
error message containing the "valid" NCoA. (the error message itself
should be sent to "tentative" NCoA, _but_ using the MN's L2 Address)
This valid NCoA must be in HAck as well. So,  FBack should be sent to
NCoA in HAck.

Thanks,

-Rajeev