Subject: RE: [Mipshop] MIPSHOP discussion on new items and milestones

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Thu, 17 Mar 2005 14:41:20 -0600

I suppose one could say, as James said, that router certificate provisioning can be viewed as not requiring a full PKI. 

On another note, I can see the AAA-based solution being applicable to v4 fast handoffs as well, in addition to v6. The CGA-based approach is only applicable to v6. Probably not a critical point though. 

Vidya

-----Original Message-----
From: Jari Arkko [mailto:[email-masked]] 
Sent: Thursday, March 17, 2005 12:50 PM
To: Narayanan Vidya-CVN065
Cc: [email-masked]
Subject: Re: [Mipshop] MIPSHOP discussion on new items and milestones

Narayanan Vidya-CVN065 wrote:

>Jari,
>I am not sure if this is true. I think we need to support AAA-based key 
>derivation mainly because not everyone has deployed a PKI, while AAA infrastructure has been widely deployed. 3gpp2 relies a lot on AAA and so, there seems to be enough demand for a AAA-based solution.
>
>More than any technical advantages of a AAA-based approach, it seems to 
>me that the main advantage is in leveraging existing infrastructure.
>  
>
I agree with your arguments against PKI-based solutions. But where did PKI come from? I don't see a proposal on the table that is based on PKI. James' draft is not based on PKI. In fact, its based on completely zero-config security so it could run on any network, if I have understood correctly.

Note that I'm not trying to argue in favor of James' solution. I'm just reacting to the notion that we need multiple handover key solutions. Of course, we could have a situation where they have very different characteristics that lead to a requirement that we need to do both (e.g. AAA is very fast and James' draft is zero-config). Or that they are complementary in the same manner as home test and care-of test optimizations are in RR. But so far I have not seen anything that tells me this would be the case.

Lets document the different user impacts that demand two mechanisms, if there are any in this case. Otherwise lets just do one scheme, either AAA or James' thing.

--Jari

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Alper Yegin <[email-masked]>
Date: Thu, 17 Mar 2005 13:04:40 -0800

> The CGA-based approach is only
> applicable to v6. Probably not a critical point though.

Why is that so?

Alper

> >derivation mainly because not everyone has deployed a PKI, while AAA
> infrastructure has been widely deployed. 3gpp2 relies a lot on AAA and
so,
> there seems to be enough demand for a AAA-based solution.
> >
> I agree with your arguments against PKI-based solutions. But where did
PKI
> come from? I don't see a proposal on the table that is based on PKI.
> James' draft is not based on PKI. In fact, its based on completely
zero-
> config security so it could run on any network, if I have understood
> correctly.
> 
> Note that I'm not trying to argue in favor of James' solution. I'm
just
> reacting to the notion that we need multiple handover key solutions.
Of
> course, we could have a situation where they have very different
> characteristics that lead to a requirement that we need to do both
(e.g.
> AAA is very fast and James' draft is zero-config). Or that they are
> complementary in the same manner as home test and care-of test
> optimizations are in RR. But so far I have not seen anything that
tells me
> this would be the case.
> 
> 
> Lets document the different user impacts that demand two mechanisms,
if
> there are any in this case. Otherwise lets just do one scheme, either
AAA
> or James' thing.

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Mar 2005 23:20:35 +0200

>I suppose one could say, as James said, that router certificate provisioning can be viewed as not requiring a full PKI. 
Yes. I'm not sure if his handover key draft requires router certs, when I
looked at it again a couple of hours ago it didn't appear to do so. But
maybe it needs to, I don't know. In any case deployment of server-side
certs has proven to be relatively easy in many environments and 
applications,
e.g., web. I've had TLS server side root certs and path validation in
my cellphones for the last 3-4 years, for instance. This is quite
different from deploying client side certs. In fact, I don't know of any
client side cert deployment that would be of the magnitude that is
required for service providers. Private organizations yes, but millions
of customers no...

>On another note, I can see the AAA-based solution being applicable to v4 fast handoffs as well, in addition to v6. The CGA-based approach is only applicable to v6. Probably not a critical point thou…
Not sure if its a critical thing for MIPSHOP. But I personally believe 
dealing
with both v4 and v6 is important in almost any type of new Internet 
technologIy.

--Jari

---

From: Vijay Devarapalli <[email-masked]>
Date: Thu, 17 Mar 2005 13:19:29 -0800

>>applicable to v6. Probably not a critical point though.

not enough bits in the IPv4 address.

Vijay

>>>I am not sure if this is true. I think we need to support AAA-based
> 
> key
> 
>>>More than any technical advantages of a AAA-based approach, it seems
> 
> to
>

---

From: Jari Arkko <[email-masked]>
Date: Thu, 17 Mar 2005 23:23:47 +0200

Alper Yegin wrote:

>>applicable to v6. 
Because the resource that your are affecting in FMIP is
bound to an IP address, and CGA keys only work with
large enough addresses, i.e., IPv6.

--Jari

---

From: "James Kempf" <[email-masked]>
Date: Thu, 17 Mar 2005 13:28:09 -0800

> required for service providers. Private organizations yes, but millions

It requires them only so far as the MN requires a trust relationship with
the router as in SEND.

> >On another note, I can see the AAA-based solution being applicable to v4
fast handoffs as well, in addition to v6. The CGA-based approach is only
applicable to v6. Probably not a critical point though.
> with both v4 and v6 is important in almost any type of new Internet

Gab and Claude's paper in TISS has some ideas about how to extend
cryptographically verifiable identifiers to IPv4.* We could look into them
if there is interest in securing FMIPv4 with this kind of solution.

        jak

Gabriel Montenegro and Claude Castellucia, "Crypto-Based Identifiers
(CBIDs): Concepts and Applications", ACM Transactions on Information and
System Security, 7(1), Feb. 2004, pp. 97-127.