Subject: RE: [Mipshop] MIPSHOP discussion on new items and milestones

From: "Soliman, Hesham" <[email-masked]>
Date: Thu, 24 Mar 2005 13:34:56 -0500

Jari, 

I basically agree with your arguments. Given that 
we already have alternatives in MIP6 I don't think adding
better alternatives here would do any harm as long as they're backward 
compatible. This work has already happened over last couple of years 
and I think it's well understood. Even if it isn't, there is enough
people in this WG that would make it work.
So I agree that this should be included in the charter.

Hesham

 > Well, I think the question about the exact performance data
 > is very interesting. But its important to understand what
 > knowledge we have and don't have about the performance.
 > One thing we actually do know very well and don't need
 > to measure is the theoretical performance. For instance,
 > We know that CGA removes the need for per-movement
 > home address tests. The draft provides some data about
 > the impact of this in terms of amount of signaling under
 > different conditions. For instance, in the "stationary
 > mobile node" (!) case the savings are obviously significant.
 > In the fast moving mobile node case the savings are roughly
 > 50% over a longer period of time (when the cost of the
 > initial setup has been amortized). In some cases this can
 > be beyond 50% if a proactive home tests a la RFC 3775
 > is applied and the movement pattern happens to lead
 > to unnecessary tests.
 > 
 > These were in terms of number of messages. We also know
 > that latency is impacted. For instance, when the home
 > address test is eliminated then you get rid of one of
 > the parallel roundtrips in RR, which has an impact when
 > the roundtrip via home network is longer than to the CN.
 > 
 > We also know pretty well the theoretical performance of
 > CBA. As you know, we've also run some calculations using
 > TCP or HTTP traffic.
 > 
 > What is it then that we don't know well? As far as I can
 > see the primary open question mark is what exact
 > traffic patterns applications have in general, and
 > how well these fit to the opportunities provided by
 > our enhancements. We also can't accurately predict
 > what typical network topologies are going to be, say
 > in terms of home vs. direct route lengths. But while we
 > don't know these exactly, I do believe we have all the
 > basic understanding already. That is, we know very
 > well that an application of a particular type will benefit
 > from a certain enhancement and another type of an
 > application does not (e.g. very asymmetric and CBA).
 > Its just that we don't know what fractions of Internet
 > usage in mobile scenarios is going to be what kind of
 > applications. But this is a general problem, affecting
 > almost everything that we do, starting from RO itself,
 > fixed-key RR, local repair schemes, the whole thing.
 > 
 > In conclusion, I think we actually know quite a bit about
 > the performance, and what we don't know... it may not
 > necessarily be related to just what we are suggesting
 > here. I don't want to be the only one who is subjected to
 > the requirement to understand the full traffic patterns
 > before we can produce a new function that we know
 > will be useful in certain cases.
 > 
 > (Also, lets not talk too much about what other SDOs may
 > or may not want. We are at the IETF and this is our
 > technology. If there are WG members and vendors who
 > support something we should do it. And yes, many people,
 > including myself, are quite happy with RR. That doesn't
 > mean that there's no room for improvement or that it
 > works well under all circumstances.)
 > 
 > --Jari
 > 
 > 
 > _______________________________________________
 > Mipshop mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mipshop
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Wassim Haddad <[email-masked]>
Date: Thu, 24 Mar 2005 20:45:14 +0200 (EET)

> So I agree that this should be included in the charter.

=> Fully agree with you and with Jari.

Regards,

Wassim H.