Subject: Re: [Mipshop] MIPSHOP discussion on new items and milestones

From: Greg Daley <[email-masked]>
Date: Wed, 16 Mar 2005 21:23:11 +0000 (GMT)

Hi James,

----- Original Message -----
From: James Kempf <[email-masked]>
Date: Wednesday, March 16, 2005 7:20 pm
Subject: Re: [Mipshop] MIPSHOP discussion on new items and milestones

[chop!]
> > RR optimizations
> > ----------------
> > I must confess to me these seem less coherent and ready as a 
> > group than the above group. E.g., it's not clear to me whether
> > a standards-track document would end up mixing different
> > proposals, and how.
> >
> > - CGA type idea from OMIP
> > - CBA (credit-based) maybe no 'spot checks', just the basic stuff
> > as is being applied to HIP, for example. this could complement
> > other proposals like CGA or preconfigured MN-HA SA, for example.
> > - EBU - but have heard concern that this *increases* signaling cuz
> > it adds messages, what we want is less (not more) signaling.
> >
> 
> Well, I have some personal, hard to substantiate opinions on these, 
> but I am open to being proven wrong.
> 
> I do believe CGA type route optimization could be a win, but, again 
> there'sthe IPR issue. IPR has only been released for SEND, not for 
> MIP. I am not a big fan of credit-based, it seems a lot of
> complexity for very little gain, and it does nothing to remove
> the basic residual vulnerability in RR.

I think it's possible to have IPR'ed systems if they've got
IPR but are completely negotiable, and have non-IPR base protocols.

The number of eyes on IPR-ed documents will be lower though.

> I think we could use a little simulation work on the various 
> alternatives,hopefully from a couple of competing groups with the 
> simulation parameters and measurement metrics set in advance, so
> that we could have some kind of objective measurement about
> which of these techniques provide  benefit. That kind of work
> sounds more appropriate for MOBOPTS.

Eric Wu from our team has simulations of EBU, Base RR and something
new (not for MIPSHOP), in a submitted paper.
We may be able to provide some information (a graph?) for people to 
look at, and see if people need to look at preprints.

Is this interesting?

We could use this sort of information to determine what's good to 
test.

Personally the base EBU is fairly sound. 

I'd like to see CBA done transparently to the MN, though.

> IHMO, however, the real issue in RO security is finding a technique 
> thatremoves the residual vulnerability in RR, even if it might 
> require somewhat more heavyweight infrastructure. If it can be
> infrastructureless or with very minimal infrastructure, even better.

Sounds nice.

Perhaps this goes to the IRTF mobopts though.

Greg.

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "James Kempf" <[email-masked]>
Date: Wed, 16 Mar 2005 13:48:08 -0800

> look at, and see if people need to look at preprints.

Yes! 

I'd like to see something on credit-based as well.

> Perhaps this goes to the IRTF mobopts though.

Yes, I think so. Alternative RO security seems still IRTF material.

            jak

---

From: Wassim Haddad <[email-masked]>
Date: Thu, 17 Mar 2005 03:15:01 +0200 (EET)

> Personally the base EBU is fairly sound.

=> I disagree. The EBU is integrated in OMIPv6, which offers *in addition*
other features that EBU does not. What do you think about that?

Regards,

Wassim H.

---

From: Greg Daley <[email-masked]>
Date: Tue, 29 Mar 2005 13:55:24 +1000

Hi Wassim,

I've only just returned today, and am processing
direct replies last...

> On Wed, 16 Mar 2005, Greg Daley wrote:
[snip]
> other features that EBU does not. What do you think about that?

I think that OMIPv6 does a good job of Home Test elimination.

The redirection of packets to the HoA with the keepflow option
seems (to me) to be a really bad idea.

Certainly with OMIPv6 there's enough authority in the
packet to prove that the Home Address is the same, but
redirecting packets to the Home Address is looking in the
wrong direction.

For devices moving to topologically close access networks,
which are a non-trivial distance from the home network
(a situation where RO will be likely deployed), there may be
wild variations in RTT for packets passing to the home network.

In MIPv6 this first received signaling packet on the CN is
considered too dangerous to create a binding cache entry to.

Your own contention is that ingress filtering mitigates the
3rd party bombing issue to the extent that CoTI/CoT is not required.

While I do not agree with your contention, in if it is accepted,
the packet should go to the unconfirmed CoA.

Personally, I think that the first packet should be able to update
the binding to the new CoA, but in a way which allows Return
Routability to be completed while packet flow is underway.

That's what EBU achieves.

Certainly, I don't think it eliminates the advantages
or obviates the need for OMIPv6.

I'm pleased to see that they can fit so readily together.

Greg

---

From: Jari Arkko <[email-masked]>
Date: Tue, 29 Mar 2005 12:40:44 +0300

> I think that OMIPv6 does a good job of Home Test elimination.

Ok.

> seems (to me) to be a really bad idea.

I do see your argument. There are some tradeoffs, however, if
you consider packet loss and jitter as potentially conflicting
goals.

In any case, from the top-level viewpoint the existing optimization
proposals have grown up in an environment where its been
really hard to assume much about other available tools.
In particular, EBU/CBA relies on frequent home address tests,
not CGA; OMIP does its own tricks with reducing packet loss
while care-of tests are going on instead of using CBA.

But if we knew methods X and Y were going forward, we
could streamline the specifications by removing stuff that
other methods do better. For instance, CGA/OMIP could
concentrate on reducing signaling and removing home
tests; CBA could concentrate on cutting the latency of
care-of address tests.

I don't necessarily mean that the drafts should be tightly
bound to each other, or merged. But knowing what else
exists makes it easier to focus on what you do best.

> I'm pleased to see that they can fit so readily together.

Great!

--Jari

---

From: Greg Daley <[email-masked]>
Date: Wed, 30 Mar 2005 13:29:21 +1000

Hi Jari,

> exists makes it easier to focus on what you do best.

Indeed. Your point about conflicting goals is well made,
especially with TCP.

If there was a mechanism to explicitly select Home Address
redirection with EBU for instance, that would match well.

I'd guess that it would be a small change to redirect the
packet to the Home Address in EBU, if the OMIPv6 draft
authors believed it was a better place to put that text.

Certainly I think there are advantages in having them
separate documents, but I don't see much harm if there's
even informational references to each other (eventually).

Greg