Subject: RE: [Mipshop] final (?) list of MIPSHOP items for new charter

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 10 May 2005 14:09:38 -0400

Hi James,

 > I registered an objection. My objection was that there was 
 > no discussion in
 > MOBOPTS on security, as was done for FMIP. Until such a 
 > discussion occurs, I
 > cannot support moving HMIP to MIPSHOP for standards-track discussion.

=>ok. We discussed this at length in private emails 
with Gab and I thought this was resolved. I don't want to
repeat this unless you want to resend those private emails to the list
(I don't have a problem with it. So, if you and Gab are happy with sending them
publicly go ahead.).

So, since this is a WG effort I'll just rely on the WG
concensus process. If other reasons are raised or if other
people share James' concern let's discuss, but it seems
like I failed to make this clearer to James. 

For the record, and the benefit of the WG, I reiterate that
the security and Internet ADs had no problems with the 
security approach in the draft.

Hesham

 > 
 >             jak
 > 
 > ----- Original Message ----- 
 > From: "Soliman, Hesham" <[email-masked]>
 > To: <[email-masked]>; <[email-masked]>
 > Sent: Tuesday, May 10, 2005 8:24 AM
 > Subject: RE: [Mipshop] final (?) list of MIPSHOP items for 
 > new charter
 > 
 > 
 > Hi Gab,
 > 
 >  > I tried to have the smallest list of items for which I sensed some
 >  > enthusiasm. We could ask for explicit commitment from folks, but
 >  > basically, for those items I felt the WG would have enough people
 >  > to edit, review and comment. Frankly, I did not see much 
 > of a group
 >  > of folks who'd do that on the HMIP side of things. If I've got the
 >  > wrong impression, please speak up (I know about you Hesham).
 > 
 > => I guess my surprise is because you put the original
 > proposal and there was no objection to having the HMIP item.
 > People objected to lack of other items. People don't normally
 > come out to support something that's already in the charter, they
 > complain about what's missing. So, I'm confused as to what you
 > expected to see (and didn't) after you sent out the charter.
 > If you want to eliminate confusion maybe you should explicitly
 > ask for people's support of different items on the charter.
 > It's not clear how you made that decision.
 > 
 > Hesham
 > 
 > 
 >  >
 >  > -gabriel
 >  >
 >  > --- "Soliman, Hesham" <[email-masked]> wrote:
 >  > > Gab,
 >  > >
 >  > > I don't understand what happened to the HMIP doc you 
 > had initially.
 >  > > Why did this disappear?
 >  > >
 >  > > Hesham
 >  > >
 >  > >  > -----Original Message-----
 >  > >  > From: [email-masked]
 >  > [mailto:[email-masked]]On
 >  > >  > Behalf Of gabriel montenegro
 >  > >  > Sent: Tuesday, May 10, 2005 4:49 AM
 >  > >  > To: [email-masked]
 >  > >  > Subject: [Mipshop] final (?) list of MIPSHOP items for
 >  > new charter
 >  > >  >
 >  > >  >
 >  > >  > Folks,
 >  > >  >
 >  > >  > Based on the discussion, interest shown, etc, here's a
 >  > >  > reduced list of next
 >  > >  > milestone items. Other items, of course, could be added once
 >  > >  > progress on
 >  > >  > this list has been made.
 >  > >  >
 >  > >  > Further work on FMIPv6
 >  > >  > ----------------------
 >  > >  >
 >  > >  > - work on MN-AR security.
 >  > >  >
 >  > >  >    - AAA-based keys for handovers -
 >  > >  >
 >  > >  >    - derive key from SeND for fmip
 >  > >  >
 >  > >  > 2 documents
 >  > >  >
 >  > >  > - work on FMIPv6 itself:
 >  > >  >
 >  > >  > 1. common information elements for use by
 >  > >  > 802.11, fmip6, fmip4
 >  > >  > 2. local repair a la FBU/FBAck/FNA
 >  > >  > 3. IP transport of those information elements
 >  > >  > from the AR
 >  > >  > (PrRtXXX + CARD MN-AR ==> ICMPv6?)
 >  > >  >
 >  > >  > potentially two docs:
 >  > >  >
 >  > >  > - info elements (#1 above)
 >  > >  > - "FMIPv6" (#2 and #3)
 >  > >  >
 >  > >  > 2 documents
 >  > >  >
 >  > >  > RR optimizations
 >  > >  > ----------------
 >  > >  >
 >  > >  > - merge of CGA-OMIP and CBA
 >  > >  >
 >  > >  > 1 document
 >  > >  >
 >  > >  > Total:  5 documents
 >  > >  >
 >  > >  > I believe this captures what the WG wants and can reasonably
 >  > >  > do in the short term.
 >  > >  > Unless the list above is terribly broken, this is what I'd
 >  > >  > like to present to the
 >  > >  > AD's for approval.
 >  > >  >
 >  > >  > -gabriel
 >  > >  >
 >  > >  > _______________________________________________
 >  > >  > Mipshop mailing list
 >  > >  > [email-masked]
 >  > >  > https://www1.ietf.org/mailman/listinfo/mipshop
 >  > >  >
 >  > >
 >  > > ===========================================================
 >  > > This email may contain confidential and privileged
 >  > material for the sole use
 >  > >  of the intended recipient.  Any review or distribution by
 >  > others is strictly
 >  > >  prohibited.  If you are not the intended recipient please
 >  > contact the sender
 >  > >  and delete all copies.
 >  > > ===========================================================
 >  > >
 >  > >
 >  > > _______________________________________________
 >  > > Mipshop mailing list
 >  > > [email-masked]
 >  > > https://www1.ietf.org/mailman/listinfo/mipshop
 >  > >
 >  >
 > 
 > _______________________________________________
 > Mipshop mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mipshop
 > 
 > 
 > 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: gabriel montenegro <[email-masked]>
Date: Tue, 10 May 2005 15:14:48 -0700 (PDT)

Hesham,

Oh, I see, that list. As you know, that was not a final list
and MN-MAP security was not the only item I dropped. 
And the reason I dropped it was that I didn't get a sense that
a group of folks would be involved in that effort (editing is
required, but others also need to care about it, review it, 
provide feedback, read the drafts, etc). Perhaps they're out
there, but I didn't get the sense that (besides the authors)
folks would be involved in the process. If they're out there,
speak out!

Perhaps you wish we make this an explicit commitment on the part
of WG members with respect to every one of the items on the list?
We can certainly do that, but I won't unless folks really find it
would be useful (and express it!).

-gabriel

---

From: Greg Daley <[email-masked]>
Date: Wed, 11 May 2005 10:05:08 +1000

Hi Gab,

I'm happy to review a document for HMIPv6.
I'm also happy to contribute to one if time allows (it may not).

As far as commitments go for these and other items, what's
important is rough consensus and running code.

We'd need interest in these techniques being pushed
to customers to pass beyond experimental, IMHO
(maybe communicated privately).

If this means going to mobopts for a while to discuss security,
that OK as far as I can see, so long as the list of charter items
doesn't get locked down.

Greg

---

From: "Junghoon Jee" <[email-masked]>
Date: Wed, 11 May 2005 10:01:58 +0900

Hi Gabriel,
I am interested in the work of HMIP security.
I am willing to review it, provide feedback and read the drafts.

Regards,
Junghoon

> [mailto:[email-masked]] On Behalf Of gabriel montenegro
> Sent: Wednesday, May 11, 2005 7:15 AM
> To: Soliman, Hesham; James Kempf; [email-masked]; 
> [email-masked]
> Subject: RE: [Mipshop] final (?) list of MIPSHOP items for new charter
> 
> 
> Hesham,
> 
> And the reason I dropped it was that I didn't get a sense 
> that a group of folks would be involved in that effort 
> (editing is required, but others also need to care about it, 
> review it, provide feedback, read the drafts, etc). Perhaps 
> they're out there, but I didn't get the sense that (besides 
> the authors) folks would be involved in the process. If 
> they're out there, speak out!
> 
> Perhaps you wish we make this an explicit commitment on the 
> part of WG members with respect to every one of the items on the list?
> We can certainly do that, but I won't unless folks really 
> find it would be useful (and express it!).
> 
> -gabriel
> 
> >  > I registered an objection. My objection was that there was  > no 
> > discussion in  > MOBOPTS on security, as was done for FMIP. 
> Until such 
> > a  > discussion occurs, I  > cannot support moving HMIP to 
> MIPSHOP for 
> > standards-track discussion.
> > 
> > =>ok. We discussed this at length in private emails with Gab and I 
> > thought this was resolved. I don't want to repeat this 
> unless you want 
> > to resend those private emails to the list (I don't have a problem 
> > with it. So, if you and Gab are happy with sending them publicly go 
> > ahead.).
> > 
> > So, since this is a WG effort I'll just rely on the WG concensus 
> > process. If other reasons are raised or if other people 
> share James' 
> > concern let's discuss, but it seems like I failed to make 
> this clearer 
> > to James.
> > 
> > For the record, and the benefit of the WG, I reiterate that the 
> > security and Internet ADs had no problems with the security 
> approach 
> > in the draft.
> > 
> > Hesham
> > 
> >  > 
> >  >             jak
> >  >
> >  > From: "Soliman, Hesham" <[email-masked]>  > To: 
> > <[email-masked]>; <[email-masked]>  > Sent: 
> Tuesday, May 
> > 10, 2005 8:24 AM  > Subject: RE: [Mipshop] final (?) list 
> of MIPSHOP 
> > items for  > new charter  >  >  > Hi Gab,  >  >  > I tried 
> to have the 
> > smallest list of items for which I sensed some  >  > enthusiasm. We 
> > could ask for explicit commitment from folks, but  >  > 
> basically, for 
> > those items I felt the WG would have enough people  >  > to edit, 
> > review and comment. Frankly, I did not see much  > of a 
> group  >  > of 
> > folks who'd do that on the HMIP side of things. If I've got 
> the  >  > 
> > proposal 
> > and there was no objection to having the HMIP item.
> >  > People objected to lack of other items. People don't normally  > 
> > come out to support something that's already in the 
> charter, they  > 
> > complain about what's missing. So, I'm confused as to what you  > 
> >  > If you want to eliminate confusion maybe you should 
> explicitly  > 
> >  >  > > I don't understand what happened to the HMIP doc you  > had 
> > initially.
> >  >  > > Why did this disappear?
> >  >  > >
> >  >  > > Hesham
> >  >  > >
> >  >  > >  > From: [email-masked]  >  > 
> >  >  > >  > Behalf Of gabriel montenegro  >  > >  > Sent: 
> Tuesday, May 
> > 10, 2005 4:49 AM  >  > >  > To: [email-masked]  >  > >  > 
> Subject: 
> > [Mipshop] final (?) list of MIPSHOP items for  >  > new 
> charter  >  > 
> > >  >  >  > >  >  >  > >  > Folks,  >  > >  >  >  > >  > 
> Based on the 
> > discussion, interest shown, etc, here's a  >  > >  > 
> reduced list of 
> > next  >  > >  > milestone items. Other items, of course, could be 
> > added once  >  > >  > progress on  >  > >  > this list has 
> been made.
> >  >  > >  >
> >  >  > >  > Further work on FMIPv6
> >  >  > >  > ----------------------
> >  >  > >  >
> >  >  > >  > 1. common information elements for use by  >  > >  > 
> > 802.11, fmip6, fmip4  >  > >  > 2. local repair a la 
> FBU/FBAck/FNA  >  
> > > >  > 3. IP transport of those information elements  >  > 
> >  > from 
> > the AR  >  > >  > (PrRtXXX + CARD MN-AR ==> ICMPv6?)  >  > 
> >  >  >  > 
> > >  > potentially two docs:
> >  >  > >  >
> >  >  > >  > - merge of CGA-OMIP and CBA  >  > >  >  >  > >  > 1 
> > document  >  > >  >  >  > >  > Total:  5 documents  >  > >  
> >  >  > >  
> > > I believe this captures what the WG wants and can 
> reasonably  >  > >  
> > > do in the short term.
> > >  > >  > like to present to the  >  > >  > AD's for approval.
> >  >  > >  >
> >  >  > >  > -gabriel
> >  >  > >  >
> >  >  > > This email may contain confidential and privileged  >  > 
> > material for the sole use  >  > >  of the intended recipient.  Any 
> > review or distribution by  >  > others is strictly  >  > >  
> > prohibited.  If you are not the intended recipient please  >  > 
> > contact the sender  >  > >  and delete all copies.