Subject: RE: [Mipshop] HMIPv6 improvements in new list of MIPSHOP items for new charter

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 10 May 2005 18:27:46 -0400

> Oh, I see, that list. As you know, that was not a final list
 > and MN-MAP security was not the only item I dropped. 
 > And the reason I dropped it was that I didn't get a sense that
 > a group of folks would be involved in that effort (editing is
 > required, but others also need to care about it, review it, 
 > provide feedback, read the drafts, etc). 

=> But you didn't ask for that! In fact, the last correspondence
we had you asked me to produce a draft on this item. People don't
go unsolicited and support something that's already in the list.
I certainly didn't.

   Perhaps they're out
 > there, but I didn't get the sense that (besides the authors)
 > folks would be involved in the process. If they're out there,
 > speak out!

=> Ok, I don't know how you expected to get that sense...anyway, if someone
is reading this email, and feels like they can contribute
to HMIPv6 improvements please let the chair know.

 > Perhaps you wish we make this an explicit commitment on the part
 > of WG members with respect to every one of the items on the list?
 > We can certainly do that, but I won't unless folks really find it
 > would be useful (and express it!).

=> All I'm saying is that we can't (and shouldn't) read anything 
in your email other than what it says. Yes, it would seem more
logical to people if you ask or at least tell us about the numbers
you think are interested in each item, based on responses you 
received. Absent that, the decision seems like a guess without
prior justification or attempt to prove that it's a correct guess.

Hesham

 > 
 > -gabriel
 > 
 > --- "Soliman, Hesham" <[email-masked]> wrote:
 > 
 > > Hi James,
 > > 
 > > 
 > >  > I registered an objection. My objection was that there was 
 > >  > no discussion in
 > >  > MOBOPTS on security, as was done for FMIP. Until such a 
 > >  > discussion occurs, I
 > >  > cannot support moving HMIP to MIPSHOP for 
 > standards-track discussion.
 > > 
 > > =>ok. We discussed this at length in private emails 
 > > with Gab and I thought this was resolved. I don't want to
 > > repeat this unless you want to resend those private emails 
 > to the list
 > > (I don't have a problem with it. So, if you and Gab are 
 > happy with sending them
 > > publicly go ahead.).
 > > 
 > > So, since this is a WG effort I'll just rely on the WG
 > > concensus process. If other reasons are raised or if other
 > > people share James' concern let's discuss, but it seems
 > > like I failed to make this clearer to James. 
 > > 
 > > For the record, and the benefit of the WG, I reiterate that
 > > the security and Internet ADs had no problems with the 
 > > security approach in the draft.
 > > 
 > > Hesham
 > > 
 > >  > 
 > >  >             jak
 > >  > 
 > >  > ----- Original Message ----- 
 > >  > From: "Soliman, Hesham" <[email-masked]>
 > >  > To: <[email-masked]>; <[email-masked]>
 > >  > Sent: Tuesday, May 10, 2005 8:24 AM
 > >  > Subject: RE: [Mipshop] final (?) list of MIPSHOP items for 
 > >  > new charter
 > >  > 
 > >  > 
 > >  > Hi Gab,
 > >  > 
 > >  >  > I tried to have the smallest list of items for which 
 > I sensed some
 > >  >  > enthusiasm. We could ask for explicit commitment 
 > from folks, but
 > >  >  > basically, for those items I felt the WG would have 
 > enough people
 > >  >  > to edit, review and comment. Frankly, I did not see much 
 > >  > of a group
 > >  >  > of folks who'd do that on the HMIP side of things. 
 > If I've got the
 > >  >  > wrong impression, please speak up (I know about you Hesham).
 > >  > 
 > >  > => I guess my surprise is because you put the original
 > >  > proposal and there was no objection to having the HMIP item.
 > >  > People objected to lack of other items. People don't normally
 > >  > come out to support something that's already in the 
 > charter, they
 > >  > complain about what's missing. So, I'm confused as to what you
 > >  > expected to see (and didn't) after you sent out the charter.
 > >  > If you want to eliminate confusion maybe you should explicitly
 > >  > ask for people's support of different items on the charter.
 > >  > It's not clear how you made that decision.
 > >  > 
 > >  > Hesham
 > >  > 
 > >  > 
 > >  >  >
 > >  >  > -gabriel
 > >  >  >
 > >  >  > --- "Soliman, Hesham" <[email-masked]> wrote:
 > >  >  > > Gab,
 > >  >  > >
 > >  >  > > I don't understand what happened to the HMIP doc you 
 > >  > had initially.
 > >  >  > > Why did this disappear?
 > >  >  > >
 > >  >  > > Hesham
 > >  >  > >
 > >  >  > >  > -----Original Message-----
 > >  >  > >  > From: [email-masked]
 > >  >  > [mailto:[email-masked]]On
 > >  >  > >  > Behalf Of gabriel montenegro
 > >  >  > >  > Sent: Tuesday, May 10, 2005 4:49 AM
 > >  >  > >  > To: [email-masked]
 > >  >  > >  > Subject: [Mipshop] final (?) list of MIPSHOP items for
 > >  >  > new charter
 > >  >  > >  >
 > >  >  > >  >
 > >  >  > >  > Folks,
 > >  >  > >  >
 > >  >  > >  > Based on the discussion, interest shown, etc, here's a
 > >  >  > >  > reduced list of next
 > >  >  > >  > milestone items. Other items, of course, could 
 > be added once
 > >  >  > >  > progress on
 > >  >  > >  > this list has been made.
 > >  >  > >  >
 > >  >  > >  > Further work on FMIPv6
 > >  >  > >  > ----------------------
 > >  >  > >  >
 > >  >  > >  > - work on MN-AR security.
 > >  >  > >  >
 > >  >  > >  >    - AAA-based keys for handovers -
 > >  >  > >  >
 > >  >  > >  >    - derive key from SeND for fmip
 > >  >  > >  >
 > >  >  > >  > 2 documents
 > >  >  > >  >
 > >  >  > >  > - work on FMIPv6 itself:
 > >  >  > >  >
 > >  >  > >  > 1. common information elements for use by
 > >  >  > >  > 802.11, fmip6, fmip4
 > >  >  > >  > 2. local repair a la FBU/FBAck/FNA
 > >  >  > >  > 3. IP transport of those information elements
 > >  >  > >  > from the AR
 > >  >  > >  > (PrRtXXX + CARD MN-AR ==> ICMPv6?)
 > >  >  > >  >
 > >  >  > >  > potentially two docs:
 > >  >  > >  >
 > >  >  > >  > - info elements (#1 above)
 > >  >  > >  > - "FMIPv6" (#2 and #3)
 > >  >  > >  >
 > >  >  > >  > 2 documents
 > >  >  > >  >
 > >  >  > >  > RR optimizations
 > >  >  > >  > ----------------
 > >  >  > >  >
 > >  >  > >  > - merge of CGA-OMIP and CBA
 > >  >  > >  >
 > >  >  > >  > 1 document
 > >  >  > >  >
 > >  >  > >  > Total:  5 documents
 > >  >  > >  >
 > >  >  > >  > I believe this captures what the WG wants and 
 > can reasonably
 > >  >  > >  > do in the short term.
 > >  >  > >  > Unless the list above is terribly broken, this 
 > is what I'd
 > >  >  > >  > like to present to the
 > >  >  > >  > AD's for approval.
 > >  >  > >  >
 > >  >  > >  > -gabriel
 > >  >  > >  >
 > >  >  > >  > _______________________________________________
 > >  >  > >  > Mipshop mailing list
 > >  >  > >  > [email-masked]
 > >  >  > >  > https://www1.ietf.org/mailman/listinfo/mipshop
 > >  >  > >  >
 > >  >  > >
 > >  >  > > ===========================================================
 > >  >  > > This email may contain confidential and privileged
 > >  >  > material for the sole use
 > >  >  > >  of the intended recipient.  Any review or distribution by
 > >  >  > others is strictly
 > >  >  > >  prohibited.  If you are not the intended recipient please
 > >  >  > contact the sender
 > >  >  > >  and delete all copies.
 > >  >  > > ===========================================================
 > >  >  > >
 > >  >  > >
 > >  >  > > _______________________________________________
 > >  >  > > Mipshop mailing list
 > >  >  > > [email-masked]
 > >  >  > > https://www1.ietf.org/mailman/listinfo/mipshop
 > >  >  > >
 > >  >  >
 > >  > 
 > >  > _______________________________________________
 > >  > Mipshop mailing list
 > >  > [email-masked]
 > >  > https://www1.ietf.org/mailman/listinfo/mipshop
 > >  > 
 > >  > 
 > >  > 
 > > 
 > 
 > 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: gabriel montenegro <[email-masked]>
Date: Wed, 11 May 2005 11:22:51 -0700 (PDT)

--- "Soliman, Hesham" <[email-masked]> wrote:

> => But you didn't ask for that! 

Hesham,

Yes I did. From my initial email (url sent recently):

- is there interest in the proposals (e.g., are folks interested
	in deploying, perhaps because the proposal enables certain
	scenarios, is there interest from *more than one party*, etc)

This is also spelled out in rfc2418 for group formation (which applies to
rechartering as well as stated in that document):

    - Is there enough expertise within the IETF in the working group's
      topic, and are those people interested in contributing in the
      working group?

But I refuse to get into this game, cuz it really boils down to something
that should be acceptable to any IETF-er: there should be interest in a
work item, and that interest must be evident from archived exchanges.

How to measure if an exchange qualifies of enough interest? And how to 
measure this factor along with any others in determining whether an item
should be adopted or not? Or how to arrive at any decision?
One can try to spell it out, and one hopes it's documentable, archived,
etc., but ultimately it's called "judgement" and I reserve my right to use it.

> In fact, the last correspondence

Disagree. We work in a context. I refuse to have to spell out the entire
context each time. Some things I believe are obvious within the context.
This is one of them. 

I'm surprised you don't see it this way and I hope this is not indicative of
any issues we may have in the editing process later on. The better response
is to try to show that there is that interest, as you have done by prompting
for folks to speak out. I see now that there is some interest from other parties,
and in spite of one registered objection I'm willing to put it on the list.

We're up to six documents now. Let's work on milestones and charter now.

-gabriel