Subject: RE: [Mipshop] final (?) list of MIPSHOP items for new charter

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 10 May 2005 10:09:39 -0400

Gab, 

I don't understand what happened to the HMIP doc you had initially.
Why did this disappear?

Hesham

 > -----Original Message-----
 > From: [email-masked] [mailto:[email-masked]]On
 > Behalf Of gabriel montenegro
 > Sent: Tuesday, May 10, 2005 4:49 AM
 > To: [email-masked]
 > Subject: [Mipshop] final (?) list of MIPSHOP items for new charter
 > 
 > 
 > Folks,
 > 
 > Based on the discussion, interest shown, etc, here's a 
 > reduced list of next 
 > milestone items. Other items, of course, could be added once 
 > progress on 
 > this list has been made.
 > 
 > Further work on FMIPv6
 > ----------------------
 > 
 > - work on MN-AR security. 
 > 
 >    - AAA-based keys for handovers - 
 >  
 >    - derive key from SeND for fmip 
 > 
 > 	2 documents
 > 
 > - work on FMIPv6 itself:
 > 
 > 		1. common information elements for use by 
 > 802.11, fmip6, fmip4
 > 		2. local repair a la FBU/FBAck/FNA
 > 		3. IP transport of those information elements 
 > from the AR
 > 			(PrRtXXX + CARD MN-AR ==> ICMPv6?)
 > 
 > 	potentially two docs:
 > 
 > 	- info elements (#1 above)
 > 	- "FMIPv6" (#2 and #3)
 > 
 > 	2 documents
 > 
 > RR optimizations
 > ----------------
 > 
 > - merge of CGA-OMIP and CBA 
 > 
 > 	1 document
 > 
 > Total:  5 documents
 > 
 > I believe this captures what the WG wants and can reasonably 
 > do in the short term.
 > Unless the list above is terribly broken, this is what I'd 
 > like to present to the
 > AD's for approval.
 > 
 > -gabriel
 > 
 > _______________________________________________
 > Mipshop mailing list
 > [email-masked]
 > https://www1.ietf.org/mailman/listinfo/mipshop
 > 

===========================================================
This email may contain confidential and privileged material for the sole use
 of the intended recipient.  Any review or distribution by others is strictly
 prohibited.  If you are not the intended recipient please contact the sender
 and delete all copies.
===========================================================

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: [email-masked]
Date: Tue, 10 May 2005 12:35:22 -0500

Hi Gabriel,

The list looks good. And reasonable to expect success in getting them done.

-Basavaraj

> Behalf Of ext gabriel montenegro
> Sent: Tuesday, May 10, 2005 3:49 AM
> To: [email-masked]

---

From: "Soliman, Hesham" <[email-masked]>
Date: Tue, 10 May 2005 13:38:47 -0400

Sorry I sent the previous email to your old address. Here's a resend:

Hi Gab, 

Here is the email I was referring to.

Hesham

 > Sent: Wednesday, March 23, 2005 2:15 PM
 > To: [email-masked]
 > Subject: Re: [Mipshop] MIPSHOP discussion on new items and milestones
 > 
 > 
 > Folks,
 > 
 > Thanks for the excellent exchange so far. At this point, 
 > based on what I've
 > seen, I'd like to share with you how I'm seeing things.
 > 
 > 
 > MN-AR security
 > 	seems like there is sufficient interest and this item is
 > 	narrow enough to warrant further work on the SeND key
 > 	reuse method as well as to develop a AAA-based solution.
 > 	Whereas we believe there may be some IPR-issues to clarify
 > 	with the SeND based approach (in spite of Jim's interpretation)
 > 	we don't have the same clarity with respect to the AAA approach.
 > 	Please come forward with your IPR disclosures on this. 
 > This is not
 > 	optional.
 > 	
 > 	looking at 2 PS documents.
 > 
 > FMIPv6 itself
 > 	I'd postpone this item given that we don't have a clear 
 > understandiung
 > 	of what the exact relationship with DNA, CARD, 802.21 
 > and the forthcoming
 > 	neighborhood discovery is (and heck, there's even a 
 > proposal for dhcp).
 > 	I'm inclined not to include it for now
 > 	until we know more, and look into it again until a few 
 > months have
 > 	gone by and we have a better grasp of the security and 
 > the discovery
 > 	portions. The former to continue here, the latter to 
 > continue elsewhere
 > 	(e.g., mobopts).
 > 
 > FMIP-over-cdma
 > 	This experimental document is a useful exercise to 
 > better understand
 > 	deployment considerations and the above issues. It's 
 > also good in that
 > 	it encourages another SDO to seriously think about 
 > this, even if it is
 > 	in a preliminary manner (I don't believe they have 
 > firms and urgent
 > 	deployment plans). I have heard of at least two groups 
 > of folks in
 > 	the working group interested in this. You know who you 
 > are, and you
 > 	should work together on one document. Highly desirable: 
 > go through the
 > 	regular channels (ietf liaisons) and produce a document 
 > from 3GPP2
 > 	on this subject.
 > 
 > 	looking at one informational document
 > 
 > MN-MAP security for HMIPv6
 > 	I'd like to think that such an item could be included, 
 > but we do need to see
 > 	a draft on this subject in very short order. 
 > Conceptually, it does not seem
 > 	a much more difficult problem than MN-AR security, so 
 > depending on how quickly
 > 	the relevant draft can be produced, this could be 
 > entertained. It seems to me
 > 	that without this piece in place, talking about other 
 > HMIP work in MIPSHOP
 > 	is premature (but it should continue elsewhere). Like 
 > FMIP, other work could
 > 	be taken on later on.
 > 
 > 	perhaps (if a first solid draft appears shortly) one PS document
 > 
 > RO issues
 > 	Not clear how much of EBU is new and how much is just 
 > further language on
 > 	rfc 3775. At any rate, it does seem like a CGA-based 
 > scheme could be
 > 	worked on (heck, the basic concept has been around for 
 > ages), using
 > 	omip as a starting point. Highly desirable: go through 
 > the ietf channels
 > 	and using the proper liaisons obtain a message from the 
 > SDOs reputedly
 > 	interested in this item. This document would have the 
 > precondition for
 > 	CBA (authenticated notification of CoA change to the 
 > CN). Ideally, we'd
 > 	have a very simple CBA scheme in place as well.  Both 
 > of these mechanism
 > 	would be optional (i.e., we're not in the business of 
 > replacing RR).
 > 
 > 	looking at one PS document.
 > 	
 > 
 > This gives us a lot already, perhaps too much:
 > 	(up to) 4 PS documents (perhaps 3)
 > 	1 informational document
 > 
 > I don't think we want to take on any more load for now. As 
 > we complete
 > items, we will look into it (as we are doing now).
 > 
 > This may not be everybody's favorite list, but hopefully it 
 > works reasonably well
 > (or at least *maximizes the distribution of unhappiness*, as 
 > Brian put it at the plenary).
 > 
 > comments? close enough, way off?
 > 
 > -gabriel
 > 
 > 
 > 
 > 
 > 	
 > 

 > From: gabriel montenegro [mailto:[email-masked]]
 > Sent: Tuesday, May 10, 2005 1:24 PM
 > To: Soliman, Hesham; [email-masked]; [email-masked]
 > Subject: RE: [Mipshop] final (?) list of MIPSHOP items for 
 > new charter
 > 
 > 
 > 
 > --- "Soliman, Hesham" <[email-masked]> wrote:
 > 
 > > Hi Gab, 
 > > 
 > >  > I tried to have the smallest list of items for which I 
 > sensed some
 > >  > enthusiasm. We could ask for explicit commitment from 
 > folks, but 
 > >  > basically, for those items I felt the WG would have 
 > enough people
 > >  > to edit, review and comment. Frankly, I did not see 
 > much of a group
 > >  > of folks who'd do that on the HMIP side of things. If 
 > I've got the 
 > >  > wrong impression, please speak up (I know about you Hesham).
 > > 
 > > => I guess my surprise is because you put the original 
 > > proposal and there was no objection to having the HMIP item.
 > > People objected to lack of other items. People don't normally
 > > come out to support something that's already in the charter, they
 > > complain about what's missing. So, I'm confused as to what you
 > > expected to see (and didn't) after you sent out the charter.
 > > If you want to eliminate confusion maybe you should explicitly
 > > ask for people's support of different items on the charter. 
 > > It's not clear how you made that decision.
 > > 
 > > Hesham
 > 
 > I'm confused, so I went back in the archives.
 > Here's the original list:
 > 
 > http://www1.ietf.org/mail-archive/web/mipshop/current/msg00960.html
 > 
 > There was no mention of HMIPv6. There was a subsequent discussion in
 > which you brought it up, though. Is that what you were 
 > thinking about?
 > 
 > -gabriel
 > 
 > > 
 > >  > 
 > >  > -gabriel
 > >  > 
 > >  > --- "Soliman, Hesham" <[email-masked]> wrote:
 > >  > > Gab, 
 > >  > >

---

From: gabriel montenegro <[email-masked]>
Date: Tue, 10 May 2005 15:08:14 -0700 (PDT)

James,

Thanks for the feedback. Haven't thought much as I want to converge
on this *&&##% list first.

But my assumption is that we'd have first versions by Paris, and
then perhaps initial WG LC discussions for Vancouver.

-gabriel

--- James Kempf <[email-masked]> wrote:
> Gab,
> 
> This sounds like an excellent list. Have you thought about a schedule of
> completion?
> 
>            jak
> 
> ----- Original Message ----- 
> From: "gabriel montenegro" <[email-masked]>
> To: <[email-masked]>
> Sent: Tuesday, May 10, 2005 1:48 AM
> > Based on the discussion, interest shown, etc, here's a reduced list of
> next
> > milestone items. Other items, of course, could be added once progress on
> > this list has been made.
> >
> > Further work on FMIPv6
> > ----------------------
> >
> > 1. common information elements for use by 802.11, fmip6, fmip4
> > 3. IP transport of those information elements from the AR
> > I believe this captures what the WG wants and can reasonably do in the
> short term.
> > Unless the list above is terribly broken, this is what I'd like to present
> to the
> > AD's for approval.
> >
> > -gabriel
> >