Subject: [Mipshop] CGA-OMIPv6+CBA

From: Wassim Haddad <[email-masked]>
Date: Wed, 13 Jul 2005 03:03:17 +0300 (EEST)

Dear all,

FYI, v00 of the new draft combining (OMIPv6-CGA + CBA = OMIPv6) is already
available:

        Title           : Applying Cryptographically Generated Addresses
                          and Credit-Based Authorization to Optimize
                          Mobile IPv6 (OMIPv6)
        Author(s)       : J. Arkko, et al.
        Filename        : draft-arkko-mipshop-cga-cba-00.txt
        Pages           : 27
        Date            : 2005-7-12

   This memo suggests a new and enhanced route optimization security
   mechanism for Mobile IPv6 (MIPv6).  The primary motivation for this
   new mechanism is the reduction of signaling load and handoff delay.
   The performance improvement achieved is elimination of all signaling
   while not moving, and most of the per-movement signaling can be done
   when payload traffic flow has already been moved.

   A URL for this Internet-Draft is:
   http://www.ietf.org/internet-drafts/draft-arkko-mipshop-cga-cba-00.txt

Comments appreciated.

Regards,

Wassim H.

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Jari Arkko <[email-masked]>
Date: Wed, 13 Jul 2005 16:15:35 +0300

Yes. I'll add that the main changes are incorporation of
the basic version of CBA (not probing part) and getting
rid of some of things that people disliked in the earlier
CGA draft, such as routing via home during handoff.

In fact, we simplified the protocol quite a bit, even
getting rid of all new messages, it works now simply
with options in BUs. This is a slightly different complexity/
efficiency tradeoff than we had in the original draft, and
even us authors are a bit unsure if we went too far
in the simplification. Comments appreciated from the
WG.

Bonus offer for quick reviewers: We may be able to
revise the spec before the -01 deadline on monday,
if we get comments.

--Jari