Subject: [Mipshop] FMIPv6 - SPI in FBU for handover keys

From: Narayanan Vidya-CVN065 <[email-masked]>
Date: Wed, 20 Jul 2005 15:31:50 -0500

All,
While writing the draft on handover keys, we had to ensure that the key is tied to the CoA of the MN, so that the AR is able to retrieve the correct key for the MN upon receiving an FBU. This is due to the fact that there is currently no way to carry an SPI in the FBU. It will be a lot cleaner if there was a way for the MN to include an SPI in the FBU sent to the oAR, so that the AR can use that to look up the SA. 

We are wondering about the feasibility of such a thing, now that FMIPv6 is already an experimental RFC. Is it something we can explore? Does that make sense? 

Rajeev, James, we would like to talk to you both in greater detail about this in Paris - perhaps we can find a suitable time over lunch or after sessions one evening? 

Thanks,
Vidya

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Vijay Devarapalli <[email-masked]>
Date: Wed, 20 Jul 2005 17:05:35 -0700

> While writing the draft on handover keys, we had to ensure that the key is tied to the CoA of the MN, so that the AR is able to retrieve the correct key for the MN upon receiving an FBU. This is du…

maybe you could use
http://www.watersprings.org/pub/id/draft-perkins-mobileip-spi-00.txt

it was written a long time ago.

Vijay

---

From: [email-masked]
Date: Wed, 20 Jul 2005 16:41:08 -0700

Hi Vidya,
 
there will be rfc4068-bis, as we move towards PS.
So, it would be good to discuss this, especially since
there needs to be similar motivation from the SEND-based
security as well.
 
Thanks,
 
-Rajeev

________________________________

From: ext Narayanan Vidya-CVN065 [mailto:[email-masked]]
Sent: Wed 7/20/2005 4:31 PM
To: [email-masked]
Cc: Venkitaraman Narayanan-CNV002; 'Tschofenig, Hannes'; 'Gerardo Giaretta'; 'Julien Bournelle'; Koodli Rajeev (Nokia-NRC/MtView); 'James Kempf'
Subject: FMIPv6 - SPI in FBU for handover keys

All,

Thanks,
Vidya