Subject: [Mipshop] Questions about wireless card selecting

From: [email-masked]
Date: Thu, 28 Jul 2005 17:48:45 +0800 (CST)

Hi all,<p><p>I was carrying on a project of FMIPv6.<p><p>And I have tried several wireless card, but none of them handover very fast ( in Layer 2). Suppose we have two APs, and both are connected to 192.168.0.1. Now we have a MN, firstly, it connects to AP1, and MN pings 192.168.0.1. And then we let MN connects to AP2, after 4~5 seconds, MN's ping packets can reach 192.168.0.1 again, and it loses 4~5 ping packets. It seams that the handover time is too much.<p><p>So could please suggest some kinds of wireless cards which should<p>1. support Linux<p>2. support 802.11b<p>3. can handover fast (in layer 2)<p>4. possible to support FMIPv6 ( I mean it provide L2 events such as link up )<p><p>Thanks.<p><p>Gary.

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Syam Madanapalli <[email-masked]>
Date: Thu, 28 Jul 2005 16:58:04 +0530

Hello Gary,

> Hi all,
> I was carrying on a project of FMIPv6.
> And I have tried several wireless card, buut none of them handover very 
> fast ( in Layer 2).
> Suppose we have two APs, and both are connected to 192.168.0.1. Now we 
> have a MN,
> firstly, it connects to AP1, and MN pings 192.168.0.1. And then we let MN 
> connects to AP2,
> after 4~5 seconds, MN's ping packets can reach 192.168.0.1 again, and it 
> loses 4~5 ping
> packets. It seams that the handover time is too much.

I think it is reasonable for 4 - 5 seconds handoff time. The latency split 
coul be

1. Detection to decide to move:
This may take upto 3 seconds depending on the decision making logic. If the
WLAN cards povides signal strength and if it makes decision to move based
on the signal strength then this part of latency can be made zero.

2. Scanning par neigborhood APs:
    This may take upto 1 second, again it will depend on the type of the 
scan.
    If it does active scanning it can complete this phase in <300 ms.

3. Association/joining: this will just take few milliseconds.

> So could please suggest some kinds of wireless cards which should
> 1. support Linux
> 2. support 802.11b
> 3. can handover fast (in layer 2)
> 4. possible to support FMIPv6 ( I mean it provide L2 events such as link 
> up )

Even though I cannot suggest any WLAN card, you may want tweak the driver
to avoid the latency for the first part. If you can do that, you can do the 
hand of
within 500 ms.

-Syam

> Thanks.
> Gary.