Subject: [Mipshop] Code field in Hack-- "not valid" and "in use" addresses

From: "GAABAB Brahim RD-CORE-CAE" <[email-masked]>
Date: Mon, 12 Sep 2005 15:54:03 +0200

Hello,

Are there any differences between two terms:
- not valid address
- address in use

The HAck message defines two different codes for both cases (1 not
valid, 2 in use).

Is "not valid"  used to refer to the case where proposed nCoA do not
match prefixes in use by the concerned nAR ?

Thanks,
Brahim.
_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: "jaehwoon" <[email-masked]>
Date: Tue, 13 Sep 2005 15:38:52 +0900

Code field in Hack-- "not valid" and "in use" addressesHi!

In FMIPv6, even though MN moves from PAR to NAR,
if MN does not send the BU message containg NCoA and its HA,
then HA/CN may send the packet to MN with PCoA as its destination address.
Therefore, packets sent by HA/CN is transmitted to MN via PAR and NAR
until MN sends BU message and the message is processed by HA/CN.
That is, the route is HA/CN -> PAR -> NAR -> MN.
When MN sends the BU message and the message is processed by HA/CN,
then the route becomes HA/CN -> NAR -> MN and the destination address of
the packet becomes NCoA.

However, if HA/CN sends packets to MN before receiving and after processing 
the BU message,
then MN may receive packets with the destination address as NCoA and PCoA
in a mixed way.
That is, in FMIPv6 there is a possibility of packet's out-of-order.

Could anyone tell me whether the the effect of packet's out-of-order is
significant or not, especially when MN moves from cellular to WLAN
or moves from Wimax to WLAN etc.

Regards,

Jaehwoon