Subject: RE: [Mipshop] FMIPv6 - NAR sets up tunnel endpoint?

From: "GAABAB Brahim RD-CORE-CAE" <[email-masked]>
Date: Tue, 20 Sep 2005 13:21:49 +0200

> De : Rajeev Koodli
> 
> GAABAB Brahim RD-CORE-CAE wrote:
> > 
> > I've forgot to mention this hypthesis: the nCoA used for FNA is 
> > different of the one sent at pAR link. Nothing prohibits 
> this in the 
> > spec.
> > Even if both nCoA are similar, accepting the nCoA after 
> rejecting it 
> > first is possible? may be rarely..
> 
> hmm.. Sounds strange. When NAR verifies [NCoA, LLA] in FNA, 
> it must know that tunnel for PCoA is set up due to HI/HAck 
> exchange, which is used so that there is no "loss of memory" :-)
> 
> -Rajeev

OK Rajeev, so nAR uses LLA (but not the nCoA) to find if a tunnel was
established for pCoA.
I think nCoA cannot be used by the nAR to find such tunnel unless the
spec explicitly mentions that MN must re-use in its FNA the same
prospective nCoA as the one sent in proactive FBU.

Regards,
Brahim.

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Tue, 20 Sep 2005 14:46:21 -0700

> prospective nCoA as the one sent in proactive FBU.

Well, the NCoA, LLA tuple is assumed throughout.
I can try stating it in some place.

Thanks,

-Rajeev