Subject: RE: [Mipshop] FMIPv6 - NAR sets up tunnel endpoint?

From: "GAABAB Brahim RD-CORE-CAE" <[email-masked]>
Date: Thu, 15 Sep 2005 11:11:37 +0200

Hi Rajeev, James,

In the case where no nCoA can delivered in an FBA received at the pAR link, the protocol operation results in two tunnels : first pAR-nAR after the end of the first HI/HAck, then pAR-nCoA after the 'successful' FBU/FBA at nAR link.

I agree with James : here we have unecessarily established the second tunnel (pAR-nCoA). IMO, there are two possibilities to deal with this :
 1. pAR and nAR delete the pAR-nAR tunnel (and corresponding host routes) after the second 'succesful' HI/HAck
 2. MN do not engage in the second FBU/FBA

Regards,
Brahim.

> De : Rajeev Koodli
> Envoyé : jeudi 15 septembre 2005 01:58
> À : James Kempf
> Cc : GAABAB Brahim RD-CORE-CAE; [email-masked]; Alexandru Petrescu
> Objet : Re: [Mipshop] FMIPv6 - NAR sets up tunnel endpoint?
> 
> 
> Hi Jim,
> 
> the PAR - NCoA is the default, normal, _predominant_ mode of 
> operation, and is required.
> 
> PAR - NAR tunnel is the fallback case when NCoA is not 
> supported by NAR for whatever reason. This feature is a MAY. 
> Sorry if this was not clear from my previous message.
> 
> 
> -Rajeev
> 
> 
> James Kempf wrote:
> > Rajeev,
> > 
> > Is there any reason why we couldn't simplify the protocol 
> by getting 
> > rid of either the PAR-NAR tunnel or the PAR-NCoA tunnel?
> > 
> >            jak
> > 
> > ----- Original Message ----- From: "Rajeev Koodli" 
> > <[email-masked]>
> > To: "GAABAB Brahim RD-CORE-CAE" <[email-masked]>
> > Cc: <[email-masked]>; "Alexandru Petrescu" 
> > <[email-masked]>
> > Sent: Wednesday, September 14, 2005 11:20 AM
> > Subject: Re: [Mipshop] FMIPv6 - NAR sets up tunnel endpoint?
> > 
> > 
> >>
> >> Folks,
> >>
> >>
> >> GAABAB Brahim RD-CORE-CAE wrote:
> >>
> >>>
> >>>> It is not clear from the document that the tunnel 
> destination for 
> >>>> PAR's tunnel endpoint can be either NAR's address or 
> NCoA's address.
> >>>>
> >>>
> >>>
> >>> There is no information about this in the spec !
> >>>
> >>
> >>
> >> Page 11, in the paragraph beginning with "After a PrRtAdv.."
> >>
> >> "In response to the
> >>    FBU, the PAR establishes a binding between PCoA ("Home 
> Address") and
> >>    NCoA, and sends the FBack to the MN.  Prior to establishing this
> >>    binding, PAR SHOULD send an HI message to NAR, and 
> receive HAck in
> >>    response."
> >>
> >> This is for PAR - NCoA tunnel.
> >>
> >> The PAR - NAR tunnel is also established in the same way 
> depending on 
> >> the HI/HAck exchange. I guess we need to add a specific 
> code value to 
> >> indicate host route support for PCoA and tunnel end-point 
> being NAR.
> >> Some context: the implicit assumption has been that 
> support for PCoA 
> >> on NAR should be a rare case.
> >>
> >> Thanks,
> >>
> >> -Rajeev
> >>
> >>
> >>> _______________________________________________
> >>> Mipshop mailing list
> >>> [email-masked]
> >>> https://www1.ietf.org/mailman/listinfo/mipshop
> >>
> >>
> >>
> >> _______________________________________________
> >> Mipshop mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/mipshop
> >>
> > 
> > 
> > 
> > _______________________________________________
> > Mipshop mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/mipshop
> 
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 15 Sep 2005 12:17:49 -0700

If the MN leaves without receiving FBack (in which indication to use 
PCoA is present), it sends FNA[FBU]. In this case, rules described on 
Page 13 apply. (See "When the NCoA corresponding to the FNA.."

And see:

"If the MN receives a Router Advertisement with a NAACK option, it
    MUST use the IP address, if any, provided in the NAACK option.
    Otherwise, the MN should configure another NCoA.  Subsequently, the
    MN SHOULD send an FBU using the new CoA.  **As a special case, the
    address supplied in NAACK could be PCoA itself, in which case the MN
    MUST NOT send any more FBUs.**"

So, the result is that the second tunnel you mention below is not 
established.

Regards,

-Rajeev

GAABAB Brahim RD-CORE-CAE wrote:
>>Envoyi : jeudi 15 septembre 2005 01:58
>>@ : James Kempf