Subject: [Mipshop] Packet forwarding in FMIPv6

From: "Hongseok, Jeon" <[email-masked]>
Date: Fri, 9 Sep 2005 14:27:34 +0900

Hi Rajeev,

>>"To reduce the Binding Update latency, the protocol specifies a 
>>binding between the Previous CoA (PCoA) and the NCoA."

In RFC3775,  "binding"  means an association between HoA and CoA
and is referred for bidirectional tunneling. 
 
If "binding" in FMIPv6 presents same meaning as that in RFC3775, 
PAR encapsulates packets destined for PCoA with outer IPv6 header destined to NCoA
and sends those encapsulated packets to MN via NAR.

Followings depict packets transmission in such a case; 
--------------------------------------------------------------------------------------------
When MN is receiver,
incoming packet (dst:PCoA, src: CN or HA) 
=> encapsulation in NAR (dst:NCoA, src:PAR) + (dst:PCoA, src: CN or HA)
=> decapsulation in MN (dst:PCoA, src: CN or HA)

When MN is sender, 
outgoing packet (dst: CN, src:PCoA)
=> encapsulation in MN (dst:PAR, src:NCoA) + (dst: CN, src: PCoA)
=> decapsulation in PAR (dst: CN, src:PCoA)
---------------------------------------------------------------------------------------------

That is my understanding. Is that correct?
      
Regards,
Hongseok

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Wed, 14 Sep 2005 10:57:47 -0700

> Followings depict packets transmission in such a case; 

yes.

-Rajeev

> Regards,
> Hongseok
> 
> 
> ------------------------------------------------------------------------
>

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 19 Sep 2005 11:44:13 +0200

> Followings depict packets transmission in such a case; 

Encapsulation happens at PAR (not in NAR); I think that is what you
meant too, and that NAR forwards (does not encapsulate) the encapsulated
packet to MN.

> => decapsulation in MN (dst:PCoA, src: CN or HA)

Yes.

> => decapsulation in PAR (dst: CN, src:PCoA)

Yes.

> That is my understanding. Is that correct?

That is my understanding too.

Alex

---

From: "Hongseok, Jeon" <[email-masked]>
Date: Tue, 20 Sep 2005 09:04:42 +0900

> meant too, and that NAR forwards (does not encapsulate) the encapsulated

You are right. That is my mistake.
Thank you for your indiciation. 

Hongseok