Subject: [Mipshop] FMIPv6 - Reactive mode operation - HI destination address

From: Subba Reddy <[email-masked]>
Date: Thu, 22 Sep 2005 18:51:29 +0530

Hi,
    If MN sends FBU from NAR's link, there may be cases
in which PAR don't know NAR's address (May be because of
PAR not having corresponding [AP-ID, AR-Info] tuple).
In such cases to which address PAR will send HI?

Is one more option (with NAR's IPv6 address)  required 
in FBU message?
(or)
Without HI, HAck exchange PAR will send FBack?

Am I missing something?

Thanks & Regards,
Subba Reddy
_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Rajeev Koodli <[email-masked]>
Date: Thu, 22 Sep 2005 10:40:52 -0700

Hi Subba,

the current suggested approach is to match the prefix in NCoA to a list 
of access routers that PAR maintains and derive the NAR's address from 
the list. (Note: prefix used in NCoA will not be the same as that in 
NAR's IP address, but a mapping is sufficient. See the last paragraph on 
page 11).

Regards,

-Rajeev

Subba Reddy wrote:
> ------------------------------------------------------------------------
>

---

From: Subba Reddy <[email-masked]>
Date: Fri, 23 Sep 2005 10:57:51 +0530

Hi Rajeev,

> NAR's IP address, but a mapping is sufficient. See the last paragraph on

True. If PAR has prefix information about that NCoA, it is fine.

Please consider the following case.
>From Section 6.1.2 (page 22)
        "When the Option-Code field in the New Access Point LLA option
         is 6, the PAR is not aware of the Prefix Information requested.
         The MN SHOULD attempt to send an FBU as soon as it regains
         connectivity with the NAR.  No other options are required in
         this case."
In this case, if MN sends FBU from NAR's link, PAR may not know
where to send HI.

Thanks & Regards,
Subba Reddy