Subject: RE: [Mipshop] new charter

From: [email-masked]
Date: Fri, 7 Oct 2005 11:51:34 -0500

Alex,

> 
> gabriel montenegro wrote:
> 
> > Hi folks,
> > 
> > You can find the proposed new charter here:
> > 
> > http://www.geocities.com/gabriel_montenegro_2000/mipshop-charter.htm
> 
> Hi Gabriel, is the Charter up for discussion?
> 
> Could I comment on the 802.21 parts.  It seems to be written well and
> with focused goals.  However, as an 802.21-outsider it still 
> looks very
> vague to me.  
Indeed for sake of brevity we could not provide more details. I realize how this brief text may be confusing for 802.21-outsiders. I'm providing some answers below, but I would also suggest reviewing the minutes and presentations from last IETF. If you need more information, you can find 802.21 documents on the free website ieee802.org/21. You can also take a look at draft-faccin-mih-infoserv-01.txt where you can find answers to many of these questions.

> May I ask the following:
> 
> > Additionally, the IEEE 802.21 Media Independent Handoff 
> (MIH) working
> >  group aims at providing services to assist with handoffs between 
> > heterogeneous link-layer technologies,
> 
> What exactly are the link-layer technologies that are 
> planned?  Is that
> 3GPP and 802.xx MAC?

802.21 focuses on 3GPP, 3GPP2 and 802.xx MAC.

> 
> > and across IP subnet boundaries.
> 
> Is that IPv4 or IPv6?  Or both?
> 
> Is 802.21 above or below IP?
802.21 is not a layer nor a protocol per-se, but a set of functionality. The aspects of relevance to MIPSHOP are the transport of 802.21 information at IP layer or above. 

> 
> > The information exchanges defined by IEEE 802.21 are 
> classified as MI
> >  (Media Independent) Event Service (MIES), MI Command 
> Service (MICS),
> >  and MI Information Service (MIIS)
> 
> I can't understand this.  Usually an information exchange is not a
> service.  An information exchange is a set of request-reply -like
> messages.  On the contrary, a service is more like a DNS service, an
> HTTP service, or some other service where one uses SLP to locate that
> service.  Would MIES, MICS and MIIS relate to SDP and SLP?
> 
> Otherwise, what exactly is an 802.21 message exchange?  What are the
> names of each message of that exchange?  E.g. in 802.11 there's a
> message called ASSOCIATE.
> 
> > The MIIS provides topological and location-related information of 
> > service networks.
> 
> What's a "service network"?  Is that a "serviced" network?  Is that a
> network providing services?
> 
> > An L2 or L3 based mechanism to identify a valid information 
> server is
> >  also required.
> 
> An L2 or an L3 -based mechanism?  Or both?
> 
> Identifying an information server could also be achieved with 
> SLP, DHAAD
> and DHCP, right?  Why not?
The intention is not to preclude the use of existing mechanisms, but studies need to take place to identify which mechanisms fit the specific needs.

> 
> > Produce the required protocol enhancements or specifications for
> > IP-based support of Media-Independent Information Services. 
> This will
> > be the initial focus, although eventually, additional work 
> on Command
> > and Event Services may be added.
> 
> Enhance which protocol?
The answer to that question would be the result of the re-chartered WG. The idea is that, once the use scenarios and requirements are stable, we should enter into the solution space and identify if any of the existing protocols fit the requirements (perhaps with extensions) or if a new protocol is needed.

> Alex

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Alexandru Petrescu <[email-masked]>
Date: Fri, 07 Oct 2005 19:18:13 +0200

[email-masked] wrote:

>> Could I comment on the 802.21 parts.  It seems to be written well 
>> and with focused goals.  However, as an 802.21-outsider it still 
>> looks very vague to me.
> 
> Indeed for sake of brevity we could not provide more details. I 
> realize how this brief text may be confusing for 802.21-outsiders. 
> I'm providing some answers below, but I would also suggest reviewing
>  the minutes and presentations from last IETF.

I attended the meeting and reviewed the minutes and the presentations,
thanks for pointing this out.

> If you need more information, you can find 802.21 documents on the 
> free website ieee802.org/21.

> You can also take a look at draft-faccin-mih-infoserv-01.txt where 
> you can find answers to many of these questions.

I can find draft-faccin-mih-infoserv-00 but not 01, has the 01 been
submitted prior to September 7th 2005?  I'll review 00 anyways, thanks
for pointing to it.

>> What exactly are the link-layer technologies that are planned?  Is
>>  that 3GPP and 802.xx MAC?
> 
> 

Thanks, so to a certain extent that does not pertain to GPRS to 802.xx
handovers.

> 802.21 is not a layer nor a protocol per-se, but a set of 
> functionality. The aspects of relevance to MIPSHOP are the transport
>  of 802.21 information at IP layer or above.

Ok, I kind of get it a little more.  There is usually much discussion
prior to integrating one layer's info into another layer's payload.

>> Identifying an information server could also be achieved with SLP,
>>  DHAAD and DHCP, right?  Why not?
> 
> The intention is not to preclude the use of existing mechanisms, but
>  studies need to take place to identify which mechanisms fit the 
> specific needs.

I see.

> The answer to that question would be the result of the re-chartered 
> WG. The idea is that, once the use scenarios and requirements are 
> stable, we should enter into the solution space and identify if any 
> of the existing protocols fit the requirements (perhaps with 
> extensions) or if a new protocol is needed.

I'm sorry but that's not what the Charter text says.  The Charter says:
 threat analysis, protocol enhancements and eventually Command and Event
Services will be worked on.

Could the Charter just say: "first set up the requirements, the goals
and the scenarios"?

Alex