Subject: RE: [Mipshop] ES and CS within the MIPSHOP charter

From: [email-masked]
Date: Thu, 13 Oct 2005 11:00:17 -0500

Vivek,
perhaps there is a bit of confusion here. What we're saying is that if you want to deploy 802.21 in a network that has both 3G access and e.g. 802.11, you need the L3 solution because it is not realistic to expect that 3GPP will modify their L2 to implement 802.21 concepts. 3GPP has clear requirements for the inter-access handoff stating that no changes to 3G access interface shall be made. Therefore, when you put together 3G and 802.xx you need the L3 solution.
Stefano

> -----Original Message-----
> From: ext Gupta, Vivek G [mailto:[email-masked]]
> Sent: Thursday, October 13, 2005 10:45
> To: Sreemanthula Srinivas (Nokia-NRC/Dallas); [email-masked];
> [email-masked]; [email-masked]; 
> Faccin Stefano
> (Nokia-NRC/Dallas)
> Cc: [email-masked]
> Subject: RE: [Mipshop] ES and CS within the MIPSHOP charter
> 
> 
> Srini,
> 
> 802.21 mostly means inter-technology handovers to me and so 
> in no way am
> I referring to intra-technology handovers. Many of us already 
> believe in
> and are working towards a L2 transport specifically for 802.11 and
> 802.16 networks.
> If the primary networks for ES and CS services over IP are 
> 802 networks
> (.11 and .16), then it would at least be worthwhile to do a pros and
> cons between L2 and L3 choices and come up with some clear 
> articulation
> as to when/why one is preferable over the another.
> 
> One of the earlier argument for L3 support in this case was 
> that L2 PoAs
> (such as APs and BSs) may take a while to be updated with new changes
> and that L3 may speed up initial deployment. Even if that is true
> (somehow...) would still be worthwhile to answer the above question.
> 
> BR,
> -Vivek
> 
> 
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] 
> Sent: Thursday, October 13, 2005 8:28 AM
> To: Gupta, Vivek G; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> Cc: [email-masked]
> Subject: RE: [Mipshop] ES and CS within the MIPSHOP charter
> 
> Vivek,
> We are not using IS/ES/CS to aid intra-technology 3G handovers because
> all the signaling and associated parameters are clearly defined in the
> 3G protocols. When the multi-access terminal needs to send or receive
> information about other link technologies in its vicinity, that's when
> we use these services. BTW, the same mechansims can also be used for
> handovers from 802.16, 802.11 etc.
> 
> Let's separate the discussion of L2 vs L3 here. We need both at the
> standards track and deployment can use just one or perhaps both.
> 
> Regards,
> Srini
> 
> >-----Original Message-----
> >From: ext Gupta, Vivek G [mailto:[email-masked]] 
> >Sent: Thursday, October 13, 2005 10:13 AM
> >To: Sreemanthula Srinivas (Nokia-NRC/Dallas); 
> >[email-masked]; [email-masked]; 
> >[email-masked]; Faccin Stefano (Nokia-NRC/Dallas)
> >Cc: [email-masked]
> >Subject: RE: [Mipshop] ES and CS within the MIPSHOP charter
> >
> >
> >If it is not 3G networks, then what are the primary candidate 
> >networks for using ES and CS services over IP?
> >
> >BR,
> >-Vivek
> >
> >
> >-----Original Message-----
> >From: [email-masked] 
> >[mailto:[email-masked]] On Behalf Of 
> >[email-masked]
> >Sent: Thursday, October 13, 2005 7:49 AM
> >To: [email-masked]; [email-masked]; 
> >[email-masked]; [email-masked]
> >Cc: [email-masked]
> >Subject: RE: [Mipshop] ES and CS within the MIPSHOP charter
> >
> >Ajoy,
> >The new (IS, ES and CS) services we are dicussing here 
> >involves multiple link technologies. We are not using ES and 
> >CS over IP for handovers within 3G networks, for that 3G SDO 
> >have already done work, which is what Eric is stating. 
> >
> >Regards,
> >Srini
> >
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Takashi Aramaki <[email-masked]>
Date: Fri, 14 Oct 2005 01:25:59 +0900 (JST)

Hi Stefano,

Would you happen to have reference to the 3GPP requirements which
states no changes are required for inter-access handoff?  I think that
will be beneficial for the WG to understand necessity of L3 solution.

Cheers,
Takashi

---

From: Alexandru Petrescu <[email-masked]>
Date: Thu, 13 Oct 2005 19:01:35 +0200

Dear all,

I personally perfectly understand the necessity of inter-access handoffs
happening at L3 layer, by L3's defnition itself and by
"media-independent" name.

What I don't understand is the following:

-why doesn't 802.21 do first L2 handovers between .11, .15 and .16
 exclusively, w/o IP.  That first, later we'll see.
-why doesn't 802.21 try to BoF first.  BoF is a common procedure at
 IETF.  Provided a critical mass is contributing, things can go
 relatively fast.
-why the architectural trait "dumb network" is not followed for
 L3 handovers.
-why local L2-triggers are needed for fast mobility, and at the same
 time fast mobility is not needed for 802.21 which in turn needs to
 encode L2-triggers.

I'm probably not in a position to raise these questions, so I wouldn't
block things that are converging without me anyways.

Alex

Takashi Aramaki wrote:
> states no changes are required for inter-access handoff?  I think 
> that will be beneficial for the WG to understand necessity of L3 
> solution.
> 
> Cheers, Takashi
> 
> 
> On Thu, 13 Oct 2005 11:00:17 -0500, [email-masked] wrote:
> 
>> Vivek, perhaps there is a bit of confusion here. What we're saying 
>> is that if you want to deploy 802.21 in a network that has both 3G 
>> access and e.g. 802.11, you need the L3 solution because it is not 
>> realistic to expect that 3GPP will modify their L2 to implement 
>> 802.21 concepts. 3GPP has clear requirements for the inter-access 
>> handoff stating that no changes to 3G access interface shall be 
>> made. Therefore, when you put together 3G and 802.xx you need the 
>> L3 solution. Stefano
>> 
>> 
>>> -----Original Message----- From: ext Gupta, Vivek G 
>>> [mailto:[email-masked]] Sent: Thursday, October 13, 2005
>>>  10:45 To: Sreemanthula Srinivas (Nokia-NRC/Dallas); 
>>> [email-masked]; Faccin Stefano (Nokia-NRC/Dallas) Cc: 
>>> [email-masked] Subject: RE: [Mipshop] ES and CS within the 
>>> MIPSHOP charter
>>> 
>>> 
>>> Srini,
>>> 
>>> 802.21 mostly means inter-technology handovers to me and so in no
>>>  way am I referring to intra-technology handovers. Many of us 
>>> already believe in and are working towards a L2 transport 
>>> specifically for 802.11 and 802.16 networks. If the primary 
>>> networks for ES and CS services over IP are 802 networks (.11 and
>>>  .16), then it would at least be worthwhile to do a pros and cons
>>>  between L2 and L3 choices and come up with some clear 
>>> articulation as to when/why one is preferable over the another.
>>> 
>>> One of the earlier argument for L3 support in this case was that 
>>> L2 PoAs (such as APs and BSs) may take a while to be updated with
>>>  new changes and that L3 may speed up initial deployment. Even if
>>>  that is true (somehow...) would still be worthwhile to answer
>>> the above question.
>>> 
>>> BR, -Vivek
>>> 
>>> 
>>> -----Original Message----- From: [email-masked]
>>>  [mailto:[email-masked]] Sent: Thursday, October
>>>  13, 2005 8:28 AM To: Gupta, Vivek G; [email-masked]; 
>>> [email-masked] Cc: [email-masked] Subject: RE: 
>>> [Mipshop] ES and CS within the MIPSHOP charter
>>> 
>>> Vivek, We are not using IS/ES/CS to aid intra-technology 3G 
>>> handovers because all the signaling and associated parameters are
>>>  clearly defined in the 3G protocols. When the multi-access 
>>> terminal needs to send or receive information about other link 
>>> technologies in its vicinity, that's when we use these services. 
>>> BTW, the same mechansims can also be used for handovers from 
>>> 802.16, 802.11 etc.
>>> 
>>> Let's separate the discussion of L2 vs L3 here. We need both at 
>>> the standards track and deployment can use just one or perhaps 
>>> both.
>>> 
>>> Regards, Srini
>>> 
>>> 
>>>> -----Original Message----- From: ext Gupta, Vivek G 
>>>> [mailto:[email-masked]] Sent: Thursday, October 13, 
>>>> 2005 10:13 AM To: Sreemanthula Srinivas (Nokia-NRC/Dallas); 
>>>> [email-masked]; Faccin Stefano (Nokia-NRC/Dallas) Cc:
>>>>  [email-masked] Subject: RE: [Mipshop] ES and CS within the 
>>>> MIPSHOP charter
>>>> 
>>>> 
>>>> BR, -Vivek
>>>> -----Original Message----- From: [email-masked] 
>>>> [email-masked] Sent: Thursday, October 13, 
>>>> 2005 7:49 AM To: [email-masked]; 
>>>> [email-masked] Cc: [email-masked] Subject: RE: 
>>>> [Mipshop] ES and CS within the MIPSHOP charter
>>>> 
>>>> Ajoy, The new (IS, ES and CS) services we are dicussing here 
>>>> involves multiple link technologies. We are not using ES and CS
>>>>  over IP for handovers within 3G networks, for that 3G SDO have
>>>>  already done work, which is what Eric is stating.
>>>> 
>>>> Regards, Srini
>>>> 
>>> 
>> _______________________________________________ Mipshop mailing 
>> list [email-masked] 
> _______________________________________________ Mipshop mailing list
>  [email-masked] https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Greg Daley <[email-masked]>
Date: Mon, 17 Oct 2005 13:36:43 +1000

Hi Alex,

Please bear with me while I try to provide some opinions.

Firstly, media independence is not (only) IP, it can be
gained somewhat using ethertypes etc.

That said, I think I understand your thought.

>  exclusively, w/o IP.  That first, later we'll see.

There's potentially a long lead time for these things, and
in some cases, a lot of deployed hardware.

Sometimes it's not appropriate to upgrade the L2 infrastructure
even if the edge (phones/laptops) are regularly upgraded.

The media independence is available if carried by IP, potentially
with more shared code and shorter lead-times for production.
I'm not sure if this makes it compelling to implement for manufacturers,
but the universality may assist adoption of handover services.

>  IETF.  Provided a critical mass is contributing, things can go

I think the original intention was to look at a BoF (and one
was proposed for last IETF), but information services were
already under consideration for MIPSHOP, and it was determined
only one effort should occur.

> -why the architectural trait "dumb network" is not followed for

If you look at DNA, the dumb network assumption is alive and well.

There are a number of areas where existing approaches are known
to be limited.

Link-layer scanning and discovery are the primary cause of delay
in IPv6 handover if a combination of
Opti-DAD/DNA/FMIPv6/HMIPv6/MobileIPv6/OMIPv6/EBU etc. are deployed
(pick an appropriate subset).

802.11 handover (scanning and probing) delays account for >90% of
handovers in some cases.

Intelligent (rather than dumb) network services are a way of
delivering ifnromation which can solve this.

If we can get to a way of doing it well which is fairly dumb, that
would be great.  There may still be value in using intelligence where
it is available though.

>  time fast mobility is not needed for 802.21 which in turn needs to

Link-layer indications are already required for FMIPv6 and DNA.
Otherwise you don't know to react quickly.

> block things that are converging without me anyways.

Questions are often helpful, though too.

Greg

---

From: Alexandru Petrescu <[email-masked]>
Date: Mon, 17 Oct 2005 13:57:43 +0200

Greg Daley wrote:

> Firstly, media independence is not (only) IP, it can be gained 
> somewhat using ethertypes etc.
> 
>> I personally perfectly understand the necessity of inter-access 
>> handoffs happening at L3 layer, by L3's defnition itself and by 
> There's potentially a long lead time for these things, and in some 
> cases, a lot of deployed hardware.

It would be a good exercise to define prototype and deploy a hand-over
between 802.11 and 802.16, with MAC only.  That would give a good
definition of 'hand-overs'.

> Sometimes it's not appropriate to upgrade the L2 infrastructure even
>  if the edge (phones/laptops) are regularly upgraded.

I agree that upgrading existing L2 infrastructure may take long time.
So the above remark makes me think that 802.21 tries to avoid that.
Speaking of which, am I right to think that 802.21 will not define
anything going into hardware?  I'm currently used to think that 802.11b
is a hardware card, 802.11a another card and 802.16e/WiBro probably yet
another card.

Do you think there will be such 802.21 cards?  Or is it that 802.21 will
only be software?

> I think the original intention was to look at a BoF (and one was 
> proposed for last IETF), but information services were already under
>  consideration for MIPSHOP, and it was determined only one effort 
> should occur.

Ok.

>> -why the architectural trait "dumb network" is not followed for L3
>>  handovers.
> 
> 

Ok.

> There are a number of areas where existing approaches are known to be
>  limited.
> 
> Link-layer scanning and discovery are the primary cause of delay in 
> IPv6 handover if a combination of 

I don't think that the scanning and probing time can be reduced by using
IP message exchanges, because IP messages can be exchanged only when L2
is up.  Do you think that the scanning and probing time can be reduced
by using IP message exchanges?  Or do you think that that time will be
eliminated entirely?

> would be great.  There may still be value in using intelligence where

Right, I share that view, use intelligence where it's available.

>> -why local L2-triggers are needed for fast mobility, and at the 
>> same time fast mobility is not needed for 802.21 which in turn 
>> needs to encode L2-triggers.
> 

Some current emails mention that 802.21 does not target doing faster
handovers.

Link-layer indications required by FMIPv6 are local, on same machine,
not Services from network.

Does 802.21 have a precise idea of what are those local link-layer
indications in the particular case of 802.11b?  Can one use that as
starting point.

Alex