Subject: RE: [Mipshop] Containers and not content for handover informationservices

From: "Singh Ajoy-ASINGH1" <[email-masked]>
Date: Tue, 18 Oct 2005 23:42:31 -0400

Hi Greg, 

Do you want IEEE emails to be cross posted at MIPSHOP as well? I think
some IEEE emails are being cross posted at MIPSHOP already. I guess
other 
option is that interested MIPSHOP folks can also participate in IEEE
discussing using IEEE reflector or at least proactively look at the
email archive at http://www.ieee802.org/21/email21/ 

and comment during HL requirement discussion. As soon as requirements
are done, we will have opportunity to discuss some more formally in
MIPSHOP. Any other suggestion? 

Regards,
Ajoy 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Greg Daley
Sent: Tuesday, October 18, 2005 6:11 PM
To: James Kempf
Cc: [email-masked]
Subject: Re: [Mipshop] Containers and not content for handover
informationservices

Hi James,

I'm happy to wait for IEEE to come with a set of official
requirements.

I do also think we need to inform the discussion over here though,
so that MIPSHOP isn't left at a standing start, when it comes
to advising additional requirements, and specifying solutions.

That's why there's a (personal opinions) take of the use cases
of IS described in draft-faccin-mih-infoserv-01.  I'd like that
document to reflect more of the understanding of 802.21 and
MIPSHOP, once those ideas are available.

Greg

James Kempf wrote:
> What are the 802.21 requirements as answers to these questions?
> 
> I do have my own ideas about how to answer them, based on my
experiences 
> with other protocols of this sort, but I think we need to hear what 
> 802.21 wants first.
> 
>            jak
> 
> 
> 
> 
> ----- Original Message ----- From: "Greg Daley" 
> <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, October 17, 2005 8:37 PM
> Subject: [Mipshop] Containers and not content for handover 
> informationservices
> 
> 
>> Hi,
>>
>> I'm writing to express my dismay about the seeming over concern
>> of people about the formatting for content which would be
>> exchanged over an information service.  At this stage, I think
>> we need to assume that the handover information is opaque to us
>> as designers of the transmission mechanism, so that we don't
>> get distracted by details.
>>
>> There are bigger issues than whether the message formats
>> will contain TLV or XML information.  In fact, I can only
>> see three ways that the content formatting itself will
>> affect the delivery of handover information service
>> messages over IP.
>>
>>
>> 1) Sequencing and Fragmentation:
>>    There needs to be message (and message fragment)
>>    identification.
>>
>>    It could be possible to avoid these in the messages
>>    themselves with a particular encoding, but I guess
>>    it's premature to optimize this
>>
>> 2) Congestion control:
>>
>>    One system may have higher overheads than another
>>    which may cause different rate limitation to be required.
>>
>> 3) Resource Control:
>>
>>    Processing resources may be consumed with a particular
>>    encoding (perhaps more than another).
>>
>>    This may encourage identification of the mobile in order
>>    to limit resource consumption on a per-node basis.
>>
>> These aren't really big problems, compared to:
>>
>> What message exchanges are needed for IS?
>>
>> What discovery mechanisms can we assume?
>>
>> Is it necessary to have IS servers > 1 hop away?
>>
>> What level of trust is required for IS servers?
>>
>> Is the communication datagram oriented or stream oriented?
>>
>> Looking too deeply into the content means that the big questions
>> are likely to be obscured, compared to more fundamental ones,
>> which will affect sequencing, congestion and resource control
>> anyway...
>>
>> Would anyone like to work on the big picture?
>>
>> I'd love to help out where I can.
>>
>> Greg
>>
>>
>> _______________________________________________
>> Mipshop mailing list
>> [email-masked]
>> https://www1.ietf.org/mailman/listinfo/mipshop
>>
> 
> 

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

_______________________________________________
Mipshop mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/mipshop

---

From: Greg Daley <[email-masked]>
Date: Wed, 19 Oct 2005 14:01:27 +1000

Hi Ajoy.

Singh Ajoy-ASINGH1 wrote:
> Hi Greg, 
> 
> Do you want IEEE emails to be cross posted at MIPSHOP as well?

No.

> I think some IEEE emails are being cross posted at MIPSHOP already.
 > I guess other option is that interested MIPSHOP folks can also
 > participate in IEEE discussing using IEEE reflector or at least
 > proactively look at the email archive at 
http://www.ieee802.org/21/email21/

This is the operating mode encouraged by IETF and IEEE
Working Group chairs AFAICS.

> MIPSHOP. Any other suggestion? 

Yes.

We shouldn't charter something which isn't understood.
Certainly we shouldn't wait around for the IEEE to bless a
set of final requirements before looking into the problem space
ourselves (as IETF participants).

What should be done with the time before an offical request
arrives from IEEE is to use the time _wisely_ in discussion
which informs the WG.

This was the essence of my idea: let's get the WG to a point
where understanding of the scenario is increased, rather than
worrying about bit patterns.

Greg